Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
85 user(s) are online (47 user(s) are browsing Forums)

Members: 1
Guests: 84

emeck, more...

Support us!

Headlines

 
  Register To PostTopic is Locked  

« 1 (2) 3 »
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Just can't stay away
Just can't stay away


See User information
@All

Don't jump to conclusions too fast, especially if you don't have ACube answer

Philippe 'Elwood' FERRUCCI
Sam460ex 1.10 Ghz
http://elwoodb.free.fr
Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Site Builder
Site Builder


See User information
Quote:
Don't jump to conclusions too fast, especially if you don't have ACube answer


I am looking forward to hearing ACube's side of the story since geennaam is so offended by their actions and decided to bring this matter public, instead of solving it with them.

@geennaam
It is interesting that instead of trying to solve any issue, you just try to victimise yourself and blame the community ones again, calling us immoral. I once again offer my help to have your drivers hosted and sold by you, if that's what you need to do.

Follow me on
Ko-fi, Twitter, YouTube, Twitch
Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Amigans Defender
Amigans Defender


See User information
@geennaam

Quote:
Walkero wrote:
I once again offer my help to have your drivers hosted and sold by you

And I will once again say that the OS4 community is very appreciative of your work. You just need to give us a chance to obtain your software legally so that we can use it.

The Rear Window blog

AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon RX 560 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Quite a regular
Quite a regular


See User information
@walkero

You (and others) completely failed to see my point.
I do not want money. Never asked for it and also declined donations.
I want people to respect my license and don't just steal something because someone else sold them something. Or that you lack the audio hardware on your product. That is the problem between them and the ones they bought their hardware from. Instead everything is somehow my fault. And if I don't like that I can gfm for the drama queen that I apparently am.

Your comment that it was my own fault because I had to find a different distribution method sooner is the most immoral and offensive of them all.

Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Quite a regular
Quite a regular


See User information
Software is licensed and you can only use it according to its license. The author has the right to decide what license the sofware is published under. It does not matter what you think, you only have two choices: accept the licence or not use the software. (This is also true for free software under GPL. You can use, distribute, modify it freely, even can ask for money to support it, but you can't make it non-free and have to give the same rights you got to others.) Those who produce commercial products and expect people to follow their licenses should also follow the license of the components they use themselves and should check and comply to those licenses.

In this case the HDA driver's license says it's only for non-commercial personal use and cannot be distributed as part of a commercial product or ask money for it. (I don't think this can be revoked once it's published so this driver version is still available under those terms and it allows to be distributed for personal use.) But the author can ask it to be removed from commercial products (or try to ask for some money for past "damage" but maybe there's not much profit made on any of this and we don't need more court cases so getting some agreement may be a more sensible approach).

The authors also have the right to decide if they want to support it further. license further versions under different license or stop making further versions. You can't force them to do something they don't want to.

Maybe people are too passionate about all these Amiga stuff and still hold on to their pieces which just hinders development so it would be better if there could be more cooperation instead of competition and forget commercial thinking where there's no real market but this seems to be the state of things now. I can only hope it will change in the future.

Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Site Builder
Site Builder


See User information
Quote:
Your comment that it was my own fault because I had to find a different distribution method sooner is the most immoral and offensive of them all.


This is reality. You have to get down to the earth. If anyone wants to use their hardware, they will try to find a way to do it. Since you decided to "panish" the community months ago just by removing the driver from OS4Depot, do not expect that the users will not try to find it any way they can.

If people share the driver "illegally" as you say, then you should help them do it legally, which you didn't. Instead of being thankful for people finding your work useful, you end up accusing us (and me personally) for being immoral. That is your opinion, but do not expect us to agree with that.

Yes, people should respect the licence file you included in your archive, but you also need to land to reality and start doing something useful.

I do not know if I am immoral because I proposed you solutions. If that's the case, so be it. But please think before you talk.

Follow me on
Ko-fi, Twitter, YouTube, Twitch
Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Site Builder
Site Builder


See User information
In my situation, I only use old SounBlaster cards, for which drivers are coming with the OS. I would suggest everyone to use these cards and get rid of this drama, having a usable system.

Follow me on
Ko-fi, Twitter, YouTube, Twitch
Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Quite a regular
Quite a regular


See User information
@walkero

Quote:
Doing something useful.


Well, turning my back to you and the "community" is probably the most useful thing that one can do.

Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Home away from home
Home away from home


See User information
@geennaam

I totally get where you’re coming from,

AEON, ACube-System or Hyperion is making money, selling your free work is illegal, I totally and I get it, if there is no agreement for distribution, it breaks the copyright end of story.

I do not get what some users have problem with that, they really hard on Hyperion for using free contract work, but at end of day, it should be developers who chose to work for free or not. And if its not paid for its no one’s business how your software is shared or distributed but your own.

And right now we come companies like Cloanto who want to take ownership of AmigaOS and its components by legal trickery, without paying the contractors. From my point of view, it be best to not bundle anything with AmigaOS. To avoid legal entanglement.

(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Just can't stay away
Just can't stay away


See User information
@walkero
Quote:
If people share the driver "illegally" as you say, then you should help them do it legally, which you didn't.
Wrong, he did exactly that. That it's not available for sale yet is not @geennaam fault.
Probably doesn't matter much anymore since I'm quite sure @geennaam wont do any AmigaOS development any more, for exactly the same reasons I stopped doing it 10-15 years ago.
It's not about making money, which isn't possible with only a few 100 users anyway, but about respect. If companies and users don't appreciate the hard work done by the developers but have no problem at all using pirate copies of their software you can't complain that there is no further development anymore either...

Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Quite a regular
Quite a regular


See User information
@joerg

He knows exactly that my drivers were to be included as contribution with enhancer. He is on the Enhancer beta list as well. As is kas1e. The NVMe driver in its latest version with improvements, bug fixes and support for 4 units was already there in the beta. (Works nicely with these adapters as well:https://www.glotrends-store.com/products/pa20)

Which is also very cynical since they are both such vocal activists against Matthew and the Enhancer project.

I had not yet transmitted the new and improved hda driver because they wanted me to include a x-dock version of hdmixer. (And I didn't have found the time yet because of what is written below.)

Which as you have guessed will not happen anymore.

Even today I was working on two hardware projects. At first I was working on something xena related which was in a really advanced state. You can read about it in the xena topic. But then Skateman, a really nice and honest guy, convinced me to work on something else with higher priority in an effort to attract more users to the platform. Something that the community has been asking for for ages. I have been teasing specifications in the amigans discord channels.
It would have been ready for ordering of prototypes in May/June.

Well, you've guessed right. Not going to happen either.

I will mind my own something not useful business like drama and such.


Edited by geennaam on 2024/4/26 18:40:28
Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Home away from home
Home away from home


See User information
@geennaam
So, we (users) should understand your reassons, by reading GPL or whatever to drivers (which no one except ones include them do), but you not worry at all that you giving them at first driver, then remove it, then tell them to not use version from webarchive. Is it friendly to them ? Is it correct way if solving issues you had with acube ? Maybe we all immoral there, but at least we not show users something, and then remove it with explains that someone guilty for. If someone use driver from webarchive - what the problem ? Tell in friendly way that driver outdated and better one will be out only with Enhancer, why all that "i will not", just because users want to use old outdated driver ? Its all can be super moral from your side, and amoral from our, but this simple speaking strange.

As for Enhancer, i am not agaisnt it, i am against of how Mattew handle it, and how he grab Hyperions versioning theme for hes replacements and how he handle SDK for classes. But its all his iwn thing, and because he didnt do as some of us want, i didnt say "i will not" or "that is reasson why i xxxx" and so on.

@joerg
Let be honest, devs stop working on amigaos as they burnout, and things go not as perfect as they wish. But instead of dealing with issues, its always cool to bring some drama on users (who give a shit) about someone being guilty for something, right ?:)

Any of us can find nany excuses why better not do anything for os4, but we do, in favor of users.

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Not too shy to talk
Not too shy to talk


See User information
Wow... this is not good

The only thing @geennaam asked for, was to not use his software for commercial purpose. Since Acube is still advertising and selling the soundblaster on their webshop as being a better upgrade for its own Amiga systems, its clear that they should at least have contacted the developer of the driver since the use is purely commercial.

Those who reflect this back on the developer just dont get it.

The news of @geennaam halting his projects is a devastating blow to the Amiga community. His projects were the single biggest hope for securing the future of our beloved Amiga hardware platform.

It's deeply frustrating to see such potential go untapped due to a short-sighted vision. @geennaam's work could have benefited us all. Hope he will return some day....

AmigaOne X5000 -> 2GHz / 16GB RAM / Radeon RX 550 / ATI X1950 / M-Audio 5.1 -> AmigaOS 4.1 FE / Linux / MorphOS
Amiga 1200 -> Recapped / 68ec020 ACA 1221ec / CF HDD / RetroNET connected to the NET
Vampire V4SE TrioBoot
RPI4 AmiKit XE
Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Quite a regular
Quite a regular


See User information
@SkatemanQuote:
Skateman wrote:Wow... this is not good

The news of @geennaam halting his projects is a devastating blow to the Amiga community. His projects were the single biggest hope for securing the future of our beloved Amiga hardware platform.

It's deeply frustrating to see such potential go untapped due to a short-sighted vision. @geennaam's work could have benefited us all. Hope he will return some day....


+1 … @geennaam stay with us 👊🏻

Amiga x5000 ı o2o ı 4GB RAM ı RadeonRX580 | SBlaster Audigy Fx - AmigaOS4.1 FInal Edition

A1200 sandwich

Warp - Croatian Amiga portal
Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Just popping in
Just popping in


See User information
@all

This is the explanation of what happened:

- we sold very few Audigy FX cards (less than 10), and then took them off as availability from our shop because there was no demand
- the sound cards were not sold with any driver included, at the time it was still possible to download the driver from OS4Depot
- the audio driver was included on the SD card we supply with the Sam460 boards to help users install the operating system and other utilities easily and as quickly as possible, a kind of 'bonus pack.' As soon as we were alerted to the problem with the audio driver, we removed it
- Our mistake was to include the driver without having read the readme

We are sorry to learn that things were misunderstood. We make our apologies to geennaam and the Amiga community.
We will make sure that things will not happen again in the future.
In any case, we invite you to contact us directly through our contacts available at www.acube-systems.com

Max Tretene, ACube Systems Srl, Soft3
Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Just popping in
Just popping in


See User information
I'd like to apologize to Geennaam, I had no idea what you wanted in relation to your creations!

Indeed the USB key supplied with my X5040 comes with HDMixer a 2021 version and I didn't know that HDMixer shouldn't have been supplied with my AmigaOS pre-installation and that they did the opposite of what you wanted.

And I'm only now reading the license.txt, because I didn't have it before.

It's true that the vendors and resellers have done the opposite of what was written in the license.txt.

I have just one more thing to say, Geennaam, please stay with us.


I hope Google translate translated what I wrote well.
I do not speak much English.

Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Just popping in
Just popping in


See User information
@Skateman +1
Even though I haven't had a need to date to use the audio driver or ssd driver, I was super excited where my imagination had taken me from @greennaam's teases for his future project.
Please know that @greennaam you are very respected and we truly will be missing out if you indeed decide to leave.
If there is anything that we can do as a community to change your mind, please let us know.
Dave

Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Not too shy to talk
Not too shy to talk


See User information
@geennaam

Stand your ground and show what license means and the complications/aftermath of breaking that license!

I know the sour feeling of creating/producing and getting fucked over.

Edit: 100%

1989-> A500, A600, A3000, A4000, A1200, CD32, µA1, PegII, A1XE, CDTV, Amy/416D79, A1X5000, Vampire 500 V2+, Vampire 600 V2, Amy-ITX, Denise ITX <-2024
Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Site Builder
Site Builder


See User information
@geennaam
Quote:
He knows exactly that my drivers were to be included as contribution with enhancer. He is on the Enhancer beta list as well. As is kas1e. The NVMe driver in its latest version with improvements, bug fixes and support for 4 units was already there in the beta. (Works nicely with these adapters as well:https://www.glotrends-store.com/products/pa20)


I am on the Enhancer beta list and as much as I know, the HDAudio driver is not included in the latest beta package, nor it was mentioned that it will be included in any email. So I didn't know that this would come or not with Enhancer, as Matthew never shared that information in the mailing list.

But even if I knew that, I couldn't share it publicly, since I, in contrast with you, I honour my NDAs.

Quote:
Well, you've guessed right. Not going to happen either.


Well, to be honest with you, I do not know what is this exceptional thing you are working on and if it will see the light of the day for the OS4 community to use. I am sure it would be useful.

I am sorry that for one more time you develop so much drama out of nowhere. I do not know why you do it, and this is not my concern, but this is the third or fourth time you do the same thing here in this forum and in the Discord channel.

So instead of attacking people personally, and the community in general, please consider deciding:
- if you want to leave, please do so
- if you want to stay, we would be more than happy to have you with us
- if you would like to develop and release software/hardware for the OS4 community, please do so
- if you want to cease all of your projects and leave, farewell and good luck

But please stop bringing drama where there is none. Respect us, respect the community, respect the companies so that you can get back all of our respect and appreciation.

And finally... HAVE FUN.
If you don't, there is no reason to be here.

Follow me on
Ko-fi, Twitter, YouTube, Twitch
Go to top
Re: Amiga X5000 and Sound Blaster Audigy FX problem
Just popping in
Just popping in


See User information
@geennaam
@joerg

I have edited my post many times and instead of writing moralizing opinions, I will write this:


Yesterday was my birthday.

Maybe you will change your decision and return to the Amiga community.

It would be a nice gift for me.


Edited by amig_os on 2024/4/27 8:14:29
Edited by amig_os on 2024/4/27 8:16:22
Edited by amig_os on 2024/4/27 8:17:54
Edited by amig_os on 2024/4/27 8:27:05
Edited by amig_os on 2024/4/27 8:28:01
Edited by amig_os on 2024/4/27 8:29:44
Edited by amig_os on 2024/4/27 8:30:14
Edited by amig_os on 2024/4/27 8:33:22
Go to top

  Register To PostTopic is Locked
« 1 (2) 3 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project