Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
41 user(s) are online (21 user(s) are browsing Forums)

Members: 1
Guests: 40

mufa, more...

Headlines

 
  Register To Post
« 1 2 3 (4) 5 6 7 »

Re: Reborn return to castle Wolfenstein
Just can't stay away
Just can't stay away


See User information
@Severin (and thread)

FTP: 91.68.221.99
Login: RTCW
Pass: HunoPPCRTCW

I put the whole HD pack (not the full game, only HD Paks) on my FTP.

--
AmigaONE X1000 and Radeon R7 250
Go to top
Re: Reborn return to castle Wolfenstein
Just popping in
Just popping in


See User information
Hi hans,

My machine == X5000 20

My drivers and libraries are:

ATIRadeon.chip 53.30
RadeonHD.chip 3.6
ogles2.library 1.22
Warp3DNova.library 1.61


Your graphic card (type, name and constructor) == TOXIC 280X
Size of memory == 3Go

Engine working ? (Yes or no) == Yes



@Hans

I am in betatest system

Indeed it may be related to my diet but I do not believe it because it looks like a memory overflow and it completely crash the machine, I did other test gpu with shaders and the machine is very stable.
For information this exceeds 256 MB of graphics memory largely

@all
It would be nice for x5000 users to put your version of drivers and 3D libraries and put us if it works or not in HD
We will succeed in isolating the problem all together

I'm not the only one to have this problem there, all the x5000 are affected at the level of my crash but not the extinction of the machine


Edited by HunoPPC on 2019/2/8 13:30:20
AmigaOS 4.1 Rulez
Resized Image
Go to top
Re: Reborn return to castle Wolfenstein
Quite a regular
Quite a regular


See User information
@HunoPPC

Also the graphics card and its ram size may be helpful.

Go to top
Re: Reborn return to castle Wolfenstein
Just popping in
Just popping in


See User information
@Spectre660
Big thanks for you help it’s appreciate

@all
Please post this informations for Reborn engine:

Your machine ==

ATIRadeon.chip ==
RadeonHD.chip ==
ogles2.library ==
Warp3DNova.library ==

Your graphic card (type, name and constructor) ==
Size of memory ==

Engine working ? (Yes or no) ==

AmigaOS 4.1 Rulez
Resized Image
Go to top
Re: Reborn return to castle Wolfenstein
Quite a regular
Quite a regular


See User information
Sam460ex Ram 2GB

ATIRadeon.chip = N/A
RadeonHD.chip = N/A
RadeonRX.chip = 1.11

ogles2.library = 1.22
Warp3DNova.library = 1.63
W3DN_GCN.library = 1.61

Asus Radeon RX 560 (Polaris)
Size of memory = 4GB

Engine working ? (Yes or no) = Y (EGL)
iortcw 1.51c-SP amigaos4-ppc Feb 2 2019
http://dl.dropboxusercontent.com/s/o4 ... /RTCW_HDSettings.jpg?dl=0


Edited by Spectre660 on 2019/2/8 13:57:11
Edited by Spectre660 on 2019/2/8 14:01:00
Edited by Spectre660 on 2019/2/8 17:27:45
Edited by Spectre660 on 2019/2/8 17:33:14
Edited by Spectre660 on 2019/2/8 17:33:53
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
Go to top
Re: Reborn return to castle Wolfenstein
Just popping in
Just popping in


See User information
@HunoPPC



Machine == X5000, 20 (2 GB RAM DDR3)
-----------------------------------------------------
ATIRadeon.chip == 53.29
RadeonHD.chip == 3.6
ogles2.library == 1.22
Warp3DNova.library == 1.58

Graphic card == SAPPHIRE AMD R9 280X
Size of memory == 3 GB, GDDR5

Engine working == YES, but Freeze only with GENERAL TEXTURES = HIGH (HD REBORN)


EGL rtcw == works with all Settings on HIGH in 1920x1080.

AaaamiiigaOne X5000
(AmigaOS 4.1 FE)
Go to top
Re: Reborn return to castle Wolfenstein
Just popping in
Just popping in


See User information
@Spectre660

open shell:
workbench : > Kickstart/

type:
version ATIRadeon.chip
version RadeonHD.chip

There you can get info

Go to top
Re: Reborn return to castle Wolfenstein
Not too shy to talk
Not too shy to talk


See User information
@HunoPPC : @all

AmigaOne X5000
Radeon HD driver v3.6
ogles2.library v1.22
Warp3dnova.library v1.58
w3dn_si.library v1.58

Radeon HD 7770 1Gb Vram I tested too with a
Radeon HD R9/270

Don't work any engine of RTCW ( return)
The old version works fine. So I think that I got a problem with SDL, other games like borony, the new flare, beret, etc. don't work for me too.

The computer hangs, and the only thing I can do, it's turn off and turn on again.

I discover a crashlog file in the main directory of RTCW.

CRASHLOG ::

tty console mode disabled
iortcw 1.51c-SP amigaos4-ppc Feb 2 2019
----- FS_Startup -----
Current search path:
Trabajo:Juegos/FPS/Return_to_Castle_Wolfenstein_MiniGL-1.51/main/z_pak_standard_os4_ui.pk3 (528 files)
Trabajo:Juegos/FPS/Return_to_Castle_Wolfenstein_MiniGL-1.51/main/sp_pak4.pk3 (21 files)
Trabajo:Juegos/FPS/Return_to_Castle_Wolfenstein_MiniGL-1.51/main/sp_pak3.pk3 (11 files)
Trabajo:Juegos/FPS/Return_to_Castle_Wolfenstein_MiniGL-1.51/main/sp_pak2.pk3 (232 files)
Trabajo:Juegos/FPS/Return_to_Castle_Wolfenstein_MiniGL-1.51/main/sp_pak1.pk3 (1345 files)
Trabajo:Juegos/FPS/Return_to_Castle_Wolfenstein_MiniGL-1.51/main/pak0.pk3 (4775 files)
Trabajo:Juegos/FPS/Return_to_Castle_Wolfenstein_MiniGL-1.51/main

----------------------
6912 files in pk3 files
execing default.cfg
execing wolfconfig.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
Com_RandomBytes: using weak randomization
Bypassing CD checks
----- Client Initialization -----
Couldn't read rtcwhistory.
Cmd_AddCommand: map_restart already defined
----- Initializing Renderer ----
---- Renderer Initialization Complete ----
RTCWKEY found.
----- Client Initialization Complete -----
----- R_Init -----
SDL using driver "OS4"
Initializing OpenGL display
1920 1080
Couldn't get a visual
WARNING: could not set mode: (26)
----- Client Shutdown (Client fatal crashed: GLimp_Init() - could not load OpenGL subsystem
) -----
RE_Shutdown( 1 )
Hunk_Clear: reset the hunk ok
-----------------------
GLimp_Init() - could not load OpenGL subsystem

END CRASHLOG


My SDl libraries are :

libsdl-1.2.so 598220 08/oct/14
libsdl-2-2.0.so 5408437 20/jan/19
libsdl2.so 6838486 08/nov/16

Thanks

AmigaOne X5000 OS4.1 FEU1 And Lubuntu 10.04
1200 towered with Blizzard PPC - BVision and Mediator
And a new fantastic Chameleon64
Go to top
Re: Reborn return to castle Wolfenstein
Home away from home
Home away from home


See User information
@ribdevel
All games you listed compiled statically, so they don't use any .so. That mean you have some other problem, but 100% its not related to sobjes.

Go to top
Re: Reborn return to castle Wolfenstein
Not too shy to talk
Not too shy to talk


See User information
@kas1e

Ok. Thanks.

I try to make a serial log.

AmigaOne X5000 OS4.1 FEU1 And Lubuntu 10.04
1200 towered with Blizzard PPC - BVision and Mediator
And a new fantastic Chameleon64
Go to top
Re: Reborn return to castle Wolfenstein
Just popping in
Just popping in


See User information
@RIBDEVIL
Hello,
Your problem is not driver just your resolution is not présent on render.
Delete a wolfconfig.cfg on main/ dir and launch game.
Please return your expérience
HunoPPC

AmigaOS 4.1 Rulez
Resized Image
Go to top
Re: Reborn return to castle Wolfenstein
Not too shy to talk
Not too shy to talk


See User information
@HunoPPC :

This is the answer.

Well, works and I can playing around, but now it's the second part. Like other games, works for about a moment, sometimes even minutes, but then hangs.

And I can't do nothing with the computer.

I bought a null modem cable, and tomorrow I will try to make a serial log. Wish me luck.

Thanks Huno. The game it's great , like all your fantastic job.

AmigaOne X5000 OS4.1 FEU1 And Lubuntu 10.04
1200 towered with Blizzard PPC - BVision and Mediator
And a new fantastic Chameleon64
Go to top
Re: Reborn return to castle Wolfenstein
Just can't stay away
Just can't stay away


See User information
@K-L

Thank you :)

I did manage to get the files myself though, I dug out an old android set top box and after a factory reset had just enough space to download the files. I then used an ftp server on the box to transfer them to my X1000.

The intro video is much better now, with the earlier releases I got slow video and echos.

I still have the keyboard problem though. I've even tried to unplug & replug and if I get a message saying there was a usb problem and device adding was aborted I get 1 keypress and then that key is forever on. If I dont get an error message the keyboard does nothing.

My keyboard is one of those apple aluminium things with the built in (so low power it's useless) hub. I will try a different keyboard over the weekend if I get time.

it Seems playable at 1024x768 (20-25fps) but is far to slow at 1920x1080 (6-9fps). I'm still waiting for a rom update to be able to use my far better RX card.

Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
Go to top
Re: Reborn return to castle Wolfenstein
Just can't stay away
Just can't stay away


See User information
@Severin

As far as I can see, Apple keyboards have always been problematic with AmigaOS 4.1

--
AmigaONE X1000 and Radeon R7 250
Go to top
Re: Reborn return to castle Wolfenstein
Quite a regular
Quite a regular


See User information
Okay i have downloaded the game and the paks and put them all in main folder. I have also downloaded and installed EGL-warapper http://hunoppc.amiga-projects.net/con ... ry-eglwrapper-opengles-20

Whwn i try to start the game it freezes at the "Office of secret action" picture. Did i miss anything? I havent touched the configuration all my graphic drivers are up to date.

AmigaOne X5000
Radeon HD 7700
Go to top
Re: Reborn return to castle Wolfenstein
Just popping in
Just popping in


See User information
@Joeled

Have you south island chip, gfx card?
If you have si card set General textures on LOW in settings.
I have same problem.


Edited by Plexus on 2019/2/9 12:09:49
Edited by Plexus on 2019/2/9 12:10:42
Go to top
Re: Reborn return to castle Wolfenstein
Just popping in
Just popping in


See User information
I have a Sam440Flex with ATi 9250 and standard AOS 4.1FE,U1

What are the prerequisites in order to run this game?
Would it run just with MiniGL? I think it needs ogles2 Library with compatible HW.

What are the possible solutions for my motherboard (PCI->PCIe adapter/converter)? Would it fit inside TheRedOne? Anybody here done something similar?

Ordell Robbie: Is she dead, yes or no?
Louis: Pretty much.
Go to top
Re: Reborn return to castle Wolfenstein
Quite a regular
Quite a regular


See User information

Go to top
Re: Reborn return to castle Wolfenstein
Site Builder
Site Builder


See User information
@all
I would like to mention here that the necessary pak files are uploaded at huno's website as well. You can download them in zip format and extract them inside the main folder.

You will still need the original sp_pak files from the game.

Go to top
Re: Reborn return to castle Wolfenstein
Not too shy to talk
Not too shy to talk


See User information
@Plexus

Thanks for the tip.
Now works fine for me too.

Virginio

P.D.

Out of thread :

I report some games that freeze my Amiga X5000.
In one of this hangs, when I turn on , all my Sys:prefs/.../sys drawer disappeared or gone to hell, I don't know.
So, the workbench start without any preferences, except screen.prefs that I configured, I tested some programs and works, then tested some games, that don't work or hangs before, to my amazement, they works now ( beret, rpgdroid, huenison, BOH, etc) and others tell me I have an old Warp3dnova libraries ( 1.58 ).

Where is version 1.63, which asks me several programs ?

I'll create the preferences and try, I hope to discover which was the fault.

Thanks



Edited by RIBDEVIL on 2019/2/9 19:41:45
Edited by RIBDEVIL on 2019/2/9 19:43:44
AmigaOne X5000 OS4.1 FEU1 And Lubuntu 10.04
1200 towered with Blizzard PPC - BVision and Mediator
And a new fantastic Chameleon64
Go to top

  Register To Post
« 1 2 3 (4) 5 6 7 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project