Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
50 user(s) are online (34 user(s) are browsing Forums)

Members: 0
Guests: 50

more...

Headlines




« 1 (2) 3 »


Re: OWB 2.16
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 4323
@joerg

Quote:

Quote:
I'm asking because this

COOKIE=Cache:Temp/OWB_CookieJar.txt

doesn't work,
Ooops, typo in the readme, the tooltype is COOKIES.


Hold the press, there seems to be a bug in the COOKIES tooltype. It reads it in from the new destination, but seems to still write it to PROGDIR:, cause whenever i visit a new site or forum on amigans.net it keeps creating the cookieCollection.txt file in PROGDIR:

_________________
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
   Report Go to top

Re: OWB 2.16
Just can't stay away
Joined:
2006/11/24 17:54
From Sanremo
Posts: 1858
@Joerg

WoW it is faster than 2.15

Thanks

   Report Go to top

Re: OWB 2.16
Quite a regular
Joined:
2006/11/24 13:43
From Long Riston, East Yorkshire.
Posts: 756
@Joerg

V2.17 Works with Ebay, and seems more responsive.

_________________
Peter Swallow

Eyetech A1XE-G3 800Mhz OS4.1
Towered A1200 OS3.9
   Report Go to top

Re: OWB 2.16 (2.17 up)
Just popping in
Joined:
2006/12/28 23:42
From Besançon
Posts: 185
@orgin
Thanks ;o)
It's Ok now
OWB Rulezzzzzzzzzzzzzzzzzzzzzz
Bye
HunoPPC

_________________
AmigaOS 4.1 Rulez
Resized Image
   Report Go to top

Re: OWB 2.16 (2.17 up)
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3433
@Joerg

Just downloaded version 1.4 for 68k, but I can get it work here, I install ixemul and ixnet library 020 separatly (taked from 48.3 Aminet's package)

(it seems that it require also AmiTCP to work)

For next release is it possible to include all the dependencies in the same lha file ?

Would be cool to use it as is, without become crazy with other package

   Report Go to top

Re: OWB 2.16 (2.17 up)
Just popping in
Joined:
2007/5/1 12:59
Posts: 149
@samo79

it seems you will need an etc: assign also

assign it somewhere for testing

assign etc: RAM:

   Report Go to top

Re: OWB 2.16
Just can't stay away
Joined:
2007/2/23 13:49
From Finland, the land of Santa, sauna, sisu and salmiakki
Posts: 1116
@joerg

Are you going to make a new shared objects version of OWB someday too ? (No hurry.)

_________________
Rock lobster bit me, so excuse me.
X1000 + AmigaOS 4.1 FE
"Anyone can build a fast CPU. The trick is to build a fast system." - Seymour Cray
   Report Go to top

Re: OWB 2.16
Just can't stay away
Joined:
2006/12/1 19:07
From Germany
Posts: 1022
@TSK

Quote:
Are you going to make a new shared objects version of OWB someday too ? (No hurry.)
As long as the problems some users have with shared objects (random crashes on startup which make no sense) which I can't reproduce aren't fixed: No.



@samo79

Quote:
Just downloaded version 1.4 for 68k, but I can get it work here, I install ixemul and ixnet library 020 separatly (taked from 48.3 Aminet's package)
I can't find ixemul 48.3 on Aminet. But if you just installed the 2 libraries it can't work, programs using ixemul.library need a minimal GeekGadgets installation (ENV[ARC]:ixemul.prefs, ENV[ARC]:IXGMTOFFSET, executing GG:Sys/S/GG-Startup from your S:user-startup to create the assigns, etc., the files in ETC: (GG:etc), ...).

Quote:
(it seems that it require also AmiTCP to work)
No, any real TCP/IP stack should work. With the incomplete UAE emulation some AmiTCP parts (the AmiTCP: assign and the files in AmiTCP:db, maybe it's usergroup.library as well) seem to be required, but maybe that's only the case if your GeekGadgets installation is incomplete and ixemul/ixnet has to use the AmiTCP:db files as fallback for the missing GeekGadgets ETC: ones.

Quote:
For next release is it possible to include all the dependencies in the same lha file ?
No, it has nothing to do with OWB, (nearly) all programs using ixemul/ixnet need a minimal GeekGadgets installation, and I don't have an AmigaOS 3.x system for testing it.

   Report Go to top

Re: OWB 2.16 (2.17 up)
Quite a regular
Joined:
2006/11/27 22:17
From Israel
Posts: 932
@joerg

I'm jumping onto this thread to say again that OWB rocks.
Online payments/banking are on par with seamonkey.
I can even type in Hebrew (using appropriate keymap with Hebrew mapped onto ALT qualifier).
Didn't try fancy sites other than bank and local govermental payment pages, but all's well when isolating the combination that makes python crash in presence of OWB.
OWB is the main browser here.

@thread

I'm trying to isolate the conflict that causes python to crash.
Involved software is Cygnix and certain X11 apps.
Here the sequence is as follows, and if anyone who uses Cygnix, I would like to verify if it triggers the ISI :

start OWB

start Cygnix

open one of the following applications: leafpad or sylpheed (or probably other AOS native gtk app)

open Amiga shell andlaunch python

if no ISI at this point: run in python "import socket"


Thanks in advance.

Jack

_________________
Resized Image
"the expression, 'atonal music,' is most unfortunate--it is on a par with calling flying 'the art of not falling,' or swimming 'the art of not drowning.'. A. Schoenberg
   Report Go to top

Re: OWB 2.16 (2.17 up)
Just can't stay away
Joined:
2006/12/1 18:01
From Copenhagen, Denmark
Posts: 1276
Is it just me, or does text render bigger now than before? I assume it could be adjusted with the XDPI and YDPI tooltypes, but I'd like to know if it is "bug or feature" before experimenting with those.

One example where it is very obvious to me is my own site, http://nbache.dk/

Best regards,

Niels

   Report Go to top

Re: OWB 2.16
Just popping in
Joined:
2007/12/10 23:22
Posts: 59
@joerg

Quote:
programs using ixemul.library need a minimal GeekGadgets installation (ENV[ARC]:ixemul.prefs, ENV[ARC]:IXGMTOFFSET, executing GG:Sys/S/GG-Startup from your S:user-startup to create the assigns, etc., the files in ETC: (GG:etc), ...).

I don't know about OWB 1.4, but this isn't correct for most, if not all, linux ports that i have tried. I don't have a GG installation/assigns or any IXxxx enviroment variable and everything works fine.

   Report Go to top

Re: OWB 2.16 (2.17 up)
Quite a regular
Joined:
2006/12/1 3:20
From Michigan, USA
Posts: 550
@joerg,

I didn't even have time to catch the 2.16 version so I didn't have any of the listed problems. You were too fast for me with the bug-fixed 2.17!

All I can say is that 2.17 works great on US eBay, at least in motors.shop.ebay.com/ Also, the problem someone else mentioned with 2.15 in which URL's would some times load half-way and then stop, seems to be gone now for me.

@Jack,

I'm curoius about the use of Hebrew fonts and typing. Is this something that can be set in the system settings, or is it specific only to certain programs which include the right to left typing capability? I can't even get this feature in the latest WordPerfect on the neighboring PC! For that matter, I can't seem to get it working correctly in Abiword under Cygnix, either, where it should actually work.

Paul

_________________
Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
   Report Go to top

Re: OWB 2.16 (2.17 up)
Quite a regular
Joined:
2006/11/27 22:17
From Israel
Posts: 932
@Paul

Quote:

Paul wrote:

@Jack,

I'm curoius about the use of Hebrew fonts and typing. Is this something that can be set in the system settings, or is it specific only to certain programs which include the right to left typing capability? I can't even get this feature in the latest WordPerfect on the neighboring PC! For that matter, I can't seem to get it working correctly in Abiword under Cygnix, either, where it should actually work.

Paul


No extra r2l functionality in OS4.x (the only setting is English + Hebrew iso8859-8 keymap). OWB does r2l internally. No other (except vim) app did it so far (there existed a hack that did the reversal of input for classic AOS, but it fails on OS4) . On pc you need win>=2k or localized version for earlier ones. Language switching is done via OS's language switcher (one needs to add the language to the list to make it appear in the selector.)
Cygnix doesn't work well with keyboard extension enabled (remote gtk apps fail to load,I use remote mozilla from time to time, now OWB freed me from using it on regular basis, but sometimes I launch one from boxes at work to save me from downloading big files to A1 and pushing them to work from home). When disabled, keyboard switching doesn't work (othewise it could have been possible to switch keyboard layout on the fly).
All the usual X11 apps rely on keyboard switching on the X11 servers side.

Fonts are OS4 builtin ones, most of them have Hebrew support.

_________________
Resized Image
"the expression, 'atonal music,' is most unfortunate--it is on a par with calling flying 'the art of not falling,' or swimming 'the art of not drowning.'. A. Schoenberg
   Report Go to top

Re: OWB 2.16 (2.17 up)
Just popping in
Joined:
2006/11/27 17:27
Posts: 237
There was a problem for me with all prior versions when started after PageStream 68k. It crashed on start.
The 2.17 version (maybe all 2.14+) solved this which is great because I don't have to keep in mind the starting order of my crucial softwares.

Thanks Joerg!

   Report Go to top

Re: OWB 2.16 (2.17 up)
Just popping in
Joined:
2008/8/22 0:02
Posts: 54
@joerg: it is working better now it seems, but the bug that hangs the system when you interact with owb while its loading a page is still making apperarance now and then. like when you input something into the adress bar or klick on an already rendered link.

   Report Go to top

Re: OWB 2.16
Just popping in
Joined:
2007/5/1 12:59
Posts: 149
@Amigamancer

Quote:

Amigamancer wrote:
@joerg

Quote:
programs using ixemul.library need a minimal GeekGadgets installation (ENV[ARC]:ixemul.prefs, ENV[ARC]:IXGMTOFFSET, executing GG:Sys/S/GG-Startup from your S:user-startup to create the assigns, etc., the files in ETC: (GG:etc), ...).

I don't know about OWB 1.4, but this isn't correct for most, if not all, linux ports that i have tried. I don't have a GG installation/assigns or any IXxxx enviroment variable and everything works fine.


it doesn't starts here with CGX4 (AmigaOS3.9BB2)

It looks for Picasso96API.library

   Report Go to top

Re: OWB 2.16 (2.17 up)
Just popping in
Joined:
2008/8/22 0:02
Posts: 54
at joerg: also i tried the 1.4 version for 68k. does it mean that you are going to continue this development?

are you aware that soeone seems to have made extensions to 68k ixemul libraries, now version 48.3 that you can find on this site: http://megacz.back2roots.org

i do not know why he didnt post it to aminet neither can i judge the quality of improvements, but i downloaded it, installed the appropriate versions and they are working with your current 68k owb port.

   Report Go to top

Re: OWB 2.16 (2.17 up)
Just can't stay away
Joined:
2007/2/23 13:49
From Finland, the land of Santa, sauna, sisu and salmiakki
Posts: 1116
OWB is getting faster and faster with every release. It's becoming more and more useful. Great !

_________________
Rock lobster bit me, so excuse me.
X1000 + AmigaOS 4.1 FE
"Anyone can build a fast CPU. The trick is to build a fast system." - Seymour Cray
   Report Go to top

Re: OWB 2.16 (2.17 up)
Just can't stay away
Joined:
2006/12/1 19:07
From Germany
Posts: 1022
@nbache
Quote:
Is it just me, or does text render bigger now than before? I assume it could be adjusted with the XDPI and YDPI tooltypes, but I'd like to know if it is "bug or feature" before experimenting with those.

One example where it is very obvious to me is my own site, http://nbache.dk/
Since you don't specify any fonts on your homepage the default fonts of the browers are used, in OWB 2.16 I changed them from the MicroSoft core fonts to the DejaVu fonts included in AmigaOS 4.1. IMHO most pages look better that way, for example http://utilitybase.com/

Unfortunately I can't get it right using the AmigaOS font engine no matter what I try, if it wouldn't be unusable slow for users who have FONTS:_TrueType on a FFS partition I would switch back to libfreetype instead.

To get the same as in OWB <= 2.15 with your main page use the following
...
<
title>Pictures from Amiga shows</title>
<
style type="text/css"
<!--
body {
   
font-family"Times New Roman"Timesserif;
}
-->
</
style>
</
head>
...


If you want to use the fonts the users want to use, the ones they have configured in their browser settings (not possible in OWB yet), but smaller than on other sites use for example
<style type="text/css"
<!-- 
body {
   
font-size75%;
}
-->
</
style>


Or specify both the font families and sizes like in the following bad example, you should either use relative or absolute font sizes but not both, for your main page
<style type="text/css"
<!-- 
body {
   
font-familyArialHelveticasans-serif;
   
font-size80%;
h2 {
   
font-family"Comic Sans MS"Helveticasans-serif;
   
font-size50px;
}
th {
   
font-familyVerdanaHelveticasans-serif;
   
font-size120%;
}
td {
   
font-familyGeorgiaTimesserif;
   
font-size11px;
}
-->
</
style>




@Amigamancer
Quote:
I don't know about OWB 1.4, but this isn't correct for most, if not all, linux ports that i have tried. I don't have a GG installation/assigns or any IXxxx enviroment variable and everything works fine.
It doesn't. Unless you are in a country where currently the local time is GMT, for example UK or Portugal in winter, either the local time or GMT is wrong for programs using ixemul if ENV:IXGMTOFFSET is missing. To create IXGMTOFFSET, I don't remeber if ixemul.library does it automatically or if you have to run BIN:ixtimezone manually, the TZ variable has to be set correctly, for example here to Europe/Berlin, and the zoneinfo files are required (ETC:zoneinfo/$TZ). It's the same for ixemul.prefs: The builtin defaults ixemul.library uses when it's missing might work for you, but not for others. ixemul programs starting other programs need BIN:sh. If they use pipes IXPIPE: has to be mounted. ...



@Framiga
Quote:
it doesn't starts here with CGX4 (AmigaOS3.9BB2)

It looks for Picasso96API.library
As written in the readme it requires Picasso96. For CGX users installing http://aminet.net/package/driver/video/P96Emu should work.



@wawa
Quote:
also i tried the 1.4 version for 68k. does it mean that you are going to continue this development?
No.

Quote:
are you aware that soeone seems to have made extensions to 68k ixemul libraries, now version 48.3 that you can find on this site: http://megacz.back2roots.org
The other updated libraries there (xml2, pthreads, freetype, ...) would have been much more important for an usable AmigaOS 3.9/m68k OWB port, but I didn't know anything about this page.

   Report Go to top

Re: OWB 2.16 (2.17 up)
Just popping in
Joined:
2008/8/22 0:02
Posts: 54
@joerg


[Quote]
@wawa
Quote:
also i tried the 1.4 version for 68k. does it mean that you are going to continue this development?
No.
[/Quote]
that hurts.. oughh. auch if its probaby most reasonable. but why did you do an update in this case?

[Quote]
Quote:
are you aware that soeone seems to have made extensions to 68k ixemul libraries, now version 48.3 that you can find on this site: http://megacz.back2roots.org

The other updated libraries there (xml2, pthreads, freetype, ...) would have been much more important for an usable AmigaOS 3.9/m68k OWB port, but I didn't know anything about this page.
[/Quote]

at least now you know the site.

   Report Go to top


« 1 (2) 3 »



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project