Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
101 user(s) are online (56 user(s) are browsing Forums)

Members: 1
Guests: 100

davec555, more...

Support us!

Headlines

 
  Register To Post  

« 1 2 (3) 4 »
Re: ProTracker clone
Amigans Defender
Amigans Defender


See User information
@smarkusg

Quote:
bad new... all save function are affected

That teaches the author for not using libsndfile! If he had used this cross-platform standard library instead of his own code, not only would more sample formats be supported but also endianness would play no role because libsndfile is endian-agnostic.

The Rear Window blog

AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon RX 560 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
Go to top
Re: ProTracker clone
Not too shy to talk
Not too shy to talk


See User information
@beworld
Quote:
L30 - L48 - L49: add ....


Ok, I have changed the values in these lines - it is ok
I changed similarly SAVE SAMPLE and it seems ok

* - tomorrow I will have more time to check more mods and samples.

Is the Morphos version as you stated here
https://www.amigans.net/modules/newbb/ ... id=144224#forumpost144224

includes these fixes ? because on Morphos there were errors when exporting the sample mod as I sent you. On AOS4 it is already ok.

You're right - I also checked "MOD2WAV" -generates some nonsense - even without a wav file header.

Go to top
Re: ProTracker clone
Just popping in
Just popping in


See User information
@smarkusg

Same progress here, i fix SAVE MODULE / SAVE SAMPLER

i disable MOD2WAV and release new beta for MorphOS

Go to top
Re: ProTracker clone
Quite a regular
Quite a regular


See User information
@trixieQuote:
trixie wrote:@smarkusg

Quote:
bad new... all save function are affected

That teaches the author for not using libsndfile! If he had used this cross-platform standard library instead of his own code, not only would more sample formats be supported but also endianness would play no role because libsndfile is endian-agnostic.


smarkusg has compiled a new version, it contains some fixes, could you test it again on your machine?

.Mod/Sample (.iff) Saving, loading and playback should not cause any problems. I did a few quick tests and it works as it should.

Otherwise there would still be the possibility that I could contact the PT2 clone developer "8bitbubsy" and point out current problems with AmigaOs.4.1 and MorphOs. Maybe it could be helpful to be able to get a clean port with all functions.

https://wetransfer.com/downloads/0d825 ... af7020231113213548/c1ec2c

- bugfix SAVE MODULE / SAVE SAMPLER
- sampler function disabled

@all

Of course everyone can take part in the testing...


Edited by Maijestro on 2023/11/14 16:17:35
Edited by Maijestro on 2023/11/14 16:22:22
MacStudio ARM M1 Max Qemu//Pegasos2 AmigaOs4.1 FE / AmigaOne A1222plus AmigaOs4.1 FE
Go to top
Re: ProTracker clone
Just can't stay away
Just can't stay away


See User information
@Maijestro

55-60% CPU usage on my X1000 with a fast module. No stereo ?

Except this, it seems to be working as expected.

--
AmigaONE X1000 and Radeon RX 560
Go to top
Re: ProTracker clone
Quite a regular
Quite a regular


See User information
@K-LQuote:
K-L wrote:@Maijestro
55-60% CPU usage on my X1000 with a fast module. No stereo ?


The CPU load should be okay, although not optimal. Also take a look at the protracker.ini "Audio settings", here you can play around with the settings. If you only use the test binary, the Protracker.ini and its settings are not available and standard values are configured. You should test it in combination with the Os4depot version.

http://os4depot.net/?function=showfil ... dio/tracker/pt2_clone.lha

[AUDIO SETTINGS]
Audio output frequency
;        SyntaxNumberin hertz
; Default value48000
;       CommentRanges from 44100 to 192000. Does not apply to MOD2WAV.
;
FREQUENCY=48000

Audio input frequency
;        SyntaxNumberin hertz
; Default value44100
;       CommentRanges from 44100 to 192000. This should be set to match
;         the frequency used for your audio input device (for sampling).
;
SAMPLINGFREQ=44100

MOD2WAV output frequency
;        SyntaxNumberin hertz
; Default value44100
;       CommentRanges from 44100 to 192000.
;
MOD2WAVFREQUENCY=44100

Filter model (Amiga model)
;        
SyntaxA500 or A1200
; Default valueA1200
;       CommentSelects what kind of Amiga to simulate (lp/hp filters).
;         
A1200 has sharper sound but more aliasing, while A500 has more
;         filtered (muddysound but less aliasingThe filter model can
;         also be toggled by pressing F12 in the program.
;
FILTERMODEL=A1200

Stereo separation
;        Syntax0 to 100 (percent)
; Default 
value20 (good value for headphones)
;       
CommentSet to 100 for the hard panning Amiga uses.
;         
Set to 0 for monowhich might be preferred in some cases.
;
STEREOSEPARATION=20

Audio buffer size
;        SyntaxNumberin unit of samples (not bytes)
; Default 
value1024
;       CommentRanges from 128 to 8192. Should be a number that is 2^n
;          (1282565121024204840968192, ...). The number you input
;          isn't necessarily the actual value the audio API decides to use.
;          Lower means less audio latency but possible audio issues, higher
;          means more audio latency but less chance for issues.
;
BUFFERSIZE=1024

; End of config file

MacStudio ARM M1 Max Qemu//Pegasos2 AmigaOs4.1 FE / AmigaOne A1222plus AmigaOs4.1 FE
Go to top
Re: ProTracker clone
Just can't stay away
Just can't stay away


See User information
@Maijestro

Thanks for the explanation :)

--
AmigaONE X1000 and Radeon RX 560
Go to top
Re: ProTracker clone
Not too shy to talk
Not too shy to talk


See User information
@beworld
Quote:
@smarkusg

Same progress here, i fix SAVE MODULE / SAVE SAMPLER

i disable MOD2WAV and release new beta for MorphOS


Thanks for the information - I checked your port. Great job.

Go to top
Re: ProTracker clone
Quite a regular
Quite a regular


See User information
@smarkusgQuote:
smarkusg wrote:@beworld
Quote:
@smarkusg

Same progress here, i fix SAVE MODULE / SAVE SAMPLER

i disable MOD2WAV and release new beta for MorphOS



The test build you sent me is the final version for now?

Or will there be another build with updates, I'm only asking because otherwise I'll upload the archive to os4depot with the new bug-fixed version.

MacStudio ARM M1 Max Qemu//Pegasos2 AmigaOs4.1 FE / AmigaOne A1222plus AmigaOs4.1 FE
Go to top
Re: ProTracker clone
Not too shy to talk
Not too shy to talk


See User information
@Maijestro

You have to ask @trixie if this version meets his current expectations. He is probably the most involved in the topic to make pt2-clone work as well as possible.
It is possible that he has already compiled a better version himself.
Updating a not fully working version every few days on os4depot is probably not the best idea.

Go to top
Re: ProTracker clone
Quite a regular
Quite a regular


See User information
@smarkusgQuote:
smarkusg wrote:@Maijestro

You have to ask @trixie if this version meets his current expectations. He is probably the most involved in the topic to make pt2-clone work as well as possible.
It is possible that he has already compiled a better version himself.
Updating a not fully working version every few days on os4depot is probably not the best idea.


In my opinion it doesn't matter how often an archive is updated. If this means program xyz works better under AmigaOs4.1. It is better to update a program than to do nothing and leave it unfinished and unusable. There are countless cases of this on os4depot because many people don't care.

It shows people that quick fixes have taken place.

MacStudio ARM M1 Max Qemu//Pegasos2 AmigaOs4.1 FE / AmigaOne A1222plus AmigaOs4.1 FE
Go to top
Re: ProTracker clone
Amigans Defender
Amigans Defender


See User information
@Maijestro

The new version works very well, saving data looks fixed. The only serious problem I get is when I click on the "Sample" button in the Sampler section. The program just stops responding; no freeze but nothing can be selected any more.

@smarkusg

Quote:
It is possible that he has already compiled a better version himself.

No, I stopped messing with the PT2 clone seeing that you're working on it in cooperation with beworld; you two are doing a great job.

The Rear Window blog

AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon RX 560 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
Go to top
Re: ProTracker clone
Quite a regular
Quite a regular


See User information
@trixieQuote:
trixie wrote:@Maijestro

The new version works very well, saving data looks fixed. The only serious problem I get is when I click on the "Sample" button in the Sampler section. The program just stops responding; no freeze but nothing can be selected any more.


I was also able to replicate it under Qemu Pegasos2, the program freezes without any error message. I can also see on the CPU display that the resources such as RAM/CPU are then released. As if the tracker has been stopped and the window is wearing out too. hmmm strange...

MacStudio ARM M1 Max Qemu//Pegasos2 AmigaOs4.1 FE / AmigaOne A1222plus AmigaOs4.1 FE
Go to top
Re: ProTracker clone
Not too shy to talk
Not too shy to talk


See User information
Quote:
The only serious problem I get is when I click on the "Sample" button in the Sampler section.


Yes - I checked.
The debug from SDL2 looks like this when frozen

--
[
OS4_SetPointerForEachWindowSetting pointer object 0x615A11E4 (type 16) for window 0x615A18C0
[SDL_CreateMutexCreated mutex 0x6FFAA2C0
[OS4_OpenDevicedevname (null)
[
OS4_OpenDevice16 bits requested, use AUDIO_S16MSB
[OS4_OpenDeviceSDL audio format 0x9010
[OS4_OpenDeviceBuffer size 4096
[OS4_OpenDeviceChannels 2
[OS4_OpenDeviceAHI format 0x3
[SDL_SYS_CreateThreadNode 0x6155EDA0
[SDL_SYS_CreateThreadCreated new thread 'SDLAudioC3' (task 0x62AA1850)
[
OS4_RunThreadThis task 0x62AA1850node 0x6155EDA0SDL_Thread 0x601A2F90
[OS4_TimerCreateCreating timer 0x6155EDB0 for task 0x62AA1850
[SDL_SYS_SetThreadPriorityChanged task 0x62AA1850 priority from 0 to 5
[OS4_ThreadInitCalled
[OS4_OpenAhiDeviceahi.device opened
[OS4_OpenAhiDeviceIO requests created
[OS4_OpenAhiDevicedeviceOpen 1
[OS4_CaptureFromDeviceStart recording
[SDL_SYS_WaitThreadWaiting for 'SDLAudioC3'
--


Currently I have blocked these two things. The theme is not the last solution, but it is better not to cause problems until possible improvement.
I tried to hide it , that is samples blocked only when selecting sample and MOD2WAV only when approving. It will not be so striking to those people who have no intention of using it.
The rest of the functionality should work. Sorry for the problems.

I will ask @Maijestro to edit the post with new files : https://www.amigans.net/modules/newbb/ ... id=144339#forumpost144339
so as not to litter the forum.
Also a request for @trixie to check if everything is working now. He is probably the most knowledgeable person on the PT topic - thank you for your help.

Go to top
Re: ProTracker clone
Quite a regular
Quite a regular


See User information
@all

Test version updated, see post:

https://www.amigans.net/modules/newbb/ ... id=144339#forumpost144339

Please test it...

MacStudio ARM M1 Max Qemu//Pegasos2 AmigaOs4.1 FE / AmigaOne A1222plus AmigaOs4.1 FE
Go to top
Re: ProTracker clone
Just can't stay away
Just can't stay away


See User information
@smarkusg

Maybe some issue in SDL2 audio capture code. Testaudiocapture binary doesn't seem to work properly anymore either.

Go to top
Re: ProTracker clone
Not too shy to talk
Not too shy to talk


See User information
@Capehill

I also checked testaudiocapture in the test directory with the SDL2 source when he filed the problem @trixie.
I didn't write about it because I checked on the old SDL2 sources and thought that was the problem.
I don't know what SDL2 sources Morphos uses but the version in morphos-store pt2clone has the same problem.

Thanks @Capehill for checking


and as for the pt2clone itself the mod problem with the export should be able to be fixed with the use of.
https://aminet.net/package/mus/edit/mod2wav
It works better than the export itself implemented in pt2clone and it should be possible to adapt it

Go to top
Re: ProTracker clone
Not too shy to talk
Not too shy to talk


See User information
@Maijestro

It seems to be working fine , no one has any problems. Please add the new version to os4depot.
The topic will be currently closed.
Thank you

Go to top
Re: ProTracker clone
Quite a regular
Quite a regular


See User information
@smarkusgQuote:
smarkusg wrote:@Maijestro

It seems to be working fine , no one has any problems. Please add the new version to os4depot.
The topic will be currently closed.
Thank you


PT2-Clone is a great port, although not perfect, but most people will probably just use this tracker to play a few mods and get a bit of a retro feel.

This port is much more usable than the original PT2 clone version of Os4Depot.

I will update the archive to Os4Depot. Thanks

Edit: Could you perhaps send me the source code with your work so that I can put it in the archive?


Edited by Maijestro on 2023/11/17 18:12:22
MacStudio ARM M1 Max Qemu//Pegasos2 AmigaOs4.1 FE / AmigaOne A1222plus AmigaOs4.1 FE
Go to top
Re: ProTracker clone
Not too shy to talk
Not too shy to talk


See User information
@Maijestro
Yes , I think it is currently better to make a patch and I will send you. I will also put it on github. The current version is not suitable for uploading to the repository. It is an open project and out of respect for the author of the code, every modification should be available and not hidden in a cupboard.

Go to top

  Register To Post
« 1 2 (3) 4 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project