Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
39 user(s) are online (22 user(s) are browsing Forums)

Members: 1
Guests: 38

Arthas, more...

Headlines

 
  Register To Post  

(1) 2 »
XMP 3.0 [solved]
Quite a regular
Quite a regular


See User information
Link to Aminet to XMP and the TuneNet plugin is lamentably broken.

edit: was, for a time. Thanks for listening!


Edited by Thematic on 2010/1/10 3:54:06
Go to top
Re: XMP 3.0
Amigans Defender
Amigans Defender


See User information
@Thematic

Works here. Maybe Aminet was down at the time?

Go to top
Re: XMP 3.0
Home away from home
Home away from home


See User information
@Chris

Imho it must be on os4depot too. Aminet suck today, and os4depot rokz (for os4 files of course).

Trying aminet version now, and have:

Package 'mus/play/xmp.lha' not found

Imho better just upload that to os4depot (if it was ported by you ?)

Go to top
Re: XMP 3.0
Amigans Defender
Amigans Defender


See User information
On closer inspection there is a problem - the database lists the files but the actual files aren't there. I've brought it to the attention of the Aminet admins.

Thanks for reporting.

Go to top
Re: XMP 3.0
Home away from home
Home away from home


See User information
@Chris

You avoid os4depot.net at all by some reassons ?:) (i see that not only i ask you about uploading it on os4depot too, but also spotup in the thread on AW.net).

Go to top
Re: XMP 3.0
Amigans Defender
Amigans Defender


See User information
@kas1e

Aminet is easier to upload to and has more redundancy. If I only upload to one place, I can keep track of versions, and with Aminet I can upload 68k builds as well.

If I start uploading things to OS4Depot I lose track of which versions are where, or it doubles the amount of work I have to do on releases. I have no problem with others uploading my stuff to OS4Depot, but I won't usually do it myself and downloaders should be aware that it isn't necessarily the latest version.

In this case there has been a glitch, but the first one in over ten years of uploading to Aminet isn't bad.

Go to top
Re: XMP 3.0
Home away from home
Home away from home


See User information
@Chris

It's no problems if i will upload to os4depot your latest os4 progs:

Ale Image processor accepting multiple inputs
XMP plugin for tunenet
XMP Extended Module Player

?

Go to top
Re: XMP 3.0
Amigans Defender
Amigans Defender


See User information
@kas1e

No problem at all.

Go to top
Re: XMP 3.0
Just popping in
Just popping in


See User information
@Thematic

here is the correct link : http://www.aminet.net/package/mus/play/xmp.lha
.

Try it. It works to me.

Nic

Go to top
Re: XMP 3.0 [solved]
Quite a regular
Quite a regular


See User information
BTW:

The XMP plugin chrashes here with TuneNet 0.92 (OS4.1 Update 1 Edition) if you start TuneNet a second time (not re-entrable?). I had to switch back to the "old" XMP plugin.

BTW, 2.: Off-topic -> while fiddling with XMP/TuneNet I discovered crashes with the "Sony/Expensive"-Skin which were caused by the BMP.datatype - or to be more precise - the nsbmp sobj. I found a newer nsbmp sobj in the NetSurf 3 package - this seem to work with no problem. Maybe someone should update the nsBMP.datatype in os4depot to the newer sobj ??

X1000|II/G4|440ep|2000/060|2000/040|1000
Go to top
Re: XMP 3.0 [solved]
Amigans Defender
Amigans Defender


See User information
@cha05e90

Yes, I saw that, I don't think it's re-entrancy as it worked with the previous TuneNet. I'm not doing anything with it until I see the new plugin SDK, but the source is at http://xmp.sf.net if anybody wants to look at it in the meantime.

nsbmp datatype - I didn't know anyone used it! I've just updated libnsbmp.so.0 in the archive and re-uploaded. Thanks for the report.

Go to top
Re: XMP 3.0 [solved]
Quite a regular
Quite a regular


See User information
@Chris

Thanks for your reply!

I use (almost) *everything* you did for OS4.x ... - thanks for all your efforts as well!

X1000|II/G4|440ep|2000/060|2000/040|1000
Go to top
Re: XMP 3.0 [solved]
Not too shy to talk
Not too shy to talk


See User information
@Chris and cha05e90

How exactly do you replicate the crash? I've noticed this thread and wanted to investigate, but haven't been able to reproduce yet.

Cheers,
Bean.

OS4.1 + an A1XE with an appetite for batteries!
Go to top
Re: XMP 3.0 [solved]
Just can't stay away
Just can't stay away


See User information
Hi @Chris

>TuneNet 0.92 (OS4.1 Update 1 Edition)
It just crashes, period, on datatype.

Go to top
Re: XMP 3.0 [solved]
Quite a regular
Quite a regular


See User information
@bean

My post actually describes TWO different (and I suppose not related to each other) crashes:

1. I have installed Chris' BMP.datatype which uses a shared object named nsbmp.sobj. The version which can be found in OS4Depot does NOT work with OS4.1 Update 1 anymore - so if TuneNet tries to load a skin with BMPs (i.e. the SONY skin) TuneNet crashes.

Chris did a newer version of the SObj in the meantime (part of Netsurf 3) which works o.k. with OS4.1 update 1 - so the solution already exists ...

2. Having Chris XMP plugin in the plugins drawer you can start TuneNet, play music, switch skins etc. - it works as expected. If you QUIT TuneNet (I mean really QUIT - not only iconify) and start it AGAIN it crashes.

The plugin worked fine with the 8x.xx version of TuneNet.

X1000|II/G4|440ep|2000/060|2000/040|1000
Go to top
Re: XMP 3.0 [solved]
Not too shy to talk
Not too shy to talk


See User information
@cha05e90

Ah right, thanks. I just managed to reproduce it. It looks like an issue with the plugin.

The crash seems to occur (at least on my machine) during the "TestPlayer" phase on the "second" TuneNet run. The actual crash points to a function within the XMP plugin called "register_format()" (from xmp_init_formats() within xmp_init())

I don't know if that helps anyone tracking the bug down. I've a lot to do at the moment, but I'll try and get round to releasing the plugin SDK soon. Essentially all the old methods should still work (there are just some better ways of doing things - especially regarding tune information), but I do understand it's never been properly documented.

Cheers,
Bean.

OS4.1 + an A1XE with an appetite for batteries!
Go to top
Re: XMP 3.0 [solved]
Amigans Defender
Amigans Defender


See User information
@Snuffy

Yes, it does. Remove the DataType plugin for now, it'll be updated soon.

@bean

xmp_init gets called from InitPlayer and TestPlayer, there is no difference between them. I don't see why it was working, and now it doesn't, hence my desire to wait for the new plugin SDK before doing anything - I might be able to restructure it.

Incidentally the code was based on my DataType plugin which, as Snuffy notes, crashes similarly when TuneNet starts up. So whatever fixes that might fix the XMP one

Go to top
Re: XMP 3.0 [solved]
Not too shy to talk
Not too shy to talk


See User information
@Chris

Quote:
Incidentally the code was based on my DataType plugin which, as Snuffy notes, crashes similarly when TuneNet starts up. So whatever fixes that might fix the XMP one


OK, I'll take a look at it this weekend

OS4.1 + an A1XE with an appetite for batteries!
Go to top
Re: XMP 3.0 [solved]
Amigans Defender
Amigans Defender


See User information
@bean

Ta. Actually, why is TestPlayer being called on startup?

Go to top
Re: XMP 3.0 [solved]
Not too shy to talk
Not too shy to talk


See User information
@Chris

Quote:
Ta. Actually, why is TestPlayer being called on startup?


It was just verifying some tunes I had in the playlist.

OS4.1 + an A1XE with an appetite for batteries!
Go to top

  Register To Post
(1) 2 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project