Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
41 user(s) are online (30 user(s) are browsing Forums)

Members: 1
Guests: 40

kas1e, more...

Headlines

 
  Register To Post  

(1) 2 »
usb boot iso over amidvd on x5k questions
Home away from home
Home away from home


See User information
@All
Want to made an emergency usb boot for x5k, but have some strange issue, maybe have a clue ..

What i do now is : take the x5000_install.iso , then, mount it via diskimage gui, and copy whole content to some directory, let's say "new_iso"

Then, i add RadeonRX.chip to the new_iso/System/Kickstart, and add line "MODULE Kickstart/RadeonRX.chip", to the both new_iso/Kickstart/kicklayout, and to the new_iso/System/Kickstart/kicklayout.

Now via rawwrite32 i burn this ISO to usb-stick, put usb-stick inside of x5000, reboot, "Esc", "usb reset" to see this usb stick, and after "Boota".

Then, things start to loads up, i see AmigaOS logo (meaning RadeonRX driver loads fine), then usuall amigaos4 install image (that one which have words "booting" in black color) , and then nothing happens.

I.e. the window asking what to do next (continue to wb futher, install or prepate, etc) do not show up.

The iso i creates is with AmiDVD on my x1000, and i give it a name as in original "AmigaOS 4.1 Final Edition", and also hit "boot AmigaOS4" mark.

On serial also nothing. Just like nothing else executes futher, while should.

If anyone have any idea where to check next, you are welcome. Maybe i just forget something which need to be done with AmiDVD.. Or maybe AmiDVD do or not do something..

Thanks!

Go to top
Re: usb boot iso over amidvd on x5k questions
Not too shy to talk
Not too shy to talk


See User information
@kas1e

I had the same problem when I added RadeonRX but I found a solution -

Open "AmigaOS 4.1 Final Edition:Installation-Support/startprefs.bat"
and comment out the following lines:

;:Installation-Support/CheckHardwareCompose
;if $RC EQ 0
;copy :Installation-Files/GUI-compose.prefs env:sys/GUI.prefs
;setenv _INSTALL_HWACCEL 1
;else
copy :Installation-Files/GUI.prefs env:sys
setenv _INSTALL_HWACCEL 0
;endif


I guess the "CheckHardwareCompose" app gets confused/crash when booting with a RadeonRX card/driver.

1989-> A500, A600, A3000, A4000, A1200, CD32, µA1, PegII, A1XE, CDTV, Amy/416D79, A1X5000, Vampire 500 V2+, Vampire 600 V2, Amy-ITX, Denise ITX <-2022
Go to top
Re: usb boot iso over amidvd on x5k questions
Just popping in
Just popping in


See User information
@khayoz

Thanks for the hint
that works perfectly

Go to top
Re: usb boot iso over amidvd on x5k questions
Quite a regular
Quite a regular


See User information
@khayoz

Nice.

Additional tip for the X5000/40 :

Replace ehci.usbhcd with the version from the AmigaOS 4.1FE update2 archive or the mouse and keyboard wont work.

Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
Go to top
Re: usb boot iso over amidvd on x5k questions
Home away from home
Home away from home


See User information
@khayoz
Oh cool ! It works ! Thanks a bunch :) Probabaly this one need a bit of checking , as seems there some bug or something. I do have serial attached when things stop, but have nothing on serial. So didn't looks like crashes, mostly like some "busy loop" or something

Go to top
Re: usb boot iso over amidvd on x5k questions
Just popping in
Just popping in


See User information
@kas1e

I found for my RX580 that you can force the 'compose' settings and it works correctly. Saves having to change the settings yourself later.

copy :Installation-Files/GUI-compose.prefs env:sys/GUI.prefs
setenv _INSTALL_HWACCEL 1

Go to top
Re: usb boot iso over amidvd on x5k questions
Quite a regular
Quite a regular


See User information
@khayoz

That also worked for the Sam460.

Cheers

Go to top
Re: usb boot iso over amidvd on x5k questions
Home away from home
Home away from home


See User information
@TiredOfLife
Interesting when i install os4 on my sam (which also have RadeonRX) i didn't have such problem.

Maybes that all related to different radeons ? I mean i use some older RadeonRX version for sam460 when install os4, it was something like 2.3 or 2.4 do not remember. But latest ones are 2.11 for public, so maybe issue starts somewhere after 2.7 or so (there was some heavy code changes in the drivers if i understand that correctly).

In other words, it can be some new bug in radeonrx

Go to top
Re: usb boot iso over amidvd on x5k questions
Just popping in
Just popping in


See User information
I once put an illustrated guide on how I created the stick online. Unfortunately in German, but you can use google translate for the link. However, the menu on the left is then a bit "shifted"

https://g-a-p.me/inside/x5kbootstick.html (german)

same link above via google translate

Go to top
Re: usb boot iso over amidvd on x5k questions
Quite a regular
Quite a regular


See User information
@kas1e

No Composite Support with the RadeonHD Lite version on the Sam460ex ISO .

Quote:
Lite version is supplied as an OEM driver under agreement to third parties. This version is intended for emergency boot and installation of the AmigaOS4.1 Final Edition CD and therefore is limited to 800x600 pixel screen resolution and compositing is not possible. It does not contain any SPE-FPU optimisations and it does not support 64-bit VRAM.



"AmigaOS 4.1 Final Edition:Installation-Support/startprefs.bat"


; $VER: OS4-Installation 53.4 (15.11.2014)
; (W) by Martin Steigerwald
; (W) by Richard Drummond
; (W) by Hans-Joerg Frieden
; (W) by Simon Archer
; (W) by Carl Moppett

;Modified for RadeonHD Lite

FailAt 21

:Installation-Support/SetCDEnv

:Installation-Support/CheckHardwareCompose
if $RC EQ 0
copy :Installation-Files/gui.prefs env:sys/gui.prefs
setenv _INSTALL_HWACCEL 0
else
copy :Installation-Files/gui.prefs env:sys/gui.prefs
setenv _INSTALL_HWACCEL 0
endif

IPrefsCTRL PAUSE

:Installation-Support/CDWelcome/CDWelcome

Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
Go to top
Re: usb boot iso over amidvd on x5k questions
Home away from home
Home away from home


See User information
@Spectre
Quote:

No Composite Support with the RadeonHD Lite version on the Sam460ex ISO .


I know that of course, but there we load up with RadeonRX driver which we add to the sam460's ISO, RadeonHD is of no use there, and this kind of "stuck" in the startprefs.bat we have exactly with RadeonRX. I didn't tested with RadeonHD, maybe there can be issue also with lite version, but what we all test there is RadeonRX, which do have composite support, and didnt' restricted to anything.

Why then when we use RadeonHD full driver, it loads up fine and pass this compositing check, but when we use full RAdeonRX driver, we didn't pass this check and stuck on.

Sounds like RAdeonRX issue, or i missed the point ? Can you a bit explain your previous post plz ?

Go to top
Re: usb boot iso over amidvd on x5k questions
Quite a regular
Quite a regular


See User information
@kas1e

For the Sam460ex the script sets

setenv _INSTALL_HWACCEL 0

in all cases.

And unlike the X1000 script there is no


:Installation-Files/GUI-compose.prefs env:sys/GUI.prefs

line so no compositing option set at installation with any video card.


Edited by Spectre660 on 2022/11/14 16:04:54
Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
Go to top
Re: usb boot iso over amidvd on x5k questions
Home away from home
Home away from home


See User information
@Spectre
Quote:

line so no compositing option set at installation with any video card.


Right... Then i not understand what mean TiredOfLife saying "That also worked for the Sam460.". I readi it like it did the trick for sam460 as well, like before he have the same issue as well.

Go to top
Re: usb boot iso over amidvd on x5k questions
Quite a regular
Quite a regular


See User information
@kas1e

You understood me well.
I did have an issue before.
Previously The CD wouldn't boot with the RX driver.
Just kept getting stuck at a black screen.
With the amendments as suggested by Khayoz, it now does.

Cheers

Go to top
Re: usb boot iso over amidvd on x5k questions
Quite a regular
Quite a regular


See User information
@TiredOfLife

Interesting.

When I did my Sam460 version I just added the Radeon RX driver to the kicklayout and it boots ok.
I created a USB drive which is writable instead of an ISO or DVD.
Using an Radeon Rx550 4B.
The updated version I did on Sunday gone also works with no other adjustments. Boot USB uses SFS/00 .

Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
Go to top
Re: usb boot iso over amidvd on x5k questions
Quite a regular
Quite a regular


See User information
@Spectre660

That is wierd.
I'd also amended the kicklayout as well originally but no joy.
Using an RX560.

I can't remember if it was version 2.8 or 2.11 of the RX driver.
Kas1e thought he had also done it with a version earlier than 2.8.

I did have 2.11 installed before reverting to 2.8

Think I will do some further tests tomorrow,see if changing between the two without the fix makes any difference.

Cheers

Go to top
Re: usb boot iso over amidvd on x5k questions
Quite a regular
Quite a regular


See User information
@TiredOfLife


First version was a while ago.
Used version 1.11 or so of the driver
Version Sunday used version 2.12 of the driver .
but it should not make a difference .

Sam460ex : Radeon Rx550 Single slot Video Card : SIL3112 SATA card
Go to top
Re: usb boot iso over amidvd on x5k questions
Just popping in
Just popping in


See User information
@McFly

Thanks for this, I was looking for instructions like yours for some time, much appreciated!

Cheers!

Go to top
Re: usb boot iso over amidvd on x5k questions
Just popping in
Just popping in


See User information
@levellord

thank you, I hope it is helpful.
I wish you success

regards
McFly

Go to top
Re: usb boot iso over amidvd on x5k questions
Quite a regular
Quite a regular


See User information
I've done some further testing.
I can now boot from the CD without the Khayoz fix and with the RX 2.11 driver.

So something else was going in on that prevented the machine from booting.

Maybe time to look at the sata card and cable.

Cheers

Go to top

  Register To Post
(1) 2 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project