Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
158 user(s) are online (54 user(s) are browsing Forums)

Members: 0
Guests: 158

more...

Support us!

Headlines

 
  Register To Post  

« 1 2 (3)
Re: Flare enough
Just can't stay away
Just can't stay away


See User information
@Thematic

There is a function that can be used to query the renderer driver name: https://wiki.libsdl.org/SDL_GetRendere ... 29%7C%28CategoryStruct%29

Go to top
Re: Flare enough
Quite a regular
Quite a regular


See User information
Tried the Empyrean Campaign and its a very nice mod.

AmigaOne X5000
Radeon HD 7700
Go to top
Re: Flare enough
Site Builder
Site Builder


See User information
@Thematic

Capehill mentioned at
http://www.amigans.net/modules/xforum ... id=112877#forumpost112877

that the new version of SDL 2 solves Flares engine rendering. Can you check if a new compile could help to have HW Surface enabled at this fine game?

Thank you for your hard work.

Follow me on
Ko-fi, Twitter, YouTube, Twitch
Go to top
Re: Flare enough
Quite a regular
Quite a regular


See User information
@walkero Not a complete surprise, since I saw a hint maybe December or slightly after. But the rc1 doesn't do joysticks properly. So that if I were to do this now, I'd use dynamic linking, which always catches somebody off guard. I'm going to keep an eye on that, in addition to Flare updates.

But sure, this is pretty much what I have to go on wrt. building that, on AmigaOS:
gcc5 c++ can compile the code if CMAKE_CXX_FLAGS:STRING=-std=gnu++14

These are the required libraries for linking:
-lSDL2_image -ltiff -lpng -ljpeg -lwebp -lz -lSDL2_mixer -lsmpeg2 -lm
-lvorbisfile -lvorbis -logg -lflac -lmikmod -lmodplug -lstdc++ -lSDL2_ttf
-lfreetype -lz -lsdl2main -lsdl2 -lauto -lpthread -lm

For some reason, I had to expand a lot of those to point to the actual file. :I

Go to top
Re: Flare enough
Just can't stay away
Just can't stay away


See User information
@Thematic

Joystick issue plagues only non-debug build. If Flare doesn't trigger per-frame prints, linking with debug build is probably fine. (Until RC2)

Go to top
Re: Flare enough
Home away from home
Home away from home


See User information
any updates?

_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Flare enough
Quite a regular
Quite a regular


See User information
@328gts

Looks quiet. There's a 1.11 from 2019. I have definitely worked on 1.10 but ran into some issues.

Ah, I have made a note of it...

Quote:

MenuItemStorage.cpp: In member function 'void MenuItemStorage::initGrid(int, const Rect&, int)':
MenuItemStorage.cpp:58:35: warning: argument 1 range [2147483648, 4294967295] exceeds maximum object size 2147483647
[-Walloc-size-larger-than=]
highlight = new bool[_slot_number];
^
In file included from /Work/dev/adtools-os4-8-20180502-562/include/c++/8.1.0/bits/stl_construct.h:59,
from /Work/dev/adtools-os4-8-20180502-562/include/c++/8.1.0/bits/stl_tempbuf.h:60,
from /Work/dev/adtools-os4-8-20180502-562/include/c++/8.1.0/bits/stl_algo.h:62,
from /Work/dev/adtools-os4-8-20180502-562/include/c++/8.1.0/algorithm:62,
from CommonIncludes.h:23,
from EngineSettings.h:25,
from MenuItemStorage.cpp:26:
/Work/dev/adtools-os4-8-20180502-562/include/c++/8.1.0/new:122:7: note: in a call to allocation function 'void* operator new
[](std::size_t)' declared here
void* operator new[](std::size_t) _GLIBCXX_THROW (std::bad_alloc)
^~~~~~~~
MenuItemStorage.cpp: In member function 'void MenuItemStorage::initFromList(int, const std::vector<Rect>&, const
std::vector<std::__cxx11::basic_string<char> >&)':
MenuItemStorage.cpp:79:35: warning: argument 1 range [2147483648, 4294967295] exceeds maximum object size 2147483647
[-Walloc-size-larger-than=]
highlight = new bool[_slot_number];
^
In file included from /Work/dev/adtools-os4-8-20180502-562/include/c++/8.1.0/bits/stl_construct.h:59,
from /Work/dev/adtools-os4-8-20180502-562/include/c++/8.1.0/bits/stl_tempbuf.h:60,
from /Work/dev/adtools-os4-8-20180502-562/include/c++/8.1.0/bits/stl_algo.h:62,
from /Work/dev/adtools-os4-8-20180502-562/include/c++/8.1.0/algorithm:62,
from CommonIncludes.h:23,
from EngineSettings.h:25,
from MenuItemStorage.cpp:26:
/Work/dev/adtools-os4-8-20180502-562/include/c++/8.1.0/new:122:7: note: in a call to allocation function 'void* operator new
[](std::size_t)' declared here
void* operator new[](std::size_t) _GLIBCXX_THROW (std::bad_alloc)
^~~~~~~~



I suppose it's meant to work on 32-bit systems without adjustments.

Go to top
Re: Flare enough
Home away from home
Home away from home


See User information
@Thematic

is the version on OS4depot the latest to try or is there a newer beta

_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Flare enough
Quite a regular
Quite a regular


See User information
Oh, I did something like only upload to Aminet earlier once? But yes, OS4Depot has the latest build.

Go to top
Re: Flare enough
Home away from home
Home away from home


See User information
for some reason I'm getting some font error on boot running v1,09 from OS$depot?

any have the flare-game-v1.09.tar.gz file as it's not on the sourcefoprge site anymore

_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Flare enough
Site Builder
Site Builder


See User information
@328gts
I uploaded it at
http://amiga-projects.net/flare-game-v1.09.tar.gz

Try to download it and please tell me if it doesn't work.

Follow me on
Ko-fi, Twitter, YouTube, Twitch
Go to top
Re: Flare enough
Not too shy to talk
Not too shy to talk


See User information
@328gts

Just tested 1.09 (Thanks Walkero) and if you turn on Hardware Surfaces, the font will disappear.

Resized Image


Turning it off, it will come back.

Resized Image


Flare 1.09 works in full screen, I just disabled it so I can capture smaller window.

Resized Image


Below is info provided by game when starting:

INFOFlare 1.09 (AmigaOS 4)
INFOActive mods: default, fantasycore (1.09), empyrean_campaign (1.09)
INFOMessageEngineUsing language 'en'
INFOInputStateNo joysticks were found.
INFOUsing Render DeviceSDLHardwareRenderDevice (hardwareSDL 2os4)
INFORenderDevice1 display(s), using display 0 (1920x1080 60hz)
INFORenderDeviceInternal render size is 640x480
INFO
RenderDeviceWindow size is 640x480
INFO
RenderDeviceFullscreen=0Hardware surfaces=0Vsync=0Texture Filter=0
INFO
RenderDeviceDisplay DPI is 0.000000
INFO
SoundManagerUsing SDLSoundManager (SDL2amigaos4)
INFOGameStateCutsceneLoading cutscene 'cutscenes/intro.txt'
INFOGameStateCutsceneNo scenes defined in cutscene file cutscenes/intro.txt


I hope this helps!

Go to top
Re: Flare enough
Home away from home
Home away from home


See User information
@walkero

got it thanks!

@ levellord

my issue was with finding some type of fonts etc. at startup and wouldn't even let me get to main screen which was strange as I had this version running great full screen for a while..anyhow all working again

_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Flare enough
Quite a regular
Quite a regular


See User information
@328gts

The same as here, 1.09 works but with Hardware Surfaces ON fonts are disappear. :)

Amiga x5000 ı o2o ı 4GB RAM ı RadeonRX580 | SBlaster Audigy Fx - AmigaOS4.1 FInal Edition

A1200 sandwich

Warp - Croatian Amiga portal
Go to top
Re: Flare enough
Not too shy to talk
Not too shy to talk


See User information
@328gts

I am glad it's working now! Did you install some fonts or it started on it's own?

Go to top
Re: Flare enough
Home away from home
Home away from home


See User information
@VooDoo @ levelord

yes working fine now. It's been a while now not playing Flare so it could be while testing other stuff I sonehow messed up some startup fonts etc needed for Flare to boot up? who knows..all's well that ends well I say

_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Flare enough
Home away from home
Home away from home


See User information
I just noticed that when I exit Flare I get a blank screen and system freeze..have to reset my X1000. This is from a new install..strange as my previous (same version) install had no issue at exit??

Can any X1000 owners confirm if a fresh install does the same thing?

_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Flare enough
Just can't stay away
Just can't stay away


See User information
@Thematic

I built the latest Flare engine today using GCC 11.2 without compiler issues. It took some time to install all library dependencies but these are all in OS4Depot. Then I tested Flare using version 1.14 data. Starts and plays OK in SW/HW mode, based on quick tests.

Just for information if you or somebody else is interested to update the port.

Go to top

  Register To Post
« 1 2 (3)

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project