Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
53 user(s) are online (42 user(s) are browsing Forums)

Members: 2
Guests: 51

ddni, SinanSam460, more...

Headlines

 
  Register To Post

Lodepaint ??
Just can't stay away
Just can't stay away


See User information
http://dl.dropbox.com/u/5482530/Images/lodepaint.jpg

The above screenshot is what I get when I try and run the current version of Lodepaint from os4depot. How do I change this?

Go to top
Re: Lodepaint ??
Home away from home
Home away from home


See User information
@alkfil
That version which on os4depot i buid about 1 year ago, and until now i not see such kind of problems, so i assume its something going wrong with minigl/warp3d/graphics settings. Did you trying to run it in window or in fullscreen ? Or maybe that via wazp3d ? Did you try to run it first time ever, or before it works and start works wrong lately ? Or maybe you use some custom-build version of minigl ?

Go to top
Re: Lodepaint ??
Home away from home
Home away from home


See User information
@alfkil

Arggg what a grab !
Never see such problem here and i use LodePaint since day 0

What is your hardware/software config ?

Go to top
Re: Lodepaint ??
Quite a regular
Quite a regular


See User information
@alfkill
smiet spionem what a big problem

Go to top
Re: Lodepaint ?? [FIXED]
Just can't stay away
Just can't stay away


See User information
I found a related thread that tracked the problem to SDL. Apparently the OS updates 3 and 4 comes with an older SDL version, so installing the latest one fixed the problem.

What a useful little app, albeit a little slowish reactionwise.

Go to top
Re: Lodepaint ?? [FIXED]
Home away from home
Home away from home


See User information
@alkfil
Quote:

Albeit a little slowish reactionwise.


Yeah .. When we discuss all of this year ago, everything coming to the conclussion about slow minigl/warp3d combo. I even ask initiall author about speed up for the programm itself, and he say that its already works very fast on very slow windowses/PCs. In other words when gallium and so on :)

Go to top
Re: Lodepaint ?? [FIXED]
Just can't stay away
Just can't stay away


See User information
@kas1e

We are all waiting . I have just done a port of a nice little other animation app called "Pencil" (for Qt), but it is so slow, that I don't think I will release it now. Blasted minigl... :-/

Go to top
Re: Lodepaint ??
Home away from home
Home away from home


See User information
@alfkil
Quote:

I have just done a port of a nice little other animation app called "Pencil" (for Qt), but it is so slow, that I don't think I will release it now. Blasted minigl... :-/


And thats not about freetype and that pixmap/raster-by-cpu slownes ? Something else ?

I just fear that maybe we will wait too long for gallium, maybe it will worth to try to update minigl ? All in all all the other users who not have radeonhd (like peg2 users), will not have gallium as well and maybe it will worth to spend time on minigl updating ? But sure, boring and unintersting work :)

Go to top
Re: Lodepaint ??
Just can't stay away
Just can't stay away


See User information

Quote:
Quote:

I have just done a port of a nice little other animation app called "Pencil" (for Qt), but it is so slow, that I don't think I will release it now. Blasted minigl... :-/


And thats not about freetype and that pixmap/raster-by-cpu slownes ? Something else ?


It is probably a combination: Qt slowness, raster slowness, freetype slowness, minigl slowness, everything slowness... Blasted slowness...

Go to top
Re: Lodepaint ??
Home away from home
Home away from home


See User information
@alkfil
Quote:

It is probably a combination: Qt slowness, raster slowness, freetype slowness, minigl slowness, everything slowness... Blasted slowness...


:) Even freetype slownes are more than enough after i see your benchmarks in other thread .. Maybe (if you of course can find a some brave for) , worth to try to reimplement freetype stuff (to be about the same as native speed, or at least not much slower) + raster stuff. Maybe even that will be enough ?

By the way, maybe if you in interst, you can also check the LodePaint code, to see, maybe slowness of LodePaint also happens because of "raster by cpu" stuff for some fucntions ?
(there is code)

Go to top
Re: Lodepaint ??
Just can't stay away
Just can't stay away


See User information
At the moment I am implementing native font code a la broadblues in the openGL paint engine. This should speed up normal text rendering by 50%. Unfortunately it will loose the ability to paint text with a texture or gradient brushes, so it is of course going to be optional (via env variable and setable in the Qt prefs app).

I will take a look at the lodepaint code shortly!


Edited by alfkil on 2012/2/10 14:38:29
Go to top
Re: Lodepaint ??
Not too shy to talk
Not too shy to talk


See User information
Quote:
I found a related thread that tracked the problem to SDL. Apparently the OS updates 3 and 4 comes with an older SDL version, so installing the latest one fixed the problem.

Glad to help (the thread was THIS one right?)

For those making fresh installs, remember to grab the latest SDL here: http://code.google.com/p/os4sdl/

SamFlex Complete System + AmigaOS4.1 Update 4
Amiga 2000 GVP GForce-040 Picasso II AmigaOS3.9 BB2
Amiga CD-32
Go to top
Re: Lodepaint ??
Just can't stay away
Just can't stay away


See User information
@ DAX

Yes, that was the thread, and thank you very much!

Go to top
Re: Lodepaint ??
Home away from home
Home away from home


See User information
@DAX
Thanks, as I wasn't able to find the latest SDL myself.

Author of the PortablE programming language.
I love using Amiga OS4
It is pitch black. You are likely to be eaten by a grue...
Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project