Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
76 user(s) are online (48 user(s) are browsing Forums)

Members: 1
Guests: 75

trixie, more...

Support us!

Headlines

 
  Register To Post  

Daylight saving settings not saving properly in Time Prefs
Just popping in
Just popping in


See User information
Hi,
Seems like random start and end days, months and times are being saved each time I hit save and try to fix it.

Is there a workaround to get this working? or is it working for everyone else?

Thanks
Dave

Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Just popping in
Just popping in


See User information
Same thing happening here on both of my NG Amigas.

Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Just popping in
Just popping in


See User information
@davec555

I am experiencing odd behaviour with the time and calendar as well. It seems to forget the time every time I shutdown. It doesn't reset to any certain date, just fails to keep up with passing time.

Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Home away from home
Home away from home


See User information
@livebyfaith74

Sounds like a failing battery to me

Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Just popping in
Just popping in


See User information
@Raziel
You are probably right. I will just try a new one.

Thanks

Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Just can't stay away
Just can't stay away


See User information
@livebyfaith74

IIRC doing "setclock reset" may also help on some h/w.

Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Quite a regular
Quite a regular


See User information
@RazielQuote:
Raziel wrote:@livebyfaith74

Sounds like a failing battery to me


Maybe not...I have similar problem with my x5000... few days ago I had dead PSU and after I changed it with new one, and replaced clock battery, I have problem with time.

I can not get clock to work correctly, after I power off x5000 and run it again, time is started from time when I shut down Amiga. So, battery it works because it remember time and, only I think that something is wrong with OS4 and saving time to board.

Before I changed battery, everything was fine. Also, I tried three new batteries. And, I read that some other Amigans have the similar problem with x5000.

For now I am getting time via Mr.Wolf app from Os4Depot

Amiga x5000 ı o2o ı 4GB RAM ı RadeonRX580 | SBlaster Audigy Fx - AmigaOS4.1 FInal Edition

A1200 sandwich

Warp - Croatian Amiga portal
Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Just can't stay away
Just can't stay away


See User information
@VooDoo

As salass00 suggests above, try "setclock reset". Your description also sounds to me like that could help.

Best regards,

Niels

Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Quite a regular
Quite a regular


See User information
@nbacheQuote:
nbache wrote:@VooDoo

As salass00 suggests above, try "setclock reset". Your description also sounds to me like that could help.

Best regards,

Niels


I tried already but no luck. I wrote that command in shell after I set up clock in Time Prefs. Maybe I am doing something wrong?

Amiga x5000 ı o2o ı 4GB RAM ı RadeonRX580 | SBlaster Audigy Fx - AmigaOS4.1 FInal Edition

A1200 sandwich

Warp - Croatian Amiga portal
Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Just can't stay away
Just can't stay away


See User information
@VooDoo

What version of battclock.resource do you have installed ("version full battclock.resource")?

There were some fixes made for the X5000 and A1222 in 2022.

Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Home away from home
Home away from home


See User information
@all

If you're sure it's not the battery, do this right after
Quote:

AddNetInterface >NIL: <NIL: *>NIL: QUIET "DEVS:NetInterfaces/~(#?.info)"

in
s:network-startup

Quote:

date SERVER xxx.xxx.xxx.xxx

where xxx is the IP address of the time server of your choice.

It will not save it your battery clock, rather will it simply update and use the internet time (so, no strain on your clock battery ... if there is any on saving to it, that is).

I too suffer from a roughly two seconds loss on every reboot and this fixes it just fine.

Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Just popping in
Just popping in


See User information
@nbache

That seemed to work for me so far. Thanks!

Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Quite a regular
Quite a regular


See User information
@salass00Quote:
salass00 wrote:@VooDoo

What version of battclock.resource do you have installed ("version full battclock.resource")?

There were some fixes made for the X5000 and A1222 in 2022.


my battclock.resource version is 54.1 (01.05.16), where I can find and download last version?

Amiga x5000 ı o2o ı 4GB RAM ı RadeonRX580 | SBlaster Audigy Fx - AmigaOS4.1 FInal Edition

A1200 sandwich

Warp - Croatian Amiga portal
Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Just can't stay away
Just can't stay away


See User information
@VooDoo

Quote:
I tried already but no luck. I wrote that command in shell after I set up clock in Time Prefs. Maybe I am doing something wrong?
Well, after "setclock reset" the current time needs to be saved into the batterybacked clock. So after the reset, set the system time (using the date command or your Time prefs), then do a "setclock save".

But if that doesn't help, then your problem must be a different one.

Best regards,

Niels

Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Quite a regular
Quite a regular


See User information
@VooDoo

The X5000 and A1222 clock chips behave slightly differently from the chips used in earlier machines and the battclock.resource had to be upgraded for them. Not all machines were affected, it worked OK about 50% of the time.

As salass00 said, there was a new version of battclock.resource released to betatesters last year to fix this problem. It has not been released to the public yet.

cheers
tony
Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Not too shy to talk
Not too shy to talk


See User information
@davec555

Quote:
davec555 wrote:Hi,
Seems like random start and end days, months and times are being saved each time I hit save and try to fix it.

Is there a workaround to get this working? or is it working for everyone else?

Thanks
Dave


Do you mean the TimePrefs from Enhancer? It's fairly broken. I haven't seen it randomly change although I have seen it fail to correctly calculate the date as per the rules you select in the UI.

Go to top
Re: Daylight saving settings not saving properly in Time Prefs
Quite a regular
Quite a regular


See User information

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project