Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
101 user(s) are online (95 user(s) are browsing Forums)

Members: 1
Guests: 100

billt, more...

Headlines

 
  Register To Post  

I don't get ScreenMode prefs and monitors
Quite a regular
Quite a regular


See User information
So, I was testing a new monitor and needed a new resolution for it.

In ScreenMode prefs I have 3 (x3) resolution for "Board 0:". Under Monitors I have two monitors: "Radeon" and "Radeon HD 6570".

I have a HD6570 in my X1000.

The 3 resolutions I have available under Screen modes are the same as those in the Radeon monitor (which I don't think I use). The "Radeon HD 6570" monitor have several resolutions ticked than what I have available.

- What's "Board 0"? Where does it get that from?
- What's the difference between my "Radeon" and "Radeon HD 6570" monitors?
- What is a DEVS:Monitors/"monitor" anyway? The driver is a Kickstart/*.chip file.

Why can't I add a resolution on-the-fly to test? Why a reboot?!?

This prefs just seems to very unintuitive, and I've been an active Amiga user since '92. Picasso96Mode was clear and straight-forward. Technical, yes, but not fuzzy and unclear. I've also use CyberGfx and other tweak tools that could do realtime change to the frequencies etc.

Software developer for Amiga OS3 and OS4.
Develops for OnyxSoft and the Amiga using E and C and occasionally C++
Go to top
Re: I don't get ScreenMode prefs and monitors
Not too shy to talk
Not too shy to talk


See User information
@Deniil

Thank you.

I have never understood this, either, and there seems little or no documentation on the subject. Maybe someone who worked on the graphics.library overhaul some years back can comment?

-- eliyahu

"Physical reality is consistent with universal laws. When the laws do not operate, there is no reality. All of this is unreal."
Go to top
Re: I don't get ScreenMode prefs and monitors
Quite a regular
Quite a regular


See User information
@Deniil

When you say "new monitor", I assume that it is a "new" monitor, recently made, not just an old CRT. If it is an old CRT or does not support DDC, then please accept my condolences and ignore this reply.

Why do you feel the need to generate special display modes at all? Why not simply enable "Detect settings automatically" and "All supported modes"? That way you will get all the possible modes that the software and monitor can both handle.

You don't need both the "Radeon" driver and the "Radeon 6570" driver. I think the "Radeon" driver is just the original default.

The graphics library interrogates the monitor (using the DDC protocol) and obtains a list of the display modes that the monitor can handle, along with its preferred mode, min/max scan rates, etc. Graphics then strikes out any modes that the card and driver can't handle and shows you a list of what's left. The only say you have in the process is to add entries to the tooltypes of the Radeon 6570. It's better to leave them all disabled (in parentheses) and let the driver sort it out.

My Radeon 6450 driver icon has:

CMPLENGTH=14
BOARDNAME=Radeon HD 6450
DDCMODE=All
...
(lots of disabled entries)
...
DISABLEFAKENATIVE=Yes
INTERRUPT=Yes

That's enough. As a result I get modes with scan rates of 640x480 all the way up to 1920x1080 (the natural resolution of the monitor), with CLUT8, RGB16 and ARGB32 for each rate.

cheers
tony
Go to top
Re: I don't get ScreenMode prefs and monitors
Quite a regular
Quite a regular


See User information
@tonyw

Yes, it was a "new" monitor, with a higher resolution than my current modes.

I think I chose to have "hardcoded" modes rather than DDC to get fewer choises in screen mode requesters so I don't have to scroll and mess around with useless modes when using PPaint and certain pic viewers and stuff.

I did switch on DDC to test this monitor though because the modes I made manually didn't work for some reason. Wrong frequency probably...

Turns out the 6750 can't display 2560x1440 on HDMI, and my DP->DVI adapter apparently doesn't work backwards from DVI output to DP input. So couldn't use that monitor.

Still, what's "Board 0"? Is that supposed to be the first option in the cycle gadget on the monitors page or what? How hard could it be to put the actual monitor name there, when it has it in the list..? unintuitive... Also very unclear which of the Radeon "monitors" it actually picked (since none of then is called "Board 0" ), and if both were compatible with my radeon why it didn't show a selection for Board 0 and Board 1..? That GUI needs some further thought I believe.

Software developer for Amiga OS3 and OS4.
Develops for OnyxSoft and the Amiga using E and C and occasionally C++
Go to top
Re: I don't get ScreenMode prefs and monitors
Quite a regular
Quite a regular


See User information
HI, RadeonHD.chip version?

I only have one "monitor" file on DEVS:Monitors/

Radeon (and Radeon.info) with tooltypes:
CMPLENGTH=6
BOARDNAME=Radeon
DDCMODE=60Hz
(VSYNCMIN=60)
(VSYNCMAX=60)
(HSYNCMIN=31000)
(HSYNCMAX=85000)
(MODE=320x240@70D)
DISABLEFAKENATIVE=Yes
INTERRUPT=Yes

Then I get all (60Hz) screenmodes availables.
I use an HDMI (gfx) to DVI (monitor) cable.
AFAIK "Board 0" is the internal name the driver assigns to the gfx card, as you can have multiple gfx cards plugged.
But the name in ScreenModes->Monitors should be (in my case) "Radeon".

Go to top
Re: I don't get ScreenMode prefs and monitors
Not too shy to talk
Not too shy to talk


See User information
@Deniil

It is better to have only one monitor file in Devs:Monitors/, put all other unused to Storage/Monitors

You can name it "Radeon" or "Radeon HD 6570", it doesn't matter.
CMPLENGTH ... should be lenght of name of your monitor, i.e. 6 or 14
BOARDNAME ... should be name
DDCMODE=All ...is best for all modern monitors, card reads possible resolution from monitor.
Alternative is manually write here all resolutions and frequencies - don't do it, only if automatic DDC not works with old monitor.


Answers:
1. - What is a DEVS:Monitors/"monitor" anyway?
In real monitor file is not config file for monitor, but for graphics card.
You should use two or three monitor files only if you have two graphics cards on board:
see here.

2. - What's the difference between my "Radeon" and "Radeon HD 6570" monitors?
There is not much difference. Use only one file, if you have one card.
If you use two files, you cannot be sure which one the system select - system reads first config file he found.
CMPLENGHT is number of characters, which are compared from the name of monitors BOARDNAME, if there is more than one monitor files, i.e.:
if BOARDNAME="Radeon HD 6570"
CMPLENGTH=6 .... for comparison is used only string "Radeon"
CMPLENGTH=12 .... for comparison is used only string "Radeon HD 65" , etc...

3. - What's "Board 0"? Where does it get that from?
In past there were real monitor names ( BOARDNAME) in screenmode settings.
In later versions, there is no names, but
Board0 for first graphics card, Board1 for second one.
So Board0 is screen resolution on your primary graphics card.


P.S. this way it works in case of one graphics card + one monitor.
With case one graphics card + more monitors I have no experiences, you shoud try.
In real, I have connected four or more computers to every monitor on table and have no space for experiments with more monitors.

AmigaOS3: Amiga 1200
AmigaOS4: Micro A1-C, AmigaOne XE, Pegasos II, Sam440ep, Sam440ep-flex, AmigaOne X1000
MorphOS: Efika 5200b, Pegasos I, Pegasos II, Powerbook, Mac Mini, iMac, Powermac Quad
Go to top
Re: I don't get ScreenMode prefs and monitors
Home away from home
Home away from home


See User information
@Deniil

Quote:
- What's "Board 0"? Where does it get that from?

Board 0 is the first graphics board in your system (in your case, the only board in the system). It's a generic name given to it, most likely because the NameInfo struct limits display mode names to 32 characters, meaning that "Radeon HD 6570: 1920x1080 ARGB32" won't fit.

The ScreenMode prefs' monitors tab is basically a UI for editing the tool-types of the files in DEVS:Monitors. It's completely disconnected from the main screen mode prefs. It was bolted on to ScreenMode prefs

Quote:
- What's the difference between my "Radeon" and "Radeon HD 6570" monitors?

They're two different monitor files in DEVS:Monitors/. In your case they're effectively for the same monitor, and it sounds like the "Radeon" file is actually being used. The AmigaOS installer probably created "Radeon HD 6570," and you may have created the "Radeon" one some other time.

The "monitor" configuration loading is rather confusing. On boot up it'll look for a monitor file that matches the name of the detected graphics card up to CMPLENGTH characters (CMPLENGTH is a tooltype). To confuse things further, the BOARDNAME tooltype needs to match the card's name (up to CMPLENGTH characters).

If you have a second graphics card, then you'll need a PCIGraphics monitor file. Why? Because all of our graphics drivers are loaded via the PCIGraphics.card driver. Yes, it's confusing...

Quote:
- What is a DEVS:Monitors/"monitor" anyway? The driver is a Kickstart/*.chip file.

AFAIK pre-RTG the monitor file defined the timings for special monitors that could be connected to the Amiga's RGB output. The creators of Picasso96 decided to use DEVS:Monitors to store graphics card settings as "monitor files" (including monitor timings). It's a hack that probably made sense at the time, but doesn't make sense now.

Quote:
Why can't I add a resolution on-the-fly to test? Why a reboot?!?

Because nobody wrote the code needed to dynamically update the screen-mode database without rebooting.

Quote:
This prefs just seems to very unintuitive, and I've been an active Amiga user since '92.

Agreed. This is one area (of many) that could use a big update. Any change should be well thought through, though, or we'll end up with a bigger mess. If we're not careful then it'll become even messier with multiple monitors connected.

IMHO, DEVS:Monitors should be for actual monitors as identified by their EDID (or graphics card & connector as backup if EDID fails). Graphics card configuration settings should be stored elsewhere.

Quote:
Picasso96Mode was clear and straight-forward. Technical, yes, but not fuzzy and unclear. I've also use CyberGfx and other tweak tools that could do realtime change to the frequencies etc.

Interesting, I find Picasso96Mode confusing. I need to relearn how to use it every time. IIRC, it'll allow you to test out modes, but you still need to reboot the system to be able to use your new custom modes.

Hans

http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more.
https://keasigmadelta.com/ - more of my work
Go to top
Re: I don't get ScreenMode prefs and monitors
Quite a regular
Quite a regular


See User information
Thanks for a very good explanation!

So even though the file sizes are not the same for both "monitors", they are the same. Do they load anything, or is someone just using their tooltypes?

Anyway, I'll remove the 6750 monitor and see how it goes.
Have an RX560 on the way, so hope I can get that working too

And maybe my memory is a bit hazy about P96Mode but at least it allowed you to try out stuff on-the-fly.

Software developer for Amiga OS3 and OS4.
Develops for OnyxSoft and the Amiga using E and C and occasionally C++
Go to top
Re: I don't get ScreenMode prefs and monitors
Home away from home
Home away from home


See User information
@Deniil

Quote:
So even though the file sizes are not the same for both "monitors", they are the same. Do they load anything, or is someone just using their tooltypes?

For the primary graphics card, only the tooltypes are read. That's because the graphics card was started before DOS was available, and DEVS:Monitors was, therefore, unavailable.

It's different for the secondary card. In that case, DEVS:Monitors is a small executable that gets the graphics.library to start the *.card driver.

Quote:
And maybe my memory is a bit hazy about P96Mode but at least it allowed you to try out stuff on-the-fly.

It did, but that didn't mean that the mode you created was added to the mode database and available for the rest of the system to use.

Hans

http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more.
https://keasigmadelta.com/ - more of my work
Go to top
Re: I don't get ScreenMode prefs and monitors
Just popping in
Just popping in


See User information
I've been playing with screenmode settings lately too, but unable to pinpoint where the bottleneck is.

Got LG 38UC99-W ultrawide monitor which is capable of 3840x1600 resolution. This works fine with displayport and pc.

On X5000 I'm unable to get the full resolution with HDMI. When modes are queried with DDCMODE=ALL it lists all possible modes, including 3840x1600. When testing this resolution with screenmode prefs screen stays black until I hit esc. 3440x1440 resolution is fine.

Monitor is capable of hdmi v2.0 and cable is high speed certified. Radeon R9 280X has HDMI 1.4 which should be able to display even 4k at 30hz?

Is it possible to define screenmodes which have different refresh rates, ie 3840x1600@30hz and all other modes smaller than this @60hz?

No matter what modes I input to devs/monitors/radeon tooltypes, only the default modes are displayed in the screenmode prefs. Even if it's only tooltype 3840x1600@30hz (yes, DCC is disabled in this case).

For some reason 3840x1600 is always reported 61hz in the screenmode prefs.

X5000, Peg2, mA1
Go to top
Re: I don't get ScreenMode prefs and monitors
Just can't stay away
Just can't stay away


See User information
@densho
Did you add VSYNCMIN=30 in the tooltypes when trying the 3840x1600@30hz mode?

Go to top
Re: I don't get ScreenMode prefs and monitors
Home away from home
Home away from home


See User information
@all

wrt uhd resolutions

This is a limitation in in gfx library
https://forum.hyperion-entertainment.com/viewtopic.php?f=14&t=4762
which has been altered/fixed and is being betatested...no idea when it will be released


Edited by Raziel on 2023/3/25 9:22:10
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Go to top
Re: I don't get ScreenMode prefs and monitors
Not too shy to talk
Not too shy to talk


See User information
@densho
Quote:
densho wrote:I've been playing with screenmode settings lately too, but unable to pinpoint where the bottleneck is.

Got LG 38UC99-W ultrawide monitor which is capable of 3840x1600 resolution. This works fine with displayport and pc.

On X5000 I'm unable to get the full resolution with HDMI. When modes are queried with DDCMODE=ALL it lists all possible modes, including 3840x1600. When testing this resolution with screenmode prefs screen stays black until I hit esc. 3440x1440 resolution is fine.

Monitor is capable of hdmi v2.0 and cable is high speed certified. Radeon R9 280X has HDMI 1.4 which should be able to display even 4k at 30hz?

Is it possible to define screenmodes which have different refresh rates, ie 3840x1600@30hz and all other modes smaller than this @60hz?

No matter what modes I input to devs/monitors/radeon tooltypes, only the default modes are displayed in the screenmode prefs. Even if it's only tooltype 3840x1600@30hz (yes, DCC is disabled in this case).

For some reason 3840x1600 is always reported 61hz in the screenmode prefs.


i have also a monior with that resolution (eizo) and a RX550 (sapphire)
it shows the screenmode with 30hz and 60hz.
30hz is working, but - honestly - not usable. mouse jumping at 30hz is really ugly!

60hz is not working. i already was in contact with hans about this and we found out that this seems to be a problem of the ROM code of the card.
when trying to use such a resolution i get on the serial output smth like:

>> RadeonRX (0): atombios stuck in loop for more than 5secs aborting
>> RadeonRX (0): atombios stuck executing D614 (len 824, WS 0, PS 0) @
>> 0xD763
>> RadeonRX (0): atombios stuck executing D4CE (len 326, WS 0, PS 0) @
>> 0xD56A

and only a black screen. i tried the card on our windows machine (with the normal windows built-in-driver) and it works like a charm in that resolution.

do you get a similar output?

i also tried another RX550 (yeston) with the same result
i'm a bit disappointed that this resolution is not working.

as proposed by hans i wanted to create a bugreport on A-EON's bug tracker. but until today i was not able to get a user there. i started trying in september last year...

btw... i'm now using a resolution of 2560x1600@60 which is working fine. but have black borders on the left + right. seems i need to live with that

regards...
michael

Go to top
Re: I don't get ScreenMode prefs and monitors
Just popping in
Just popping in


See User information
@Joerg

Yes, VSYNCMIN was defined.

@Raziel @MichaelMerkel

Exactly the same problem, good info - thanks!

Can't check the serial output at the moment.. So, it looks like this problem is related to either graphics.library bug or to gfx card rom code handling.. It's weird that on some setups 30hz is working but on some it's not.

X5000, Peg2, mA1
Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project