Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
69 user(s) are online (25 user(s) are browsing Forums)

Members: 0
Guests: 69

more...

Support us!

Headlines

 
  Register To Post  

(1) 2 »
Problems with AmiUpdate
Quite a regular
Quite a regular


See User information
I ran AmiUpdate today, which was the first is probably a year.

It started, checked for update OK, and scanning reveiled AmiSSL 5.8, IBrowse 2.5 and MUI libraries plus something more.

But most failed to update! Only two out of eight items updated properly. Any known issues?

Here's part of the log:
...
21:23:20 Creating working directory...
21:23:20 Created
21:23:20 Starting update of 'AmiSSL-5.8-OS4.lha'
21:23:20 Error returned from downloading file 'AmiSSL-5.8-OS4.lha': Transfer failed
21:23:20 Update finished
21:23:20 Checking for other entries in the same archive...
21:23:20 None found
21:23:20 Starting update of 'emotionupdate1.1-1.9.lha'
21:23:20 Trying to connect to: www.entwickler-x.de on port: 80
21:23:20 Connected
21:23:20 Redirection required, following link....
21:23:20 Error returned from downloading file 'emotionupdate1.1-1.9.lha': Transfer failed
21:23:20 Update finished
21:23:20 Checking for other entries in the same archive...
21:23:20 None found
21:23:20 Starting update of 'IBrowse2.5.8-PPC.lha'
21:23:20 Error returned from downloading file 'IBrowse2.5.8-PPC.lha': Transfer failed
21:23:20 Update finished
21:23:20 Checking for other entries in the same archive...
21:23:20 None found
21:23:20 Starting update of 'MUI-5.0-20210831-os4.lha'
21:23:20 Trying to connect to: github.com on port: 80
21:23:20 Connected
21:23:20 Redirection required, following link....
21:23:20 Error returned from downloading file 'MUI-5.0-20210831-os4.lha': Transfer failed
21:23:20 Update finished
21:23:20 Checking for other entries in the same archive...
21:23:20 None found
21:23:20 Starting update of 'MUI-5.0-20210831-os4-contrib.lha'
21:23:20 Trying to connect to: github.com on port: 80
21:23:20 Connected
21:23:20 Redirection required, following link....
21:23:20 Error returned from downloading file 'MUI-5.0-20210831-os4-contrib.lha': Transfer failed
21:23:20 Update finished
21:23:20 Checking for other entries in the same archive...
21:23:20 None found
21:23:20 Deleting working directory...
21:23:20 No succesfull updates performed

Software developer for Amiga OS3 and OS4.
Develops for OnyxSoft and the Amiga using E and C and occasionally C++
Go to top
Re: Problems with AmiUpdate
Not too shy to talk
Not too shy to talk


See User information
If I remember correctly, its because of the version of AmiSSL you currently have installed is too old, so you may need to download that from OS4Depot separately before everything else works.

Go to top
Re: Problems with AmiUpdate
Quite a regular
Quite a regular


See User information
@derfs

Thanks, that worked better. How about a useful error message..?

But the MUI-5.0-20210831-os4.lha installer has a problem:
Failed to copy unpacked files to 'RAM Disk:Unpacked'

There is no such thing as "RAM Disk:". "RAM:" is the proper device mounted by kickstart and available on all systems.
Attempting "RAM Disk:" for RAM: is like attempting "Workbench4.1:" for SYS:. It just won't work, except for "me".

Software developer for Amiga OS3 and OS4.
Develops for OnyxSoft and the Amiga using E and C and occasionally C++
Go to top
Re: Problems with AmiUpdate
Not too shy to talk
Not too shy to talk


See User information
@Deniil

That is the default setting/location for where to extract failed files.

You can change the destination for 'Temporary directory for unpacking' in preferences (update tab).

Doesn't stop it being a bad default, but at least it can be worked around

Go to top
Re: Problems with AmiUpdate
Quite a regular
Quite a regular


See User information
@derfs

So it wasn't MUI but the updater. Strange that it worked for everything else then...

Anyway, changed

Software developer for Amiga OS3 and OS4.
Develops for OnyxSoft and the Amiga using E and C and occasionally C++
Go to top
Re: Problems with AmiUpdate
Just can't stay away
Just can't stay away


See User information
@Deniil

Quote:
Strange that it worked for everything else then...
Probably it works for everyone who hasn't changed the default volume name of RAM: (which is "RAM Disk" with a space).

Personally, as a beta tester, I have always found it useful to have the original name with the space, because it makes it very easy to find bugs in programs or scripts which fail to treat volume names and paths correctly.

But apart from that, I totally agree with you. Hardcoded default paths in applications are a nuisance, and if used, at least they should never contain explicit volume names (I believe e.g. Prefs/WBPattern also used to do that until someone finally addressed that bug).

Best regards,

Niels

Go to top
Re: Problems with AmiUpdate
Home away from home
Home away from home


See User information
New problems today

AmiUpdate 2.49 (02.01.2022Part of the AmiUpdate suite

Log opened on 11
-8-2023 at 16:49:40

16
:49:40 Performing online version check...

16:49:40   Testing for active network connections...
16:49:40     Found interface Vodafone(8169), testing...
16:49:40     Interface is currently configuredchecking state...
16:49:40     Interface is UPcheck complete
16
:49:41 Connection to amiupdate.codebench.co.uk failed.

There may be a problem with your Internet connection.
16:49:41 Online version check completed.

16:49:43 Program started

16
:49:43 Started system scan

16
:49:43   Found host machine as: X1000

16
:49:43   Synchronising with server'amiupdate.codebench.co.uk'...

16:49:43   Testing for active network connections...
16:49:43     Found interface Vodafone(8169), testing...
16:49:43     Interface is currently configuredchecking state...
16:49:43     Interface is UPcheck complete
16
:49:44 Connection to amiupdate.codebench.co.uk failed.

There may be a problem with your Internet connection.
16:49:44       HTTPFetch errorTransferring the file was not possible due to a previous error

Go to top
Re: Problems with AmiUpdate
Not too shy to talk
Not too shy to talk


See User information
@Raziel

amiupdate.codebench.co.uk is down

Go to top
Re: Problems with AmiUpdate
Home away from home
Home away from home


See User information
@derfs

The sdk server too?

Go to top
Re: Problems with AmiUpdate
Just popping in
Just popping in


See User information
my AmiUpdate has the following servers listed:

www.amiupdate.net
update.amigaos.net

When I press "Scan" a Ringhio pops up:
-----------------
AmiUpdate
Connection to codebench.co.uk failed.

There may be a problem with you internet connection.
-----------------

It seems codebench.co.uk is still down. Are there any updates worth mentioning since 2023-07-01?

Go to top
Re: Problems with AmiUpdate
Quite a regular
Quite a regular


See User information
@all

Apart from this problem, are there any other servers that should be entered for AmiUpdate ?

MacStudio ARM M1 Max Qemu//Pegasos2 AmigaOs4.1 FE / AmigaOne A1222plus AmigaOs4.1 FE
Go to top
Re: Problems with AmiUpdate
Just can't stay away
Just can't stay away


See User information
@Tuvok : no

@Maijestro : no

--
AmigaONE X1000 and Radeon RX 560
Go to top
Re: Problems with AmiUpdate
Home away from home
Home away from home


See User information
@all

So, is amiupdate.codebench.co.uk down for good?

Quite some time has passed already

Go to top
Re: Problems with AmiUpdate
Not too shy to talk
Not too shy to talk


See User information
"network problems".
rigo knows about it.
no idea when it will be back.

regards...
michael

Go to top
Re: Problems with AmiUpdate
Just popping in
Just popping in


See User information
Hi Everyone,

This is has been down for a while now. And it is a very useful part of OS 4. Has someone got in touch with the Simon Archer to find out what is going on. If he no longer wants to host it, maybe we can get someone else to host it or get a donation going to get it hosted somewhere.

Yogi

Go to top
Re: Problems with AmiUpdate
Home away from home
Home away from home


See User information
@yogi
Quote:

Has someone got in touch with the Simon Archer to find out what is going on

As Michael says Rigo (Simon Archer) already aware about, probably right after the topic starts (i see from him a mail in beta list explaining that something going on with hosters or something). So he is aware for sure.

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: Problems with AmiUpdate
Home away from home
Home away from home


See User information
@kas1e

Then it would have been nice if he informed others outside the beta world as well, since everyone, still using his software, is affected...just saying

Go to top
Re: Problems with AmiUpdate
Just popping in
Just popping in


See User information
Hi Everyone,

Amiupdate server is still down. Like I said earlier, is the owner willing to let us host the site ourselves. Start a fund me and get it back up. Any updates about what is going on here?

Thanks,

Yogi

Go to top
Re: Problems with AmiUpdate
Home away from home
Home away from home


See User information
@all

Still the same errors after all this time?

Maybe ask someone who understand web hosting?

Go to top
Re: Problems with AmiUpdate
Not too shy to talk
Not too shy to talk


See User information
@Raziel

Works over here in Swe, got an AmiSSL and Ibrowse update today!
Happy for every little update that shows up in OS4 land! :)

Coders, Porters and Supporters of this beatiful OS hang in there
and Thank You all for your work!!

1989-> A500, A600, A3000, A4000, A1200, CD32, µA1, PegII, A1XE, CDTV, Amy/416D79, A1X5000, Vampire 500 V2+, Vampire 600 V2, Amy-ITX, Denise ITX <-2024
Go to top

  Register To Post
(1) 2 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project