Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
44 user(s) are online (31 user(s) are browsing Forums)

Members: 1
Guests: 43

daveyw, more...

Headlines

 
  Register To Post  

Amiga games Quake 2 and Battle Squadron
Quite a regular
Quite a regular


See User information
Hi

I have great expectations to run again Battle Squadron and Quake 2 on my AmigaOne X5000.Last months I lost both games as I lost AmigaOS 4.1 FE Update 2 and later restored.That was at this point that dramatically but logically lost these hgames on an OS4.1 HD formatting procedure.

On the case of Battle Squadron I don't have Cope-Com e-mail to send me a playable exe of the game.I have the original game and I want to play again.But my joypad isn't recognized.And this game was buyed years ago so it is original for sure.

And Quake 2? Well I have the original CD on a DVD box and I installed and later downloaded the Quake 2 package from os4depot and I don't kinow why doesn't run it.

And as you know are great games I want to make them run again on my X5000

Tell me what you know and help me.

Expect you can share some ideas about these games to run it again

Cheers

Amiga 500 1MB Chip RAM with ACA 500+ACA1232,CD32,Amiga 1300 030/50 Mhz,32MB (now on my hands at least)and Amiga One G3 XE PPC 800 Mhz,ATI Radeon 9250 128 MB,256 MB RAM,Seagate 200 GB HD,2 working DVD drives,X-Arcade double for MAME,Sil0680,4 USB ports,LG
Go to top
Re: Amiga games Quake 2 and Battle Squadron
Quite a regular
Quite a regular


See User information
@MamePPCA1

Only to know, has anyone similar experiences on an AmigaOne X5000?

How can I fix it and play these games?

Thank you

Amiga 500 1MB Chip RAM with ACA 500+ACA1232,CD32,Amiga 1300 030/50 Mhz,32MB (now on my hands at least)and Amiga One G3 XE PPC 800 Mhz,ATI Radeon 9250 128 MB,256 MB RAM,Seagate 200 GB HD,2 working DVD drives,X-Arcade double for MAME,Sil0680,4 USB ports,LG
Go to top
Re: Amiga games Quake 2 and Battle Squadron
Just popping in
Just popping in


See User information
Battle Squadron Fix for RadeonHD:


1)

http://www.amigans.net/modules/xforum ... t_id=97886#forumpost97886

(...) That black-screen issue happens because the HD 7xxx apparently doesn't directly support the Motorola-byte-order 16bit RGB565 bitmap format which Battle Squadron uses to draw the playfield.
Since the AOS4 driver lacks a "compatibility workaround" (= convert it to a Intel-byte-order bitmap internally and use that) this task is now done by BS itself.
Actually the new version contains two render paths now, because on HD 4xxx and 5xxx it's the other way around: there the Intel-byte-order variant doesn't work. The driver author promised to fix the latter soon though.

Alas the original Battle Squadron doesn't feature an auto-update mechanism. My plan is to release a special updater on os4depot soon. If you can't wait for that then please simply send me a mail to battlesquadron at goldencode dot de and attach the original AOS4 executable inside an LHA or ZIP or whatever. I'll send you the fresh version then.
Please don't use the cherry-darling mail address for this! Battle Squadron is no Cherry-Darling game! Instead mail me directly ( battlesquadron at goldencode dot de ).

Cheers,
Daniel



2)

https://amigaworld.net//modules/newbb/ ... _id=40652&forum=32#771316

Note:
every AOS4 user (who bought it (receipt or exe or photo of the box to prove it)) can send me a mail to
battlesquadron at golden-garbage-code dot de (remove the part "-garbage-" )
and I'll send you the update.
The update includes:

- workaround for black-playfield issue on some RadeonHDs due to the driver lacking support for Motorola-byte-order bitmaps.
- workaround for jerky-mouse and similar issues on recent OS versions
- cut-scenes now available on R100 / R200 systems (before that those were disabled because of guard-band issues with Compositing on such systems, workaround added)
- no more OpenAL related crashs on startup due to a corupt alsoft.conf file in envarc
- new: new tooltype HDR_FIX to manually enforce the black-screen-patch if the auto-detection doesn't work with your RadeonHD driver / SI card combination because CompositeTags returns "success" even on failure.

Daniel



3)

https://amigaworld.net//modules/newbb/ ... _id=40652&forum=32#771537

This morning one of the guys, Nexus, asking for an update told me that even the new version produced the black-screen issue on his system (Radeon R9 270, Ranger reports it as HD 7800, RadeonHD driver 2.4).
The only guess I had was that the auto-detection I added to the game gave the wrong result, so that the patch wasn't activated.
Turned out I was right

The patch works as follows:
On game's startup a RGBFB_R5G6B5 (BigEndian/Motorola-byte-order) bitmap is created and a test-blit using CompositeTags with COMPFLAG_HardwareOnly is issued to the drawing surface.
If that call returns anything but COMPERR_Success the game switches to "I swizzle the 16bit-pixel-data myself and use RGBFB_R5G6B5PC (little endian) instead, because RGBFB_R5G6B5 doesn't work".

However, on Nexus' machine this call return "success" although it should not...
Therefore the game thinks that the big-endian-bitmaps work and doesn't activate the patch.

So, because with the RadeonHD drivers you apparently cannot rely on the return value of that function depending on the card or version you use, I had no choice but to add yet another workaround, because the auto-detection won't work for everybody.
A new tooltype has been added, in lack of a better name I called it "HDR_FIX":

HDR_FIX=0 (default): auto-detection (the one that fails for Nexus)
HDR_FIX=1 : force little endian (by that it finally works on Nexus' machine)
HDR_FIX=2 : force big endian (for completeness, who knows what other HD variants or future driver versions do)

The people I supplied with the previous version should have received a mail about this issue, but in case I forgot somebody, here you go.

So, the only remaining issue I know about is pretty uncritical:
on some (or all, dunno, I don't have one) SI cards you will see a nice small grey, actually not existing, triangle near the spaceship during the "enter level" animation.
Don't ask me where this comes from, I have no idea and certainly don't paint it. Appears only on SI.

Now, since it finally seems to work for everybody again, I'd say:
happy shooting

Daniel

Go to top
Re: Amiga games Quake 2 and Battle Squadron
Not too shy to talk
Not too shy to talk


See User information
@amig_os

I just tried emailing Daniel at the address you posted, but got an 'undeliverable' message back. Is there another that might work?

-- eliyahu

"How do you know I’m mad?" said Alice.
"You must be," said the Cat, "or you wouldn’t have come here."
Go to top
Re: Amiga games Quake 2 and Battle Squadron
Just can't stay away
Just can't stay away


See User information
@MamePPCA1

Quote:

And Quake 2? Well I have the original CD on a DVD box and I installed and later downloaded the Quake 2 package from os4depot and I don't kinow why doesn't run it.


AFAIK there is only one Quake2 port on OS4Depot and it requires MiniGL + Warp3D. Which graphics card do you use and are you able to run other MiniGL apps?

Go to top
Re: Amiga games Quake 2 and Battle Squadron
Quite a regular
Quite a regular


See User information
@Capehill

Hello Capehill

I have a Radeon HD 5450 that is great for amulators such MAME (that I can't load now or run the exe with xMAMEGUI) and Final BurnI like my AmigaOne X5000 but sometimes is a bit unstable,but I supposese I pass it by

And I don't know if I can run other OpenGL apps.I don't know really

Out of topic: Anyone can help0 me with MAME?

Thanks if you can do itI

Amiga 500 1MB Chip RAM with ACA 500+ACA1232,CD32,Amiga 1300 030/50 Mhz,32MB (now on my hands at least)and Amiga One G3 XE PPC 800 Mhz,ATI Radeon 9250 128 MB,256 MB RAM,Seagate 200 GB HD,2 working DVD drives,X-Arcade double for MAME,Sil0680,4 USB ports,LG
Go to top
Re: Amiga games Quake 2 and Battle Squadron
Quite a regular
Quite a regular


See User information
@amig_os

I have sent you an e-mail with the BS exe included but it returns me with an error message.

Can you help me Daniel to solve this issue?

Thank you and help me,I want to play Battle Squadron on my deluxe AmigaOne X5000 system

It happens the same as the previous Amigans.net user

Hope we can resolve this soon

Ah! And it says: "Mail Delivery Subsystem"

Good luck

Amiga 500 1MB Chip RAM with ACA 500+ACA1232,CD32,Amiga 1300 030/50 Mhz,32MB (now on my hands at least)and Amiga One G3 XE PPC 800 Mhz,ATI Radeon 9250 128 MB,256 MB RAM,Seagate 200 GB HD,2 working DVD drives,X-Arcade double for MAME,Sil0680,4 USB ports,LG
Go to top
Re: Amiga games Quake 2 and Battle Squadron
Just can't stay away
Just can't stay away


See User information
@MamePPCA1

I don't think your graphics card is supported by Warp3D, AFAIK it's only for Southern Islands series (until NovaBridge).

1) You need a supported graphics card
2) Or you need Quake2 from Hyperion (it should support SW rendering)
3) Or maybe you can use Wazp3D

Go to top
Re: Amiga games Quake 2 and Battle Squadron
Just popping in
Just popping in


See User information
@eliyahu
@MamePPCA1


Daniel Müßener / GoldenCode
Am Langen Weiher 11
50170 Kerpen
Deutschland

http://www.goldencode.de/

kontakt@goldencode.de

info@cherry-darling.net

Go to top
Re: Amiga games Quake 2 and Battle Squadron
Quite a regular
Quite a regular


See User information
@amig_os

I just send you and e-mail now.

Hope this works and you can make the great Battle Squadron game to run and play on my Amiga with OS4.1.I already have an AMigaOne X5000,that's my beautiful system

Thanks anyway and...hope to receive soon your e-mail

Cheers and good-byeQuote:
amig_os wrote:@eliyahu
@MamePPCA1


Daniel Müßener / GoldenCode
Am Langen Weiher 11
50170 Kerpen
Deutschland

http://www.goldencode.de/

kontakt@goldencode.de

info@cherry-darling.net

Amiga 500 1MB Chip RAM with ACA 500+ACA1232,CD32,Amiga 1300 030/50 Mhz,32MB (now on my hands at least)and Amiga One G3 XE PPC 800 Mhz,ATI Radeon 9250 128 MB,256 MB RAM,Seagate 200 GB HD,2 working DVD drives,X-Arcade double for MAME,Sil0680,4 USB ports,LG
Go to top
Re: Amiga games Quake 2 and Battle Squadron
Quite a regular
Quite a regular


See User information
@Capehill

Only one more thing: Convert your drems if you want to release new games for the Amiga.Wew need excelent coders and great games too.Be AMIGA again and ever.

I want to see new Goldencode games released for the Amiga

Thanks and have a good day

Amiga 500 1MB Chip RAM with ACA 500+ACA1232,CD32,Amiga 1300 030/50 Mhz,32MB (now on my hands at least)and Amiga One G3 XE PPC 800 Mhz,ATI Radeon 9250 128 MB,256 MB RAM,Seagate 200 GB HD,2 working DVD drives,X-Arcade double for MAME,Sil0680,4 USB ports,LG
Go to top
Re: Amiga games Quake 2 and Battle Squadron
Quite a regular
Quite a regular


See User information
@MamePPCA1

Only to remember that I payed for the game and I need the exe to play so: DO IT OK?

Thanks and awaiting for your news

Javi

Amiga 500 1MB Chip RAM with ACA 500+ACA1232,CD32,Amiga 1300 030/50 Mhz,32MB (now on my hands at least)and Amiga One G3 XE PPC 800 Mhz,ATI Radeon 9250 128 MB,256 MB RAM,Seagate 200 GB HD,2 working DVD drives,X-Arcade double for MAME,Sil0680,4 USB ports,LG
Go to top
Re: Amiga games Quake 2 and Battle Squadron
Quite a regular
Quite a regular


See User information
@amig_os

I only will write here in order I want you Daniel the Battle Squadron executable file to play it again on my X5000 AmigaOne.Aka AmigaOne X5000

I want to be sure you will send me again.

Amiga is the best and I like its games of course and I hope you can send you will send me I want and expect my BS exe file.

Thanks in advance Daniel

Amiga Dreams forever and ever yeah

Amiga 500 1MB Chip RAM with ACA 500+ACA1232,CD32,Amiga 1300 030/50 Mhz,32MB (now on my hands at least)and Amiga One G3 XE PPC 800 Mhz,ATI Radeon 9250 128 MB,256 MB RAM,Seagate 200 GB HD,2 working DVD drives,X-Arcade double for MAME,Sil0680,4 USB ports,LG
Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project