Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
48 user(s) are online (33 user(s) are browsing Forums)

Members: 0
Guests: 48

more...

Headlines

 
  Register To Post

Mednafen Port for AmigaOS4
Not too shy to talk
Not too shy to talk


See User information
Hi all. I have been working on porting Mednafen to AmigaOS4 and so for I have something working. Mednafen supports the following:
Apple II/II+
Atari Lynx
Neo Geo Pocket 
(Color)
WonderSwan
GameBoy 
(Color)
GameBoy Advance   <--- rjd324This is the only module not included in the build
Nintendo Entertainment System
Super Nintendo Entertainment System
/Super Famicom
Virtual Boy
PC Engine
/TurboGrafx 16 (CD)
SuperGrafx
PC
-FX
Sega Game Gear
Sega Genesis
/Megadrive
Sega Master System
Sega Saturn 
(64-bit only)
Sony PlayStation


Why did I do it? Because I am looking for a Playstation emulator actually. FPSE does not quite do what I want it to do, so I set about looking for the easiest thing to port over, and this looked like it.

It is just the beginning here. For instance, due to threading issues - at least when using PSX - I get some DSI errors that I can ignore. But, I cannot enable audio yet. So, that is something to look into.

The port is based on mednafen version 1.29, of course, with various modifications and or hacks to the code base to get it to work with AOS4.

It was compiled with SDK 53.34, adtools gcc 11.3, newlib. All statically linked. There is no altivec support in the version uploaded, but that is possible. OpenGL/SDL, for me, at least, testing with GL4ES on my X5000 Enhancer 2.1. On my X1000 using only the Warp3D nova, I do not get the results I expected and I need to switch to software rendering, rather than opengl. Need to look into that.

I will be uploading what essentially is a: run at your own risk version onto the depot while I look into some of the issues some more since maybe someone can test whether it works with any other module other than PSX. I did try the SNES module and that seemed to work also, but we already have more than capable SNES emulators today! I am only doing this selfishly since I want to be able to play some of my PSX games.

===

You should define an environment variable named HOME. eg:
setenv HOME Workbench:S


If there is a trailing slash at the end, it will not work as intended.

Mednafen has no front end (at least, not that I am aware of). It is a command line tool with a cfg file. But, the command line is quite simple. It is just:
[mednafen <ROM>]

Though, initially, I would suggest just running "mednafen" for it to create a default configuration file or to see whether it trashes your machine.

On initial launch, the a configuration (.mednafen folder) will be created with a lot of default files generated within in the HOME directory. This will include a mednafen.cfg file.

Recommended things to do in the mednafen.cfg file:

1. Change "cd.image_memcache 0" to value 1 - load into memory instead.
2. Change "sound 1" to 0 - as I say, this is just a test binary at this point
3. For any modules that you are using, say Playstation: search for "psx.videoip" and ensure that value is 0, otherwise filtering is turned on, and that slows things down. For snes, consider looking at "snes.videoip" etc.
4. "video.driver" is where you set the main driver. "default" goes to OpenGL. As I said, on my X5000 this is okay, but on my X1000 using Warp3D Nove / minigl etc this does not seems to work right now, instead I set it to "softfb" : this is software rendering.
5. maybe you will consider setting "video.glvsync" to 0.

All of these settings above are just total guesses from my part. I am not an expert. I think the only important ones are disabling the sound and potentially using software rendering. Sound may work for some modules. I am not sure.

If the Grim Reaper appears, do not blame me.

I will upload this totally broken binary at some point this evening and link it here:
http://os4depot.net/?function=showfil ... n/gamesystem/mednafen.lha.
===

See also: https://mednafen.github.io/


Edited by rjd324 on 2022/7/24 21:03:12
If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: Mednafen Port for AmigaOS4
Home away from home
Home away from home


See User information
This is very very interesting

Go to top
Re: Mednafen Port for AmigaOS4
Not too shy to talk
Not too shy to talk


See User information
I am quite happy with the playstation module so far. Able to play games that I could never play with FPSE. The cfg file takes a little bit of tweaking. This is all with the very same version I uploaded to Os4Depot.

Need to figure out how to fix sound next. I have no idea about the other modules (non-playstation. Other than SNES which I tested and it worked). Test them out by all means.

Also tested with a USB controller. During a game you just press Alt+Shift+F1, or Alt+F1 - cannot remember. Do a search on google. You get a screen at the bottom which runs through the buttons and asks you to map them onto the device.

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: Mednafen Port for AmigaOS4
Quite a regular
Quite a regular


See User information
@rjd324

Hi, just tried it from RAM:
#mednafen.r107.exe
Starting Mednafen 1.29.0
Build information:
Compiled with gcc 11.3.0
Compiled against zlib 1.2.11, running with zlib 1.2.11(flags=0x00000055)
Compiled against SDL 2.0.22(), running with SDL 2.0.22()
Running with libFLAC 1.3.2
Base directory: SYS:/.mednafen
Emulation modules: apple2 nes snes gb pce lynx md pcfx ngp psx ssfplay vb wswan sms gg sasplay snes_faust pce_fast demo cdplay
Error creating base directory: Error creating directory "SYS:/.mednafen": No such file or directory

***¡Comando 'mednafen.r107.exe' returned with unfreeded signals 0x01E00000!
#

and a tiny/small readme would be nice to add to the archive.


EDIT: solved the basedir with: "setenv MEDNAFEN_HOME DH7:mednafen"

EDIT2: here it doesn't create the ".mednafen" drawer at all ¿:-/ rebooted system and executed again and all files/drawers are there now.

Now how do I load a PSX ISO?!?! TiA


Edited by jabirulo on 2022/7/25 9:53:18
Edited by jabirulo on 2022/7/25 9:53:50
Edited by jabirulo on 2022/7/25 10:16:06
Go to top
Re: Mednafen Port for AmigaOS4
Not too shy to talk
Not too shy to talk


See User information
Hi.

I would possibly change the xres and yres of psx. Maybe start with 320 240. Also xscale yscale turn to 1.0000 instead of the default 5.000. Mess with those by
All means.

You just pass the .cue file in to the mednafen binary and it should just open it.

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: Mednafen Port for AmigaOS4
Quite a regular
Quite a regular


See User information
@rjd324

ok thx for tips, Must be a .CUE or can in be a "typicall" .ISO?
or just be renaming .ISO -> .CUE is ok?

Go to top
Re: Mednafen Port for AmigaOS4
Not too shy to talk
Not too shy to talk


See User information
FILE "image-name.BIN" BINARY
TRACK 1 MODE2
/2352
INDEX 1 00
:00:00


Just replace the image-name.bin with whatever. It is just a text file.

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: Mednafen Port for AmigaOS4
Just popping in
Just popping in


See User information
What an awesome attempt Mate!
Really looking forward to what you
might achieve in your next releases.

Maybe Daniel could help you regarding
OGLES2 🤔

Could you please have a look into the
SEGA SATURN part too (after PSX of course 😅)?

This would be an Amiga first if you could get that one
to work. Saturn is IMO one of the best 2D Platforms
out there. Fantastic Games on it.

Thanks for your efforts 👍🏼😘

OS4 Betatester

X1000
X5000/40
Go to top
Re: Mednafen Port for AmigaOS4
Quite a regular
Quite a regular


See User information
@rjd324
...
Pac-ManWorld.bin                      57986208 ----rwed 24-Dic-96 22:32:00
Pac
-ManWorld.cue                            74 ----rwed Hoy 14:26:00
...

#mednafen.r107.exe Pac-ManWorld.cue
Starting Mednafen 1.29.0
 Build information
:
   
Compiled with gcc 11.3.0
   Compiled against zlib 1.2.11
running with zlib 1.2.11(flags=0x00000055)
   
Compiled against SDL 2.0.22(), running with SDL 2.0.22()
   
Running with libFLAC 1.3.2
 Base directory
BASURA:mednafen
 Emulation modules
apple2 nes snes gb pce lynx md pcfx ngp psx ssfplay vb wswan sms gg sasplay snes_faust pce_fast demo cdplay
 Opening lockfile
...
 
Loading settings from "BASURA:mednafen/mednafen.cfg"...
  
Loaded 3654 valid settings and 0 unknown settings.
 
Initializing joysticks...
 
Loading "Pac-ManWorld.cue"...
Error opening CDError opening file "./Pac-ManWorld.bin"No such file or directory
#


.CUE:
FILE "Pac-ManWorld.bin" BINARY
TRACK 01 MODE2/2352
INDEX 01 00:00:00


Seems some issues wiht path/root/parent, any ideas? TiA

Go to top
Re: Mednafen Port for AmigaOS4
Not too shy to talk
Not too shy to talk


See User information
@zerec thanks for the words.

@jabirulo It looks like it is a path-ing issue. I can reproduce your issue when the "mednafen.r107.exe" binary is in the same location as the ".cue" and ".bin" file. For now it seems like the work around is to just ensure that the program is not in the same location as the CUE/BIN files until a future release.

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: Mednafen Port for AmigaOS4
Home away from home
Home away from home


See User information
@rjd324

I have exactly the same problem of Javier.
For the next release it would be possible to provide a ready-made directory tree in the archive, rather than having to create it manually everytime?

Go to top
Re: Mednafen Port for AmigaOS4
Quite a regular
Quite a regular


See User information
@rjd324

YES!!! Creating a "_test" drawer inside mednafen and moving .cue .bin there and executing mednafed.exe _test/file.cue at least loads file ok.

will do some test ASAP

Go to top
Re: Mednafen Port for AmigaOS4
Not too shy to talk
Not too shy to talk


See User information
I have a config file which seems to work okay for most of my psx games. Ofc, with no audio. But it plays them okay so far and I can actually save and load.

I can send that configuration file over if you want. But yours maybe better.

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: Mednafen Port for AmigaOS4
Quite a regular
Quite a regular


See User information
@rjd324

will be nice to have a "default" cfg to compare with the one I use.

THX

Go to top
Re: Mednafen Port for AmigaOS4
Just popping in
Just popping in


See User information
@rjd324
I tested all emulated platforms today. Of course, you need to turn off the sound so that the program does not crash. With the sound turned off, most things work OK.

Apple II/II+ - Games are running. Unfortunately, the Apple virtual keyboard is not working, so I couldn't start games.
Atari Lynx - work ok.
Neo Geo Pocket (Color) - work ok.
WonderSwan (and Wonderswan Color) - work ok.
GameBoy (Color) - work ok.
GameBoy Advance - not work, allways this message:
Loading "Emulacja:VisualBoyAdvance/romy/SuperMarioAdvance4.gba"...
Applying IPS file "Emulacja:VisualBoyAdvance/romy/SuperMarioAdvance4.gba.ips"...
Failed: Error opening file "Emulacja:VisualBoyAdvance/romy/SuperMarioAdvance4.gba.ips": No such file or directory
Unrecognized file format.


Nintendo Entertainment System - work ok.
Super Nintendo Entertainment System/Super Famicom - work ok.
Virtual Boy - work ok.
PC Engine/TurboGrafx 16 (CD) - work ok.
SuperGrafx - work ok.
PC-FX - work ok.
Sega Game Gear - work ok.
Sega Genesis/Megadrive - work ok.
Sega Master System - work ok.
Sega Saturn (64-bit only) - not work. Games are loading as music tracks. That in the configuration of the emulator we must have the sound turned off, I have not heard anything.
Sony PlayStation - work ok.

Go to top
Re: Mednafen Port for AmigaOS4
Not too shy to talk
Not too shy to talk


See User information
@mufa thank you for the testing.

Following is always in a playstation context:

With the released r122 version, I can actually deletes the .mednafen folder and have a brand new one created. I then only need to change two settings, which is to load the image onto RAM and to set the sound "period time" to a value of 100000. This means that the default drives (opengl, sdl sound), with bilinear filtering, enhanced scaling, work acceptably. This is running through Minigl/MiniGL4GL4ES (Polaris RX 560, X5000/20).

I have tried the same on the X1000 with poor results compared to the X5000, even with altivec support. This is going through the Warp3D+Southern Islands driver.

I also have built a version (r130) combined with pure GL4ES.

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project