Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
49 user(s) are online (37 user(s) are browsing Forums)

Members: 1
Guests: 48

flash, more...

Support us!

Headlines

 
  Register To Post  

« 1 ... 3 4 5 (6)
Re: updating sgit
Not too shy to talk
Not too shy to talk


See User information
@MartinW

larger downloads without any problem) . But as I wrote I don't use this tool. I'm sure you can do better and adapt it to your needs. I just recompiled sgit for a test and out of curiosity. If you need anything let me know.

Resized Image

Go to top
Re: updating sgit
Not too shy to talk
Not too shy to talk


See User information
@smarkusg, @all

I think it's still publishing, but in case it helps anyone. Although I doubt it!

As it says at the end of the video, the sun is shining for once here in the UK, so I'm going out





Amiga x5040 ı 16GB ı RX580
GB-A1000 060@100,
A1200 PiStorm32-Lite CM4
Go to top
Re: updating sgit
Just popping in
Just popping in


See User information
@smarkusg I gather your new build is from the latest simple git on github from sba1?

If so, do you mind post8ng the new binary?

Thanks
Dave.

Ps. Old version is working for me, but I need to see what the size of the project that I am using it with is.

Go to top
Re: updating sgit
Not too shy to talk
Not too shy to talk


See User information
@davec555 @MartinW

I will comfort you or sadden you ... and yes sgit will not work.
As I wrote earlier I did a quick compilation test.
I checked my sources but ... my mistake was that I did not check what @Raziel wrote
https://www.amigans.net/modules/newbb/ ... id=145316#forumpost145316

The fact that the program compiles is not everything. It's not a problem with SSL, it's a problem with the old libgit2 library.
It overruns the right ranges and therefore does not work. Who will fix it? I do not know
I hope I am wrong and @billyfish finds a solution and refutes my thinking


Resized Image

Go to top
Re: updating sgit
Not too shy to talk
Not too shy to talk


See User information
That looks a lot like the format of git pack files has changed. Which, let's face it wouldn't be a massive surprise! So compiling would be a great first step as it would allow us to dig into it.

I've just spent another half an hour looking at the build and it's failing massively on building LHA from old sources from around the year 2000. Not sure why it's trying to do that but I guess there's a reason for it. I can only surmise that there's something different about whatever cross compiler setup the original build used vs the docker cross compiler image. I might look into that I suppose.


Amiga x5040 ı 16GB ı RX580
GB-A1000 060@100,
A1200 PiStorm32-Lite CM4
Go to top
Re: updating sgit
Just can't stay away
Just can't stay away


See User information
@MartinW

Almost there mate!!!!

Looks it fails to build LhA.
Can't LHASA (apt install lhasa) be used instead and just "remove" the LhA build part.

maybe in the docker LhA command exists ¿:-/

Go to top
Re: updating sgit
Not too shy to talk
Not too shy to talk


See User information
@MartinW

Now I see on your video , you build from makefiles.aos4*.
I didn't do it that way. I did with cmake directly.
build libgit2 in the first place
you have the declarations in makefile.aos4
then build simplegit

Go to top
Re: updating sgit
Not too shy to talk
Not too shy to talk


See User information
@davec555 @MartinW

I have rebuilt sgit a bit under the latest libgit and openssl under AOS4.
The problem is still the same. I checked the old version of sgit with http://web.archive.org/ ... same problem
I will also check on some cheap system compi with UP1 and old libraries under AOS4.
Under Linux the sgit code from the https://github.com/sba1/simplegit repository works fine under Linux x86_64.
It follows that the simplegit client works fine but under AOS4. I don't know what could be the cause. It is possible that it has never worked properly for 10 years.
There is probably no point in checking it further unfortunately

Resized Image

Resized Image

Go to top
Re: updating sgit
Just popping in
Just popping in


See User information
@smarkusg do you mind giving a step by step in how you built it?

Go to top
Re: updating sgit
Just popping in
Just popping in


See User information
Hi all

So I've got my cross compiler set up so can now look at simplegit again. So I have it forked at https://github.com/billyfish/simplegit/ and https://github.com/billyfish/simplegit/blob/master/build.md explains the different build options I added and these were things like which c runtime library to use, which libgit2 directory to use, whether to link to the AmiSSL shared library, etc.

I can double track which revision it was that libgit2 moved from using straightforward memory copies to using mmap () and munmap () but it will now be a few years ago. So if we want to use the latest libgit2, we'll need implementations for those or workarounds

libgit2 also comes with an example client, lg, which is what I built in the past.

I'll take a look at the current state of play in libgit2 in the next day or two and see how many calls there are to mmap () and munmap () and adapt the build process to be able to use clib4 too

Go to top
Re: updating sgit
Not too shy to talk
Not too shy to talk


See User information
Would be better to stick with newlib IMO until clib4 is officially released as part of the sdk and known to be bug free. At the moment as far as I know it’s experimental


Amiga x5040 ı 16GB ı RX580
GB-A1000 060@100,
A1200 PiStorm32-Lite CM4
Go to top
Re: updating sgit
Just can't stay away
Just can't stay away


See User information
@Raziel

Today I hit a similar issue with the SDL repo. If I try to fetch from it, I get libgit error 9. If I try to clone the repo, I get libgit error 12 :(

https://github.com/AmigaPorts/SDL.git in case somebody wants to try.

Go to top
Re: updating sgit
Home away from home
Home away from home


See User information
@Capehill

many repos are affected, only the small ones in size still work

it seems something is timing out too soon

i stopped using sgit as it has become too much of a nuisance when it stops mid downloading/uploading

my standard stuff is updating itself on a daily basis on a synology nas now and i simply sync it to the amiga if needed

one time downloads i do on a pc/linux machine and move the whole dir to the amiga

not ideal...but working

Go to top

  Register To Post
« 1 ... 3 4 5 (6)

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project