Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
41 user(s) are online (27 user(s) are browsing Forums)

Members: 1
Guests: 40

zerec, more...

Headlines

 
  Register To Post  

(1) 2 3 »
LiteXL v2.1.0 is released
Site Builder
Site Builder


See User information
The best-ever version of LiteXL 2.1.0r1 is released. It's so good that it deserves a new forum post, in my opinion.

A lot of new features and fixes are included in this release. Even the scrollbar side is better now and not tiny :D

Find more info at https://ko-fi.com/post/LiteXL-2-1-0r1-release-A0A4FLYNG, where you will find the URLs to download it if you don't already know them. ;)

If you like the new version and find it useful, please consider spreading the word, so more people learn about it and maybe keep me awake at night working on my projects by buying me more coffee.

Go to top
Re: LiteXL v2.1.0 is released
Just popping in
Just popping in


See User information
Thanks for your service. Already installed and running.

AMIGA 1200 | Vampire 1200 II | 128 MB RAM | Indivision AGA Mk3 | 256 GB SD | AmigaOS 3.2.2
AMIGA 600 | Vampire 600 II | 128 MB RAM | Indivision ECS Mk3 | 256 GB SD | AmigaOS 3.2.2
Go to top
Re: LiteXL v2.1.0 is released
Just popping in
Just popping in


See User information
@walkero
I really like this editor... it means previous version so far.
Good job!

Go to top
Re: LiteXL v2.1.0 is released
Just popping in
Just popping in


See User information
Good works, thanks

Go to top
Re: LiteXL v2.1.0 is released
Quite a regular
Quite a regular


See User information
Tried last version, but it seems I have problems. When I try to load .html file I get this error and after that LiteXL closed it self.

"Error: Posao:aPPs/tExT/LiteXL2/data/core/tokenizer.lua:228: attempt to compare number with nil
stack traceback:
Posao:aPPs/tExT/LiteXL2/data/core/tokenizer.lua:228: in function 'core.tokenizer.tokenize'
Posao:aPPs/tExT/LiteXL2/data/core/doc/highlighter.lua:91: in function 'core.doc.highlighter.tokenize_line'
Posao:aPPs/tExT/LiteXL2/data/core/doc/highlighter.lua:100: in function 'core.doc.highlighter.get_line'
Posao:aPPs/tExT/LiteXL2/data/core/doc/highlighter.lua:110: in function 'core.doc.highlighter.each_token'
Posao:aPPs/tExT/LiteXL2/data/core/docview.lua:332: in function <Posao:aPPs/tExT/LiteXL2/data/core/docview.lua:329>
(...tail calls...)
Posao:aPPs/tExT/LiteXL2/data/core/docview.lua:439: in upvalue 'old_draw'
Posao:aPPs/tExT/LiteXL2/data/plugins/linewrapping.lua:512: in function 'core.docview.draw'
Posao:aPPs/tExT/LiteXL2/data/core/node.lua:588: in function 'core.node.draw'
Posao:aPPs/tExT/LiteXL2/data/core/node.lua:32: in function 'core.node.propagate'
Posao:aPPs/tExT/LiteXL2/data/core/node.lua:593: in function 'core.node.draw'
... (skipping 3 levels)
Posao:aPPs/tExT/LiteXL2/data/core/node.lua:32: in function 'core.node.propagate'
Posao:aPPs/tExT/LiteXL2/data/core/node.lua:593: in function 'core.node.draw'
Posao:aPPs/tExT/LiteXL2/data/core/rootview.lua:451: in upvalue 'draw'
Posao:aPPs/tExT/LiteXL2/data/plugins/autocomplete.lua:571: in upvalue 'root_view_draw'
Posao:aPPs/tExT/LiteXL2/data/plugins/contextmenu.lua:31: in upvalue 'root_view_draw'
Posao:aPPs/tExT/LiteXL2/data/plugins/treeview.lua:512: in function 'core.rootview.draw'
Posao:aPPs/tExT/LiteXL2/data/core/init.lua:1303: in function 'core.step'
Posao:aPPs/tExT/LiteXL2/data/core/init.lua:1347: in function 'core.run'
(...tail calls...)
[string "local core..."]:12: in function <[string "local core..."]:2>
[C]: in function 'xpcall'
[string "local core..."]:2: in main chunk"

Amiga x5000 ı o2o ı 4GB RAM ı RadeonRX580 | SBlaster Audigy Fx - AmigaOS4.1 FInal Edition

A1200 sandwich

Warp - Croatian Amiga portal
Go to top
Re: LiteXL v2.1.0 is released
Site Builder
Site Builder


See User information
@Voodoo
Try to change the country on prefs to something like UK or US and let me know if it works. This is a problem I had with MorphOS versions, which is fixed but haven't heard that is happening on OS4. If it works, I will build a new OS4 version.

Go to top
Re: LiteXL v2.1.0 is released
Quite a regular
Quite a regular


See User information
@walkero
Quote:
walkero wrote:@Voodoo
Try to change the country on prefs to something like UK or US and let me know if it works. This is a problem I had with MorphOS versions, which is fixed but haven't heard that is happening on OS4. If it works, I will build a new OS4 version.


I tried, the same. Previous version worked fine for me.

Amiga x5000 ı o2o ı 4GB RAM ı RadeonRX580 | SBlaster Audigy Fx - AmigaOS4.1 FInal Edition

A1200 sandwich

Warp - Croatian Amiga portal
Go to top
Re: LiteXL v2.1.0 is released
Not too shy to talk
Not too shy to talk


See User information
@walkeroQuote:

I'm getting a capcha request on this site when I access via Odyssey, and no matter how many times I solve it, I can't get through. Have seen it on cloudflare protected sites as well.

Does anyone know how to configure Odyssey so it isn't seen as a bot?

Go to top
Re: LiteXL v2.1.0 is released
Home away from home
Home away from home


See User information
@walkero

will check this text editor out...thanks for the update

_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: LiteXL v2.1.0 is released
Site Builder
Site Builder


See User information
@daveyw
No worry about this site if you do not have any other way to check this out. LiteXL can be downloaded from OS4Depot and the needed information to have that running is included in the archive.

Go to top
Re: LiteXL v2.1.0 is released
Just popping in
Just popping in


See User information
@walkero

That's good. Does it work on the X1000 yet?

Go to top
Re: LiteXL v2.1.0 is released
Site Builder
Site Builder


See User information
@Hypex
It should. If not, let me know and we will figure out how to fix it.

Go to top
Re: LiteXL v2.1.0 is released
Not too shy to talk
Not too shy to talk


See User information
@walkeroQuote:
walkero wrote:@daveyw
No worry about this site if you do not have any other way to check this out. LiteXL can be downloaded from OS4Depot and the needed information to have that running is included in the archive.


Yep, I downloaded it from OS4 Depot. Looks really good - I'll really only be using it for Arexx scripts, but it has a nice clean UI. Real software developers may hate me for saying this, but I'd like to have line warp.

Still, would be good if someone could figure out how to get thru CloudFlare with Odyssey.

Go to top
Re: LiteXL v2.1.0 is released
Home away from home
Home away from home


See User information
Tested latest version : good progress, almost as native. Through, find out issue with marking+copy of blocks. To reproduce:

-- open any text file
-- hit ctrl, and while hold it, mark by mouse some rectangle area. hit ctrl+c for copy
-- now try to put via ctrl+v this marked block in any place : instead of the block, it will paste all in one single line.

Dunno through if it issue with port or with original , or maybe this is default settings issue, but at least in all other editors where marking of columns works, things pastes as they were copied, and not in one string

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: LiteXL v2.1.0 is released
Site Builder
Site Builder


See User information
@kas1e
Thank you for testing it. I just tested it and I was able to reproduce it. I will look for a fix in a few days and I will let you know what I found.

Created the issue https://git.walkero.gr/walkero/lite-xl/issues/22 so to not forget it.

Go to top
Re: LiteXL v2.1.0 is released
Quite a regular
Quite a regular


See User information
I downloaded this version of LiteXL2 today and used it to edit some files. Still getting used to it but I like it.

Thanks.
redfox

Go to top
Re: LiteXL v2.1.0 is released
Just popping in
Just popping in


See User information
@walkero

Thanks. Unfortunately it still broke again. Same thing. Reaper gave me an 81000009 free mem twice guru again.

I thought it may be a missing HOME variable but I don't see it look for one.

I got out Snoopy. The last thing it does is UnLock("lite-xl") and then Reaper takes over. Up to then it goes fine opening and examining files. Suppose I should grab a full log.

Go to top
Re: LiteXL v2.1.0 is released
Site Builder
Site Builder


See User information
@Hypex
Thank you for testing it. Did you create a new installation? Did you use the old .config/litexl folder? If yes, please try to remove it and try again. This should be either under the LiteXL folder or under the HOME folder, if you have that environment variable set.

If the problem remains, please send me the crashlog and I will try to find a solution.

Also, please let me know the full path you run LiteXL from.

It is weird because I believe that others run it fine on X1000.

Go to top
Re: LiteXL v2.1.0 is released
Home away from home
Home away from home


See User information
@Walkero,Hypex

I remember that Hypex often not up2date with his OS4 install, so for sure need to know on what version he check, and versions of his libs, etc.

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: LiteXL v2.1.0 is released
Site Builder
Site Builder


See User information
@kas1e
Yeah, that might be the cause of the problem, or the problem exists for everyone but it remains hidden. The thing is that because this editor uses SDL and other libraries that are all linked statically, there are not many things used from the system. Maybe newlib is one of those things.

Go to top

  Register To Post
(1) 2 3 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project