Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
39 user(s) are online (33 user(s) are browsing Forums)

Members: 0
Guests: 39

more...

Headlines

 
  Register To Post
« 1 2 3 (4) 5 »

Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Home away from home
Home away from home


See User information
@all

Can I set LDFLAGS, CPPGLAGS in cygnix?

People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Just popping in
Just popping in


See User information
@Raziel

Yes, LDFLAGS and CPPFLAGS are pretty much just usual variables in Makefiles (makefile/gmakefile/smakefile).

Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Home away from home
Home away from home


See User information
@trgswe

Yes, but can i set them "globally", like on AMigaOS4 with an envvar?
(Should have been more precise)

People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Amigans Defender
Amigans Defender


See User information
an advice.. with Windows 10 and Windows 11 it is really better to use WSL2.. I've compiled on Windows 11 the compiler in some minutes using ubuntu.

i'm really tired...
Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Home away from home
Home away from home


See User information
@afxgroup

WSL2?

People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Amigans Defender
Amigans Defender


See User information

i'm really tired...
Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Home away from home
Home away from home


See User information
@afxgroup



I don't even know exactly what i'm doing on Windows, let alone Linux...i would probably run away screaming if i tried to install or even use that...

People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Just popping in
Just popping in


See User information
@Raziel

Yes, sort of you use cmake-gui it will parse the cmakefiles and hopefully at least make it easier to alter some options.
cmake-gui is usually a separate tool you need to download, but it should be readily available (dont't actually know if it is made in C/C++ or some script language, there is no amiga version that i know of).

Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Not too shy to talk
Not too shy to talk


See User information
@kas1e

Similar question again :)

Now I am GCC10
How do I update from GCC 10 to GCC11 on Cygwin64 ?

Where do we look at Sodero's github ?

git clone --branch topic/gcc11??? https://github.com/sodero/adtools/

Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Quite a regular
Quite a regular


See User information
@SinanSam460

Maybe something like in #51: https://www.amigans.net/modules/newbb/ ... id=122768#forumpost122768


cd /
mkdir /amiga
cd /amiga
git clone --branch topic/gcc11.1_support https://github.com/sodero/adtools/
cd adtools

git submodule init
git submodule update

gild/bin/gild clone
gild/bin/gild checkout binutils 2.23.2
gild/bin/gild checkout gcc 11.1 (<- or maybe just 11)

Or changing it to 11.2

Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Home away from home
Home away from home


See User information
@Sinan
As far as i can see, 11.2 already in main adtools repo commit by SBA from Sodero. So you can just use this one as always, just doing "gild checkout gcc 11.2" instead of 8.4


Edited by kas1e on 2022/3/15 17:01:32
Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Just popping in
Just popping in


See User information
@SinanSam460

Just like kas1e says, please don't use the sodero repo. Everything you want is in the SBA repo. The sodero repo might contain things you don't want :)

Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Home away from home
Home away from home


See User information
@All
Just to keep topic in sync, and maybe someone will need it later for reference: i build latest gcc 11.3 from adtools by fresh install of cygwin with latest cygwin's packages and all going well. In summary what changes:

1. There is the version of cygwin's newer packages used now:

autoconf 13.1
automake 
11.1
bison 
3.8.2-1
cmake 
3.23.2-1
cvs 
1.11.23-2
flex 
2.6.4-2
gcc
-core 7.4.0-1
gcc
-g++ - 7.4.0-1
git 
2.37.3-1
libgmp
-devel 6.2.1-2
libintl
-devel 0.19.8.1-2
libisl
-devel 0.25-1
libmpc
-devel 1.2.1-2
libmpfr
-devel 4.1.0-2
libtool 
2.4.6-7
make 
4.3.1
mercurial 
6.1.4-1
perl 
5.32.1-2
python27 
2.7.18-4
scons 
4.4.0-1
subversion 
1.14.1-1
wget 
1.21.3-1


2.
Then when time to do gild checkout we do all as always, just "gild/bin/gild checkout gcc 11" instead of "gcc 8", (it will automatically take latest 11.x which is 11.3 for now).

3.
And then as always we do change link to correct/latest SDK in the makefile. Now we at SDK 53.34, so new line for Makefile is:

SDK_URL=http://www.hyperion-entertainment.biz/index.php?option=com_registration&view=download&format=raw&file=125&Itemid=82


4. Start compiling

5.

When things about to be compiled, you will meet with error in original clib2 build, "crtbegin.c:42:10: fatal error: exec/types.h: No such file or directory", that because in new SDK we do have name of exec archive now "execsg_sdk-54.26.lha", while before things about kernel/utility/etc was in the "base.lha". So, either you manually copy from downloaded SDK from adtools/native-builds/downloads content of execsg_sdk-54.26 to SDK in /usr/local/amiga/ppc-amigaos/SDK, or you modify original makefile in adtools/native-build, by adding another "cd downloads/SDK_Install && lha xf execsg_sdk-54.26.lha" where need it, etc.

But it's good idea to just copy content manually over as it can be more issues with unpacking new SDK, so if you didn't want to bother with all the details, just unpack all the shit where is need it.

6.

And you also will be in needs to deal with Reschedule() until new SDK is not out by replacing in gthr-amigaos-native.c this funtion on:

struct Task *me IExec->FindTask(NULL);
IExec->SetTaskPri(meme->tc_Node.ln_Pri);


And that all

Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Not too shy to talk
Not too shy to talk


See User information
@kas1e

Hi, that is exactly what https://github.com/3246251196/adtools is trying to achieve automatically, although, in this one I use the latest clib2.

libunix / libnet are missing from latest clib2 vs older one used, which is necessary for builing the coreutils though. Only because the makefile explicitly includes those libs in LIBS when running the "native-install" rule. They can be removed since - I guess - that those libraries are not needed anymore if using the latest clib2.


Edited by rjd324 on 2022/9/6 15:33:12
Edited by rjd324 on 2022/9/6 15:47:49
If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Not too shy to talk
Not too shy to talk


See User information
Can someone do me a favour with GCC 11.3 then?

Go to afxgroup and compile
test_programs/threads/try_to_time.cpp


When I tried with 11.3 I got dwarf errors, with version 10 and below I do not. I just do not feel confident using 11.3 until that is corrected. Despite that, I have been using 11.3 for sometime, but that is also before @walkero suggested that building the cross-compiler for adtools should really be done using the latest clib2 because the very act of compiling the cross compiler requirers the latest clib2: it is the classic bootstrap scenario.

See also my thread: https://www.amigans.net/modules/newbb/viewtopic.php?topic_id=8959

I hope something like this can bring us even closer together so that we can get things done.

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Home away from home
Home away from home


See User information
@rjd324
For me this one compiles without dwarf errors, that for sure:

user@DESKTOP-3NFAB0O /amiga/clib2-master/test_programs/threads
ppc-amigaos-g++ -athread=native -mcrt=clib2 try_to_time.cpp -o try_to_time -lpthread
try_to_time
.cppIn function ‘voidthread_function(void*):
try_to_time.cpp:86:1warningno return statement in function returning non-void [-Wreturn-type]
   
86 | }
      | ^

user@DESKTOP-3NFAB0O /amiga/clib2-master/test_programs/threads

user
@DESKTOP-3NFAB0O /amiga/clib2-master/test_programs/threads
ls -la try*
-
rwxrwxr-x1 user Отсутствует 10910967 Sep  7 07:05 try_to_time
-rwxrwxr-x1 user Отсутствует     2195 Sep  1 12:11 try_to_time.cpp

user
@DESKTOP-3NFAB0O /amiga/clib2-master/test_programs/threads



Through i do not recompile adtools with new clib2, i compile it with old one, and then compile new clib2 on top.

But, Dwarf errors usually mean differences between too new compiler and too old binutils. What we need , it's new binutils update. I have locale at lest next to 2.32.2 version, which is 2.24, just wasn't commit necessary changes to adtools. But the version of binutils which we surely need in end to have binutils and gcc be in sync in terms of "dwarf" is : 2.29. Once that done, all kind of dwarf errors should gone.

Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Just popping in
Just popping in


See User information
@Raziel

WSL2 Is probably the easiest way of running linux, even easier
than a pre-built linux machine. If you are used to a amiga with
abc-shell WSL2 is easier, and you can install Qt from the
distro's repo(s).

You simple download WSL2 from windows appstore and a couple of
minutes later you have a linux machine with your prefered
distro, ubuntu, Debian, Kali Linux, OpenSUSE (my favorite),
Alpine Linux, Fedora 36+ (for openSUSE it's the latest current
distro version)

There might be some additional ones now.and notice that WSL2 is
one of the things that MS updates alot with new stuff added on a
weekly basis, to update simply go to the windows appstore and
select update.

Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Just popping in
Just popping in


See User information
@Raziel

WSL2 Is probably the easiest way of running linux, even easier
than a pre-built linux machine. If you are used to a amiga with
abc-shell WSL2 is easier, and you can install Qt from the
distro's repo(s).

You simple download WSL2 from windows appstore and a couple of
minutes later you have a linux machine with your prefered
distro, ubuntu, Debian, Kali Linux, OpenSUSE (my favorite),
Alpine Linux, Fedora 36+ (for openSUSE it's the latest current
distro version)

There might be some additional ones now.and notice that WSL2 is
one of the things that MS updates alot with new stuff added on a
weekly basis, to update simply go to the windows appstore and
select update.

Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Not too shy to talk
Not too shy to talk


See User information
@kas1e
@all
Quote:

But it's good idea to just copy content manually over as it can be more issues with unpacking new SDK, so if you didn't want to bother with all the details, just unpack all the shit where is need it.

I am not sure if LHA issues are what you are talking about here. But, it is worth mentioning on this thread:

As for the LHA available through the standard repository on linux. Instead it is best to use:
https://github.com/jca02266/lha.git

and compile it from source. There are no such problems with this version of LHA. After installing it, then
lha --version

shoud report:
LHa for UNIX version 1.14i-ac20220213 (x86_64-pc-linux-gnu)

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: How to build AmigaOS4 cross-compiler (Binutils 2.23.2 & GCC 8.3.0) on CYGWIN
Home away from home
Home away from home


See User information
@rjd324
Quote:

I am not sure if LHA issues are what you are talking about here.


Nope i mean just issues with missing SDK includes in new SDK when not everything unpacked by installer. Lha which i use originally in my howto on first page of this topic works well:

cd /amiga
git 
clone https://github.com/fragglet/lhasa
cd lhasa
./autogen.sh
make
make install

Go to top

  Register To Post
« 1 2 3 (4) 5 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project