Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
68 user(s) are online (51 user(s) are browsing Forums)

Members: 3
Guests: 65

K-L, MartinW, Georg, more...

Headlines

 
  Register To Post  

how hide empty console output of VIM (was falsely about IconX)
Home away from home
Home away from home


See User information
Howdy, have some lame question:

I have some plain shell scrtip which run another command.
I make an icon for it, where i point out that it:

1) script
2) Default tool : C:IconX
3). Start from Workbench

So when i run that script from shell, everything runs fine (understandable, as it runs not from workbench, so IconX didn't handle it).

But when i run it from workbench, then while it all runs fine too, it also bring me some empty window from IconX, which i want to hide. I know it should be something trivial, like pointing out in default tool not just "C:IconX" , but something with run >NIL: or co, but i just can't make it work.

Any ideas ? (without creating another scripts of course)


Edited by kas1e on 2019/5/1 16:05:07
Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: how hide empty console output of C:IconX
Home away from home
Home away from home


See User information
@kas1e

Did you check the "Script" Protection bit on the first tab?

People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Go to top
Re: how hide empty console output of C:IconX
Home away from home
Home away from home


See User information
@Raziel
Sure, i point it by number 1

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: how hide empty console output of C:IconX
Just popping in
Just popping in


See User information
Hi,

To run your command, did you use run >nil: mycommand.exe ?
Any example?

regards,
Petrol

Go to top
Re: how hide empty console output of C:IconX
Home away from home
Home away from home


See User information
@Petrol
Quote:

To run your command, did you use run >nil: mycommand.exe ?


As i say its IconX which is problem. Its output empty shell window when i use it from workbench. Using "run >nil: C:IconX" in the default tool tab not works, saying "please insert volume run >NIL:". Putting the same line to the ".." also didn't help and give the same error.

@All
I do check IconX doc, and find that it have tooltype WINDOW, so i can specify window, name, size, etc. But something like WINDOW=CON:0/0/0/0/ didn't work sadly.

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: how hide empty console output of C:IconX
Not too shy to talk
Not too shy to talk


See User information
@kas1e

Quote:
But when i run it from workbench, then while it all runs fine too, it also bring me some empty window from IconX, which i want to hide.


1) you don't need the script bit if you use IconX

2) add WINDOW=NIL: to the tool types.



Go to top
Re: how hide empty console output of C:IconX
Home away from home
Home away from home


See User information
@Thomas
Thanks for suggestion, but when i use WINNDOW=NIL: it just didnt' starts :(

That how my script looks like (if that make any difference):

.KEY vim_args/F
vim 
-<vim_args>


Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: how hide empty console output of C:IconX
Just can't stay away
Just can't stay away


See User information
@kas1e

Why use IconX at all?



Use a tool icon, select 'start from shell' and turn off prompt for input.

IIRC IconX is just for backwards compatability.


Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
Go to top
Re: how hide empty console output of C:IconX
Home away from home
Home away from home


See User information
@Severin
Quote:

Use a tool icon, select 'start from shell' and turn off prompt for input.


Give the same empty "output window" together with running main binary :(


Edited by kas1e on 2019/4/30 7:00:15
Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: how hide empty console output of C:IconX
Home away from home
Home away from home


See User information
@kas1e

The empty output window does not come from IconX.
It comes from vim.

There's probably no output window when started from shell because shell *is* the output window.
Since you start it from workbench the shell output is created.

People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Go to top
Re: how hide empty console output of C:IconX
Home away from home
Home away from home


See User information
@Raziel

Indeed, the output window is probably not 'empty'. Something somewhere is writting whitespace to STDOUT . Or even just an empty string.

Go to top
Re: how hide empty console output of C:IconX
Home away from home
Home away from home


See User information
As Ola says its probably come from os_amiga.c:
https://github.com/vim/vim/blob/master/src/os_amiga.c

Morphos and aros didnt have that window, so it probably can be some Open calls causing that, or IsInteractive part in some amigaos ifdefs

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: how hide empty console output of C:IconX
Just can't stay away
Just can't stay away


See User information
@kas1e

If it's debug info going to a con: rather than a true shell window try using *>nil: when calling the script to redirect it to nil:

Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
Go to top
Re: how hide empty console output of C:IconX
Just can't stay away
Just can't stay away


See User information
@Severin

How about forwarding output to an actual file instead? Maybe it would be possible to see what was written, then?

Go to top
Re: how hide empty console output of C:IconX
Home away from home
Home away from home


See User information
@Capehill
When i just do in shell "gvim >ram:test", and then exit from vim, then i have in ram: test file of 0 bytes.

But when i run it from shell i have no output window (as shell is output window as others says), but when i run it from WB (and does not matter how, even just pure binary without icon by dbl-click), it always create me "Output window" with nothing in.

That for sure something in the VIM's initialisation code in amigaos4 ifdefs (or in general amiga ifdefs, just on amigaos4 it reacts like this) from the original os_amiga.c:

http://kas1e.mikendezign.com/aos4/vim/os_amiga.c



Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: how hide empty console output of C:IconX
Just popping in
Just popping in


See User information
@kas1e

I think I have a fix for this. It's not a problem in the Amiga specific parts of Vim, it's about the general startup procedure of Vim that needs to be adapted so that we can support both console mode and GUI mode. And still support the possibility to start a shell from within the GUI version for '!' operations.

Go to top
Re: how hide empty console output of VIM (was falsely about IconX)
Home away from home
Home away from home


See User information
@sTix
Right, was about to write there that it was Vim and that you fix it :)

Thanks !

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project