Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
82 user(s) are online (59 user(s) are browsing Forums)

Members: 0
Guests: 82

more...

Headlines




« 1 ... 22 23 24 (25) 26 27 28 ... 30 »


Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2988
@tommysammy

yes

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2007/7/23 21:35
Posts: 739
@joerg

Sorry meant to say, I was streaming the clips.

Cheers

   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2009/6/1 14:11
From Germany
Posts: 733
@LiveForIt
Cool i feel it a little bit. I will test it and upload a new video to YouTube, but not before weekend

_________________
Amiga600/Vampire2/PrismaMegaMix​/32GB CF Card/2x Rys Mk2/A604n/IndivisionECS/Gotek
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2006/11/29 8:09
From Lyon, France
Posts: 1101
Well, only LiveForItMplayer 4.2 is on OS4Depot, isn't it ?

_________________
--
AmigaONE X1000 (not used anymore)
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2988
@K-L

This is 2en time some thing I have uploaded has disappeared.
Uploaded it again.

http://www.os4depot.net/index.php?fun ... lay/liveforit-mplayer.lha


Edited by LiveForIt on 2014/5/21 11:09:53
_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2988
@tommysammy

Did you download 5.1 from upload queue before it was removed? Or did you download the 4.2?

The Altivec version did have cache support in 4.2 as well, only the non Altivec version did not.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just popping in
Joined:
2007/1/1 12:01
From Latina, Italy
Posts: 209
@joerg

Give me the exact steps for benchmarking them please nad i'll do that...

thanks

_________________
Sam 460EX, 2Gb Ram, Radeon R7 250, AmigaOS4.1 FE
A4000 PPC604@233, Mediator
A1200 PPC603@160, Mediator
uA1 G3@800, 512 Mb [sold]
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2009/6/1 14:11
From Germany
Posts: 733
@LiveForIt
I downloaded this morning V5.1 from os4depot uploads
I use now cache over the MPlayer Gui

_________________
Amiga600/Vampire2/PrismaMegaMix​/32GB CF Card/2x Rys Mk2/A604n/IndivisionECS/Gotek
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2006/12/1 19:07
From Germany
Posts: 1022
@sofistisoftware

Quote:
Give me the exact steps for benchmarking them please nad i'll do that...
You could use any video, you just have to use the same one with all MPlayer versions, but it would be best if you get http://www.amiga-ng.org/resources/Mplayer/Superman.flv and test with that one since it was used in previous MPlayer benchmarks.

Copy all MPlayer executables into the same directory to make sure they use the same (or no) conf/mplayer.conf. Start them as "mplayer -quiet -nosound -benchmark Superman.flv" in a shell and post the 2 BENCHMARK output lines from each version.

   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2008/11/19 22:44
From Tarsus IV
Posts: 548
Is there any possibility to include unicode in subs, so that we can watch them correctly (eg. greek)?

_________________
To Be A True Adventurer, You Ought To Play Real Text Adventures
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2006/12/1 19:07
From Germany
Posts: 1022
@Phantom

Quote:
Is there any possibility to include unicode in subs, so that we can watch them correctly (eg. greek)?
Should be very easy, if it doesn't work already, since it's using a truetype font (one of the DejaVu ones by default in my version) for it.
I need a small video with greek sub titles for testing/fixing it.

   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2988
@sofistisoftware

Last version of LiveForIt Mplayer I optimized for slower computers whit old Radeon cards by using RGB, but it will only be activated by a video output switch.

So for Radeon cards use:

mplayer -quiet -benchmark -ao null -nosound -vo comp::rgb superman.flv

for RadeonHD cards use:

mplayer -quiet -benchmark -ao null -nosound superman.flv

EDIT:

Actually can you test with and without the rgb option, so we can see the difference it makes, on the MicroAmigaONE and maybe the A1200/A4000 of yours. That is if composition is working on the A1200/A4000 computers.

And one more thing don't forget to test all bugs that they really are fixed like AREXX, SDL crash on exit and so on.


Edited by LiveForIt on 2014/5/21 19:13:42
Edited by LiveForIt on 2014/5/21 19:14:42
Edited by LiveForIt on 2014/5/21 19:18:45
Edited by LiveForIt on 2014/5/21 19:20:25
_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Not too shy to talk
Joined:
2006/12/2 0:31
From Poland
Posts: 329
@LiveForIt

mplayer -quiet -benchmark -ao null -nosound ram:superman.flv

BENCHMARKs: VC: 43.934s VO: 29.419s A: 0.000s Sys: 0.494s = 73.848s
BENCHMARK%: VC: 59.4931% VO: 39.8381% A: 0.0000% Sys: 0.6688% = 100.0000%


mplayer -quiet -benchmark -ao null -nosound -vo comp::rgb ram:superman.flv

BENCHMARKs: VC: 44.102s VO: 34.257s A: 0.000s Sys: 0.466s = 78.825s
BENCHMARK%: VC: 55.9495% VO: 43.4594% A: 0.0000% Sys: 0.5910% = 100.0000%




_________________
Sam440 flex 800MHz RAM 1GB R9250 128MB OS4.1 SBLive! ->
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2988
@mr2

what graphic card do you use?

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Not too shy to talk
Joined:
2006/12/2 0:31
From Poland
Posts: 329
R9250 128MB, SAM440 flex...

_________________
Sam440 flex 800MHz RAM 1GB R9250 128MB OS4.1 SBLive! ->
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2007/2/6 13:57
From Donostia (SPAIN)
Posts: 658
SAM460ex RadeonHD6570

#mplayer-noaltivec -benchmark -nosound -quiet ram:Superman.flv
MPlayer LiveForIt V5.1 - SVN-rSVN-r32634-4.2.4(C) 2000-2010 MPlayer Team
...
BENCHMARKs: VC: 36.581s VO: 11.854s A: 0.000s Sys: 0.415s = 48.850s
BENCHMARK%: VC: 74.8844% VO: 24.2660% A: 0.0000% Sys: 0.8496% = 100.0000%


#mplayer-noaltivec -benchmark -nosound -quiet -vo comp::rgb ram:Superman.flv
MPlayer LiveForIt V5.1 - SVN-rSVN-r32634-4.2.4(C) 2000-2010 MPlayer Team
...
BENCHMARKs: VC: 35.664s VO: 18.364s A: 0.000s Sys: 0.490s = 54.519s
BENCHMARK%: VC: 65.4163% VO: 33.6843% A: 0.0000% Sys: 0.8994% = 100.0000%


#mplayer-noaltivec -benchmark -nosound -quiet -vo comp::argb ram:Superman.flv
MPlayer LiveForIt V5.1 - SVN-rSVN-r32634-4.2.4(C) 2000-2010 MPlayer Team
...
BENCHMARKs: VC: 36.271s VO: 12.066s A: 0.000s Sys: 0.437s = 48.774s
BENCHMARK%: VC: 74.3666% VO: 24.7380% A: 0.0000% Sys: 0.8954% = 100.0000%


#md5sum ram:Superman.flv
a59b3bc3eb2c34cf271d498caab7240e ram:Superman.flv

   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3433
@LiveForIt

Quote:
And one more thing don't forget to test all bugs that they really are fixed like AREXX, SDL crash on exit and so on.


Yes confirmed, the crash at exit with SDL is now fixed

Comp driver behaviour seems different instead, compared to the previews 4.2 release pressing pause doesn't make any glitch. however the video area become completely white when paused ..

Still also the white stripes in p96 driver .. sadly this issue was re-introduced since version 4 ..

P.S.
I just reported in Google repo a few more bugs/request.
Most of them were just the old features taked from the Afxgroup's changelog so you should already have all the code in repo ..

Hope to have reported anythings


Edited by samo79 on 2014/5/22 0:35:36
Edited by samo79 on 2014/5/22 0:59:29
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Not too shy to talk
Joined:
2006/12/2 1:41
From VA, USA
Posts: 295
@LiveForIt

Hi,

First, let me add my thanks for your (and everyone's)
efforts with these new MPlayer releases!

Second, I tried the latest v5.1 builds on my X1K with the
stock 4650 gfx card. With or without the altivec version
I was able to play this x720 video at 100% speed (according
to the -benchmark output):

The_World_Outside_My_Window_-_Time_Lapse_of_Earth_from_the_ISS
http://www.youtube.com/watch?v=GOAEIMx39-w

But I did encounter another pair of bugs related to pausing
a playing video (hitting the space bar).

Playing in a window on a "normal" 1920x1200 screen, if I
hit the space bar, the window contents turn gray.

Playing in a window on my usual 2560x1200 autoscrolling
screen, the video freezes and the image shifts down and to
the right of the window, like this:

http://www.pjsa.net/paused-grab.jpg

Here's a shot of what that stretch of video should look
like:

http://www.pjsa.net/playing-grab.jpg

OTOH, If I play the video in full screen mode. then pausing
seems to mostly work OK.

FWIW, this is happening on a beta X1K.

Thanks,

PJS

   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2009/6/1 14:11
From Germany
Posts: 733
@LiveForIt

X1000 with radeon 687012
/0.AmigaOS4.1:> mplayer -quiet -benchmark -ao null -nosound ram:superman.flv
MPlayer LiveForIt V5.1 - SVN-rSVN-r32634-4.2.4(C) 2000-2010 MPlayer Team

Playing ram:superman.flv.
libavformat file format detected.
[flv @ 0x45133890] Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0
VIDEO: [H264] 640x266 0bpp 25.000 fps 326.2 kbps (39.8 kbyte/s)
Clip info:
duration: 86
starttime: -inf
totalduration: 86
width: 640
height: 266
videodatarate: 319
audiodatarate: 129
totaldatarate: 455
framerate: 25
bytelength: 4888212
canseekontime: true
sourcedata: BADC214E4HH1348869781057134
purl:
pmsg:
VO: [comp] Welcome man !.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
Audio: no sound
Starting playback...
Movie-Aspect is undefined - no prescaling applied.
VO: [comp] 640x266 => 640x266 Planar YV12
VO: Disabling blanker
[swscaler @ 0x42b53d80]ALTIVEC: Color Space ARGB
[swscaler @ 0x42b53d80]using unscaled yuv420p -> argb special converter
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (progdir:conf/subfont.ttf).
subtitle font: load_sub_face failed.
New_Face failed. Maybe the font path is wrong.
Please supply the text font file (progdir:conf/subfont.ttf).
subtitle font: load_sub_face failed.


BENCHMARKs: VC: 9.203s VO: 3.802s A: 0.000s Sys: 0.108s = 13.113s
BENCHMARK%: VC: 70.1824% VO: 28.9930% A: 0.0000% Sys: 0.8246% = 100.0000%
VO: Enabling blanker
VO: Enabling blanker

Exiting... (End of file)


_________________
Amiga600/Vampire2/PrismaMegaMix​/32GB CF Card/2x Rys Mk2/A604n/IndivisionECS/Gotek
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2009/6/1 14:11
From Germany
Posts: 733
@LiveForIt

Now it is possible to play my Battleship.avi 1080p synchron and in good quality.
I will make a video of it.
720p videos over SMTube works now a little bit better

_________________
Amiga600/Vampire2/PrismaMegaMix​/32GB CF Card/2x Rys Mk2/A604n/IndivisionECS/Gotek
   Report Go to top


« 1 ... 22 23 24 (25) 26 27 28 ... 30 »



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project