Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
60 user(s) are online (45 user(s) are browsing Forums)

Members: 1
Guests: 59

trixie, more...

Headlines

Forum Index


Board index » All Posts (mr2)




Re: Official release date of Doom3 for AmigaOS4
Not too shy to talk
Not too shy to talk


While my SAM440 has HD7750 and a full Enhancer, it has only 1GB RAM. I was hoping for some fun with testing with the lowest possible settings...:(

...others anyway, have fun!

Sam440 flex 800MHz RAM 1GB HD7750 128MB OS4.1 SBLive! ->
Go to top


Re: ScummVM&Grim Fandango
Not too shy to talk
Not too shy to talk


@kas1e

Yeah I know Wazp3D is slow but now I know the game stars OK and the problem was lack of W3D_SI.
SAM440 & HD7750 & Enhancer 2.1

Go to top


Re: ScummVM&Grim Fandango
Not too shy to talk
Not too shy to talk


@corto

It didn't cross my mind to look at the Extras ...but it turned out that this file from github is ok, too.

@corto, kas1e

Oh my, I forgot about that War3D_SI, that I do not have it
Wazp3D did the trick enough to see that game starts. Intro is OK and the rest of the game has wrong colors and is sloooow. But it works

Quote:
If you want, i can build gl4es binary of scummvm for you, so you will be able to have decent speed


What about Scumm options Graphics->SDL Surface and in SDL2 Prefs change driver to...I'm lost . If you think others will have an advantage too, then why not, thanks

@Raziel
Quote:
...unfortunately no active development on supporting it in scummvm main.


Oh well, I've just lost 6 euros since I'm totally not interested to play it on PC

Go to top


ScummVM&Grim Fandango
Not too shy to talk
Not too shy to talk


Hi,
I bought GF Remastered and then realized it is not supported. I hope they will add it later.
Grim Fandango (original) runs fine on my PC laptop but does not start om my SAM440&HD7750. It complains about lack of "grim-patch.lab" file but there is no such file on my PC. Here is a list of files in my SAM directory:

CREDITS.LAB DATA000.LAB DATA001.LAB DATA002.LAB
DATA003.LAB DATA004.LAB gfupd101.exe GRIM.EXE
GrimFandango.EXE MOVIE00.LAB MOVIE01.LAB
MOVIE02.LAB MOVIE03.LAB MOVIE04.LAB VOX0000.LAB
VOX0001.LAB VOX0002.LAB VOX0003.LAB VOX0004.LAB
YEAR0MUS.LAB YEAR1MUS.LAB YEAR2MUS.LAB YEAR3MUS.LAB
YEAR4MUS.LAB

I found such file on a github but then ScummVM 2.5.1 (default setings) "failed to create MiniGL context". If I change to OpenGL graphic ->"OpenGLGraphicsManager::endGFXTransaction: Could not load any graphics mode"
Files veryfication went fine, other games runs. Any help?

Go to top


Re: Should I expect better video playback performance? (Southern Island/X1000 Updates)
Not too shy to talk
Not too shy to talk


@Spectre660

Does anyone test it on SAM440?

Go to top


SAM440 HD7750 - Emotion crash
Not too shy to talk
Not too shy to talk


Hi, I have two crashes with Emotion player. Both easy to reproduce. The first one is skipable.
First one is when I try to tick "Hide window border" and then "Window on Top"
It's OK on X1000 and X5000:

Crash log for task "Emotion"
Generated by GrimReaper 53.19
Crash occured in module intuition.library.kmod at address 0x01A63BE4
Type of crash: DSI (Data Storage Interrupt) exception
Alert number: 0x80000003

Register dump:
GPR (General Purpose Registers):
0: 6FA1323C 540362F0 00000000 51224C20 00000000 51224C20 00000000 00000001
8: 540361A8 01A63BCC 00000000 00000002 4A442228 57FD8810 00000000 00000000
16: 00000004 000F0000 00100000 000A0000 000B0000 00050000 00060000 00010000
24: 54036340 511D0008 57FD0000 57FD0000 00570001 00090000 000D0000 511D0008


FPR (Floating Point Registers, NaN = Not a Number):
0: nan 0 1 0.181836
4: 0.222222 4.5036e+15 406 406
8: 256 653 4.5036e+15 0
12: 0 2.14748e+09 0 2.73172e+12
16: 4.90817e-193 0 0 0
20: 0 0 0 0
24: 0 2.65249e-315 0 0
28: 0 0 0 5.58066e-222

FPSCR (Floating Point Status and Control Register): 0x82000000


SPRs (Special Purpose Registers):
Machine State (msr) : 0x0002F030
Condition (cr) : 0x53FF7DC0
Instruction Pointer (ip) : 0x01A63BE4
Xtended Exception (xer) : 0x0183B24C
Count (ctr) : 0x00000000
Link (lr) : 0x00000000
DSI Status (dsisr) : 0x0185BB0C
Data Address (dar) : 0x00000000



680x0 emulated registers:
DATA: 00000001 00000001 00000000 00000000 00000000 00000000 00000000 00000000
ADDR: 5FFA4000 B2C1C400 00000000 00000000 00000000 00000000 00000000 54036030
FPU0: 0 0 0 0
FPU4: 0 0 0 0



Symbol info:
Instruction pointer 0x01A63BE4 belongs to module "intuition.library.kmod" (HUNK/Kickstart)

Stack trace:
native kernel module intuition.library.kmod+0x00014864
module Emotion at 0x6FA1323C (section 0 @ 0xF218)
module Emotion at 0x6FA22CF0 (section 0 @ 0x1ECCC)
module Emotion at 0x6FA0A854 (section 0 @ 0x6830)
native kernel module newlib.library.kmod+0x0000260c
native kernel module newlib.library.kmod+0x00003338
native kernel module newlib.library.kmod+0x0000385c
Emotion:_start()+0x1e0 (section 1 @ 0x1DC)
native kernel module dos.library.kmod+0x0002a458
native kernel module kernel+0x00057104
native kernel module kernel+0x0005717c

Second one is while trying to use Emotion with IOStreams and Youtube
A message "I/O error" appears and then I have a crash in Emotion decode thread:

Crash log for task "emotion decode thread"
Generated by GrimReaper 53.19
Crash occured in module kernel at address 0x02000000
Type of crash: ISI (Instruction Storage Interrupt) exception
Alert number: 0x80000003

Register dump:
GPR (General Purpose Registers):
0: 6CADF9F8 4AF3CCA0 00000000 49D20A80 00000000 00000001 50B78E30 000000DB
8: 49F90000 02000000 0227D9D2 018354CC 4A442284 00000000 FFFFFFFF 4A330000
16: 51311550 4A330000 00000000 01930000 4E1B6DF8 50B78E7A 142F3925 6CC362F4
24: 49F90000 4AA1E2F0 49F90000 4A808A60 018611C0 49F90000 50BCE220 02169BD4


FPR (Floating Point Registers, NaN = Not a Number):
0: nan 1 0 1
4: 0.222222 4.5036e+15 1016 128
8: 386 1417 60 4.5036e+15
12: 4.5036e+15 2.14748e+09 0 2.41793e-295
16: 0 0 0 0
20: 0 0 0 0
24: 0 2.65249e-315 4.23883e-270 nan
28: 0 0 0 5.58058e-222

FPSCR (Floating Point Status and Control Register): 0x82004000


SPRs (Special Purpose Registers):
Machine State (msr) : 0x0002F030
Condition (cr) : 0x4AA35DC0
Instruction Pointer (ip) : 0x02000000
Xtended Exception (xer) : 0x0183B24C
Count (ctr) : 0x00000000
Link (lr) : 0x00000000
DSI Status (dsisr) : 0x0185BB0C
Data Address (dar) : 0x00000000



680x0 emulated registers:
DATA: 00000001 00000000 00000000 00000000 00000000 00000000 00000000 00000000
ADDR: 5FFA4000 B27CA100 00000000 00000000 00000000 00000000 00000000 4AF3BE90
FPU0: 0 0 0 0
FPU4: 0 0 0 0



Symbol info:
Instruction pointer 0x02000000 belongs to module "kernel" (HUNK/Kickstart)

Stack trace:
native kernel module kernel+0x00800000
CURRDIR:Libs/avformat2.library:Release()+0x120 (section 1 @ 0xA54)
native kernel module ramlib.kmod+0x00000218
module APPDIR:emotion at 0x6CC38520 (section 0 @ 0x134FC)
native kernel module dos.library.kmod+0x0002a458
native kernel module kernel+0x00057104
native kernel module kernel+0x0005717c

Go to top


Re: Should I expect better video playback performance?
Not too shy to talk
Not too shy to talk


@amigakit

Sounds intriguing

Since you are here Can we expect some info about A1222plus?

Go to top


Re: Should I expect better video playback performance?
Not too shy to talk
Not too shy to talk


@amigakit

Quote:
 This is why is made no financial sense when Hyperion reduced OS4.1 to 29 EUR 


Fully agreed.

As for the rest of your post - sounds ok for me.

I know it's risky but can you give any rough timing?

Thank you.

Go to top


Re: Should I expect better video playback performance?
Not too shy to talk
Not too shy to talk


@Amigo1

The price is over 88 euros plus taxes and my concerns have nothing to do with the X1000. 3D Nova is fun but has limited use due to the lack of 3D software and the nature of my very poor hardware. The reason I decided to buy the ES2.0 was the UVD support and respect for the developers. I knew this was only for Polaris cards, but I was hoping that the SI ​​cards would be added later.
Looks like I'll have to buy a full V54 just to get that goddamn UVD.
All this means that when I bought the ES2.0 I got much less than the Polaris users.

Go to top


Re: Should I expect better video playback performance?
Not too shy to talk
Not too shy to talk


@amigakit

ES2.0 includes UVD support for RX cards. So, Polaris card owners got it for the price of the ES2.0 package. I already have ES2.1 and an SI card. Will I have to pay again to get UVD support?

Go to top


Re: Exodus The Last War patching : v0.1 patch on os4depot
Not too shy to talk
Not too shy to talk


@nbache

I didn't even think about it. There is an "Auto" button but it does nothing. The OSD menu shows that something can "scale" but is inactive so I think this model does not have such a function. Thanks anyway, you were close :)

Sam440 flex 800MHz RAM 1GB HD7750 128MB OS4.1 SBLive! ->
Go to top


Re: Exodus The Last War patching : v0.1 patch on os4depot
Not too shy to talk
Not too shy to talk


@kas1e

Yeah, all 640x480 look the same...all above are scrambled. Nevermind, its OK as it is now :)

Sam440 flex 800MHz RAM 1GB HD7750 128MB OS4.1 SBLive! ->
Go to top


Re: Exodus The Last War patching : v0.1 patch on os4depot
Not too shy to talk
Not too shy to talk


@kas1e

Quote:
How you was able to scale it at all to 1920x1080? Just by choosing that video mode? If so it means os4's scale it.


I mean, I choose 640x480 but monitor native resolution is 1920x1200. So to cover the whole area three monitor pixels are used to show one game pixel. That makes it blury. I thought about using smaller part of the monitor. I don't know if I explained it well .

Sam440 flex 800MHz RAM 1GB HD7750 128MB OS4.1 SBLive! ->
Go to top


Re: Exodus The Last War patching : work in progress
Not too shy to talk
Not too shy to talk


Working good. The only major drawback is the 640x480 screen streched to 1920x1200 size looks blury. Is it possible to not to scale it up....with black borders o sth?

Sam440 flex 800MHz RAM 1GB HD7750 128MB OS4.1 SBLive! ->
Go to top


Re: Foundation patching: v0.1 patch on os4depot
Not too shy to talk
Not too shy to talk


@kas1e

Sure, I have read readme but couldn't hear any SFX even with a high volume. Ok, I will play more with it.

Sam440 flex 800MHz RAM 1GB HD7750 128MB OS4.1 SBLive! ->
Go to top


Re: Foundation patching: v0.1 patch on os4depot
Not too shy to talk
Not too shy to talk


@kas1e

Working good I use a modified EVO theme and gadgets don't fit, still. Luckily, they are visible and working.
CD audio works but I can't hear sound FXs during a game...or maybe music exludes SFXs?

Sam440 flex 800MHz RAM 1GB HD7750 128MB OS4.1 SBLive! ->
Go to top


Re: Foundation patching: v0.1 patch on os4depot
Not too shy to talk
Not too shy to talk


@kas1e

Nice! Is it possible to increase the size of a window, in a WB mode?
Max is 800x600.

I will test the patch later...

Sam440 flex 800MHz RAM 1GB HD7750 128MB OS4.1 SBLive! ->
Go to top


Re: Pixy new pixel editor for amigaos4
Not too shy to talk
Not too shy to talk


Suddenly, the initial crash has gone :-O I'm 100% sure it was with the new version, too.

But more important is, it consumes 100% CPU immediately after start and all the time. So smooth painting is no go on my SAM440 HD7750.

Sam440 flex 800MHz RAM 1GB HD7750 128MB OS4.1 SBLive! ->
Go to top


Re: DVPlayer 54.4 minor bugs
Not too shy to talk
Not too shy to talk


@amigakit

Due to my ignorance of the subject, I asked the wrong question...
so, once again. Do I have to buy DVPlayer to get the UVD Southern Islands driver for VA Lib? I have ES2.1.

Quote:
On another side subject, did the InfoWB Polish catalogs work ? InfoWB now supports Shift+click and should be fully localised for Polish users.


Usually I do not install such replacements so I had to install it now.
While shift+LMB works fine, Polish catalogs do not. During the installation a message came out. RAWBinfo will be disabled but it was removed from WBStartup. Should be unticked, not removed. Plus, InfoWB was not ticked.


Sam440 flex 800MHz RAM 1GB HD7750 128MB OS4.1 SBLive! ->
Go to top


Re: DVPlayer 54.4 minor bugs
Not too shy to talk
Not too shy to talk


A quick test (only 3 films) done by one of the users showed DVPlayer is unable to play 4K vids ("unable to display") while Emotion play them OK.
My SAM440/HD7750 is waiting. 720p is OK for my needs but why RX owners gets more for the buck than SI owners? And why a bundle VA.lib with DVPlayer. If I'm forced to buy this library I prefer to buy it separately and then the Emotion...
...and in 2022, System54 (a new name for ES3.0 IMO;)) with the same library and DVPlayer,again.
Anyway, at least there is a confirmation, UVD for SI is in the works because pobably, we won't be able to use RXs in our little SAMs.

BTW. I'm a registered user of a previous DVplayer.

Sam440 flex 800MHz RAM 1GB HD7750 128MB OS4.1 SBLive! ->
Go to top



TopTop
(1) 2 3 4 ... 16 »




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project