Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
88 user(s) are online (65 user(s) are browsing Forums)

Members: 1
Guests: 87

musashi5150, more...

Headlines






[SOLVED] SimpleMail Corruption...
Not too shy to talk
Joined:
2006/11/22 19:55
From P'Boro, UK... Could that be ?
Posts: 496
Dear All,

I'm been using SimpleMail for quite some time... But (and it's the second time) it got corrupted !
I managed to launch it, but as soon as I click "Fetch", I have a DSI error, and I can not kill it... After a ahile the A1 generally freeze as well !

Did anyone else ever got that problem ?

Jerry


Edited by AmiGame on 2007/12/12 9:00:49
_________________


Defender of my A1XE-G4 / AOS4 Final Update !
Looking for a new toy ? Then try a GP2X...
   Report Go to top

Re: SimpleMail Corruption...
Amigans Defender
Joined:
2006/11/19 17:45
From Cambridgeshire, UK.
Posts: 2108
@AmiGame

Sorry, thankfully mine is working correctly. You updated any MUI libs or such like lately?

_________________
Mikey C

No cause is lost if there is but one fool left to fight for it.
   Report Go to top

Re: SimpleMail Corruption...
Not too shy to talk
Joined:
2006/12/3 23:51
From France
Posts: 455
@AmiGame

using latest simplemail too but no corruption so far, and I do regular backups

   Report Go to top

Re: SimpleMail Corruption...
Not too shy to talk
Joined:
2006/11/29 15:01
From Earth
Posts: 257
@AmiGame
happened to me a couple of times. I don't think it is SimpleMail's fault. It is usually caused by a message that has been fetched and which contains maybe spyware or worse. I manually delete the offending message from the inbox folder before starting Simplemail after a fast reboot.

_________________
A1XEG4 PPC 7457 1.3GHz
CDTV!!
   Report Go to top

Re: SimpleMail Corruption...
Not too shy to talk
Joined:
2006/11/22 19:55
From P'Boro, UK... Could that be ?
Posts: 496
@Swisso

Thanks. I will try that tonight or tomorrow. That might well be the problem indeed !

@Mikey_C
After the first corruption a couple of weeks ago, I had my AOS4: partition entering a validation state which then corrupted my MUI folder (impossible to open it then)... After restoring a "fairly" old MUI backed up folder (about 6 months old), I managed to restore my system to its normal self...

Jerry

_________________


Defender of my A1XE-G4 / AOS4 Final Update !
Looking for a new toy ? Then try a GP2X...
   Report Go to top

Re: SimpleMail Corruption...
Home away from home
Joined:
2007/5/19 14:23
From England
Posts: 3559
@Swisso
I guess this is a case where full memory protection would be a good thing, because the problem isn't strictly speaking SimpleMail's fault. Although it should really do better input validation...

Perhaps something to add SimpleMail's bug tracker?

   Report Go to top

Re: SimpleMail Corruption...
Amigans Defender
Joined:
2006/11/26 23:16
From Canada
Posts: 986
@AmiGame
You might want to hook up a serial cable and see if you get anything out that way. When an application freezes input.device you have no way to interact with the reaper.

_________________
ExecSG Team Lead
   Report Go to top

Re: SimpleMail Corruption...
Not too shy to talk
Joined:
2006/11/22 19:55
From P'Boro, UK... Could that be ?
Posts: 496
@All,

Thanks all. After removing a few recent email from the incoming email folder (physical folder not through SimpleMail), no more problems !

The emails causing me trouble were Emails with a PPS attached from a trusted source (no virus detected when I opened it on the wimpblows machine with Avast AV loaded)...

Jerry

_________________


Defender of my A1XE-G4 / AOS4 Final Update !
Looking for a new toy ? Then try a GP2X...
   Report Go to top

Re: SimpleMail Corruption...
Not too shy to talk
Joined:
2006/11/22 19:55
From P'Boro, UK... Could that be ?
Posts: 496
@All

I just changed the Thread Title to "SOLVED"...

Now this corruption... Could it be caused by the attachment being too large (I think it was over 2MB) ?

Jerry

_________________


Defender of my A1XE-G4 / AOS4 Final Update !
Looking for a new toy ? Then try a GP2X...
   Report Go to top

Re: SimpleMail Corruption...
Just popping in
Joined:
2007/2/24 10:59
From Near Cologne, somewhere in the deep forest
Posts: 147
@AmiGame

Well, I had this "corruption" from time to time in the past and I had the deep impression that it originated from the HTML view part of SimpleMail.

Size seemed to be no point, as I had this corruption even with very small mails (there was a very small mail breaking SimpleMail, something about 2K of size). For the last months, the corruption problem didn't occur for me anymore, don't know exactly what the reason is.

But I can tell you that PPS files are not the cause, because I received several PPS, even very big ones, and SimpleMail doesn't crash because of them.

Regards

   Report Go to top





[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project