Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
36 user(s) are online (15 user(s) are browsing Forums)

Members: 2
Guests: 34

salass00, eliyahu, more...

Headlines

 
  Register To Post  

« 1 2 3 (4)
Re: Switch between many amigaos4 machines
Just can't stay away
Just can't stay away


See User information
@kas1e

I wrote: Quote:
The other new USB hub is now on the ATEN CS 1764A connecting my Sam440ep and my Sam460ex. I had hoped they would react to the keyboard in UBoot as well, but that doesn't seem to have happened. I'm going to have to experiment more with that.
Finished experimenting.

It works on the 460ex now, both with the USB hub connected to the front general USB port of the (CS1764A) and to the rear general USB port.

But on the 440ep, it doesn't work, neither in the front nor in the rear port.

Again, one out of two ain't bad . So thanks again.

Best regards,

Niels

Go to top
Re: Switch between many amigaos4 machines
Home away from home
Home away from home


See User information
@nbache

By didn't works you mean didn't works even when os4 loads up ? Or only in firmware ? For me (at least with Tesmart switch) all different os4 machines works when os4 loads. I.e. all machine works even before i use additional usb-port, just sam and peg didnt' works in firmware. Once i add passive usb hub and start use additional usb port, then sam460 works in firmware as well (and continue to works in os4 too).

Pegasos2 also works when os4 loads up, just in firmware didn't (even with this usb-passive hub trick).

I understand correclty that sam440 didn't works in firmware, but works in os4 ?

(just trying to gather all information about, so maybe we can find how to make peg2 and sam440 works in firmware too).

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: Switch between many amigaos4 machines
Just popping in
Just popping in


See User information
I have KVM switches with stereo sound, but poor quality.

I use home made box, similar to kas1e's scheme for 6 computers. Quality is much better than from KVM switches.
And now I have to build another one for 8-10 computers.
I will look if I find my old scheme and post it here.

AmigaOS3: Amiga 1200
AmigaOS4: Micro A1-C, AmigaOne XE, Pegasos II, Sam440ep, Sam440ep-flex, AmigaOne X1000
MorphOS: Efika 5200b, Pegasos I, Pegasos II, Powerbook, Mac Mini, iMac, Powermac Quad
Go to top
Re: Switch between many amigaos4 machines
Home away from home
Home away from home


See User information
@Sailor
IMHO (at least how i understand it) , KVM switches are bad for sounds/music. And what can be used is strandalone audio-only switches. Passive or active ones.

For this (passive) one:
https://www.amazon.com/EKDSPW-Passive- ... e+mix%2Caps%2C295&sr=8-30

I read some good info about, and trust in because it probabaly about the same as on scheme i post, just a little bit more protection from loosing the quality. But as it passive it surely will have a bit loose of volume in out, but that can be controlled easy. Anyway, ordered this one already , should be at my hands in next 10 days, so can test it till death.

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top
Re: Switch between many amigaos4 machines
Just popping in
Just popping in


See User information
@kas1e
It looks perfect. But for me too few inputs - only four.
On my new place I need now 8 inputs, so it will be wise made 10-12 input device.

But of course, device from your link is far better, my have no mixing volume - it simply add all signals together.

And poor sound have both my KVM switches. Maybe other are better

AmigaOS3: Amiga 1200
AmigaOS4: Micro A1-C, AmigaOne XE, Pegasos II, Sam440ep, Sam440ep-flex, AmigaOne X1000
MorphOS: Efika 5200b, Pegasos I, Pegasos II, Powerbook, Mac Mini, iMac, Powermac Quad
Go to top
Re: Switch between many amigaos4 machines
Just popping in
Just popping in


See User information
@sailor
For my computer audio mixdown I'm using a Behringer 8 stereo channel 1 unit rack mixer:
https://www.behringer.com/behringer/product?modelCode=P0DB6

I have the "original" model, though. I don't know what the V2 brings to the game.

It's not the cheapest solution, and it does take up some desk space. But for me it does a pretty good job. Plus you can stack other things on top of it, it being a rack mixer

Regards,
Thomas

Go to top
Re: Switch between many amigaos4 machines
Just popping in
Just popping in


See User information
@graff
it looks super! Unfortunatelly has no sales in Czech republic.

AmigaOS3: Amiga 1200
AmigaOS4: Micro A1-C, AmigaOne XE, Pegasos II, Sam440ep, Sam440ep-flex, AmigaOne X1000
MorphOS: Efika 5200b, Pegasos I, Pegasos II, Powerbook, Mac Mini, iMac, Powermac Quad
Go to top
Re: Switch between many amigaos4 machines
Just popping in
Just popping in


See User information
@kas1e

Here is my simple device. On drawing are only three inputs and one output.
In real I have six jack + one cinch inputs and jack + cinch output ( have to select one output only)

Now I can made 10-12 input device, with the same parameters.

Of course, it is not high quality professional, but cheap, simple and working.


Edited by sailor on 2022/12/5 18:02:00
AmigaOS3: Amiga 1200
AmigaOS4: Micro A1-C, AmigaOne XE, Pegasos II, Sam440ep, Sam440ep-flex, AmigaOne X1000
MorphOS: Efika 5200b, Pegasos I, Pegasos II, Powerbook, Mac Mini, iMac, Powermac Quad
Go to top
Re: Switch between many amigaos4 machines
Just can't stay away
Just can't stay away


See User information
@kas1e

Quote:
By didn't works you mean didn't works even when os4 loads up ? Or only in firmware ?
Yeah sorry, that wasn't so clear.

It works fine in all cases when booted to OS4, I'm only talking about the behaviour in UBoot.

Best regards,

Niels

Go to top
Re: Switch between many amigaos4 machines
Quite a regular
Quite a regular


See User information
https://forum.hyperion-entertainment.com/viewtopic.php?t=4884

Hi. This link is not to do with KVM.

I notice the time out polling too. When the keyboard is not working I see the keyboard being driven by the boot driver, not hid.usbfd.

Do you also see this @kas1e.

What is the solution in a nutshell to save me reading... get a cheap powered USB hub, bung the USB hub into any USB port on the X5 and then bung the keyboard into the powered USB hub?

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: Switch between many amigaos4 machines
Home away from home
Home away from home


See User information
@rjd324
Quote:

What is the solution in a nutshell to save me reading... get a cheap powered USB hub, bung the USB hub into any USB port on the X5 and then bung the keyboard into the powered USB hub?


For the “polling out” output in the firmware of x5000, it was enough to use the additional USB port on the KVM instead of the special “keyboard” one. Yeah, you lose extra combos of KVM then, but you then have “usual” USB without adding extra layers on top). But it was on X5000 only, and only when KVM involved.

With x1000 and sam460, I didn't have those “polling out” warnings, but sam460 wasn't working in the firmware at all. So to make that one work, I got a very cheap passive 4-port USB hub, attached a mouse and keyboard to it, and connected the hub itself to the same “additional” KVM's USB port. Then, the X5000, X1000, and Sam460 keyboards started to work everywhere, in the firmware and in the OS itself. And X5000 as i say have no “polling” warnings anymore.

But should to add, that when I connected my keyboard directly to any Amiga hardware, it works all the time and in all the firmware, and in the os4 itself too.

And even with KVM, I do have a working keyboard always when the OS4's USB stack is up and without any additional USB hubs. Mambo-jambo with additional hub was only because of sam460 no working in firmware and “polling” warnings on the X5000. With additional passive USB hub, those issues gone.

Maybe, it will help your X1000 polling out errors too. I do not know what passive USB hubs to do, but still they have some logic too, which seems to make impact sometime.


As for bootkeyboard.usbfd : i do use bootkeyboard.usbfd 52.7 (05/24/2021) , which probably much newer than public one, but this one anyway required latest beta of USB-stack as well too, so dunno how to check for you if that is the cause.

But if you have "polling out" warnings even in firmware, it mean issues is not on the software level (or, also on software level, but in both, in the firmware usb-code itself, and in the os4 usb-stack), but trying some cheap passive hub can worth a shot anyway (but for tests attach exactly to the first port as it really can make differences. At least for tests).

Join us to improve dopus5!
AmigaOS4 on youtube
Go to top

  Register To Post
« 1 2 3 (4)

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project