Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
48 user(s) are online (24 user(s) are browsing Forums)

Members: 0
Guests: 48

more...

Headlines

 
  Register To Post  

« 1 (2) 3 »
Re: IBrowse 3.0 released
Just popping in
Just popping in


See User information
Excellent. I bought Ibrowse 2.5 and have kept up with all the upgrades.

Thanks for letting those who bought the Ibrowse 2.5 key have version 3.0 for free!

Go to top
Re: IBrowse 3.0 released
Not too shy to talk
Not too shy to talk


See User information
I absolutely love IBrowse and must try to type a message using it and it is somehow more fun than using any other browser, as is browsing the web with the sites that works.

It rarely if ever crashes no matter what sites I visit and are very usable for downloading files like already mentioned. Fast and just a very nice experience overall. It's and always will be THE webbrowser for AOS IMHO.

Go to top
Re: IBrowse 3.0 released
Just popping in
Just popping in


See User information
@daveyw

Quote:
daveyw wrote:BTW, had a slight hiccup when I upgraded from 2.5 to 3.0. The installer detected the version bump, and created a new directory for 3.0 and migrated files across. But I had some custom buttons that I had custom images for. These sit in the same dir as the other button images but for some reason were not migrated. So when I first started 3.0 I got a bunch of missing images error messages. Took me a few moments to figure out what went wrong. Installer should copy across the entire directory including any images I have added.

Yes, I did ponder heavily over what to do in cases like this - I should probably have mentioned in the installer that you'll need to copy over any custom images manually, just as you installed them originally.

The thinking was that some users may either not have installed any custom images or may have a load of junk in there. Those who upgraded their installs from a 2.3 or earlier install, this will be especially true - they might even have the old pre-2.4 imageset installed still (it bugs me when I see people posting screenshots with those old images, which we already changed 17 years ago!).

If this is the worst thing to go wrong with the 3.0 release, I'll be very happy . Certainly, this is something I can revisit for 3.1, to see if I can come up with a better solution, although obviously it is too late for those who already upgraded.

IBrowse, AmiSSL and Warp Datatype Developer
Go to top
Re: IBrowse 3.0 released
Quite a regular
Quite a regular


See User information
IBrowse 3.0

Go to top
Re: IBrowse 3.0 released
Just can't stay away
Just can't stay away


See User information
Let's hope Oliver manage to have some kind of CSS improvements in the near future since IBrowse is THE Amiga browser

Actually, I mainly use IBrowse on my FPGA Replay to go on Aminet and Amigans (sometimes on AW but no one should continue going there).


Edited by orgin on 2023/11/24 17:45:45
--
AmigaONE X1000 and Radeon RX 560
Go to top
Re: IBrowse 3.0 released
Home away from home
Home away from home


See User information
@K-L

Implementing a fully working CSS functionality won't be done in a morning, it will be a rather complex process... to get an idea just try browsing with NetSurf, although nominally it also partially supports CSS3 in reality we are far away from how the pages are actually displayed by a modern WebKit based browser (for ex. Odyssey)

Go to top
Re: IBrowse 3.0 released
Site Builder
Site Builder


See User information
@hotrod
I request that you refrain from engaging in personal attacks and derailing the discussion. Such behaviour is not acceptable in this context.

Follow me on
Ko-fi, Twitter, YouTube, Twitch
Go to top
Re: IBrowse 3.0 released
Just popping in
Just popping in


See User information
Managed to get iBrowse 3 downloaded and had a quick play around with it on my A1200 Tower using a BPPC 060. So far so good. A lot more snappier than V2.5.

Go to top
Re: IBrowse 3.0 released
Not too shy to talk
Not too shy to talk


See User information
@Futaura

Not sure what happened, but IBrowse 3.0 reports an 'error 2002' when trying to load any of the GUI buttons and graphics. I have all datatypes installed just fine, and in fact can open all files in PROGDIR:images via MultiView just fine. Any ideas?

-- eliyahu

"Physical reality is consistent with universal laws. When the laws do not operate, there is no reality. All of this is unreal."
Go to top
Re: IBrowse 3.0 released
Not too shy to talk
Not too shy to talk


See User information
@Futaura

Apparently the problem with loading graphics was my preferences were imported from version 2.5, and there I had graphics in a different drawer which no longer exists in the version 3.0 drawer.

However, I still have an issue with IBrowse 3.0 in that it complains that my AmiSSL is too old -- but I have version 5.12 installed, which is the latest available. Any ideas on this?

-- eliyahu

"Physical reality is consistent with universal laws. When the laws do not operate, there is no reality. All of this is unreal."
Go to top
Re: IBrowse 3.0 released
Just can't stay away
Just can't stay away


See User information
@eliyahu

what vesion libs do you have?
Mines:
#version LIBS:amisslmaster.library file full
amisslmaster.library 5.12 (25-10-2023)
os4 version

#version LIBS:AmiSSL/#? file full
LIBS:AmiSSL/amissl_v097g.library: amissl_v097g.library 3.7 ( 2-04-2006)
OS4 version
LIBS:AmiSSL/amissl_v111m.library: amissl_v111m.library 4.12 (11-02-2022)
os4 version
LIBS:AmiSSL/amissl_v314.library: amissl_v314.library 5.12 (25-10-2023)
os4 version


AFAIK, if you still have in IB protocols drawer https.protocol is not needed anymore, as it is merged with http.protocol

Go to top
Re: IBrowse 3.0 released
Just popping in
Just popping in


See User information
@eliyahu

Yes, sorry, the installer doesn't yet take care of any custom images you may have specifying in your settings :(. It is quite tricky to deal with, but I should have at least mentioned it in the installer, so users like you know that they will need to copy them to your 3.0 drawer manually.

No issues have been raised regarding AmiSSL - it sounds like an installation issue. @jabirulo listed the correct libraries, if you have v3, v4 and v5 all installed. It is critical that amisslmaster.library is v5.12.

IBrowse, AmiSSL and Warp Datatype Developer
Go to top
Re: IBrowse 3.0 released
Not too shy to talk
Not too shy to talk


See User information
@Futaura

For whatever reason the AmiSSL installer did not replace the libraries correctly. So I manually copied them over, restarted, and now all is well. Many thanks for your long work on IBrowse. It's wonderful to see it still under active development.

-- eliyahu

"Physical reality is consistent with universal laws. When the laws do not operate, there is no reality. All of this is unreal."
Go to top
Re: IBrowse 3.0 released
Just popping in
Just popping in


See User information
I also had issues with installing the latest AmiSSL from IBrowse's site (5.12) on my Amiga X5000. The Installer kept saying that some application is using AmiSSL, even after fresh boot, refusing to copy the new libraries. So I went to the LIBS folder, manually renamed the available AmiSSL libs with appending _OLD to their names, then copying the new libraries from the AmiSSL package and rebooting.

Everything worked fine after.

Go to top
Re: IBrowse 3.0 released
Illusionist
Illusionist


See User information
@drHirudo

Same result here with OS4. The AmiSSL installer says that something is using the lib and needs to be shut down. It should be noted that AmiSSL installed fine on OS3 and IBrowse 3 works correctly there.

I haven't tried a manual install -- I'll just wait for the next update.

-- Ken

Go to top
Re: IBrowse 3.0 released
Just popping in
Just popping in


See User information
@klesterjr

This is common. To install AmiSSL I have to shutdown the following:

ZitaFTP
AAMP Apps
VNCd
Synergy

You can use "status" to see what apps are running. To end a task use "break <#>". Looks like this:

> status
Process 3: Loaded as command: AAMP:Common/bin/xlaunch
Process 4: Loaded as command: AAMP:Common/libexec/mysqld
Process 5: Loaded as command: AAMP:Common/bin/httpd
Process 9: Loaded as command: LIBS:Hollywood/polybios.ext
Process 10: Loaded as command: alt-wb:OtherUtilities/Hostsmgr-1.0/HostsMgr
Process 11: Loaded as command: sys:UHC/c/SynergyClient
Process 12: Loaded as command: Work:Internet/VNC/RVNCd/RVNCd
Process 13: Loaded as command: CSD2:Internet/ZitaFTPServer/ZitaFTPServer
Process 14: Loaded as command: FilerCX
Process 15: Loaded as command: AmIRC.os4-3.1.5
Process 16: Loaded as command: status
Process 17: Loaded as command: Odyssey
Process 19: Loaded as command: alt-wb:OtherC/wb2filer
Process 22: Loaded as command: alt-wb:OtherUtilities/Filer/Filer


To shutdown ZitaFTPServer use "break 13"

Hope this helps!
Bill "tekmage" Borsari

Go to top
Re: IBrowse 3.0 released
Not too shy to talk
Not too shy to talk


See User information
@tekmage

I'm using Nick Clover's Weather Python script http://os4depot.net/?function=showfil ... =network/misc/weather.lha which I need to comment out of network.startup and reboot in order to upgrade AmiSSL.

Go to top
Re: IBrowse 3.0 released
Illusionist
Illusionist


See User information
@tekmage

Status shows only PatchASL & Soundplayer as running.

Probably a typo in the install script that isn't widely reported because many (most) people do a manual install -- or they're like me and assume that it will be fixed in the next release. ;)

-- Ken

Go to top
Re: IBrowse 3.0 released
Just popping in
Just popping in


See User information
@klesterjr

You'll be waiting a long time - there is no typo

It is different on OS3 - you can just overwrite libs even if they are loaded into memory and in use. Due to some very boring details, when the AmiSSL libraries are in memory on OS4, the libraries have file locks on them, so the installer can't simply copy the new versions over them (object in use error). So, the installer does some tricks to flush the libraries from memory, so it can then copy the libraries over. But, if something is still actually using AmiSSL, this can't happen, hence the error.

This is/was a limitatation of elf.library and I have rewritten the code there to fix this, but this hasn't been publically released yet, although has been supported in AmiSSL since v5.6.

IBrowse, AmiSSL and Warp Datatype Developer
Go to top
Re: IBrowse 3.0 released
Illusionist
Illusionist


See User information
@Futaura

Okay, good to know. :)

Go to top

  Register To Post
« 1 (2) 3 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project