Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
52 user(s) are online (26 user(s) are browsing Forums)

Members: 0
Guests: 52

more...

Support us!

Headlines

 
  Register To Post  

« 1 ... 3 4 5 (6) 7 »
Re: MPlayer 1.5 released!
Quite a regular
Quite a regular


See User information
here is the MPlayer Radeon RX version without defects to be more precise.
If it helps in both Comp and SDL the sound is clean and full screen.

https://youtu.be/dkLI4UX3V2M

Go to top
Re: MPlayer 1.5 released!
Just can't stay away
Just can't stay away


See User information
@white
Is the Voodoo3 emulation in WinUAE incomplete and doesn't support overlay, or why do you keep using slow software rendering VOs like sdl, comp or wpa instead of the ones suitable for a (real) Voodoo3 gfx card like -vo amiga or -vo pip?

Go to top
Re: MPlayer 1.5 released!
Just can't stay away
Just can't stay away


See User information
@white

Hi, any place were I can download the video you're using to test on my system?

the mickJT RX mplayer:
...
This is a hacked version to make the comp_yuv and comp_yuv2 modes work with the RadeonRX.chip
...

The "hack" is to work on RX when using -VO comp_yuv or comp_yuv2

Can't remember how much of vo_comp driver we updated/changed, will try to investigate, but AFAIK only the window creation and such. The decoding code wasn't changed (but not sure) as it worked fine.

Go to top
Re: MPlayer 1.5 released!
Quite a regular
Quite a regular


See User information
@jabirulo

here on mediafire the video I use for the test:

https://tinyurl.com/ypysvdps



General

Format : AVI
Format/Info : Audio Video Interleave
Format settings : BitmapInfoHeader / WaveFormatEx
File size : 345 MiB
Duration : 42 min 16 s
Overall bit rate : 1 142 kb/s
Frame rate : 25.000 FPS
Writing application : VirtualDubMod 1.5.10.2 (build 2540/release)
Writing library : VirtualDubMod build 2540/release
FileExtension_Invalid : avi

Video
ID : 0
Format : MPEG-4 Visual
Format profile : Advanced Simple@L5
Format settings : BVOP2
Format settings, BVOP : 2
Format settings, QPel : No
Format settings, GMC : No warppoints
Format settings, Matrix : Default (H.263)
Codec ID : XVID
Codec ID/Hint : XviD
Duration : 42 min 16 s
Bit rate : 1 004 kb/s
Width : 624 pixels
Height : 352 pixels
Display aspect ratio : 16:9
Frame rate : 25.000 FPS
Original frame rate : 23.976 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Compression mode : Lossy
Bits/(Pixel*Frame) : 0.183
Stream size : 304 MiB (88%)
Writing library : XviD 1.1.2 (2006-11-01)

Audio
ID : 1
Format : MPEG Audio
Format version : Version 1
Format profile : Layer 3
Format settings : Joint stereo / MS Stereo
Codec ID : 55
Codec ID/Hint : MP3
Duration : 42 min 16 s
Bit rate mode : Constant
Bit rate : 128 kb/s
Channel(s) : 2 channels
Sampling rate : 48.0 kHz
Compression mode : Lossy
Stream size : 38.7 MiB (11%)
Alignment : Aligned on interleaves
Interleave, duration : 40 ms (1.00 video frame)
Interleave, preload duratio : 504 ms


Edited by white on 2024/4/26 13:33:03
Go to top
Re: MPlayer 1.5 released!
Just can't stay away
Just can't stay away


See User information
@white

thx downloading and will see what happens on my system.
THXaLOT

Go to top
Re: MPlayer 1.5 released!
Quite a regular
Quite a regular


See User information
@jabirulo

No problem

Waiting to know which graphics card to buy for qemu and a possible driver to buy or something like that.
Because up to now I have understood very little about what is being worked on on the video card side with qemu

Go to top
Re: MPlayer 1.5 released!
Just can't stay away
Just can't stay away


See User information
Tried and it spit loooots (but looots) of SEEK FAILED but plays. alas I have a RX550 on my SAM460ex.

#KDH1:DIBUJOS/Mplayer/mplayer -vo comp PRUEBAS:The_Sarah_Connor.avi *>ram:aaaaaaa
MPlayer 1.5-rc2 SVN-r38440-snapshot-11.3.0 (C2000-2023 MPlayer Team

Playing PRUEBAS
:The_Sarah_Connor.avi.
libavformat version 60.3.100 (internal)
AVI file format detected.
[
aviheaderVideo stream found, -vid 0
[aviheaderAudio stream found, -aid 1
VIDEO
:  [XVID]  624x352  12bpp  25.000 fps  1006.2 kbps (122.8 kbyte/s)
VO: [compWelcome man !
VO: [compScreen use driverRadeonRX.chip
Opening video filter
: [screenshot]
==========================================================================
Opening video decoder: [ffmpegFFmpeg's libavcodec codec family
libavcodec version 60.3.100 (internal)
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
Clip info:
 Software: VirtualDubMod 1.5.10.2 (build 2540/release)
Load subtitles in PRUEBAS:
==========================================================================
Opening audio decoder: [mpg123] MPEG 1.0/2.0/2.5 layers I, II, III
AUDIO: 48000 Hz, 2 ch, s16be, 128.0 kbit/8.33% (ratio: 16000->192000)
Selected audio codec: [mpg123] afm: mpg123 (MPEG 1.0/2.0/2.5 layers I, II, III)
==========================================================================
AO: [ahi_dev2] 48000Hz 2ch s16be (2 bytes per sample)
Starting playback...
Movie-Aspect is undefined - no prescaling applied.
[swscaler @ 0x50c105f8]using unscaled yuv420p -> rgb24 special converter
VO: [comp] 624x352 => 624x352 Planar YV12 
VO: Disabling blanker
Movie-Aspect is 1.77:1 - prescaling to correct movie aspect.
VO: [comp] 624x352 => 624x352 Planar YV12 
Internal COMP FPS 24
VO: Enabling blanker

Exiting... (Quit)



try this frrom shell/CLI:
<path_to_mplayer> -vo comp PRUEBAS:The_Sarah_Connor.avi *>ram:aaaaaaa

so all errors go to ram file aaaaa

Go to top
Re: MPlayer 1.5 released!
Just can't stay away
Just can't stay away


See User information
@white
Please test -vo amiga or -vo pip on your setup.
Not sure about WinUAE's Voodoo3 emulation, but on real hardware it's much faster than -vo comp, -vo sdl, etc.

Go to top
Re: MPlayer 1.5 released!
Not too shy to talk
Not too shy to talk


See User information
@white
I have checked on the Qemu A1 everything works fine.
I don't use WinUAE I am not able to help you.





Just to mention the whole mplayer doesn't use the libraries from os4depot or from @MickJT (only dvd and openssl...).
The rest of the libraries starting with libz were rebuilt from scratch for AOS4 and Mplayer 1.5 (as in Linux Gentoo).
This cost us a lot of effort and time. All of ffmpeg and mplayer has its own libraries that were built specifically for this program.
@MickJT has his version of ffmpeg. Mplayer 1.5 has its own libraries
Even the SLD output has been adapted to work for Pegasos 2 G4 QEMU emulation.
The whole project is GPL and all sources are available.

I wanted to thank you because there was no opportunity to mention all of them - see README.
Thanks guys !!!
I am only a small part of this project but thank you very much for your time and work on previous versions of Mplayer.

I am writing about this because I read the thread today:
https://www.amigans.net/modules/newbb/ ... id=147943#forumpost147943

Go to top
Re: MPlayer 1.5 released!
Quite a regular
Quite a regular


See User information
@smarkusg

Thanks for the tips,
I restored qemu pegasos after a long time.
MPlayer works well.

I also updated to BB-0.7

I have to create the -fat partition again for exchanging files

This is the current command line I use:

qemu-system-ppc -M pegasos2 -cpu 750cxe -accel tcg -kernel /home/white0/Downloads/bboot-0.7/bboot -initrd /home/white0/Downloads/Kickstart.zip -m 2048 -serial stdio -device sm501 - drive if=none,id=hd,file=/home/white0/Scaricati/32gb.raw,format=raw -device ide-hd,drive=hd,bus=ide.1 -device rtl8139,netdev=mynet0 -netdev user ,id=mynet0 -vga none -drive if=none,id=hd1,file=/home/white0/Scaricati/coffin.raw,format=raw -device ide-hd,drive=hd1,bus=ide.1 -display gtk,zoom-to-fit=on -full-screen

but a few things have changed reading the various posts.
what changes could I make to the command line.
Thank you.

here the test I used MPlayer-GUI seems to work for not using command line.
So I use MUI-ASL again.


I still have to update qemu to version 9
is it better to update from the qemu site?
or there is the Balaton repository.
to which link?

Thank you.
https://youtu.be/5rGR5RXg3JE

Go to top
Re: MPlayer 1.5 released!
Just can't stay away
Just can't stay away


See User information
@white

Basically, not much has changed. There is nothing to improve in your line that could improve the executability.

But there are other things you can test...the Amiga community has also adapted some software gems for Qemu/AmigaOs4.1 so that we can have some more fun with it.

And @smarkusg has also made his own ports which already work very well.

DGen (Sega Mega Drive) Emulator
Snes9x

Both are also available on Os4Depot in very recent versions. Otherwise here is another source where you can also find E-UAE in a customized version for the CPU G4.

https://github.com/smarkusg?tab=repositories

Bigger changes would only happen if Virtio drivers are written for (network/GPU/sound....) which could increase the performance significantly.

Since we are already off topic I might recommend to use the official Qemu thread.

https://www.amigans.net/modules/newbb/ ... &order=ASC&status=&mode=0

MacStudio ARM M1 Max Qemu//Pegasos2 AmigaOs4.1 FE / AmigaOne A1222plus AmigaOs4.1 FE
Go to top
Re: MPlayer 1.5 released!
Not too shy to talk
Not too shy to talk


See User information
Hey guys,

First, thanks guys for your continued quiet, dilligent work
on MPlayer. No drama, just results. :D

I've been using this MPlayer:

MPlayer 1.5-rc2 (01/26/2024) SVN-r38440-snapshot-11.3.0

...mostly for YT streaming, etc. and I'm noticing that it most
often seems to quit before reaching the end of the stream.

I wondered if anyone else has noticed this or if any of the devs
working on this might have any insight on what's happening.

This is on my X5K using Mick's YT.rexx (directly or via
IBrowse) using the mostly default .config with whichever VO is
used with the RadeonHD 6450.

Thanks again,

PJS

Go to top
Re: MPlayer 1.5 released!
Not too shy to talk
Not too shy to talk


See User information
@white

I welcome you back after a small break and I'm glad you're back to using AOS4.
You are/were a regular on Amigans.net and it was always a pleasure to read your posts.

Regarding Mplayer and the GUI. Mplayer 1.5 has some added features which mean you don't have to use the GUI.
If you are using AmiDock place the Mplayer icon on the bar. Move the video file you want to play into the Mplayer icon.
It will play automatically (requires configuration of the configuration file as in the video I sent you)

In addition, always if you want to play a new video file and another one is playing, place the file in the video in its window,
The new file will be played automatically. You can also move up to 3 video files selected at the same time into the window - they will be automatically played one below the other (D&D - small playlist )
Part of the code is from @MickJT and has been improved by @Javier for all video output versions including SDL1

If you are able to build QEMU with all dependencies you better rebuild it.
The standard packages mostly have very neutral compilation options set.
Add -O3 and LTO via environment variables. You can also do this by editing the meson.build file ( 3rd line change 'optimization=2' to 'optimization=3') and adding ‘--enable-lto’ when calling ‘./configure’.
Performance increase between 20-50%

Have fun

Go to top
Re: MPlayer 1.5 released!
Not too shy to talk
Not too shy to talk


See User information
@pjs

It is possible that changing the ‘cache’ option in the config file will help.
I will try to change it from the value 8192 to 20480. It is a very large value but you can try to change it to suit your needs.
Let me know if it helped

Go to top
Re: MPlayer 1.5 released!
Quite a regular
Quite a regular


See User information
@smarkusg

Thank you !
And thanks for the advice,
I've tried E-UAE static for now without using SDL I'll take my time after backups.
But the work is exceptional now I can use -cpu 7457 with E-UAE with "uaegfx"

I have to make many additions now I will recompile the qemu 9 version with your suggestions.

Here your E-UAE (static) (last OT post) I will put my questions in the right post-branches.

qemu-system-ppc -M pegasos2 -cpu 7457 -accel tcg -kernel /home/white0/Scaricati/bboot-0.7/bboot -initrd /home/white0/Scaricati/Kickstart.zip -m 2048 -serial stdio -device sm501 -drive if=none,id=hd,file=/home/white0/Scaricati/32gb.raw,format=raw -device ide-hd,drive=hd,bus=ide.1 -device rtl8139,netdev=mynet0 -netdev user,id=mynet0 -vga none -drive if=none,id=hd1,file=/home/white0/Scaricati/coffin.raw,format=raw -device ide-hd,drive=hd1,bus=ide.1 -display gtk,zoom-to-fit=on -full-screen -drive file=fat:rw:/tmp/qemu-amiga,id=ufat,format=raw,if=none -device usb-storage,drive=ufat


https://youtu.be/A_M6BP7PebA

Go to top
Re: MPlayer 1.5 released!
Just can't stay away
Just can't stay away


See User information
@white
It's very important to use the correct VO for your (emulated) hardware.
Neither "comp(_yuv(2))" nor "sdl" are usable for emulation. It may work, but very slow.
WinUAE with Voodoo3 emulation: Use -vo amiga or -vo pip.
QEmu with SM50x emulation: Use -vo sdl_sm502

Go to top
Re: MPlayer 1.5 released!
Quite a regular
Quite a regular


See User information
@joerg

It was just out of curiosity, thanks anyway

Go to top
Re: MPlayer 1.5 released!
Quite a regular
Quite a regular


See User information
@smarkusg

meson.build

original:
>3 'b_staticpic=false', 'stdsplit=false', 'optimization=2', 'b_pie=true'],

do you think this is right is this what you meant ?

>3 'b_staticpic=false', 'stdsplit=false', 'optimization=3', 'b_pie=true'],


compile:

./configure --target-list=ppc-softmmu --disable-dbus-display --enable-slirp --enable-lto --enable-sdl --enable-gtk


Edited by white on 2024/4/27 23:08:04
Go to top
Re: MPlayer 1.5 released!
Quite a regular
Quite a regular


See User information
@white
Use the official QEMU sources from gitlab (see qemu.org Download menu item), I don't have a separate repo to use now.

I think you can set optimization level from configure without editing meson.build by adding -Doptimization=3 to configure. That would be better than modifying meson.build because then you can easily update from git. I don't know how much difference it makes but if you use opt 3 and see problems also check with the default optimization level just to make sure it's not some compile error. The results of opt 3 on Linux with gcc might be different than on macOS with clang.

For your QEMU command line -cpu 7457 -accel tcg are the default so you can drop these, only need to add -cpu if you want to use other than the default 7457 CPU. You can use -display gtk,zoom-to-fit=on,full-screen=on instead if separate -full-screen option that may be removed at some point and specifying it as a -display option is now preferred.

Instead of separate -drive if=none and corresponding -device ide-hd option there's a shortcut to define a drive with one option:
-drive media=disk,index=0,file=/home/white0/Scaricati/32gb.raw,format=raw
-drive media=disk,index=1,file=/home/white0/Scaricati/coffin.raw,format=raw

which does not need a separate -device ide-hd option so it's shorter and more readable. (Since QEMU 9.0 this also works with sam460ex now which previously did not support these short options.)

Go to top
Re: MPlayer 1.5 released!
Quite a regular
Quite a regular


See User information
Quote:
samo79 wrote:
@ktadd

Maybe its due to FFMpeg, the latest version we use for 1.5 may be slower


I was using -O4 (mplayer's source uses that by default) rather than -O2. I think that would make a noticeable difference. A quick google search says that -O4 is the same as -O3, and probably reserved for future purposes.


Edited by MickJT on 2024/4/28 18:18:19
Go to top

  Register To Post
« 1 ... 3 4 5 (6) 7 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project