Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
109 user(s) are online (69 user(s) are browsing Forums)

Members: 0
Guests: 109

more...

Support us!

Headlines

 
  Register To Post  

SiI 3112 won't boot A!-XE either. Help!
Quite a regular
Quite a regular


See User information
The subject has changed from the previous thread so I'm starting a new topic. Here's what I tacked onto the end of the previous topic:

Back again after our move.

One of the first things I worked on after settling in was to put in one of the new SiI 3112 cards I ordered. Still no boot from hard drive.

I get the following after it now finds the SLB:

"No config file found in any supported media/device!"
"No configuration file in any partitions."
"Press any key to continue"

A close look at the SiI card reveals that it is a 3112A Does this revision mean I have two more SiI cards that won't boot?

I've re-written the RDB on the offending drive, repartitioned and reformatted it and reinstalled 4.1 FE using the CD to boot from the onbhoard VIA PATA


Help! I miss my Amiga!

Paul

Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
Go to top
Re: SiI 3112 won't boot A!-XE either. Help!
Just popping in
Just popping in


See User information
@Paul

On my AmigaOneXE, each time I go into the UBoot menus, I have to set the boot drive/sequence again, otherwise it gives the same message you have.

Sam460 : X1000 : X5000
Go to top
Re: SiI 3112 won't boot A!-XE either. Help!
Quite a regular
Quite a regular


See User information
@logicalheart

Do you make those changes by typing in setenv variables or by using the cursor and return key to choose variables? Since I can only boot from the onboard PATA cd-rom, I go in through the Uboot menu and change the boot sequence to choose that, make whatever changes i experiment with, and then change the boot sequence again to try booting from the HD.

It's been years since I have typed in any setenv variables. If that's what you are doing, what are the lines you type in?

Paul

Nice collection of next-gen Amiga's there!!

Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
Go to top
Re: SiI 3112 won't boot A!-XE either. Help!
Home away from home
Home away from home


See User information
@Paul

Quote:
It's been years since I have typed in any setenv variables. If that's what you are doing, what are the lines you type in?


It will depend on what cable is plugged into what port. And what the cable is connected to in the other end, anyway do you know the cables are ok?

Should be sii3112_conf or sil3112_conf, the value should be number of two decimals, because it's a controller with two ports.

Valid values is:

00
01
02
10
11
12
20
21
22

saveenv to store the value.
printenv to show the value/values.
setenv to set the value.

Someone might have asked you to delete value, think your computer will auto detect HD's and CD's.

Uboot prefs should do the same thing, but I'm not sure if variable name is correct for all controllers.

There is also the sii3112_xfer or sil3112_xfer that sets the max speed of the port on the controller.

The rest should be easy to configure using the uboot menu.

(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
Go to top
Re: SiI 3112 won't boot A!-XE either. Help!
Just can't stay away
Just can't stay away


See User information
The doc files you want to read are in the drawer SYS:Documentation/IDE/.

BTW, the driver (and thus variable and doc file) names start with sii, not siL. The correctly-cased acronym for the company is SiI, which is Si for Silicon, and I (upper case i, not lower case L) for Image.

Best regards,

Niels

Go to top
Re: SiI 3112 won't boot A!-XE either. Help!
Quite a regular
Quite a regular


See User information
@nbache & LiveForfIt

Thanks for the responses.

I've gone to the Uboot shell and run "setenv sii3112_conf 11" for two hard drives connected to the card. Cables must be OK because when booting from the CD, all my partitions from both drives show up on workbench.

Did a "saveenv"

Printenv shows sii3112_conf 11 in the list.

But it still won't boot except from the CD in the PATA DVD drive.

I ordered two of these 3112's. I'll have to try the other one and see what happens.

Paul

Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
Go to top
Re: SiI 3112 won't boot A!-XE either. Help!
Just can't stay away
Just can't stay away


See User information
@Paul

You are misspelling the variable name. It should be sii3112ide_conf - note the "ide" after the number and before the underscore.

This is the general fomat of all those variables.

Best regards,

Niels

Go to top
Re: SiI 3112 won't boot A!-XE either. Help!
Quite a regular
Quite a regular


See User information
@nbache

Thanks for clarifying that. I removed that errant entry, and reentered it correctly. Printenv shows it is listed correctly. But no joy. I also added sii3112ide_maxbus 2 for good measure, but that didn't help any, either.

I'm going to try reversing the two hard drive cables and see if anything changes. Then I'll try my second 3112 card if nothing improves.

Paul

Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
Go to top
Re: SiI 3112 won't boot A!-XE either. Help!
Just popping in
Just popping in


See User information
@Paul

FYI: I use the menus (cursor keys) to set the boot drive and sequence, not the command line.

Sam460 : X1000 : X5000
Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project