Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
107 user(s) are online (56 user(s) are browsing Forums)

Members: 0
Guests: 107

more...

Support us!

Headlines

 
  Register To Post  

AHI bug (changing frequency while playing)
Just popping in
Just popping in


See User information
AHI in AmigaOS4.1 (but not in AmigaOS4.0) has bug which reveals itself when you change player frequency (with AHI_ControlAudio function and AHIA_PlayerFreq) while playing module (when AHIC_Play is set). Once frequency is changed - the audio output become very noisy. Interesting is fact that there is no such bug in AHI for AmigaOS4.0 classic.

I need to change frequency to properly handle frequency changes in MED music modules. On A1200 PPC it worked, but on Sam440ep it doesn't (audio become noises when frequency is changed).

For now I use software interrupt to handle replaying timing, but it's not best method.

Go to top
Re: AHI bug (changing frequency while playing)
Just popping in
Just popping in


See User information
Really no reply about this? I need to solve this problem for my music player.


Edited by RNS-AMiGA-Club on 2012/10/16 17:15:56
Go to top
Re: AHI bug (changing frequency while playing)
Not too shy to talk
Not too shy to talk


See User information
please try the support forum:
here

regards...
michael

Go to top
Re: AHI bug (changing frequency while playing)
Just popping in
Just popping in


See User information
I worked around the problem and it seems OK! Music from my player is just nice, I'm listening to it right now (music from Lemmings 2)

I just call
AHI_ControlAudio(actrl, AHIC_Play, FALSE, TAG_DONE);
AHI_ControlAudio(actrl, AHIA_PlayerFreq, frequency, TAG_DONE);
AHI_ControlAudio(actrl, AHIC_Play, TRUE, TAG_DONE);

With the neighbourhood of the 2 perimeter functions setting the frequency doesn't produce noises. All right, now the production of Diamond Player 2.0 can progress further

It is currently a program written in C++ with the use of its many interesting features. MOD and MED modules are for example the childs of abstract Music Module class, also audio output is a template in Music Player class, so there is a possibility to use different audio output methods like audio.device for example or AHI like it is now.

The workaround doesn't cause any problems (only there is a tiny, almost unnoticably break when changing frequency). Cheers.

Go to top
Re: AHI bug (changing frequency while playing)
Quite a regular
Quite a regular


See User information
I have this problem with my Sam460ex and nothing it continues, you should wait to correct tjis problem with Update5, 6, Amiga OS 4.2, etc., etc., etc.,

Go to top
Re: AHI bug (changing frequency while playing)
Quite a regular
Quite a regular


See User information
This could very well be a sound card driver problem as well, not AHI, since you probably use OS4.1 on something else than a Classic.

Software developer for Amiga OS3 and OS4.
Develops for OnyxSoft and the Amiga using E and C and occasionally C++
Go to top
Re: AHI bug (changing frequency while playing)
Just popping in
Just popping in


See User information
@Deniil
Quote:
This could very well be a sound card driver problem as well, not AHI, since you probably use OS4.1 on something else than a Classic.

The platforms the problem exists:

- Sam440ep
- AmigaONE

The platform the problem doesn't exist:

- Amiga+PPC+Paula

So it's true the problem lies in AHI sound card driver.

Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project