Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
48 user(s) are online (29 user(s) are browsing Forums)

Members: 1
Guests: 47

trixie, more...

Headlines

 
  Register To Post  

displaying SVG files in Ibrowse
Just popping in
Just popping in


See User information
I've installed the svg.datatype from os4depot but neither ibrowse or multiview will load a .svg file

check out the examples on http://www.w3schools.com/svg web page.

Any Ideas

Bloodmoon Games has released its RPG game content for free for personal use visit http://bloodmoongames.com today, or my blogg on http://bloodmoongames.blogspot.com

Wii number is : 4394 2248 4262 8983
Go to top
Re: displaying SVG files in Ibrowse
Home away from home
Home away from home


See User information
@aldur

Have you installed the expat library? The SVG datatype requires it.

Hans

Go to top
Re: displaying SVG files in Ibrowse
Just popping in
Just popping in


See User information
@Hans

Yes I have version 2.3 installed

I have also added the image/svg+xml mimetype to Ibrowse to attempt to get it to work but no luck

Bloodmoon Games has released its RPG game content for free for personal use visit http://bloodmoongames.com today, or my blogg on http://bloodmoongames.blogspot.com

Wii number is : 4394 2248 4262 8983
Go to top
Re: displaying SVG files in Ibrowse
Amigans Defender
Amigans Defender


See User information
@aldur
Quote:
Yes I have version 2.3 installed

From the SVG datatype instructions:
Quote:
This library can be found as part of the expat-ppc (dev/lib) archive on OS4Depot.

If you have version 2.3 installed you are not following the instructions...

ExecSG Team Lead
Go to top
Re: displaying SVG files in Ibrowse
Just can't stay away
Just can't stay away


See User information
@aldur

Works here, I had to update the svg datatype (both in classes and devs as the descriptor in devs has changed alot) and install expat.library from the archive ssolie mentioned.

You don't need any mimetypes setup in ibrowse, it just works.

Don't forget to 'adddatatypes refresh' or reboot.

Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
Go to top
Re: displaying SVG files in Ibrowse
Just popping in
Just popping in


See User information
@All

The version of Expat on Os4Depot is version 2.3 the version that is installed with the SDK is 4.1

Thanks its working now

But I did have to add image/svg+xml as a mime type and set it to use internal viewer.

Thanks for all the pointers

Bloodmoon Games has released its RPG game content for free for personal use visit http://bloodmoongames.com today, or my blogg on http://bloodmoongames.blogspot.com

Wii number is : 4394 2248 4262 8983
Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project