Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
28 user(s) are online (20 user(s) are browsing Forums)

Members: 1
Guests: 27

khayoz, more...

Headlines

 
  Register To Post  

« 1 2 3 (4)
Re: Bug in Milky-Tracker :-(
Just can't stay away
Just can't stay away


See User information
@K-L

Good to hear. Updated also MilkyTracker! Binary here: http://capehill.kapsi.fi/

Go to top
Re: Bug in Milky-Tracker :-(
Just can't stay away
Just can't stay away


See User information
@Cpaheill

Thanks. One little bug : trhe requester opens again on WB screen even if FullScreen is selected causing screen switchings.

--
AmigaONE X1000 and Radeon R7 250
Go to top
Re: Bug in Milky-Tracker :-(
Just can't stay away
Just can't stay away


See User information
@K-L

Reproduced the issue. Thanks.

Go to top
MilkyTracker 1.02
Just can't stay away
Just can't stay away


See User information
MilkyTracker 1.02 released: http://capehill.kapsi.fi/

Filerequester issue should be fixed as well.

Go to top
Re: Bug in Milky-Tracker :-(
Just can't stay away
Just can't stay away


See User information
Thanks ! It's ok indeed

--
AmigaONE X1000 and Radeon R7 250
Go to top
Re: Bug in Milky-Tracker :-(
Just can't stay away
Just can't stay away


See User information
@Capehill

Hi,

We've just found a new bug. When converting some modules to WAV files, samples are slightly quircky (so modules with multiple loops overlaping give a very bad rendering).

I don't know if you see what I mean but former versions did not have this behaviour.

--
AmigaONE X1000 and Radeon R7 250
Go to top
Re: Bug in Milky-Tracker :-(
Just can't stay away
Just can't stay away


See User information
@K-L

Which module? which export parameters? Which version worked, what is "former"?

How do you verify WAV files, which player?

Go to top
Re: Bug in Milky-Tracker :-(
Just can't stay away
Just can't stay away


See User information
@Capehill

Modules created by Pseudaxos who is using MilkcyTracker to create new mods.

When he converts his work to WAV (default parameters), mods containing loops get corrupted (loops are desynced whereas they aren't when they are created and listened to).

The trouble occured with SDL2 version, no problem with SDL1 version.

I can send you (by mail) one module to test.

--
AmigaONE X1000 and Radeon R7 250
Go to top
Re: Bug in Milky-Tracker :-(
Just can't stay away
Just can't stay away


See User information
@K-L

SDL is not used when exporting module. File is written using standard C library functions. It would be interesting to know how Linux version works, please test it if possible. Windows version is not so interesting because the code branches in many places. I mean Windows version runs different code than Amiga/Linux sometimes.

So far this sounds like a pure MilkyTracker issue but if you can upload the example module somewhere, for example the GitHub ticket tracker, I could try it myself.

Go to top
Re: Bug in Milky-Tracker :-(
Just can't stay away
Just can't stay away


See User information
Hi,

Comparing Linux and AmigaOS 4.1 versions of MilkyTracker, I've just found this bug : stereo (panning) is not working on AmigaOS 4.1 version.

In MilkyTracker, you can have Amiga style panning (channels 1-3-5-7-... are left and 2-4-6-8-... are right), Milkytracker style panning (balanced) and Mono.

MilkyTracker AmigaOS 4.1 always outputs in mono (and if you try Amiga panning, all the right channels are mute).

--
AmigaONE X1000 and Radeon R7 250
Go to top
Re:panning
Just can't stay away
Just can't stay away


See User information
@K-L

Is that a little or big endian system? I think there was earlier some endian issues related to how MT handles events internally.

Go to top
Re:panning
Just can't stay away
Just can't stay away


See User information
@Capehill

I tested on Linux x64 vs AmigaOne X1000.

--
AmigaONE X1000 and Radeon R7 250
Go to top
Re:panning
Just can't stay away
Just can't stay away


See User information
@K-L

This is a strange issue. Which sound card you are using?

I have an EMU10K card in X5000 and I'm not able to separate left/right channels on AHI-level so it doesn't seem an MT or SDL2 issue. I modified some AHI example code to alternate between left and right and on X5000 I can't hear any difference (sounds mono) but on Sam440 and WinUAE I can hear left and right.

A small tester: http://capehill.kapsi.fi/ahi/AhiStereoTest.lha

I'm speculating that it could be some driver issue, or my (EMU10K) sound card is a strange one...

Go to top
Re:panning
Just can't stay away
Just can't stay away


See User information
@Capehill

True indeed, with HD Audio on my X1000, you sound test outputs mono.

Using TuneNet, if I want to hear only right channel, I get no sound. Weird.

Edit : sorry, my fault, my jack to jack cable was broken. I replaced it and it's ok now.

(But maybe you found a bug with EMU10K driver).

--
AmigaONE X1000 and Radeon R7 250
Go to top
Re:panning
Just can't stay away
Just can't stay away


See User information
@Capehill

Me and my old demoscene group are going to have a reunion this autumn, and we're working on a small demo to commemorate our 30th anniversary. In the past few days I've been writing a short module using MilkyTracker - the first Amiga tune I've worked on since 2002.

I love MilkyTracker but one thing keeps getting in the way. Modules and samples keep the same path history, so with every sample loaded the module path changes, and vice versa. As a result I spend a lot of time in the ASL requester flipping through directories, which is a bit annoying.

I wonder if it were possible to have separate paths in the Amiga port, with defaults configurable for example through icon tooltypes? This would really improve the usability of the program!

The Rear Window blog

AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon RX 560 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
Go to top
Re: Bug in Milky-Tracker :-(
Not too shy to talk
Not too shy to talk


See User information
@Capehill
Your AHIStereoTest gives stereo left/right alternating on my X5000 and ESI Juli@.

1989-> A500, A600, A3000, A4000, A1200, CD32, µA1, PegII, A1XE, CDTV, Amy/416D79, A1X5000, Vampire 500 V2+, Vampire 600 V2, Amy-ITX, Denise ITX <-2022
Go to top
Re:panning
Just can't stay away
Just can't stay away


See User information
@trixie

Checked the code and it should be possible to have separate load/save paths at least since there is a mode flag passed to the dialog code.

Go to top
Re:panning
Just can't stay away
Just can't stay away


See User information
@Capehill

Quote:
it should be possible to have separate load/save paths at least since there is a mode flag passed to the dialog code.

That would be fantastic, and I'd not hesitate to send a donation.

The Rear Window blog

AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon RX 560 / ESI Juli@ / AmigaOS 4.1 Final Edition
SAM440ep-flex @ 667MHz / 1GB RAM / Radeon 9250 / AmigaOS 4.1 Final Edition
Go to top

  Register To Post
« 1 2 3 (4)

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project