Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
63 user(s) are online (50 user(s) are browsing Forums)

Members: 0
Guests: 63

more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 2 3 (4) 5 6 7 ... 9 »


Re: The MiniGL thread
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5329
@ddni
You use last version of game from BSzili's site as well as you have 100% minigl.library and mglut.library of today version ? You my try take them from my archive just to be sure you have latest ones.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: The MiniGL thread
Not too shy to talk
Joined:
2015/6/11 8:51
From Cologne
Posts: 261
@kas1e
Thanks for packaging it up that way!
However, I suggest to wait with uploading until we have definitely found out what's the problem with that light-saber.

_________________
[Facebook] [YouTube Channel]
   Report Go to top

Re: The MiniGL thread
Quite a regular
Joined:
2008/4/10 13:57
From Northern Ireland
Posts: 901
Just checked Bszili site. I am using latest version.
I only installed the new minigl today from Dans site.

Resized Image

_________________
AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
   Report Go to top

Re: The MiniGL thread
Quite a regular
Joined:
2013/10/17 15:21
From Hungary
Posts: 585
@ddni
You should upload your jaconfig.cfg to make sure everybody uses the same settings.

_________________
I see the jimmies have been rustled.
   Report Go to top

Re: The MiniGL thread
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5329
@ddni
Yeah, minigl library are right one on your side. And you also as me on x5k / SI with all latest stuff ?

If you can upload your openjk.cfg as BSzili suggest, i can try it on my side too

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: The MiniGL thread
Quite a regular
Joined:
2007/7/14 20:30
From Lothric
Posts: 717
@kas1e

License file seems to use Multiviewer tool. That is part of Enhancer?

   Report Go to top

Re: The MiniGL thread
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5329
@Capehill
Ha, good catch ! My def_txt is set to use .txt files with multiviewer, so when i snapshot them it added like this, will fix.

Through that damn lightsaber issue , i really can't reproduce it. I tried to lower all settings, to raise all setting, middle one, enalbe/disable lights, glows, shadows , etc,etc : no bug..

@ddni
Do you have by some luck maybe some environemnts for minigl sets ?

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: The MiniGL thread
Quite a regular
Joined:
2008/4/10 13:57
From Northern Ireland
Posts: 901
@kas1e

Hi, I am on X1K with R9270x card.
Will share my config soon.

What environments do you mean?

_________________
AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
   Report Go to top

Re: The MiniGL thread
Just popping in
Joined:
2016/3/10 14:15
From Poland
Posts: 50
My config:

AmigaOne X1000
Radeon R9 280X/3GB/GDDR5

   Report Go to top

Re: The MiniGL thread
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5329
@ddni,amig_os
So both of you on x1000, which in compare with x5000 have dma enabled in graphics.library and altivec. As far as i see, minigl have altivec based flags/code, maybe related somehow.. But firstly we need your configs so i can test on my.

@amig_os
Can you upload your openjk.cfg too ? It placed in .openjk/base directory

@ddni
Minigl have some settings controled via environments, and they placed in env:minigl/ if i remember right

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: The MiniGL thread
Quite a regular
Joined:
2008/4/10 13:57
From Northern Ireland
Posts: 901

_________________
AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
   Report Go to top

Re: The MiniGL thread
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3136
@kas1e

Yeah, seems perfectly fine to me
Aniway just to say about the archiving thing, just found the ancient 1.5.1 on Aminet and in the readme there is a part of changelog that we may include as reference also in our latest readme .. all that 1.5 and 1.5.1 changelog part perhaps may be usefull as historical reference to have aswell as the old credits related to the old mantainers of the library

See: http://aminet.net/package/dev/c/MiniGL_OS4

   Report Go to top

Re: The MiniGL thread
Not too shy to talk
Joined:
2015/6/11 8:51
From Cologne
Posts: 261
@ddni
@kas1e
OpenJK on my X5000 SI: either crashs with a checksum error on one of the big game files (read: it manages to corupt its game file) or freezes right before entering a level. Doesn't matter which MGL version I use.
From what I see it's simply not the most stable game?!

_________________
[Facebook] [YouTube Channel]
   Report Go to top

Re: The MiniGL thread
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5329
@ddni
Tried your config : for me lightsaber looks blocking and with 2.20 and with 2.23 with your config. It didn't looks scretched, just a bit blocky (because in your config in MoreVideo/Brightness option it set to maximum, but slider should be on about 20%). But then i see no difference with 2.20 and 2.23 in that case.

Can you show a screenshot of how it looks like on your setup wth your config on 2.20, and then on 2.23 ?

@Daniel
It should runs for sure , we use OpenJK (Jedi Academy):
http://bszili.morphos.me/ports/openjk-os4.lha

And over it installed data from the original CDs , from which you got just:

assets0.pk3 - 561.806.019
assets1.pk3 - 652.804.510
assets2.pk3 - 1.116.384

and patch which is just:

assets3.pk3 - 9.282.026
taken there:
http://www.x-raiders.net/download/?file=assets3

It may freeze when you use very hight textures, or sometime freezes when you just change video settings on the fly and reapply them, but it for sure starts and i didn't have checksum erros (which probabaly can be just becaues of badly copied file, or wrong ones maybe from Jedi Outcast ?)

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: The MiniGL thread
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5329
@all
Looking on the corruption amig_os show in the Jedi, i have to say i have pretty close looking corruption in the RCTW (not latest one which works of gl4es, but old one working over minigl), when in first level i look at the blood on the floor and move a bit.

But (!) its the same and with 2.20 and with 2.23.

There is how it looks like (press open in new tab for fullscreen)

Resized Image

And that is with both, mgl 2.20 and 2.23. Just corruption from amig_os screenshoot looks very much like the same (?)

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: The MiniGL thread
Not too shy to talk
Joined:
2015/6/11 8:51
From Cologne
Posts: 261
@kas1e
The JK files I got should be okay but anyway:
the last screenshot of yours looks simply like some sort of z-fighting to me. I didn't see the corupt light-saber effect in action, but could also be just z-fighting.

Can one of the guys who suffer from it please record a small video of it, moving around a bit?

_________________
[Facebook] [YouTube Channel]
   Report Go to top

Re: The MiniGL thread
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5329
@Daniel
And i remember where i else see this effect: in neverball. It also happens and with 2.20 and with 2.23, and it also seems z-fighting, as it "blinks". I through can catch 2 screenshots of how it looks like, also looks pretty the same as on RCTW screenshot and as lasersaber issue in Jedi (imho), check this out (press open in new tab for fullsize):

Resized Image

Resized Image

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: The MiniGL thread
Home away from home
Joined:
2007/9/11 11:31
From Russia
Posts: 5329
@ddni, amig_os

No luck to get a video from any of you showing the bug with moving around a bit ?

Daniel think it can be very well z-buffers issues, and that they may be cause also by the fact that new minigl builded with different optimisation flags which may have impact on the floats which can cause in end z-fighting issues. So, i build 2 version of latest mgl source code

One is just the same as Daniel do, just instead of gcc 5.4.0, its 8.2.0, there is:

http://kas1e.mikendezign.com/aos4/minigl/mgl_gcc820.zip

And another one, as Daniel ask is version builded without any optimisation flags, just pure -O2 (also builded via 8.2.0 on my side), there is:

http://kas1e.mikendezign.com/aos4/minigl/mgl_gcc820_opt2.zip

Plz give them a go (carefull, to be sure you not mess it up when testing, all after reboots, checking size of libs after reboot to be sure its correct one, etc).

But also in any case if one of you will made a video of bug, it will be easy to understand if it z-fighting issue or not.

@Daniel

At least with RCTW and Neverball z-fighting, pure -O2 build change nothing. But in case with those 2, issues was there and with 2.20 as well.

_________________
Join us to improve dopus5!
zerohero's mirror of os4/os3 crosscompiler suites
   Report Go to top

Re: The MiniGL thread
Just popping in
Joined:
2017/5/18 10:12
From Audruicq, France
Posts: 28
Hi,

I did a briefly test also last weekend and I'd also got the same distortion, stripes in lightsaber lightening on objects, which is new and didn't appear with the prebuild one from last year.
I didn't test further due to lack of time, but I've also reported some bad behaviour of the game with lastests version of minigl via BZ (graphics trashes and system crashs). Systems lockup seemed to be cause by semi transparent objects that could be shown on screen like when you use the force (around caracter's hand sometimes the glow effect is totaly trashed).
If time permits, this WE I'll test it again further with the versions you posted.

Thanks.
Petrol

   Report Go to top

Re: The MiniGL thread
Not too shy to talk
Joined:
2015/6/11 8:51
From Cologne
Posts: 261
@all
A video of that issue would be good to see because right now I'm only guessing that it's z-fighting, seeing it in motion would help to (in)validate that.

@kas1e
Back online, thanks for posting and building
Let's see what those guys with that problem say to the -o2 build. On the other hand, when reading Petrols post:

@petrol
The prebuild version from last year was compiled with the same compiler and the same compiler flags. If I look at the svn then the only thing that could maybe have the theoretical power to have such an impact is the new dxt lib (stuff like the extension-string bug aside, I'd say we cought all those new issues in the meantime), but IIRC we already ruled that out. What HW do you have? And please check the bugzilla for your other issues.


Edited by Daytona675x on 2019/3/20 9:40:39
Edited by Daytona675x on 2019/3/20 9:54:55
_________________
[Facebook] [YouTube Channel]
   Report Go to top


« 1 2 3 (4) 5 6 7 ... 9 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project