Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
62 user(s) are online (45 user(s) are browsing Forums)

Members: 0
Guests: 62

more...
Support us!
Recent OS4 Files
OS4Depot.net



(1) 2 »


Frustation
Not too shy to talk
Joined:
2010/1/22 20:03
From VIGO SPAIN
Posts: 385
Frustration, that's the word, and also abandoned.
That's how I feel, I have long been trying to find some graphics card of the 7xxx series that works in my Sam440. No, all other series work correctly, but just the only valid for new drivers and probably future programs do not work. And that's very frustrating.
I don't know if the fault is ACube (if it still exists, for years no signs of life), for not to update the UBoot, as was done with the 460.
Or worse, of A-Eon, who has just made new drivers for 7xxx, so the others will stay behind in everything that comes.
Who guarantees me that when buying a X5000, not the same thing happen in a couple of years?

Finally, frustrated and abandoned, so I am, I would not have to say (as they sang Led Zeppelin) "babe, I'm gonna leave you."

_________________
AmigaOne X5000 OS4.1 FEU1 And Lubuntu 10.04
1200 towered with Blizzard PPC - BVision and Mediator
And a new fantastic Chameleon64
   Report Go to top

Re: Frustation
Home away from home
Joined:
2006/11/26 21:45
From a story that hasn't been written yet
Posts: 3255
@RIBDEVIL

Sorry to hear that.

Maybe your thread will spawn some Sam440 users (or the devs) to help you out with links to working cards or maybe even cards themself.

Don't give up hope yet

...and btw, it *will* be the same situation for every "Amiga NG" hardware to come...with that small pool of developers we got it won't be possible to support more/older/outdated/other companies cards than what has been/will be announced.

_________________
If slaughterhouses had glass walls, everyone would be a vegetarian. ~ Sir Paul McCartney
-
Did everything just taste purple for a second? ~ Philip J. Fry
-
Ain't got no cash, ain't got no style, ladies vomit when I smile. ~ Dr. John Zoidberg
   Report Go to top

Re: Frustation
Not too shy to talk
Joined:
2006/12/2 0:31
From Poland
Posts: 252
@RIBDEVIL

I can see your pain, I'm in similar situation but ACube was making a great support thruogh all these years. I still hope they will make the needed changes in UBoot because no one writes the drivers for the older cards...and honestly, how long a multi bilion dollar company support your cell phone? Mine doesn't get updates after two years...
...so Tabor to the rescue?!

PS. You have to buy an expensive PCI to PCIe adapter, probably a new case and the result would not be spectacular...Hmmm, I don't know....

_________________
Sam440 flex 800MHz RAM 1GB R9250 128MB OS4.1 SBLive! ->
   Report Go to top

Re: Frustation
Not too shy to talk
Joined:
2007/1/6 5:59
Posts: 324
I made similar thread some time ago.

http://www.amigans.net/modules/xforum ... id=102310#forumpost102310

I asked other Sam 440ep Flex owners to write aCube and ask uboot update. Have you asked update?

   Report Go to top

Re: Frustation
Not too shy to talk
Joined:
2010/1/22 20:03
From VIGO SPAIN
Posts: 385
@utri007

Yes,sometime ago.

_________________
AmigaOne X5000 OS4.1 FEU1 And Lubuntu 10.04
1200 towered with Blizzard PPC - BVision and Mediator
And a new fantastic Chameleon64
   Report Go to top

Re: Frustation
Home away from home
Joined:
2006/11/30 18:43
From Norway
Posts: 2468
The sam440 is outdated. That's just how it is. I'm guessing it will be easier to wait for the tabor and replace the 440. It's said to be cheaper than 400$ anyway. And it will support warp3d nova.

_________________
Sam460 Lite
   Report Go to top

Re: Frustation
Not too shy to talk
Joined:
2007/1/6 5:59
Posts: 324
@Antique

It is outdated, no doubt. How ever, problems with HD7XXX cards is not because it is outdated, it is because uboot has a flaw. Atheros wlan driver doesn't work either.


   Report Go to top

Re: Frustation
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2713
@RIBDEVIL

The problem with Sam440 is that its PCI only, not PCIe, and the Radeon HD7xxxx is all PCIe. Sell the Sam440, get some bucks for it and upgrade to Sam460 or Tabor, that’s way I do in that position. I know X5000 is but if out price range for most that have a Sam440, but there are options.

Sam440 is neat computer for people who like to play around with GPIO and I2C, people with some electronic skills.

So it can't be worth nothing.

@Utri007

As "M3X" wrote, he did not have Radeon HD 7xxxx card, so he was unable to fix it. So maybe if you sent him a Radeon HD 7xxxx card he might do it.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Frustation
Just popping in
Joined:
2006/12/1 12:20
From Anzio (Rome), Italy
Posts: 101
@RIBDEVIL

Does your 7xxx card show any video signal when starting the machine (ie the u-boot output) and then stop displaying after loading the kickstart files, or there isn't any video signal at all ?

If the former, the problem is that you need both the pcigraphic.library kmod and the RadeonHD lite driver from the AmigaOS 4.1 FE Sam460 CD (or the full driver from A-Eon)

_________________
Max Tretene, ACube Systems Srl, Soft3
   Report Go to top

Re: Frustation
Not too shy to talk
Joined:
2007/1/6 5:59
Posts: 324
@m3x

Can you debug it yourself it we get you PCI to PCIe adapter?

   Report Go to top

Re: Frustation
Not too shy to talk
Joined:
2010/1/22 20:03
From VIGO SPAIN
Posts: 385
@m3x

I try with pcigraphics.library from Sam460, but radeonhd for sam440, I try later with both from 460. Thanks.

But I thing that at the end, I'll have to do extra hours at work, to buy a X5000. :(

_________________
AmigaOne X5000 OS4.1 FEU1 And Lubuntu 10.04
1200 towered with Blizzard PPC - BVision and Mediator
And a new fantastic Chameleon64
   Report Go to top

Re: Frustation
Not too shy to talk
Joined:
2007/1/6 5:59
Posts: 324
@RIBDEVIL

Could you please make those tests. I would also very interested to results. I don't have PCIe to PCI adapter, so I can't do those myself.

Does it give any signals, or does you monitor say all the time "no signal"?


   Report Go to top

Re: Frustation
Not too shy to talk
Joined:
2010/1/22 20:03
From VIGO SPAIN
Posts: 385
@utri007

I can see the init boot and load de kickstart. Then Sam hangs and screen turns black.

:(

If select Linux, the screen turns black.

:((

_________________
AmigaOne X5000 OS4.1 FEU1 And Lubuntu 10.04
1200 towered with Blizzard PPC - BVision and Mediator
And a new fantastic Chameleon64
   Report Go to top

Re: Frustation
Not too shy to talk
Joined:
2007/1/6 5:59
Posts: 324
@RIBDEVIL

So is it so that it is not a uboot problem after all?

http://forum.hyperion-entertainment.biz/viewtopic.php?f=17&t=3547

   Report Go to top

Re: Frustation
Home away from home
Joined:
2007/1/26 21:48
From New Zealand
Posts: 2033
@utri007

Quote:
So is it so that it is not a uboot problem after all

Nope. I've dealt with other situations where a card showed the Uboot/DVR screen, and still failed due to a Uboot/CFE problem. If the same card boots fine on other AmigaOS machines, then initialisation by Uboot is the most likely culprit.

Hans

_________________
http://hdrlab.org.nz/ - Amiga OS 4 projects, programming articles and more.
https://keasigmadelta.com/ - more of my work
   Report Go to top

Re: Frustation
Just popping in
Joined:
2014/6/29 14:12
From Montserrat
Posts: 231
@RIBDEVIL

What version of Linux and the Linux kernel are you using ?
and do you have the verde firmware in /libs/firmware/radeon ?
If I remember correctly I was geting a text display from Linux with the Radeon HD7750 and then a crash before the graphics display loaded . This was with a 3.15.6 kernel and there were a few changes in kernels after that .

Edit Just confirmed that I did get the Text console on the Sam440ep-flex and Radeon HD7750 .


On 13/07/2014 2:43 p.m., Julian Margetson wrote:
>
> Uboot works with the HD7750 and Linux will boot up to text console
> but not graphics as I get an kernel crash with debug output pointing to
> an error in a particular section of the radeon code.

   Report Go to top

Re: Frustation
Just popping in
Joined:
2006/12/1 12:20
From Anzio (Rome), Italy
Posts: 101
@utri007

at this point we need a debug output from serial to know exactly what's the real problem. It could still be a u-boot problem, or maybe a bug/misconfiguration on the AmigaOS4 side.

_________________
Max Tretene, ACube Systems Srl, Soft3
   Report Go to top

Re: Frustation
Just popping in
Joined:
2014/6/29 14:12
From Montserrat
Posts: 231
@m3x

I have some serial debugs from 2014 if these are any help .

   Report Go to top

Re: Frustation
Not too shy to talk
Joined:
2010/1/22 20:03
From VIGO SPAIN
Posts: 385
@Spectre660

I use Lubunto 14.04
kernel 4.40

And confirm, text console yes, and crash in graphics.

Yes, verde firmware installed.

_________________
AmigaOne X5000 OS4.1 FEU1 And Lubuntu 10.04
1200 towered with Blizzard PPC - BVision and Mediator
And a new fantastic Chameleon64
   Report Go to top

Re: Frustation
Just popping in
Joined:
2006/12/1 12:20
From Anzio (Rome), Italy
Posts: 101
@all

we just released an official u-boot update (version 1.3.1f) for Sam440ep boards (both mini-itx and flex variants)

ACube web site will be updated shortly, in the meantime, interested flex users may download the new updater from this location:

http://www.soft3dev.net/firmware/Sam440ep-flex_updater_131f.zip

It solves some compatibility issues with some Radeon HD cards (but it's untested with 7xxx cards)

Please read the instructions carefully !

_________________
Max Tretene, ACube Systems Srl, Soft3
   Report Go to top


(1) 2 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project