Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
38 user(s) are online (21 user(s) are browsing Forums)

Members: 0
Guests: 38

more...
Support us!
Recent OS4 Files
OS4Depot.net



« 1 ... 24 25 26 (27) 28 29 30 »


Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2006/11/29 8:09
From Lyon, France
Posts: 1070
Yes, with on from DropBox.

Same for me this week-end, I won't have too much time free.

_________________
--
AmigaONE X1000 1,8Ghz, 2GB, Sapphire Radeon HD 7700, with Amiga OS 4.1 FE
http://www.amiga-ng.org
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2787
@K-L

Where do you read the FPS anyway?


VIDEO: [H264] 640x266 0bpp 25.000 fps 326.2 kbps (39.8 kbyte/s)


this line shows the fps the video was record in, not the fps the video is played in.


Edited by LiveForIt on 2014/5/25 16:53:27
Edited by LiveForIt on 2014/5/25 16:54:00
_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2009/6/1 14:11
From Germany
Posts: 733
@LiveForIt

Please send me your e-mail address over PM

_________________
Amiga600/Vampire2/PrismaMegaMix​/32GB CF Card/2x Rys Mk2/A604n/IndivisionECS/Gotek
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just popping in
Joined:
2007/1/1 12:01
From Latina, Italy
Posts: 209
@Joerg, LiveForIt

these are my test results:

mplayer-joerg-beta11 -quiet -nosound -benchmark WORK:VIDEOS/Superman.flv
MPlayer SVN-r37148-4.5.4 (C) 2000-2014 MPlayer Team

Playing WORK:VIDEOS/Superman.flv.
libavformat version 55.33.100 (internal)
libavformat file format detected.
[flv @ 0x51266b88]Stream discovered after head already parsed
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0
VIDEO: [H264] 640x266 0bpp 25.000 fps 326.2 kbps (39.8 kbyte/s)
Clip info:
starttime: 0
totalduration: 86
totaldatarate: 455
bytelength: 4888212
canseekontime: true
sourcedata: BADC214E4HH1348869781057134
purl:
pmsg:
Load subtitles in WORK:VIDEOS/
VO: [amiga]
[amiga] Unable to open a window
[amiga] Unable to open a window
[amiga] Unable to open a window
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 55.52.102 (internal)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
Audio: no sound
Starting playback...
Movie-Aspect is undefined - no prescaling applied.
VO: [amiga] 640x266 => 640x266 Planar YV12


BENCHMARKs: VC: 28.429s VO: 10.055s A: 0.000s Sys: 0.529s = 39.013s
BENCHMARK%: VC: 72.8722% VO: 25.7731% A: 0.0000% Sys: 1.3547% = 100.0000%

Exiting... (End of file)




mplayer-noaltivec -quiet -nosound -benchmark -ao null WORK:VIDEOS/Superman.flv
MPlayer LiveForIt V5.1 - SVN-rSVN-r32634-4.2.4(C) 2000-2010 MPlayer Team

Playing WORK:VIDEOS/Superman.flv.
libavformat file format detected.
[flv @ 0x54cce080] Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0
VIDEO: [H264] 640x266 0bpp 25.000 fps 326.2 kbps (39.8 kbyte/s)
Clip info:
duration: 86
starttime: -inf
totalduration: 86
width: 640
height: 266
videodatarate: 319
audiodatarate: 129
totaldatarate: 455
framerate: 25
bytelength: 4888212
canseekontime: true
sourcedata: BADC214E4HH1348869781057134
purl:
pmsg:
VO: [comp] Welcome man !.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
Audio: no sound
Starting playback...
Movie-Aspect is undefined - no prescaling applied.
VO: [comp] 640x266 => 640x266 Planar YV12
VO: Disabling blanker
[swscaler @ 0x508d64b8]No accelerated colorspace conversion found from yuv420p to argb.
[swscaler @ 0x508d64b8]using unscaled yuv420p -> argb special converter


BENCHMARKs: VC: 31.460s VO: 10.188s A: 0.000s Sys: 0.406s = 42.055s
BENCHMARK%: VC: 74.8078% VO: 24.2257% A: 0.0000% Sys: 0.9665% = 100.0000%
VO: Enabling blanker
VO: Enabling blanker

Exiting... (End of file)





mplayer-noaltivec -quiet -nosound -benchmark -ao null -vo comp::rgb WORK:VIDEOS/Superman.flv
MPlayer LiveForIt V5.1 - SVN-rSVN-r32634-4.2.4(C) 2000-2010 MPlayer Team

Playing WORK:VIDEOS/Superman.flv.
libavformat file format detected.
[flv @ 0x54d1b080] Estimating duration from bitrate, this may be inaccurate
[lavf] stream 0: video (h264), -vid 0
[lavf] stream 1: audio (aac), -aid 0
VIDEO: [H264] 640x266 0bpp 25.000 fps 326.2 kbps (39.8 kbyte/s)
Clip info:
duration: 86
starttime: -inf
totalduration: 86
width: 640
height: 266
videodatarate: 319
audiodatarate: 129
totaldatarate: 455
framerate: 25
bytelength: 4888212
canseekontime: true
sourcedata: BADC214E4HH1348869781057134
purl:
pmsg:
VO: [comp] Welcome man !.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
Audio: no sound
Starting playback...
Movie-Aspect is undefined - no prescaling applied.
VO: [comp] 640x266 => 640x266 Planar YV12
VO: Disabling blanker
[swscaler @ 0x50cfe4b8]No accelerated colorspace conversion found from yuv420p to rgb24.
[swscaler @ 0x50cfe4b8]using unscaled yuv420p -> rgb24 special converter


BENCHMARKs: VC: 32.512s VO: 19.571s A: 0.000s Sys: 0.417s = 52.500s
BENCHMARK%: VC: 61.9281% VO: 37.2779% A: 0.0000% Sys: 0.7940% = 100.0000%
VO: Enabling blanker
VO: Enabling blanker

Exiting... (End of file)


All test made on my Sam460 RadeonHD 4670 ddr3

_________________
Sam 460EX, 2Gb Ram, Radeon R7 250, AmigaOS4.1 FE
A4000 PPC604@233, Mediator
A1200 PPC603@160, Mediator
uA1 G3@800, 512 Mb [sold]
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2006/12/1 19:07
From Germany
Posts: 1022
@sofistisoftware

Quote:
mplayer-joerg-beta11 -quiet -nosound -benchmark WORK:VIDEOS/Superman.flv
MPlayer SVN-r37148-4.5.4 (C) 2000-2014 MPlayer Team
...
BENCHMARKs: VC: 28.429s VO: 10.055s A: 0.000s Sys: 0.529s = 39.013s
BENCHMARK%: VC: 72.8722% VO: 25.7731% A: 0.0000% Sys: 1.3547% = 100.0000%


mplayer-noaltivec -quiet -nosound -benchmark -ao null WORK:VIDEOS/Superman.flv
MPlayer LiveForIt V5.1 - SVN-rSVN-r32634-4.2.4(C) 2000-2010 MPlayer Team
...
BENCHMARKs: VC: 31.460s VO: 10.188s A: 0.000s Sys: 0.406s = 42.055s
BENCHMARK%: VC: 74.8078% VO: 24.2257% A: 0.0000% Sys: 0.9665% = 100.0000%
Nearly the same speed. I could make the RGB mode of my video output a few % faster on the Sam460ex by using onchipmem.resource, but probably not enough to make a noticeable difference. I'll change my amiga video output back to pip again and remove the 16 bit RGB mode, that way my vo_pip can be used as the first video output and MPlayer will automatically switch to the next one (vo comp) on gfx cards without overlay support.

   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2787
@joerg

Yes I expected that, and speed difference can be down to you maybe having newer FFMPG bundled whit the newer MPlayer core.

Anyway after all bugs are fixed in google mplayer code, some one or I should maybe upgrade to a newer mplayer core, as I see big difference, VC speed.

Your H264 is 28.429s, my H264 is 31.460s
so that makes my H264 around 9-10% slower.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2006/12/1 19:07
From Germany
Posts: 1022
@LiveForIt

Quote:
Yes I expected that, and speed difference can be down to you maybe having newer FFMPG bundled whit the newer MPlayer core.
FFmpeg isn't included in the MPlayer SVN any more, the sources are still required and used for building MPlayer but you have to copy them into the MPlayer source tree yourself. I'm using FFmpeg 2.2.1.

Quote:
Anyway after all bugs are fixed in google mplayer code, some one or I should maybe upgrade to a newer mplayer core, as I see big difference, VC speed.

Your H264 is 28.429s, my H264 is 31.460s
so that makes my H264 around 9-10% slower.
It could be because of the newer GCC version or different compiler options as well. I'm using -O2, it's faster than -O3 and -Os on my Sam440ep, -O3 may be faster on the PA6T and other CPUs with much larger caches.

I've committed my vo_pip.c, incl. disabled 16 bit RGB code, but to be able to use it with the old MPlayer version you'll probably have to do some changes.

   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2787
@joerg

Quote:
but to be able to use it with the old MPlayer version you'll probably have to do some changes.


Most likely, as I have tried to standardize stuff in cgx_common.c

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2006/11/29 8:09
From Lyon, France
Posts: 1070
@LiveForIt

I do not see them (the FPS) but as far as I can tell, it eems to be played at this rate.

_________________
--
AmigaONE X1000 1,8Ghz, 2GB, Sapphire Radeon HD 7700, with Amiga OS 4.1 FE
http://www.amiga-ng.org
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2006/12/1 19:07
From Germany
Posts: 1022
@LiveForIt

Quote:
Most likely, as I have tried to standardize stuff in cgx_common.c
It should be changed to use that, but it's not required to include it (vo pip currently doesn't need nor use anything from any other AmigaOS MPlayer part).

The arguments of at least one of the video output functions changed and you have to change it to the old version to be able to use vo pip at all with the old MPlayer.

   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2008/4/10 14:57
From Northern Ireland
Posts: 939
Benchmark with LiveForIt latest version (I think) on X1000 and Radeon 6850

8.System:> WORK:Programs/Video/liveforit-mplayer/mplayer-altivec -quiet -nosound -benchmark -ao null -vo comp::argb WORK:Media/Movies/Superman.flv
MPlayer LiveForIt V5.1 - SVN-rSVN-r32634-4.2.4(C) 2000-2010 MPlayer Team

VO: [comp] Welcome man !.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
Audio: no sound
Starting playback...
Movie-Aspect is undefined - no prescaling applied.
VO: [comp] 640x266 => 640x266 Planar YV12
VO: Disabling blanker
[swscaler @ 0x58c42d80]ALTIVEC: Color Space ARGB
[swscaler @ 0x58c42d80]using unscaled yuv420p -> argb special converter


BENCHMARKs: VC: 6.228s VO: 3.852s A: 0.000s Sys: 0.253s = 10.332s
BENCHMARK%: VC: 60.2760% VO: 37.2801% A: 0.0000% Sys: 2.4439% = 100.0000%
VO: Enabling blanker
VO: Enabling blanker

Same test with -vo comp::argb Forced to fullscreen (-fs)on video startup

BENCHMARKs: VC: 7.121s VO: 4.048s A: 0.000s Sys: 0.116s = 11.286s
BENCHMARK%: VC: 63.0979% VO: 35.8727% A: 0.0000% Sys: 1.0294% = 100.0000%



Same test with -vo SDL (defaults to fullscreen)

BENCHMARKs: VC: 7.216s VO: 29.914s A: 0.000s Sys: 0.140s = 37.270s
BENCHMARK%: VC: 19.3625% VO: 80.2631% A: 0.0000% Sys: 0.3744% = 100.0000%


Just to compare altivec to noaltivec
WORK:Programs/Video/liveforit-mplayer/mplayer-noaltivec -quiet -nosound -benchmark -ao null -vo comp::argb WORK:Media/Movies/Superman.flv
MPlayer LiveForIt V5.1 - SVN-rSVN-r32634-4.2.4(C) 2000-2010 MPlayer Team

BENCHMARKs: VC: 8.745s VO: 5.763s A: 0.000s Sys: 0.107s = 14.615s
BENCHMARK%: VC: 59.8371% VO: 39.4313% A: 0.0000% Sys: 0.7316% = 100.0000%

WORK:Programs/Video/liveforit-mplayer/mplayer-altivec -quiet -nosound -benchmark -ao null -vo comp::argb WORK:Media/Movies/Superman.flv
MPlayer LiveForIt V5.1 - SVN-rSVN-r32634-4.2.4(C) 2000-2010 MPlayer Team

BENCHMARKs: VC: 6.228s VO: 3.852s A: 0.000s Sys: 0.253s = 10.332s
BENCHMARK%: VC: 60.2760% VO: 37.2801% A: 0.0000% Sys: 2.4439% = 100.0000%




Edited by ddni on 2014/5/27 12:30:48
_________________
AmigaOne X1000.
Radeon R9 270X

http://www.tinylife.org.uk/
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2787
@ddni

Yes AltiVec does make big difference, note if you are using the unofficial I shared using DropBox, use the novsync option, anyway I don't think you are

mplayer-altivec -quiet -nosound -benchmark -ao null -vo comp::argb:novsync WORK:Media/Movies/Superman.flv

anyway argb does not need to be included, its default graphic mode.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3320
@LiveForIt

I added a new comment for issue #37

http://code.google.com/p/mplayer-amigaos/issues/detail?id=37

   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2006/11/22 17:57
From Italy, Rome
Posts: 592
Could someone summarize the download link for each version?
I would like to test the one with the gui.


Thank you

_________________
Retired
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2006/11/24 18:52
From Gloucestershire, UK.
Posts: 1171
@AmigaBlitter

There isn't one with a GUI, it's separate.

Liveforit's version is here: http://os4depot.net/share/video/play/liveforit-mplayer.lha

joerg's version is here: http://www.sendspace.com/file/93ka2m

The GUI is Here: http://os4depot.net/share/video/misc/mplayer-gui.lha

_________________
Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2006/11/22 17:57
From Italy, Rome
Posts: 592
@Severin

Thank you Severin

_________________
Retired
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Home away from home
Joined:
2006/11/20 16:26
From Norway
Posts: 2787
@Severin

That's not 100% true, there is a built in Reaction GUI but it was shown at some Italian show many years ago.

LiveForIt-Mplayer does not have the menu nor the GUI included.

_________________
(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2006/11/24 18:52
From Gloucestershire, UK.
Posts: 1171
@LiveForIt

I meant in this thread, the recent updates, not everywhere or I would have listed muimplayer.

_________________
Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Quite a regular
Joined:
2009/6/1 14:11
From Germany
Posts: 733
@LiveForIt# Write your default config options here!
lavdopts=skiploopfilter=all
# Set language.
slang=de
alang=de
# Align subs. (-1: as they want to align themselves)
spualign=-1
#For Cache
cache=8192
cache-min=4

This is my config.
720HD videos works very well over SMTube.
720HD movies works without any problems.CPU usage is at 70%-80%
1080HD movies are stuttering too much.That will surely be even better.

I saw that no AC3 is supported. Is that right?
Maybe that is the reason why Avatar is only in english(DVPlayer plays it in german)

_________________
Amiga600/Vampire2/PrismaMegaMix​/32GB CF Card/2x Rys Mk2/A604n/IndivisionECS/Gotek
   Report Go to top

Re: Mplayer Altivec test version for G4 and PA6T-1682M
Just can't stay away
Joined:
2006/11/29 8:09
From Lyon, France
Posts: 1070
TommySammy : I understand better how you can read 720HD movies without stuttering. You degrade (a lot) quality of the movie with the skiploopfilter option.

As the image is really ugly with this option, I do not use it and make all my tests without it.

For a better experience I'd recommend not using this option (use it only for really demanding videos).

I would not promote the X1000 launching videos (with skiloopfilter) on front of friends who use a PC unless I want them to laugh at me.

_________________
--
AmigaONE X1000 1,8Ghz, 2GB, Sapphire Radeon HD 7700, with Amiga OS 4.1 FE
http://www.amiga-ng.org
   Report Go to top


« 1 ... 24 25 26 (27) 28 29 30 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project