Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
31 user(s) are online (23 user(s) are browsing Forums)

Members: 0
Guests: 31

more...

Headlines




(1) 2 3 »


VICE 2.4 Test Version - please test!
Quite a regular
Joined:
2006/11/27 17:23
Posts: 535
Hi everybody,

I've today uploaded a preliminary test version of VICE 2.4. I finally get fed up of the public version not working.
http://www.retroreview.com/iang/Vice_AmigaOS4_2.4_test.lha

The reasons why the public version didn't work are quite scary... it could never have worked. It didn't do basic things like calling GetInterface() on the library base, and so of course fell over on the first library call. There's lots of AMIGA_OS4 defines in there, but none of them do the interface opening... yet it DOES call the interface closing. Very strange. Fixed now.
Another crash was joyai_open() being called to initialise AmigaInput before the library was loaded. Also not good.

The best bit, though, and the trickiest bit, was the hang after the window had opened which is what you got if you fixed the other problems.
The Amiga code was calling p96LockBitMap() on the bitmap, and then calling the render routine, and then returning to call p96UnlockBitMap().
All seems fair enough? Yes. Until you realise that the render routine checks for a palette change, and can load the pallete off disk.

Loading off disk while the BitMap is locked? Not a good idea. It would work, but then as soon as Vice tried to call BltBitMap on the bitmap it hung solid. Presumably the loading while locked trashed the bitmap structure somehow.

This version is here is the non-stripped version of x64. Copy it into the standard VICE-2.4 distribution, but make sure you either rename "x64.exe.info" to "x64.info", or call "x64" from the CLI. If you just double click on the icon from Workbench, it'll run x64.exe which is the old, broken version.

I am aware that the monitor crashes in the locale library. Probably a NULL interface again.

Any other crashes please report them in this thread and I'll see if I can fix them.

_________________
--
Ian Gledhill
ian.gledhill@btinternit.com (except it should be internEt of course...!)
Check out my company's shop: http://www.mutant-caterpillar.co.uk/shop/ - specialising in Sinclair Spectrums but will be adding Amigas!
   Report Go to top

Re: VICE 2.4 Test Version - please test!
Home away from home
Joined:
2006/12/2 3:55
From Italy, Perugia
Posts: 3433
@Spirantho

Many thanks Spirantho, indeed it never worked normally under OS4, at the time i also reported a few bugs but no one take them so i'll give up, see:

http://sourceforge.net/p/vice-emu/bugs/search/?q=os4

Once we have tested all the things i hope you will commit all the fix into the repository

For now just tried your test version and it start

   Report Go to top

Re: VICE 2.4 Test Version - please test!
Just popping in
Joined:
2013/10/23 15:18
From Kuusamo, Finland
Posts: 93
Hi!

Thanx for this new test version, i have't found any crashes but still I have
speed problems with Vice2.4 ( actually version 2.1 is the only one which works at normally speed).
Everything is running slower, graphics and sound is slower and crispy
I have wonder that am I onlyone who have this kind of problems.

My system is: X1000, update6

_________________
\o/....X1000....\o/
   Report Go to top

Re: VICE 2.4 Test Version - please test!
Quite a regular
Joined:
2008/10/29 10:20
From Uppsala, Sweden
Posts: 801
@Spirantho

Thanks

_________________
AmigaOne X5000
Radeon HD 7700
   Report Go to top

Re: VICE 2.4 Test Version - please test!
Quite a regular
Joined:
2006/11/27 17:23
Posts: 535
@Breed

I just ran it on my X1000 (I fixed it on my Sam440ep) and it runs 1450% when in warp mode. At normal speed, it just runs at a steady 100% (and judging by the King Crimson OGG playing perfectly in the background, I'd say it's not chewing up all the CPU time, either).

Have you tried with default settings? Sounds like something is odd somewhere...
Anything odd about your system (not using compositing, using an odd sound card, that sort of thing)?

_________________
--
Ian Gledhill
ian.gledhill@btinternit.com (except it should be internEt of course...!)
Check out my company's shop: http://www.mutant-caterpillar.co.uk/shop/ - specialising in Sinclair Spectrums but will be adding Amigas!
   Report Go to top

Re: VICE 2.4 Test Version - please test!
Quite a regular
Joined:
2008/10/29 10:20
From Uppsala, Sweden
Posts: 801
Hmm i just emailed Spirantho about fixing this and then i see its already fixed. I completely forgot about this. So, is everything working?

_________________
AmigaOne X5000
Radeon HD 7700
   Report Go to top

Re: VICE 2.4 Test Version - please test!
Just popping in
Joined:
2006/11/27 17:27
Posts: 237
Here is a new bugfix test version by Bszili:

http://www.amigans.net/modules/xforum ... t_id=98867#forumpost98867

   Report Go to top

Re: VICE 2.4 Test Version - please test!
Quite a regular
Joined:
2008/10/29 10:20
From Uppsala, Sweden
Posts: 801
@bszili
Please upload to os4depot so more ppl can enjoy it. Thanks.

_________________
AmigaOne X5000
Radeon HD 7700
   Report Go to top

Re: VICE 2.4 Test Version - please test!
Just can't stay away
Joined:
2006/11/24 17:54
From Sanremo
Posts: 1858
@Spirantho

Does this version include the fixes applied by bszili? (Competition Pro USB for example)

Thanks

   Report Go to top

Re: VICE 2.4 Test Version - please test!
Quite a regular
Joined:
2013/10/17 16:21
From Hungary
Posts: 675
This is why thread necroing is dangerous

_________________
This is just like television, only you can see much further.
   Report Go to top

Re: VICE 2.4 Test Version - please test!
Quite a regular
Joined:
2008/10/29 10:20
From Uppsala, Sweden
Posts: 801
@lazi
Will try the settings you recommended.

@TSK
I managed to get my TAC2 to work using usb-adapter but its not easy.

@all
Whats the benefit with using Bszilis version compare to old 2.2? I mean whats new in 2.4?


Edited by Joeled on 2015/11/24 18:37:57
_________________
AmigaOne X5000
Radeon HD 7700
   Report Go to top

Re: VICE 2.4 Test Version - please test!
Just popping in
Joined:
2006/11/27 17:27
Posts: 237
@Joeled:

Sound settings:

http://www.amigans.net/modules/xforum ... t_id=98390#forumpost98390

Nubechecorre posted this:
about sound problem, I solved using these settings, open->Sound Settings:

Sample rate: 44100Khz
Buffer size: 150msec
Fragment size: Very Large
Speed Adjustment: Flexible
Volume: 100
Sound Output mode: Stereo

I also changed the "VICII Video Setting" setting the "Render filter settings" to: "none"

   Report Go to top

Re: VICE 2.4 Test Version - please test!
Just can't stay away
Joined:
2007/2/23 13:49
From Finland, the land of Santa, sauna, sisu and salmiakki
Posts: 1116
I tested that latest version quickly and emulation is slower than in the older version I had installed making C64 sluggish even to move the cursor on screen. Also I couldn't configure joysticks properly in either of the versions. Nothing happens when clicking "Configure AI/Joystick A" or "Joystick B" buttons.

_________________
Rock lobster bit me, so excuse me.
X1000 + AmigaOS 4.1 FE
"Anyone can build a fast CPU. The trick is to build a fast system." - Seymour Cray
   Report Go to top

Re: VICE 2.4 Test Version - please test!
Just can't stay away
Joined:
2006/11/24 17:54
From Sanremo
Posts: 1858
to all, use the BSZili version, it is updated and bug fixed! :)

   Report Go to top

Re: VICE 2.4 Test Version - please test!
Quite a regular
Joined:
2008/10/29 10:20
From Uppsala, Sweden
Posts: 801
@lazi
Will try the settings you recommended.

@TSK
I m playing with my TAC2 using a usb-adapter. Its not easy to configure but i manage to do it somehow. There are different joystickadapters to choose from.

@all
Whats the benefit with using 2.4 compare to old 2.2? Whats new in the latest version?

_________________
AmigaOne X5000
Radeon HD 7700
   Report Go to top

Re: VICE 2.4 Test Version - please test!
Quite a regular
Joined:
2008/9/20 23:21
From Gothenburg, Sweden (via Finland)
Posts: 523
Thanks guys on your work on VICE

_________________
AmigaOS 4.1 FE Update 2 on Sam440ep-flex, 800Mhz, 1GB RAM, Radeon 9250 Resized Image
A1200/040, 2+4MB, external 3.5''HDD / A1200 (spare) / A500+ (sold) / C128 (sold)
http://m4rko.com/AMIGA
   Report Go to top

Re: VICE 2.4 Test Version - please test!
Just popping in
Joined:
2006/11/27 17:27
Posts: 237
@Joeled

Whats the benefit with using 2.4 compare to old 2.2? Whats new in the latest version?

Really working AmigaInput support. Two joysticks simultaneously never worked before.

   Report Go to top

Re: VICE 2.4 Test Version - please test!
Quite a regular
Joined:
2008/10/29 10:20
From Uppsala, Sweden
Posts: 801
@lazi
Okay, now everything works just fine Thanks for the recommended settings. I hope there is a way for other ppl to find this excellent updated version on os4depot in the future.

@nubechecorre
We need this version on os4depot. Can you fix it? What about the rest of the commodre versions in Vice2.4? Do they work?

Resized Image


_________________
AmigaOne X5000
Radeon HD 7700
   Report Go to top

Re: VICE 2.4 Test Version - please test!
Just popping in
Joined:
2006/12/8 13:37
From Netherlands
Posts: 106
@lazi

That are the correct soundsettings for me, the standard settings did not work and produces rubbish.

It is the BSZili version i use (thanks BSZili).

I noticed that the executable filesize is very large: 41MB vs 4MB (but it works, as th 2.4 version on sourceforge gave a Grimreaper)

CPU load varies between 10 and 100% load.

   Report Go to top

Re: VICE 2.4 Test Version - please test!
Quite a regular
Joined:
2008/9/20 23:21
From Gothenburg, Sweden (via Finland)
Posts: 523
@thread

Uploaded to OS4Depot.

The BSZili version works fine here, it hasn't crashed (yet), thanks


_________________
AmigaOS 4.1 FE Update 2 on Sam440ep-flex, 800Mhz, 1GB RAM, Radeon 9250 Resized Image
A1200/040, 2+4MB, external 3.5''HDD / A1200 (spare) / A500+ (sold) / C128 (sold)
http://m4rko.com/AMIGA
   Report Go to top


(1) 2 3 »



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project