Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
99 user(s) are online (87 user(s) are browsing Forums)

Members: 0
Guests: 99

more...

Support us!

Headlines




« 1 (2)


Re: Aquaria Crashing all the time on sam44ep (mini-itx)
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 3741
I tried with upping the stack but to no avail.

The problems i have with Aquaria (which makes the game unplayable for me sadly)

Minor - Sounds starts to crackle as if the framerate is going down and the systems starts to draw everything it can get to the cpu power.
Places:
1) In the intro when "bit blot" is fading towards the screen
2) Whenever ego is swimming into a tight tube and most on the screen is darkness

Major - Loosing USB completely (either mouse and keyboard simply stops working which is a MAJOR nuisance, or the game switches back to Workbench presenting me a "Unsolvable USB problems" - both times hard reset!)
Places:
1) Sometimes when i load a game and at least one other program is open (YAM, OWB, whatever)
2) Right now i can reproduce it when swimming into the next level after loading a game from the very first save crystal)
3) Probably lots of other places

So as badly as i want to play the game i can't

_________________
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
   Report Go to top

Re: Aquaria Crashing all the time on sam44ep (mini-itx)
Just popping in
Joined:
2008/12/20 13:58
Posts: 185
Quote:

ChrisH wrote:
@Dwyloc Quote:
I think I will reinstall update 2 and 3 when I get home tonight and see if that makes Aquaria any more stable on my little sam440.

That should NOT be necessary, as Aquaria makes backups of your old files. So a little renaming is all that is needed.

Also, I don't know if Update 2 & 3 contain all the files that are replaced by Aquaria, so reinstalling from Update 2 might not work. In short: Please try renaming the files Aquaria backed-up for you.


Yes I actually did that first then re-applied the updates in case I had missed something, but it made no difference to my problems with the game crashing sadly.

_________________
Sam440ep 667mhz 512megs OS4.1 + Minimig, 4MB RAM, ARM add-on board
WinUae 2.3.2, OS 3.9, BB2, Catweasel MkIV
Amiga 1200, BlizzardPPC 060/200 with SCSI, mediatorSX, Voodoo3, pci lan
   Report Go to top

Re: Aquaria Crashing all the time on sam44ep (mini-itx)
Home away from home
Joined:
2007/5/19 14:23
From England
Posts: 3553
Quote:
Major - Loosing USB completely (either mouse and keyboard simply stops working which is a MAJOR nuisance, or the game switches back to Workbench presenting me a "Unsolvable USB problems" - both times hard reset!)

If you have Sam440ep_setup running, try disabling it (suggest hard reset aftwards to clear it's effects).

_________________
Author of the PortablE programming language.
I love using Amiga OS4.1
It is pitch black. You are likely to be eaten by a grue...
   Report Go to top

Re: Aquaria Crashing all the time on sam44ep (mini-itx)
Just popping in
Joined:
2008/12/20 13:58
Posts: 185
Quote:

afxgroup wrote:
try to run it from shell but use something like

stack 10000000



OK I set the stack to 10000000 from the shell and started the game and left my game running and as normal it crashed as normal in under an hour without me interacting with the game so I would not expect it to have to load any new sections or data other than music and the music continues even after the crash window is displayed.

_________________
Sam440ep 667mhz 512megs OS4.1 + Minimig, 4MB RAM, ARM add-on board
WinUae 2.3.2, OS 3.9, BB2, Catweasel MkIV
Amiga 1200, BlizzardPPC 060/200 with SCSI, mediatorSX, Voodoo3, pci lan
   Report Go to top

Re: Aquaria Crashing all the time on sam44ep (mini-itx)
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 3741
@ChrisH

I fixed it (at least for me)...

SWAP seemed to be broken and was the one causing trouble.
I had set it too low (512MB with 512MB RAM)

I removed it and set it up on another partition (now 1GB), leaving everything at default but the blocksize (set to 4096).

The game itself runs fine now, no crashes anymore apart from a lockup after exit

Maybe everyone who got crashes and/or USB misbehaving check their SWAP again?

_________________
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
   Report Go to top

Re: Aquaria Crashing all the time on sam44ep (mini-itx)
Just popping in
Joined:
2008/12/20 13:58
Posts: 185
@Raziel

Thanks for the advice I will check my SWAP settings when I get home from memory I have a 2GB SWAP partition, but I may try deleting it and recreating it with the same settings as you are using to see if that resolves my problem.

_________________
Sam440ep 667mhz 512megs OS4.1 + Minimig, 4MB RAM, ARM add-on board
WinUae 2.3.2, OS 3.9, BB2, Catweasel MkIV
Amiga 1200, BlizzardPPC 060/200 with SCSI, mediatorSX, Voodoo3, pci lan
   Report Go to top

Re: Aquaria Crashing all the time on sam44ep (mini-itx)
Quite a regular
Joined:
2007/2/27 10:47
From Gravity well
Posts: 686
I have had swap disabled for a while now, and ran it without problems yesterday. I noticed free RAM went below 500 KiB briefly, but maybe the game has some failsafes. So it should work with 512 MB RAM without doing any memory saving measures before starting it.

   Report Go to top

Re: Aquaria Crashing all the time on sam44ep (mini-itx)
Just popping in
Joined:
2008/12/20 13:58
Posts: 185
It would seem I have a problem with swap just not working on my sam440ep, as disabling deleting the swap partition stops Aquaria from crashing randomly.

I reported in a different thread that swap did not seem to work on my system in the past but I was informed I was just not testing if correctly.

I have tried creating a partition in different locations on my disk and even doing a clean install of OS4.1 update 1, 2 and 3 in a new partition and creating a new swap partition as documented in the release notes, but all it does in make applications crash at random


Edit: link to my old amigaworld thread on swap http://amigaworld.net/modules/newbb/v ... _id=34347&forum=14#630780

_________________
Sam440ep 667mhz 512megs OS4.1 + Minimig, 4MB RAM, ARM add-on board
WinUae 2.3.2, OS 3.9, BB2, Catweasel MkIV
Amiga 1200, BlizzardPPC 060/200 with SCSI, mediatorSX, Voodoo3, pci lan
   Report Go to top

Re: Aquaria Crashing all the time on sam44ep (mini-itx)
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 3741
It may not be SWAP alone...

Aquaria seems to become very memory hungry later in the game.
I have a save where i can't even get into the game without lowering the in-game resolution to 640x480 (note: i played the game upto this point in 1024x768) but when in the game i can do at most two or three level switches and it will always lock up.

I tried with deleting SWAP from the partitions but it will simply crash with a recoverable alert then...still i think that if SWAP worked flawlessly it would be playable :-/

uhm...btw, i'm on an AmigaOneXE...this behaviour is not limited to Sams

_________________
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
   Report Go to top

Re: Aquaria Crashing all the time on sam44ep (mini-itx)
Home away from home
Joined:
2006/11/26 21:45
From a dying planet
Posts: 3741
@Dwyloc

I opened a thread on the Hyperion forums.
Please go ahead and comment

_________________
People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
   Report Go to top

Re: Aquaria Crashing all the time on sam44ep (mini-itx)
Just popping in
Joined:
2008/12/20 13:58
Posts: 185
@All looks like update 4 fixed SWAP being enabled crashing Aquaria on my sam440ep (mini-itx) as I played for a number of hours yesterday without getting a DSI

The only other problem is that Aquaria real seems to struggle on my system even at 640x480, but at least its not crashing any longer which is much better.

_________________
Sam440ep 667mhz 512megs OS4.1 + Minimig, 4MB RAM, ARM add-on board
WinUae 2.3.2, OS 3.9, BB2, Catweasel MkIV
Amiga 1200, BlizzardPPC 060/200 with SCSI, mediatorSX, Voodoo3, pci lan
   Report Go to top


« 1 (2)



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project