Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
51 user(s) are online (43 user(s) are browsing Forums)

Members: 0
Guests: 51

more...

Support us!

Headlines

 
  Register To Post  

(1) 2 »
Using USB CD Drive with OS4 / X5040
Not too shy to talk
Not too shy to talk


See User information
Part software part hardware I guess...

Is there anything special I need to do to get an external USB CD drive to work on OS4 (4.1FE fully updated)?

I ask because I'm now on my second attempt at getting a USB CD drive to use with the machine. The first didn't work because the machine couldn't supply enough power so it just shut down the ports.

Today I got another, this one has a second USB port for power alone and I have that connected to a battery pack. It works, but if I put an audio CD in, the OS sees this as a hard drive that has no files, it doesn't see it as an audio CD.

Similarly, if I insert Heretic disk 2 for the CD audio, the game doesn't see it. This will be for the same reason. I get that I can image the CD (and that is how I use it) but that's not the point here, the point is I am trying to find a USB CD drive that I can use because my case intentionally has no 5.25" bays.

The device reported for the CD drive is 'usbdisk.device unit 0' - i mean, that doesn't even sound CD-like, although mounter does say CDFS for the file system. But it just doesn't see it as an audio CD.


Amiga x5040 ı 16GB ı RX580
GB-A1000 060@100,
A1200 PiStorm32-Lite CM4
Go to top
Re: Using USB CD Drive with OS4 / X5040
Just can't stay away
Just can't stay away


See User information
@MartinW
Quote:
the point is I am trying to find a USB CD drive that I can use because my case intentionally has no 5.25" bays.
Using an external eSATA CD drive, if there are any, should work better with the AmigaOS drivers.

Quote:
The device reported for the CD drive is 'usbdisk.device unit 0' - i mean, that doesn't even sound CD-like, although mounter does say CDFS for the file system. But it just doesn't see it as an audio CD.
For audio and video CDs/DVDs the MMC commands (SCSI/ATAPI, on AmigaOS HD_SCSICMD) are required: 2352 bytes/sector, TOC with multiple tracks, etc.
For data CDs/DVDs/BDs, USB sticks and HDs/SSDs the trackdisk/ATA commands are enough, data CDs/DVDs/BDs: 2048 bytes/sector and everything in a single track (AmigaOS commands TD_READ64 and TD_WRITE64).
I don't know if the AmigaOS 4.x USB massstorage driver supports MMC commands, or SCSI/ATAPI ones in general, probably and according to your results it doesn't.

Go to top
Re: Using USB CD Drive with OS4 / X5040
Just can't stay away
Just can't stay away


See User information
@MartinW

I also use an external USB DVD/RW Rom on my A1222 and it works without any problems. The DVD drive has no external power source, as it is known that the NG hardware might not provide enough power I connected it to a USB HUB.

I also tested it as you did with the Heretic2 AudioCD and there were no problems with playback. The only additional thing I did was to change the device in PlayCD to "usbdisk.device" and "unit 0".

Here you can see which DVD/RW drive I am using:

Resized Image

Resized Image

Resized Image

You also need to add the same setting in the Audio Source options to Heretic2, that should normally work. Unfortunately I cannot test this.


Edited by Maijestro on 2024/6/22 7:51:23
MacStudio ARM M1 Max Qemu//Pegasos2 AmigaOs4.1 FE / AmigaOne A1222plus AmigaOs4.1 FE
Go to top
Re: Using USB CD Drive with OS4 / X5040
Not too shy to talk
Not too shy to talk


See User information
@MartinW

An audio CD should show up as data CD with AIFF files. If it doesn't something has gone wrong. As least for a pure audio CD.

To play it the audio out jacks need to be connected to the computer or some external stereo system. The drive would be sent a play command and going with what joerg stated it would be an MMC command by the looks of it. This is how things usually worked in a classic Amiga with a CD drive connected internally. It's also how things worked in the XE days with CD audio out connected to sound card.

The other way was to read the CDDA data direct from the drive and then play it to an audio device. This method is fine for newer systems with 16 bit audio. But it wasn't as common early on. Later on it became more common. Especially with digital outs and leaving analogue CD outs to be depreciated.

It shouldn't matter with ubsdisk.device not sounding CD-like, the same as scsi.device isn't CD like either. It's just a transport device. But I think what does matter is supporting the MMC commands. Given USB uses some SCSI subset of commands it should know more than generic ATA commands.

It may or may not help but SYS:Documentation/Kickstart/CDFileSystem.doc does give you some keys you can press on CD insert:
Supported qualifiers (press when inserting the CD):
    - <
ctrl>: Disables data track on mixed audio+data CDs,
    
mounts HFS/HFSinstead of ISO 9660 on hybrid CDs.
    - <
shift>: Disables audio tracks on mixed audio+data CDs.

Go to top
Re: Using USB CD Drive with OS4 / X5040
Not too shy to talk
Not too shy to talk


See User information
@all

Based on the replies here, I'll give holding CTRL down when I insert the CD but it indeed sounds like my drive is not behaving like a standard drive, it sounds like it's presenting to the system the same way a USB disk would. Or maybe it's not supporting the relevant commands, whichever technicality it is, the result is the same to me!

Probably the easiest and cheapest next step here is to disconnect the powered hub that I have from my Mac and connect it to the Amiga. Then I can see if the first drive I bought works. If so, I'll look for a powered hub. That would be cheaper than other options which would be at least a PCIe SATA card with external eSATA and / or a different case that has a 5.25" bay.

Incidentally, what is the generally accepted way to refer to the computer? Is it an AmigaOne? Is it just an Amiga? X5000? Obviously there are times when you need to be specific and say X5040, but otherwise I'd prefer something more generic but I don't know what. A minor detail for sure


Amiga x5040 ı 16GB ı RX580
GB-A1000 060@100,
A1200 PiStorm32-Lite CM4
Go to top
Re: Using USB CD Drive with OS4 / X5040
Not too shy to talk
Not too shy to talk


See User information
Update: A powered USB hub and my original USB CD drive behaves exactly the same and holding CTRL during insert of disk didn't make any difference - which doesn't surprise me much as it doesn't seem capable of reading the audio portion of the disk at all, whether pure audio or hybrid.

So I'm back to square one really. Either PCIe SATA controller with eSATA and external eSATA caddie for my SATA optical drive, or keep trying different USB CD drives. Maybe starting with the specific LG model shown above if it can still be found.

Either option not ideal.


Amiga x5040 ı 16GB ı RX580
GB-A1000 060@100,
A1200 PiStorm32-Lite CM4
Go to top
Re: Using USB CD Drive with OS4 / X5040
Just can't stay away
Just can't stay away


See User information
@Maijestro
Quote:
I also tested it as you did with the Heretic2 AudioCD and there were no problems with playback. The only additional thing I did was to change the device in PlayCD to "usbdisk.device" and "unit 0".
Audio CD players like PlayCD use different MMC commands than CDFileSystem does for creating the fake AIFF files.

Does playing the Track01, Track02, etc. file with double click, or loading them with MultiView or MultiViewer work as well?

Go to top
Re: Using USB CD Drive with OS4 / X5040
Just can't stay away
Just can't stay away


See User information
(deleted double post)

Go to top
Re: Using USB CD Drive with OS4 / X5040
Just can't stay away
Just can't stay away


See User information
@MartinW
Quote:
So I'm back to square one really. Either PCIe SATA controller with eSATA and external eSATA caddie for my SATA optical drive, or keep trying different USB CD drives.
Do you have 2 HDs/SSDs installed already, or why an additional PCI(e) SATA controller?

The X5000 has 2 SATA ports, with something like https://www.amazon.de/-/en/GRAUGEAR-Ex ... tion-G-5251/dp/B0BT28M912 (there are probably much cheaper ones) and a SATA to eSATA cable any 20€ "internal" SATA CD/DVD drive should work.

Quote:
Maybe starting with the specific LG model shown above if it can still be found.
The one Maijestro is using seems to be https://www.amazon.de/-/en/GP50NB40/dp/B00AWRTXVS/

Go to top
Re: Using USB CD Drive with OS4 / X5040
Not too shy to talk
Not too shy to talk


See User information
So, I don't have 2 SSDs in there at the moment but I did buy a second disk for either linux or MOS the other day. I haven't tackled the GPU side of it yet - that's another can of worms.

Another reason is that my case doesn't have a 5.25" bay and the case was £200 so I don't really want to replace it for one that does. I DO have a SATA DVD writer that used to be in a machine that I could do something with (like get an enclosure).

Anyway, I think we've answered the question that the 2 drives I have here don't work with OS4. None of this is urgent, or any kind of priority, as per my original question, I just wondered if I needed to do anything special and it sounds like the answer is, no, not if the drive is fully supported, and these don't appear to be.

[EDIT] Somewhere, hiding in a box of cables, I know I have a bracket that would bring power and sata to the back and I could use a simple eSATAp cable. That's probably the easiest option as I could then attach either an SSD or a DVD drive depending on the situation..


Amiga x5040 ı 16GB ı RX580
GB-A1000 060@100,
A1200 PiStorm32-Lite CM4
Go to top
Re: Using USB CD Drive with OS4 / X5040
Just popping in
Just popping in


See User information
Hi all,

I noticed the same problem when inserting a CD, a disk icon is displayed instead of a CD.

I would like to resolve this detail.

Go to top
Re: Using USB CD Drive with OS4 / X5040
Not too shy to talk
Not too shy to talk


See User information
I think the first thing to do is for me to grab my internal DVD drive and connect it to the SATA port as normal, which I can do just by removing the side panel of the case and confirm that it is the USB drive causing the issue and not the OS. Right now I assume it is, but it would be prudent of me to check. I think I can check this tonight as I should only need a SATA and power cable.


Amiga x5040 ı 16GB ı RX580
GB-A1000 060@100,
A1200 PiStorm32-Lite CM4
Go to top
Re: Using USB CD Drive with OS4 / X5040
Not too shy to talk
Not too shy to talk


See User information
I'll upload a photo to this shortly when I can remember my image host and credentials, but suffice to say, after 2 cables and a whole lot of reboots, I've got an internal SATA DVD writer attached and it's exactly the same. Audio CD shows as a hard drive. So at this point I'm glad I didn't spend out on any extra hardware.

It was flaky getting here too. Most of the time the system wouldn't boot with a disk in the drive, it would hang on scanning SATA port 1. The first time it booted with Heretic 2 CD in the drive (a hybrid disk) and I could browse the files. If i went into the game and selected vsata.device unit 1 it was an instant system hang (no crash, just a hang). Then I rebooted to workbench, ejected Heretic2 disk 2 and inserted an audio CD and something kernel panic'd so I had to reboot again. This time I got to the same point I was at with the external USB drive of the audio CD being a hard drive with no files on it.

So I'm back to...

Do I need to configure something or change something? Could something be setup wrong on my system? Honestly I've never touched optical media on any Amiga before this so I'm a complete noob here. Obviously I've had CDs and DVDs before, just not on Amiga or Amiga-like's.

Here's some of the u-boot log since I have a serial console attached the rest is quite long:
EHCI timed out on TD token=0x80008c80
EHCI timed out on TD 
token=0x80008c80
4 USB Device
(sfound
EHCI timed out on TD 
token=0x80008d80
EHCI timed out on TD 
token=0x80008d80
SATA0 
(3 Gbps)
       
SATA1 (1.5 Gbps)
CE at device
scanning bus 
for devices...
  
Device 0: (1:0VendorHL-DT-ST Prod.: DVD-RAM GH22LS30 Rev1.03
            Type
Removable CD ROM
            Capacity
491.2 MB 0.4 GB (251515 x 2048)
Found 1 device(s).
## Starting application at 0x00200000 ...


Amiga x5040 ı 16GB ı RX580
GB-A1000 060@100,
A1200 PiStorm32-Lite CM4
Go to top
Re: Using USB CD Drive with OS4 / X5040
Not too shy to talk
Not too shy to talk


See User information
One more update before I pack up for the night. I found part of the culprit for SATA at least.

The culprit is p50x0sata.device. If I comment that one out and instead use p5020.device things works as I would expect, audio CDs have the gold CD icon on the desktop and after adjusting the tool types for "PlayCD" it will play the CD, eject the CD and do all the things you'd expect it to.

DVDs also appear as discs but DVPlayer play the video but honestly, that might not be setup right. I have only the old one that comes with the OS and I'm not purchasing the one you can buy separately just to do some testing (I'm never, ever likely to sit in front of the computer to watch a DVD when I have a perfectly good 55" TV in the living room!).

Icing on the cake though is that the system will not boot with a disc in the drive, it just hangs on scanning the SATA bus. So that's never going to work for me as I'd never remember to eject the disc every time. Never mind how you're meant to install an OS from a CD

Heretic 2 couldn't read the disk, as soon as I set the device to p2020sata.device and unit 1 the whole system hangs. Not sure what that's about.

So, putting the system all back together (without the SATA), and going back to the USB devices and it's just the same as it was before. Not a big surprise given it's using usbdisk.device not p5020sata.device. I think that's about as far as I can go for now unless there's software things I can try.


Amiga x5040 ı 16GB ı RX580
GB-A1000 060@100,
A1200 PiStorm32-Lite CM4
Go to top
Re: Using USB CD Drive with OS4 / X5040
Just popping in
Just popping in


See User information
I fixed the problem where the hard drive icon was displayed when inserting a CD/DVD.

Please note this is for those who have a 5.25" CD/DVD drive and who use the second SATA port.

I don't have a USB CD/DVD drive and I can't try to see if it can have a default icon.

In DefIcons, add a disk under the disk heading, I named it CDO or whatever you want.

In the right part "Actions" I added a Correspondence, as my CD drive is on SATA1, at the bottom in the "Corresponds" box I wrote SATA1: "with the colon"

And in Prefs/env-archive/Sys rename your default icon to def_SATA1 or use an existing CD icon to use it.



I just thought of one thing, I think I wouldn't even need to go to DefIcons, just have a default icon called def_SATA1.

Go to top
Re: Using USB CD Drive with OS4 / X5040
Not too shy to talk
Not too shy to talk


See User information
But the problem isn't really about the icon - it's about the fact that it doesn't see any audio portion of the disk. For example, on H2 disk 2 none of the audio tracks are present. On any audio CD, regardless of whether it's an audio icon or hard disk icon, none of the audio tracks are present.

This is with p50x0sata.device or usbdisk.device. If I use p5020.device (for the internally attached drive), all is well in that regard, there are other problems, but not that.


Amiga x5040 ı 16GB ı RX580
GB-A1000 060@100,
A1200 PiStorm32-Lite CM4
Go to top
Re: Using USB CD Drive with OS4 / X5040
Just popping in
Just popping in


See User information
On the other hand, when I open an audio CD it doesn't display anything in the window but in DiretoryOpus it shows me the tracks.

Go to top
Re: Using USB CD Drive with OS4 / X5040
Quite a regular
Quite a regular


See User information
I have an external DVD drive (ASUS SDRW-08D2S-U with double USB) connected to my X5000/20 and although the audio CD is showing as harddisk icon, audio files are accessible and playable (with Tunenet)

for PlayCD, you have to change the icon tooltype to match your usb disk.
in my case :
DOSDEV=USB0
DEVICE=usbdisk.device
UNIT=0

Go to top
Re: Using USB CD Drive with OS4 / X5040
Not too shy to talk
Not too shy to talk


See User information
@Lio

I'll give that a go when I get time. I hope it's that simple, and if it is, thanks! I'm not convinced it's something I tried yet, not the DOSDEV anyway.


Amiga x5040 ı 16GB ı RX580
GB-A1000 060@100,
A1200 PiStorm32-Lite CM4
Go to top
Re: Using USB CD Drive with OS4 / X5040
Not too shy to talk
Not too shy to talk


See User information
@Lio - bingo, that works, so it just needed the right device and unit specifying. I should have read more carefully as it looks like Maijestro already said this earlier up. Oops!

And also, creating a CD def icon for USB0 also puts the finishing touch on and makes it looks right.

It's a bit picky about not picking up the disk if it was in at boot until after you've ejected it and put it back in again but I think I've read that elsewhere. And it can stick after you've ejected it so I'm guessing some task has not let go of it, but that's minor details I can live with.

Sorted then. I have a drive I can use on the odd occasion I need it.


Amiga x5040 ı 16GB ı RX580
GB-A1000 060@100,
A1200 PiStorm32-Lite CM4
Go to top

  Register To Post
(1) 2 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project