Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
131 user(s) are online (82 user(s) are browsing Forums)

Members: 0
Guests: 131

more...

Support us!

Headlines

 
  Register To Post  

Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Home away from home
Home away from home


See User information
Q over at Hold and Modify on YouTube just posted a Lightwave Raytrace Scene benchmark and I absolutely love this type of stuff so if you're interested please follow the link below to follow the simple steps to run the benchmark and post your results & system specs

Hold and Modify Lightwave3D Benchmark Raytrace Scene!

For those that don't want to watch the whole vid here's the quick setup:

1- File-Load Scene-Benchmarks folder-choose Raytrace scene
2- Camera Panel- set to low resolution- set to square pixels
3- click Render or hit F9

Q's system results:

A3000, Phase5-MKII (060@50), OS3.2.1- 52m24s
A1200, TF1260 (060@50)128MB, OS3.2.1-54m22s
A4000, BFG060 (rev5) 060@50, 128MB, OS3.2.1- 43m46s
A2500, PP&S (040@25), OS3.3.2.1- 2h2m8s


Edited by 328gts on 2023/1/22 23:05:04
Edited by 328gts on 2023/1/24 4:28:08
Edited by 328gts on 2023/1/29 18:43:05
_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Home away from home
Home away from home


See User information
A4000, CS-MKIII, 060@50 (Rev1), OS3.2.1- 47m21

A1200, TF1260, 060@50 (Rev1), OS3.2.1- 51m48


Edited by 328gts on 2023/1/21 5:20:17
Edited by 328gts on 2023/1/21 5:30:36
_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Site Builder
Site Builder


See User information
It's interesting that this happened, because yesterday I run with some friends Lightwave benchmarks on different systems like you mentioned above, but with the benchmark scenes not modified. This way, in my opinion, you can be sure that you have the same testing point everywhere.

I also contacted Kevin to help with these tests, but it seems what he did in that video is not useful for my benchmarking, because he changes the scenes.

Today, I am going to run some more tests and then I can provide the results if you want.

Just to get an idea of where PPC computers like the X5000 stand, some time ago I did a benchmark of the unmodified scenes, which you can see below:




Follow me on
Ko-fi, Twitter, YouTube, Twitch
Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Home away from home
Home away from home


See User information
@walkero

thanks for the vid and too bad we can’t get the render screens working properly under OS4.1

The resolution on the video is very low and can’t make out the shell commands to render…can you please post here how to render from shell


Edited by 328gts on 2023/1/23 15:35:46
_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Just popping in
Just popping in


See User information
With the settings Q provided, my AmigaONE X5000 renders this in 3m 27s.

Current Amiga computers: Vampire V4-SA, Sam460ex, A1-X5000/020
Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Home away from home
Home away from home


See User information
@Cageman

how do we render from shell again? Since FE came out I can’t get render screens to work at all

_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Just popping in
Just popping in


See User information
@328gts

I do not use shell rendering...

Start LW, load benchmark scene and adjust the settings per Q:s instructions.

When you hit F9, you will get a Grim Reaper... just click on more and then click on ignore DSI errors

Once you do that, you will go back to the black screen with some text. Once the render is complete, you will see a very buggy looking image. LMB click and you will be returned to the black screen with text. There you can see the rendertime.

Make sure you do a second F9 render after the first, because I think the DSI error on the very first render might add some extra time.

I will suggest that you use either ModePro or NewMode to promote Layout to a proper screenmode. I use NewMode and promote Layout to a 720x480x8 screen.

Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Home away from home
Home away from home


See User information
@Cageman

Thanks will try it out

_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Home away from home
Home away from home


See User information
@328gts

I think my betterfakemode can display ham6/8. if remember correct, just it might not work all programs.

VistaPro is pritty fast on X1000

(NutsAboutAmiga)

Basilisk II for AmigaOS4
AmigaInputAnywhere
Excalibur
and other tools and apps.
Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Home away from home
Home away from home


See User information
from YouTube thread:

AmigaONE X5000/020-PPC-OS4.1FE- 3m27s

_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Just popping in
Just popping in


See User information
Did anyone compare those new 68k/68kEmu things (PiStorm, Vampire) to a decent PPC setup this way ?

Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Home away from home
Home away from home


See User information
@TheMagicSN

not yet

_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Site Builder
Site Builder


See User information
Hello everyone.
As I mentioned before, I run some benchmarks with Lightwave on different systems, with the Lightwave scenes unchanged.

You can find the results and some findings of my own at
https://ko-fi.com/post/Lightwave-5-ben ... ng-and-findings-Z8Z3I8IOX
and at the
gemini://gem.walkero.gr/ko-fi/Lightwave ... hmarking-and-findings.gmi

Follow me on
Ko-fi, Twitter, YouTube, Twitch
Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Home away from home
Home away from home


See User information
@walkero

thanks

_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Home away from home
Home away from home


See User information
using Shell to render as per walkero:

AmigaONE X1000, PPC, OS4.1FE- 17m10s

as noted below I can't render via LW even with NewMode for some reason it just keeps doing stuff for over an hour ?


@ Cageman

can you try rendering from the shell with this command on your X5000 and post your results ALSO make sure you are using v5 of Lightwave or it won't work

xx:xx/Lwsn.fp -3 scenes/benchmark/Raytrace.lws 0 0 (x is location of your Lightwave folder)


Edited by 328gts on 2023/1/31 2:31:56
_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Just popping in
Just popping in


See User information
@328gts

I am using Lightwave AW (LW5.0 release version), which should be the same version Q uses on his real Amiga computers. Also, rendering via Screamernet is always faster than rendering within the software. For that reason we should follow Q:s steps in order to make a similar comparsion, including rendering from within the software.

Unless Q does a render via ScreamerNet, for this particular test with the settings he provided, I do not see the point in doing so because it would be moving the goalpost.

Also, I wonder if you are quoting the correct scene that Walkero is rendering, since he is rendering all benchmark scenes? From Walkeros video it takes 10m 49s for the Raytracing scene to render in the original setup, which is 2x resolution, 4x more pixles to render compared to Q:s setup.

When I open LW and render the Raytrace scene without any changes, it takes 13m 46s to render on my machine. I very much doubt that the X1000 would render the same scene, even when using ScreamerNet in 1m 39s.

:)

EDIT: The difference from my result and Walkeros result regarding the same scene... him rendering via ScreamerNet and I render within the software is quite understandable, since LW never had any hardware acceleration regarding displaying data on screen while also showing the render progress in a black and white render, so the CPU will have to deal with all the displays when rendering in the software compared to rendering with ScreamerNet in Shell

EDIT2: I think Walkero is using an X5000/ 040, which is clocked at 2,2 GHz while my machine is the 020, clocked at 1995MHz rounded up to 2 GHz.


Edited by Cageman on 2023/1/31 1:04:45
Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Home away from home
Home away from home


See User information
@Cageman

ah yes stupid mistake I didn't use the Raytrace.lws file using it I got 17m10s

I agree to just stick with Q's method to keep things apple to apples but I can't get my X1000 to render inside LW...tried a ton of times and it just goes on for an hour so something is off.


Edited by 328gts on 2023/1/31 2:50:48
_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Just popping in
Just popping in


See User information
fs-uae on mac M2

Emulating A4000 phase 5 060, OS3.2.1 0m 2 seconds.

Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Just popping in
Just popping in


See User information
@Tuvok

That is not emulating an 060 though. You have to turn off JIT in order to emulate the speed.

It is interesting though that your result in FS-UAE on your M2 Mac can render this in 2 seconds. Are you sure you loaded the Raytrace.lws from the Benchmark folder?

On my Threadripper 3990X (64 cores / 128 threads) it takes 45 seconds when using WinUAE emulating a 68060 with JIT enabled. I doubt that an M2 processor is more than 40 times faster, even on a singlethreaded process which emulation of AmigaOS is.

If I open this scene up in LightWave 2020.0.3 (PC version), it renders in 1.9 seconds, but that is because it uses all cores/threads. If I halve the resolution, per Q:s test, it renders in 0.6 seconds. :D

Go to top
Re: Lightwave benchmark for users with PPC, 060, PiStorm, Vampire accelerators
Home away from home
Home away from home


See User information
Amiga 1200, PiStorm32 with Raspberry Pi3a+ (March 10/23 firmware), Amiga OS3.2.2

5m59sec

_______________________________
c64-dual sids, A1000, A1200-060@50, A4000-CSMKIII
Catweasel MK4+= Amazing
! My Master Miggies-Amiga1000 & AmigaONE X1000 !
mancave-ramblings

Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project