Remember me

Lost Password?

Register now!


Who's Online
38 user(s) are online (25 user(s) are browsing Forums)

Members: 0
Guests: 38



  Register To Post

AmiCygnix environment time
Not too shy to talk
Not too shy to talk

See User information

The AmiCygnix environment seems to be within Euro time always. I have not looked into this in detail, but is there a quick way to force AmiCygnix to just use the system time that I have set?

In fact, it seems to not be euro time. When I save a file in jasspa memacs, the save time is one hour behind. Possibly it is GMT without considering day light savings (bst).


If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: AmiCygnix environment time
Quite a regular
Quite a regular

See User information

Did you set the environment variable "Cygnix/TZ" correctly? For Germany it must be set to "Europe/Berlin". See the
directory "Cygnix:CygnixPPC/etc/zoneinfo" for your correct setting.

I must admit, that it is a bit confusing, as the time management in AmiCygnix depends sometimes on Cygnix/TZ and
sometimes on the OS system time. So both settings must be conform! The reason is, that libaos4util does not
implement/replace the full set of functions available in Newlib.

I tried this here on my system and it works:

* Opened the "Locale" settings of OS4 and set country to "United States" and the timezone to UTC - 5.
* Opened the "Time" settings of OS4 and set the time using the time server.
* Set the timezone for AmiCygnix with: "setenv Cygnix/TZ America/New_York"

X-5000 PPC 5020/2 GHZ, Fractal Define XL R2-Tower, OS 4.1 final update 2, 4 GB, Radeon HD 7770, ESI Juli@ XTe
SAM 460ex/1,15 GHZ, OS 4.1 final, 2 GB, Radeon HD 6450
Amiga 4000D/040 25 Mhz, OS 3.9 BB2, 272 MB, X-Surf, 250 MB ZIP
Go to top

  Register To Post


Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )

Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project