Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
43 user(s) are online (24 user(s) are browsing Forums)

Members: 1
Guests: 42

kas1e, more...

Headlines

 
  Register To Post  

AmiCygnix environment time
Not too shy to talk
Not too shy to talk


See User information
@CygnusEd

The AmiCygnix environment seems to be within Euro time always. I have not looked into this in detail, but is there a quick way to force AmiCygnix to just use the system time that I have set?

In fact, it seems to not be euro time. When I save a file in jasspa memacs, the save time is one hour behind. Possibly it is GMT without considering day light savings (bst).

Regards.


Edited by rjd324 on 2022/8/10 23:41:47
Edited by rjd324 on 2022/8/14 14:53:45
If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: AmiCygnix environment time
Quite a regular
Quite a regular


See User information
@rjd324


Did you set the environment variable "Cygnix/TZ" correctly? For Germany it must be set to "Europe/Berlin". See the
directory "Cygnix:CygnixPPC/etc/zoneinfo" for your correct setting.

I must admit, that it is a bit confusing, as the time management in AmiCygnix depends sometimes on Cygnix/TZ and
sometimes on the OS system time. So both settings must be conform! The reason is, that libaos4util does not
implement/replace the full set of functions available in Newlib.

I tried this here on my system and it works:

* Opened the "Locale" settings of OS4 and set country to "United States" and the timezone to UTC - 5.
* Opened the "Time" settings of OS4 and set the time using the time server.
* Set the timezone for AmiCygnix with: "setenv Cygnix/TZ America/New_York"

X-5000 PPC 5020/2 GHZ, Fractal Define XL R2-Tower, OS 4.1 final update 2, 4 GB, Radeon HD 7770, ESI Juli@ XTe
SAM 460ex/1,15 GHZ, OS 4.1 final, 2 GB, Radeon HD 6450
Amiga 4000D/040 25 Mhz, OS 3.9 BB2, 272 MB, X-Surf, 250 MB ZIP
Go to top
Re: AmiCygnix environment time
Not too shy to talk
Not too shy to talk


See User information
@cygnusEd

Ed, thank you. Solved.

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: AmiCygnix environment time
Not too shy to talk
Not too shy to talk


See User information
Well, it is not really solved. The important thing is that when I save a file the time is correct now on the Amiga. Before, it was an hour behind.

cat envarc:cygnix/tz

Shows:
Europe/London


I notice that when I start cygnix in fullscreen (which I rarely do, because I just normally use stand-alone), it believes that it is 5 hours a head of Europe/London time.

Not sure why.

Since my main issue is solved, I am not too bothered. But it is interesting why it believes 5 hours ahead.

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project