Remember me

Lost Password?

Register now!


Who's Online
92 user(s) are online (84 user(s) are browsing Forums)

Members: 0
Guests: 92



  Register To Post  

GrimReaper with AmiCygnix
Just popping in
Just popping in

See User information
Actually, it used to work pretty well for me -- and i mainly use it for remotely starting some
programms like skype. However, I didn't used Amicygnix for several weeks now. Today,
tried to start it again and get the following GR, which cannot be ignored (AOS4 freezes completely):

Crash log for task "Cygnix:CygnixPPC/X11R6.3/bin/Esetroot"
Generated by GrimReaper 53.2
Crash occured in module Esetroot at address 0x6ED5D3CC
Type of crash: DSI (Data Storage Interrupt) exception

Register dump:
GPR (General Purpose Registers):
0: 6EC44FC4 52786950 00000000 80000000 00004B00 000003FF 00000000 00000040
8: 5712D200 00000000 000000C8 5712D154 0000016C 56012E00 00000000 56010000
16: 57128448 56010000 56010000 00000000 52786A20 56010000 00000060 571273A8
24: 00000064 56010000 56010000 56010000 56000000 5712D190 00000010 52786950

FPR (Floating Point Registers, NaN = Not a Number):
0: nan 8.96835e-44 2.8481e-306 7.29113e-304
4: 8.53558e-270 1.87021e-301 6.91771e-312 3.32897e+78
8: 5.38393e-104 6.06641e+206 2.56256e-189 nan
12: 2.122e-314 4.39838e-315 0 0
16: 0 0 0 0
20: -4.57466e-306 0 0 0
24: 0 0 0 0
28: 1.55795e-285 0 0 0

FPSCR (Floating Point Status and Control Register): 0x82000000

SPRs (Special Purpose Registers):
Machine State (msr) : 0x0002F030
Condition (cr) : 0x48422022
Instruction Pointer (ip) : 0x6ED5D3CC
Xtended Exception (xer) : 0x20000008
Count (ctr) : 0x00000003
Link (lr) : 0x6EC44FC4
DSI Status (dsisr) : 0x00000000
Data Address (dar) : 0x00000054

680x0 emulated registers:
DATA: 5FFAB318 00000000 00000000 00000000 00000000 00000000 00000000 00000000
ADDR: 52786F48 55FD1020 00000000 00000000 00000000 00000000 00000000 52786D30
FPU0: 0 0 0 0
FPU4: 0 0 0 0

Symbol info:
Instruction pointer 0x6ED5D3CC belongs to module "Esetroot" (HUNK/Kickstart)

Stack trace:
module Cygnix:CygnixPPC/X11R6.3/bin/Esetroot at 0x6ED5D3CC (section 5 @ 0x1543AC)
module Cygnix:CygnixPPC/X11R6.3/bin/Esetroot at 0x6EC44FC4 (section 5 @ 0x3BFA4)
module Cygnix:CygnixPPC/X11R6.3/bin/Esetroot at 0x6EC2F640 (section 5 @ 0x26620)
module Cygnix:CygnixPPC/X11R6.3/bin/Esetroot at 0x6EC1D084 (section 5 @ 0x14064)
module Cygnix:CygnixPPC/X11R6.3/bin/Esetroot at 0x6EC0CDC0 (section 5 @ 0x3DA0)
module Cygnix:CygnixPPC/X11R6.3/bin/Esetroot at 0x6EC09B00 (section 5 @ 0xAE0)
native kernel module newlib.library.kmod+0x00001f4c
native kernel module newlib.library.kmod+0x00002b98
native kernel module newlib.library.kmod+0x00002d5c
_start()+0x1A4 (section 1 @ 0x1a4)
native kernel module dos.library.kmod+0x0001b524
native kernel module kernel+0x00036290
native kernel module kernel+0x00036310

I can provide the full GR log if of any help.
But maybe someone can already tell me what's wrong?

Thanks a lot,

Edit: System: Sam440ep, AOS 4.1.2

Go to top
Re: GrimReaper with AmiCygnix
Quite a regular
Quite a regular

See User information

please check, if the libraries "sysvipc.library" and "threads.library" are still in LIBS:. The libraries are included in the base archive (directory "install-data/libs").

Go to top
Re: GrimReaper with AmiCygnix
Just popping in
Just popping in

See User information

Actually, yes, they are still in the libs dir.
However, for some reasons, there was no assign anymore to that directory.
Now it works again.

Thanks, although, I don't know what has changed in the last week


Go to top
Re: GrimReaper with AmiCygnix
Not too shy to talk
Not too shy to talk

See User information

I had problems after update2, just needed to re-install it from my backup. Never did figure out what changed.

Go to top

  Register To Post


Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )

Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project