Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
40 user(s) are online (27 user(s) are browsing Forums)

Members: 3
Guests: 37

kas1e, VooDoo, SinanSam460, more...

Headlines

 
  Register To Post

OS4.1(.1) and WiFi
Just popping in
Just popping in


See User information
Hi,

I bought a PCI WiFi card from AmigaKit which I have installed in my SAM-flex. The card uses the prism2.device driver. Now, the card itself works fine (too bad there's no WPA encryption support in the driver), but I noticed that when the net interface is running (as long as the machine is switched on, really ) if i try to do a soft reset, the USB will freeze and I have to do a hard reset to get it back up. I had the problem on OS4.1, but I thought it would go away on update 1. It didn't so now I am posting here.

Also, there is a "wifi manager" that is supposed to go in WbStartup folder and will bring up a status icon on AmiDock, with the current signal strength. I can launch this from workbench now and it will appear in AmiDock, but if I set in the WbStartup prefs that it should be launched at startup, it gets started, but it does not appear on AmiDock (which kind of renders it useless). This worked before Update 1, when the WbStartup folder still existed.

Has anyone else had these issues? And are they solvable (esp. the soft reset issue)?

Go to top
Re: OS4.1(.1) and WiFi
Quite a regular
Quite a regular


See User information
@RuDeE

I'm in contact via email with the authors of both the driver and wifisignal utility.

I'll direct them to this post too. FYI I have the exact same issues. You can use the older version of the driver (and setprism2defaults utility too) that AmigaKit give you, and it will allow you to hard-reboot with lamiga+alt+alt, but a soft reboot still freezes the system.

Go to top
Re: OS4.1(.1) and WiFi
Just popping in
Just popping in


See User information
@MickJT

Allright, thanks! Let's hope these issues gets resolved then. For now I can live with it.

Go to top
Re: OS4.1(.1) and WiFi
Amigans Defender
Amigans Defender


See User information
@RuDeE

The WifiSignal docky is an AmiDock problem. It could be worked around easily within WifiSignal (with a Delay() based on a tooltype), or you can create a script, make it a project of IconX and stick that in WBStartUp Prefs instead:
wait 2 secs
wbrun wifisignal

Go to top
Re: OS4.1(.1) and WiFi
Just popping in
Just popping in


See User information
@RuDeE

Ive added a delay as suggested by Chris below to my WifiSignal prog.

You can download and test from:

www.curtyh.talktalk.net/wifisignal

A1XE G4 800mhz,512mb,Radeon9200,SonyDRU-510A and 800a, Esi Juli@,Sil680,WiFi.
Go to top
Re: OS4.1(.1) and WiFi
Just popping in
Just popping in


See User information
@MickJT

In regard to the no transparency in 16 bit with compostion on,
i can recreate her and have reported this to an OS4 developer.

A1XE G4 800mhz,512mb,Radeon9200,SonyDRU-510A and 800a, Esi Juli@,Sil680,WiFi.
Go to top
Re: OS4.1(.1) and WiFi
Quite a regular
Quite a regular


See User information
@RuDeE

I now have a prism2.device I compiled that works fine. If anyone else is interested, let me know.

Go to top
Re: OS4.1(.1) and WiFi
Just popping in
Just popping in


See User information
@MickJT

How about uploading it to OS4Depot?

Go to top
Re: OS4.1(.1) and WiFi
Quite a regular
Quite a regular


See User information
@HammerD

I'll see if I can get the go ahead from Neil Cafferkey.

Go to top
Re: OS4.1(.1) and WiFi
Just popping in
Just popping in


See User information
Quote:

Chris wrote:
project of IconX


Why do people use IconX?

Since like forever you can change icon type to "Tool", set the S-flag and set it to start from shell.

-- kolla
Go to top
Re: OS4.1(.1) and WiFi
Just popping in
Just popping in


See User information
@Curty

Thanks! I'll try it out

@MickJT

Cool, thanks

Go to top
Re: OS4.1(.1) and WiFi
Amigans Defender
Amigans Defender


See User information
@kolla

Apparently that's not (supposed to be) supported by WBStartUp. *shrug*

Go to top
Re: OS4.1(.1) and WiFi
Quite a regular
Quite a regular


See User information
I have permission now to upload it to OS4Depot (not that I needed permission, but..). Expect it there in a few hours. Gotta go out right now, will upload later.


Edited by MickJT on 2010/1/28 7:43:35
Go to top
Re: OS4.1(.1) and WiFi
Just popping in
Just popping in


See User information
@MickJT

Cool that's great :)

Go to top
Re: OS4.1(.1) and WiFi
Amigans Defender
Amigans Defender


See User information
@Curty

That link doesn't work.

Go to top
Re: OS4.1(.1) and WiFi
Quite a regular
Quite a regular


See User information

Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project