Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
30 user(s) are online (4 user(s) are browsing Forums)

Members: 0
Guests: 30

more...

Support us!

Headlines

 
  Register To Post  

Bug RNOXfer
Just popping in
Just popping in


See User information
Hi all,

I noticed a problem on the new version of RNOXfer (1.3). I was unable to report this issue to os4depot. My comment was not registered. So I try to communicate on the forum.

The problem is a regression, because version 1.2 did not have this behaviour. Accented characters are no longer tolerated (éèçà etc).

If the author of RNOXfer (jPV) sees my comment here...

AmigaOne X5000 2Ghz / 8Gb Ram - SSD 2x4Tb - Radeon RX 560 4Gb - AmigaOS4.1 FE
Amiga 1200 2Mb Chip - PiStorm32 lite - CF 128Gb - Scandoubler Indivision MK3 - GOEX Drive - WiFi 802.11b - WB 3.2.2.1 - Star LC10 Printer
Go to top
Re: Bug RNOXfer
Just popping in
Just popping in


See User information
A small addition to my bug report:

I just noticed that the accent problem was already present in version 1.2. It was declared only in the remote window and not in the local window. In version 1.3, the problem is reversed: the local window no longer accepts accented characters, the remote window works well.

AmigaOne X5000 2Ghz / 8Gb Ram - SSD 2x4Tb - Radeon RX 560 4Gb - AmigaOS4.1 FE
Amiga 1200 2Mb Chip - PiStorm32 lite - CF 128Gb - Scandoubler Indivision MK3 - GOEX Drive - WiFi 802.11b - WB 3.2.2.1 - Star LC10 Printer
Go to top
Re: Bug RNOXfer
Just popping in
Just popping in


See User information
Hmm.. I don't remember I've changed anything related in the code, on purpose at least, but I'll try to check it... thanks for the report anyway.

Go to top
Re: Bug RNOXfer
Just popping in
Just popping in


See User information
Maybe this works better, or at least more consistent now. I think there was some bug in Hollywood and plugin locations that could affect to this, which has been fixed.

I have also changed charset handling for the new version now. Earlier versions didn't support UTF-8 in filenames, but handled non-English characters in ISO/Amiga charsets, which basically is against FTP specifications, but old Amiga FTP clients did that too and some servers didn't care. I've now made the program to work according the specs and non-English characters are allowed only in UTF-8 if a server supports it.

Here's a change log for the new version I just released:

Version 1.4:
- Added editing fields in the server list window
- Added the comment column on the server list
- Added the default local path setting
- Added the private keyfile setting for SFTP connections
- Added a check for server list changes at exit
- Added UTF-8 support to be RFC 2640 compliant
- Massive speedup in directory handling
- More verbose file size comparison when a file exists
- Added an option to save selected files/dirs as a text file
- Fixed advanced.conf handling
- Fixed issues with the settings file format
- Adjusted window sleep modes
- Disconnects from the previous server when double-clicking a new server from the server list
- Uses hURL 2.0 (requires AmiSSL 5 on AmigaOS)

Go to top
Re: Bug RNOXfer
Just popping in
Just popping in


See User information
Hey jPV,

Thank you for the correction. It actually modifies the display of characters. The problem no longer arises.

RNOXfer is an excellent software that I use almost daily. Well done !

AmigaOne X5000 2Ghz / 8Gb Ram - SSD 2x4Tb - Radeon RX 560 4Gb - AmigaOS4.1 FE
Amiga 1200 2Mb Chip - PiStorm32 lite - CF 128Gb - Scandoubler Indivision MK3 - GOEX Drive - WiFi 802.11b - WB 3.2.2.1 - Star LC10 Printer
Go to top
Re: Bug RNOXfer
Just popping in
Just popping in


See User information
Good to hear, thanks for reporting!

Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project