Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
63 user(s) are online (25 user(s) are browsing Forums)

Members: 0
Guests: 63

more...

Headlines

 
  Register To Post  

Radeon 7950 HD Help [SOLVED]
Quite a regular
Quite a regular


See User information
Hey all,

Can someone please tell me what power cable I need for the video card?

PSU:
https://i.postimg.cc/xjhQG999/20220216-131336.jpg

Card:
https://www.guru3d.com/miraserver/images/2012/7950-cfx/IMG_5711.jpg

I am confused by all the cables that I search for on eBay. So a link to an actual one would be great.


Edited by rjd324 on 2022/2/22 18:53:18
Edited by rjd324 on 2022/2/26 18:47:34
Reason: Solved.
Go to top
Re: Radeon 7950 HD Power Cable Help
Not too shy to talk
Not too shy to talk


See User information
your psu should have come with 2 pci-e cables - the 2 8-pin connectors on the top left of the psu picture. use those as you should be able to unclip 2 pins to make it a 6-pin connector that you need.

Go to top
Re: Radeon 7950 HD Power Cable Help
Quite a regular
Quite a regular


See User information
I bought the X1000 from a previous owner and I don't have one of those cables. But, with your info I think I can just buy an 8pin to two 8(6+2) cable.

https://www.ebay.co.uk/itm/PSU-8Pin-to ... 6&mkrid=710-127635-2958-0

They all have to be male too. Please correct if I am wrong.

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: Radeon 7950 HD Power Cable Help
Quite a regular
Quite a regular


See User information
Actually, the PSU end of that cable would not fit into my PSU red ports.

OMG, I am confused.

At the point I might just get some good AWG copper wire and just hack a solder job!

If liberty means anything at all, it means the right to tell people what they do not want to hear.
George Orwell.
Go to top
Re: Radeon 7950 HD Power Cable Help
Quite a regular
Quite a regular


See User information
Okay, well I think I have bought an appropriate cable. It looks like the correct "fit".

I cannot believe that PSU vendors have their own proprietary cables. I would have expected a single standard.

Nevertheless...

Go to top
Re: Radeon 7950 HD Power Cable Help
Home away from home
Home away from home


See User information
@rjd324

I've got the same board and my PSU already had the connector for it...I suppose older PSU's wouldn't have the connector as standard?

Go to top
Re: Radeon 7950 HD Help
Quite a regular
Quite a regular


See User information
Okay. So I got the appropriate cable. I now have the HD 7950 installed. I simply exchanged it with the original 4650 and I can boot into Workbench but after 5 or so seconds it freezes. I then tried to use the first contact CD and it never boots which is exactly the same the thing that happened with the 250X I had. Difference is, I though the 7950 was supported.

Am I some software here ? I would have expected First Contact to boot with a compatible card...?

Go to top
Re: Radeon 7950 HD Help
Quite a regular
Quite a regular


See User information
As an update. For whatever reason, when I put my First Contact Cd in the drive, and ask it to boot into my hard drive partition, it boots into first contact and I can actually move around the screen and sort files out. Why it does not boot directly from Cd I do not know.

But, when I had my 4650 installed, the only thing I copied over to my hard drive in kickstarts was RadeonHD.chip which is version 3.7.

Do I need to copy anything else over for the 7950?

Go to top
Re: Radeon 7950 HD Help
Quite a regular
Quite a regular


See User information
Woah,

Now I am just baffled. I copied over the original First Contact RadeonHD.chip to my workbench:kickstart, I deleted my devs/monitors/Radeon V730.

And yet, when I put the original 4650 back in, I boot into WB with the full 1920 resolution screenmode which I thought was impossible with the First Contact RadeonHD.chip.

I am literally running my full resolution and, yet:
version radeonhd.chip

says:
RadeonHD.chip 0.32


I am in serious need of some education here.

Sorry for the repeated posts, I just really want the capabilities of the WARP stuff etc, I have now spent over 100£ on failed video card upgrades.

Anyway, I will now wait patiently for some professional help.

===
EDIT: Regarding the power cable. It is a single cable split into two 6 pins that go into the radeon 7950 (I am now using my original 4650 for now though). I doubt that the power is the issue. Surely, our Amiga systems will not draw enough current for a single split cable to be the issue).

Go to top
Re: Radeon 7950 HD Help
Home away from home
Home away from home


See User information
@rjd324

hmm pretty sure that's the only file you need but let me check when I'm back in front of my X1000 to confirm

Go to top
Re: Radeon 7950 HD Help
Just can't stay away
Just can't stay away


See User information
@rjd324:

I'm pretty sure the limited version of RadeonHD.chip found on e.g. OS4.1 FE was 0.68 or thereabouts. So your 0.32 is probably an unrestricted version, but older, so only the cards known back then work (e.g. your HD 4650), but then, *if* they work, they do so in full resolution.

Best regards,

Niels

Go to top
Re: Radeon 7950 HD Help
Quite a regular
Quite a regular


See User information
Thanks. Even though the 0.32 version seems to be handling video playback just as good as the 3.7 version.

So, here are my steps:

- Copy over the RadeonHD.chip 3.7 to Workbench:Kickstart
- Pull out the 4K card after removing the DVI connection
- Replace it with the 7950 and plug the DVI connection back in
- Plug in the cable that goes from the PSU (8 pin) and plug the 2 split 6 pins into the 7950
- Start the Amiga X1000
- Notice that, after getting to the Workbench it freezes after about 5 seconds

Why am I having such bad luck with this?

Here is what I think is a relevant section of my Kicklayout:
;
MODULE Kickstart/pasemi_dma.resource.kmod
MODULE Kickstart
/graphics.library.kmod
MODULE Kickstart
/PCIGraphics.card
MODULE Kickstart
/RadeonHD.chip
MODULE Kickstart
/ATIRadeon.chip
MODULE Kickstart
/3DLabsPermedia2.chip
MODULE Kickstart
/3dfxVoodoo.chip
MODULE Kickstart
/petunia.library.kmod
;


Unless someone tells me otherwise, I just do not think it is a power issue. I do not think the Amiga system will have the 7950 draw that much current. It is not like I am using the 7950 in a system that it was originally designed for which includes intensive gaming. I am just on the startup WB screen and then it freezes. I can test the 7950 in my X86 machine I suppose, but at the minute I am suspecting some bad software and a fault of my own.

Go to top
Re: Radeon 7950 HD Help
Home away from home
Home away from home


See User information
@rjd324

so with my RadeonHD7950 I'm using RadeonHD.chip V3.7, Warp3D v53.27/ Nova v1.85, MinigGLv2.24, Ogles2 V3.1

Running OS4.1FE-Update 2, kickstart:54.30, Workbench:53.62

my kicklayout:

MODULE Kickstart/pasemi_dma.resource.kmod
MODULE Kickstart/graphics.library.kmod
MODULE Kickstart/PCIGraphics.card
MODULE Kickstart/RadeonHD.chip
MODULE Kickstart/ATIRadeon.chip
MODULE Kickstart/3DLabsPermedia2.chip
MODULE Kickstart/3dfxVoodoo.chip
MODULE Kickstart/petunia.library.kmod

Looks like your files are ok...I'd check to see if the card works in a PC with no issues...also maybe that verison of the card doesn't play nice with Update 2?? what make/model number is your card?

Go to top
Re: Radeon 7950 HD Help
Quite a regular
Quite a regular


See User information
@328gts

Appreciate the help. What I will do today is this:

Check that the 7950 does work in my Windows x86 machine and attempt to check its authenticity and,

if that is successful I will post the information and perhaps some pictures here, and,

I will insert a blank HDD into my Amiga, install the 7950 and start to install Amiga OS 4.1 FE from scratch just to see what happens.

Go to top
Re: Radeon 7950 HD Help
Just popping in
Just popping in


See User information
Hi,

Huge cards end near and touch the sata cables sometimes.

Regards,

Go to top
Re: Radeon 7950 HD Help [SOLVED]
Quite a regular
Quite a regular


See User information
Today I had some time. Since I was running a mechanical SATA drive and wanted to start from fresh with a Samsung SSD 860.

Firstly, the issues with FirstContact crashing were my own fault. I needed to re-educate myself about the CFE booting process. What was happening was that I was using the later version of the firmware (amigaboot.of) and then booting into the FirstContact CD. This is bad, because the latest firmware combined with FC will result in a crash. I reconfigured all my CFE so that it was nice and clean.

I did notice that the 7950 would always work with the FC and Amiga OS 4.1FE CDs so I was thinking it was possibly a software conflict.

So, I started from the beginning and used the 7950 HD throughout and installed a new system on the SSD. I updated to Update 2 + HotFix, I installed the enhancer packs (core and enhancer 2). Everything working. I then made a backup of my mechanical drive.

The only difference this time was that I decided to move the video card to the TOP PCI-E x16 slot rather than the bottom one.

I thought it may be LimpidClock that was causing the issue, but I am writing this post on my original mechanical drive since I wanted to test that out.

I guess that - afterall - it must be the fact that I am using the top PCI-E x16 slot that has solved the issue!

I guess I now need to get the WARP 3D software package from the AmiStore?

Go to top
Re: Radeon 7950 HD Help [SOLVED]
Home away from home
Home away from home


See User information
@rjd324
Quote:

I guess I now need to get the WARP 3D software package from the AmiStore?


You will need for RadeonHD that:

1. Latest RadeonHD driver (3.7 if i remember the last one for the public).

2. Warp3D SI (for have support for classic Warp3D/minigl games/apps).

3. Warp3DNova (for all modern enough stuff).

4. ogles2.library (this one often used by games of late)

Before spending any money, you need to be sure that you got exactly those components, as there was a mess back in past with all those enhancers lite/middle/full/v1/v2/etc/etc.

Go to top
Re: Radeon 7950 HD Help [SOLVED]
Quite a regular
Quite a regular


See User information
Okay, so I have the radeonhd that came with enhancer v2. I have 3.7.

I must now buy the Warp3d driver from the store, right?

Does Warp3d SI and Warp3dNova come with that Warp3d amistore package?

Presumably, the ogles2.library I get from the Os4depot and bung it in libs:

Ty.

Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project