Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
54 user(s) are online (32 user(s) are browsing Forums)

Members: 2
Guests: 52

Rigo, eliyahu, more...

Headlines

 
  Register To Post  

(1) 2 »
AOS4 graphics update is slower now
Quite a regular
Quite a regular


See User information
I wonder if this happens only here.
After the update, as soon as I moved a window for the first time, I noticed a major slowdown. I hoped it was just an impression, but then I had to accept that it was not so: window moving and resizing *are* less smooth. The perception of the slowdown is strong.
For a more objective test, I used a proggie I've created in 2004 which performs various graphical operations: a particular test dropped from ~316 fps to ~260 fps.

I have a RADEON 9000 card, with the following monitor settings:
BOARDTYPE=Radeon
CMPLENGTH
=6
(CHIPTYPE=ATIRadeon.chip)
(
BORDERBLANK=Yes)
(
BIGSPRITE=Yes)
SOFTSPRITE=No
IGNOREMASK
=Yes
(DISPLAYCHAIN=Yes)
FAKENATIVEMODES=No
INTERRUPT
=Yes
VSYNCMIN
=60
VSYNCMAX
=85
HSYNCMIN
=31500
HSYNCMAX
=64000
SETTINGSFILE
=ENVARC:Sys/P96.prefs

(setting INTERRUPT=No makes things a little slower)

The update causes no other problem whatsoever (apart from some compatibility issue with Personal Paint which I still have to investigate further).

Any idea anybody?

saimo

Go to top
Re: AOS4 graphics update is slower now
Not too shy to talk
Not too shy to talk


See User information
Maybe the "Avoid flicker"-Switch in the GUI prefs?

Go to top
Re: AOS4 graphics update is slower now
Quite a regular
Quite a regular


See User information
@ZeroG

Quote:
Maybe the "Avoid flicker"-Switch in the GUI prefs?

Unfortunately, it is not a matter of flickering.

edit: I did not change any setting: everything is like before.

saimo

Go to top
Re: AOS4 graphics update is slower now
Just can't stay away
Just can't stay away


See User information
oh no!
I use PPaint every day!
I get a requester saying 'Attention Memory Save Mode'
when i start it now. :/

And yes, window moving is slower here too.

Go to top
Re: AOS4 graphics update is slower now
Just can't stay away
Just can't stay away


See User information
try using the new mode tooltypes instead of the old p96 steeings file

Quote:


I have a RADEON 9000 card, with the following monitor settings:
BOARDTYPE=Radeon
CMPLENGTH
=6
(CHIPTYPE=ATIRadeon.chip)
(
BORDERBLANK=Yes)
(
BIGSPRITE=Yes)
SOFTSPRITE=No
IGNOREMASK
=Yes
(DISPLAYCHAIN=Yes)
FAKENATIVEMODES=No
INTERRUPT
=Yes
VSYNCMIN
=60
VSYNCMAX
=85
HSYNCMIN
=31500
HSYNCMAX
=64000
SETTINGSFILE
=ENVARC:Sys/P96.prefs


atm your mixing BOTH systems together:

VSYNCMIN=60
VSYNCMAX=85
HSYNCMIN=31500
HSYNCMAX=64000

are the new system

SETTINGSFILE=ENVARC:Sys/P96.prefs

is the old system

Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
Go to top
Re: AOS4 graphics update is slower now
Quite a regular
Quite a regular


See User information
I just checked the Gears demo with the updated current beta system and OS4 Final and I also found the new release slower (116 fps instead of 132). However, I tracked down the cause:

With no "640x480" mode in my Radeon tooltypes and no "Picasso96Settings" file in Devs:, Gears was opening an 800x600 screen and running more slowly in that.

When I added a "640x480@70" mode in the Radeon tooltypes, Gears ran at its old speed again.

I don't think this is Saimo's problem on his WB, but it might be for other apps.

Go to top
Re: AOS4 graphics update is slower now
Quite a regular
Quite a regular


See User information
@spotUP

Quote:

oh no!
I use PPaint every day!
I get a requester saying 'Attention Memory Save Mode'
when i start it now. :/

I use PP a lot as well and that's really annoying indeed.
I tried fiddling with the settings, but no matter what I do, it will insist on trying to close the WB and go in memory save mode. My guess is that it cannot handle the big numbers returned now for the CHIP memory because of the new (and great ) "unified" memory model.
BTW: if you push the settings too much, it will eventually refuse to run complaining about missing blit libraries - the only way to roll back is editing by hand the prefs files or replacing them with working ones.

Quote:
And yes, window moving is slower here too.

I'm happy it's not just a problem with my setup (you know, I installed everything by hand after mounting the ISO image), but definitely unhappy with the slowdown
I'd like to point out that IMHO it's not just a matter of window moving, but, a general issue with blitting (f.ex., even SDL blits are slower now).

saimo

Go to top
Re: AOS4 graphics update is slower now
Quite a regular
Quite a regular


See User information
@Severin

Quote:
try using the new mode tooltypes instead of the old p96 steeings file

Quote:

I have a RADEON 9000 card, with the following monitor settings:
BOARDTYPE=Radeon
CMPLENGTH=6
(CHIPTYPE=ATIRadeon.chip)
(BORDERBLANK=Yes)
(BIGSPRITE=Yes)
SOFTSPRITE=No
IGNOREMASK=Yes
(DISPLAYCHAIN=Yes)
FAKENATIVEMODES=No
INTERRUPT=Yes
VSYNCMIN=60
VSYNCMAX=85
HSYNCMIN=31500
HSYNCMAX=64000
SETTINGSFILE=ENVARC:Sys/P96.prefs


atm your mixing BOTH systems together:

VSYNCMIN=60
VSYNCMAX=85
HSYNCMIN=31500
HSYNCMAX=64000

are the new system

SETTINGSFILE=ENVARC:Sys/P96.prefs

is the old system

I know that I'm mixing the two things, but since I'm not defining any mode with the new method, the mix should not have side effect - in fact, if I remove the sync parameters from the tooltypes, nothing changes.
I'm not keen on using the new method as it gives less freedom for fine-tuning and, anyway, I don't think it would change a thing given that the Picasso layer would still be there doing its job.

saimo

Go to top
Re: AOS4 graphics update is slower now
Just can't stay away
Just can't stay away


See User information
Quote:

saimo wrote:
@spotUP

Quote:

oh no!
I use PPaint every day!
I get a requester saying 'Attention Memory Save Mode'
when i start it now. :/

I use PP a lot as well and that's really annoying indeed.
I tried fiddling with the settings, but no matter what I do, it will insist on trying to close the WB and go in memory save mode. My guess is that it cannot handle the big numbers returned now for the CHIP memory because of the new (and great ) "unified" memory model.
BTW: if you push the settings too much, it will eventually refuse to run complaining about missing blit libraries - the only way to roll back is editing by hand the prefs files or replacing them with working ones.
saimo


Edit your startup-sequence, add "ADDCHIPRAM=2" to setpatch to add 2 mb of emulated chipram and get ppaint working.

Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
Go to top
Re: AOS4 graphics update is slower now
Quite a regular
Quite a regular


See User information
@Severin

Quote:
Edit your startup-sequence, add "ADDCHIPRAM=2" to setpatch to add 2 mb of emulated chipram and get ppaint working.

Thanks for the hint (I had just tried it after reading what you said in the "Report your 'AmigaOS 4.0 Final' bugs here!" thread).
It works, but unfortunately that amount of CHIP RAM gets pre-allocated, so it is basically wasted. I'll do without, as I can live with PP trying to close the WB

saimo

Go to top
Re: AOS4 graphics update is slower now
Just popping in
Just popping in


See User information
I notice a 2D graphic slowdown too.
I try to play with parameter in gui prefs.

AmigaOne XE G3 750FX 800Mhz/2 GB Ram + Radeon 9000PRO 128MB +AmigaOS4.1
A4000T CyberstormPPC 604e-200Mhz/060/128MB+CybervisionPPC 8MB +AmigaOS4
and anymore other Amigas...
Go to top
Re: AOS4 graphics update is slower now
Quite a regular
Quite a regular


See User information
I dont understand whats going on here...

I watched a betatester show us a comparison against a stock A1-XE, G4 and the new system totally blew away the upd 4 system.

Using PPaint he then demonstrated the speedup by rendering graphics changes almost 3 times faster.

So what has changed or in what way are these peoples systems different ?

Are we nearly there yet ?
Go to top
Re: AOS4 graphics update is slower now
Quite a regular
Quite a regular


See User information
I wonder if it is caused by a change in GUI preferences?

Go to top
Re: AOS4 graphics update is slower now
Quite a regular
Quite a regular


See User information
I think the usergroups are going to be busy this meeting !!

Are we nearly there yet ?
Go to top
Re: AOS4 graphics update is slower now
Amigans Defender
Amigans Defender


See User information
@Outcast
i just run ppaint without trouble no adding anything to startup etc and speed is fantastic compared too update 4

Amiga is the heart and soul of computing nothing else comes close
Go to top
Re: AOS4 graphics update is slower now
Quite a regular
Quite a regular


See User information
but are window movements slower ?

Are we nearly there yet ?
Go to top
Re: AOS4 graphics update is slower now
Just popping in
Just popping in


See User information
I too noticed thta moving windows is slower. I just ignored it though, thinking it was just me seeing it differently. Now I've bumped into this thread, I thought I'd join in although I've not had chance to play with my Amiga since I installed the Final Update.

FuZion.

Go to top
Re: AOS4 graphics update is slower now
Amigans Defender
Amigans Defender


See User information
@Outcast
window movement better here with update

Amiga is the heart and soul of computing nothing else comes close
Go to top
Re: AOS4 graphics update is slower now
Just can't stay away
Just can't stay away


See User information
A slowdown also here in my micro.. it' s not a saimo problem..

Go to top
Re: AOS4 graphics update is slower now
Not too shy to talk
Not too shy to talk


See User information
Have you tweaked tooltypes of your monitor?

Go to top

  Register To Post
(1) 2 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project