Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
42 user(s) are online (26 user(s) are browsing Forums)

Members: 0
Guests: 42

more...

Headlines

 
  Register To Post  

« 1 (2)
Re: MUIOWB fonts
Not too shy to talk
Not too shy to talk


See User information
@nbache

From a previous question:

Quote:
On a related note, can somebody remind which file I need to delete to stop MUI-OWB scanning fonts every time it starts up?


Your answer to delete the long file name I remembered and it doesn't work for me now but did previously?

I had to re-install MUIOWB and had the scanning fonts issue and remembered to delete the long file name in MUIOWB/Conf/font/long name -ppc-amigaos.cache-2 but this time round doesn't work for me, it still keeps loading fonts at start-up!

SAM 460 with 2GB or RAM, 1000GB HD, 4 port SATA, DVDRW drive and Radeon HD 4650 GFX card.
Go to top
Re: MUIOWB fonts
Home away from home
Home away from home


See User information
@sicky

Could you please post the first 40 lines of MUIOWB/Conf/font/fonts.conf?

People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Go to top
Re: MUIOWB fonts
Not too shy to talk
Not too shy to talk


See User information
@Raziel

Quote:
Could you please post the first 40 lines of MUIOWB/Conf/font/fonts.conf?


<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/fonts.conf file to configure system font access -->
<fontconfig>

<!--
DO NOT EDIT THIS FILE.
IT WILL BE REPLACED WHEN FONTCONFIG IS UPDATED.
LOCAL CHANGES BELONG IN 'local.conf'.

The intent of this standard configuration file is to be adequate for
most environments. If you have a reasonably normal environment and
have found problems with this configuration, they are probably
things that others will also want fixed. Please submit any
problems to the fontconfig bugzilla system located at fontconfig.org

Note that the normal 'make install' procedure for fontconfig is to
replace any existing fonts.conf file with the new version. Place
any local customizations in local.conf which this file references.

Keith Packard
-->

<!-- Font directory list -->

<dir>fonts:_TrueType</dir>
<dir>fonts:_ttf</dir>

<!-- Font cache directory list -->

<cachedir>PROGDIR:conf/font</cachedir>

<!--
Accept deprecated 'mono' alias, replacing it with 'monospace'
-->
<match target="pattern">
<test qual="any" name="family">
<string>mono</string>
</test>
<edit name="family" mode="assign">
<string>monospace</string>
</edit>
</match>

<!--
Accept alternate 'sans serif' spelling, replacing it with 'sans-serif'
-->
<match target="pattern">
<test qual="any" name="family">
<string>sans serif</string>
</test>
<edit name="family" mode="assign">
<string>sans-serif</string>
</edit>
</match>

<!--
Accept deprecated 'sans' alias, replacing it with 'sans-serif'
-->
<match target="pattern">
<test qual="any" name="family">
<string>sans</string>
</test>
<edit name="family" mode="assign">
<string>sans-serif</string>
</edit>
</match>

<!--
Load local system customization file
-->
<include ignore_missing="yes">conf.d</include>

<config>
<!--
These are the default Unicode chars that are expected to be blank
in fonts. All other blank chars are assumed to be broken and
won't appear in the resulting charsets
-->

SAM 460 with 2GB or RAM, 1000GB HD, 4 port SATA, DVDRW drive and Radeon HD 4650 GFX card.
Go to top
Re: MUIOWB fonts
Home away from home
Home away from home


See User information
@sicky

OK, thanks, seems allright

Which version of MUIOWB are you using?

I have 1.9 (06.08.2010)

EDIT: You might have tried this already, but please redo the following steps

1) Delete *-ppc-amigaos-cache-2 in MUIOWB/Conf/font/
2) Reboot your miggy
3) Start MUIOWB and let the font search run through
4) Close MUIOWB
5) Reboot your miggy once again
6) Start MUIOWB

If the behaviour of MUIOWB searching for fonts still persists there might be something wrong with your OWB install and i can only tell you to reinstall and hope for the best :-/

People are dying.
Entire ecosystems are collapsing.
We are in the beginning of a mass extinction.
And all you can talk about is money and fairytales of eternal economic growth.
How dare you!
– Greta Thunberg
Go to top
Re: MUIOWB fonts
Quite a regular
Quite a regular


See User information
There is only one version of MUI-OWB currently for AmigaOS 4.1, and that's v1.9.

Although does it has to do with the codesets.library? Check your codesets directory in LIBS:. Just a thought.

To Be A True Adventurer, You Ought To Play Real Text Adventures
Go to top
Re: MUIOWB fonts
Not too shy to talk
Not too shy to talk


See User information
@Raziel

Quote:
OK, thanks, seems allright

Which version of MUIOWB are you using?

I have 1.9 (06.08.2010)

EDIT: You might have tried this already, but please redo the following steps

1) Delete *-ppc-amigaos-cache-2 in MUIOWB/Conf/font/
2) Reboot your miggy
3) Start MUIOWB and let the font search run through
4) Close MUIOWB
5) Reboot your miggy once again
6) Start MUIOWB

If the behaviour of MUIOWB searching for fonts still persists there might be something wrong with your OWB install and i can only tell you to reinstall and hope for the best :-/


Yippee that worked at last I didn't need to do the re-boots between before but it has sorted the problem, thank you very much

SAM 460 with 2GB or RAM, 1000GB HD, 4 port SATA, DVDRW drive and Radeon HD 4650 GFX card.
Go to top
Re: MUIOWB fonts
Just can't stay away
Just can't stay away


See User information
Quote:
Paul wrote:
Quote:
nbache wrote:
What does a "GetEnv Charset" in a Shell say?
ISO-8859-1is all that comes back in the shell.
And that is also your charset setting in MUIOWB? (Settings->Preferences->Fonts->Text Encoding.)

I'm puzzled ...

It's got to have something to do with the charset, though.

But maybe related to a specific font. Do you know whether it always happens with a specific font? If so, which one?

Best regards,

Niels

(Edit: Hadn't noticed the pageful of OT - in relation to Paul's problem - posts, so thought I could do without quoting.)

Go to top
Re: MUIOWB fonts
Amigans Defender
Amigans Defender


See User information
Go here: http://www.xhaus.com/headers

Look for "Accept-Language" and check it doesn't contain "el".

My OWB-MUI isn't sending an Accept-Language header but yours might be for some reason.

edit I typed "gr" originally, but looks like "el" is the correct code for Greek. I've added both to my NetSurf config and everything is still coming up in English on those two pages, so I don't think it's that anyway.


Edited by Chris on 2012/11/1 0:16:52
Edited by Chris on 2012/11/1 0:19:40
Go to top
Re: MUIOWB fonts
Quite a regular
Quite a regular


See User information
@Niels,

Yes, it's also 8859-1 in the MUIOWB prefs, too.

As to whether it's a specific font, how do I check? "View" > "Show source code" in the OWB menu? and then look at the offending page?

Paul

Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
Go to top
Re: MUIOWB fonts
Quite a regular
Quite a regular


See User information
@ Chris
Quote:
Look for "Accept-Language" and check it doesn't contain "el".

My OWB-MUI isn't sending an Accept-Language header but yours mi


Mine is not sending the Accept-Language header, either. Thanks

Paul

Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
Go to top
Re: MUIOWB fonts
Quite a regular
Quite a regular


See User information
@Phantom,
Quote:
Although does it has to do with the codesets.library? Check your codesets directory in LIBS:. Just a thought.


Thanks. I just checked and all that's in mine is the readme file.

Paul

Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
Go to top
Re: MUIOWB fonts
Quite a regular
Quite a regular


See User information
@ Paul

Inside LIBS: there's a directory named 'Charsets'. Check if that's empty. If yes, reinstall codesets.library from OS4Depot.

To Be A True Adventurer, You Ought To Play Real Text Adventures
Go to top
Re: MUIOWB fonts
Quite a regular
Quite a regular


See User information
@Phantom,

I was hopeful that you had the answer, since my directory was empty. But after installing the contents of the codesets library lha and a reboot, the usual suspects are still showing up in a Greek font.

Thanks, again

Paul

Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
Go to top
Re: MUIOWB fonts
Just can't stay away
Just can't stay away


See User information
Quote:

Paul wrote:
@Niels,

Yes, it's also 8859-1 in the MUIOWB prefs, too.
Okay, just wanted to make sure.

Quote:
As to whether it's a specific font, how do I check? "View" > "Show source code" in the OWB menu? and then look at the offending page?
That can give some hints, but often the page will not prescribe an exact font, but instead just ask for e.g. a sans serif font, or suggest a list of fonts to choose from. Also, modern pages will not specify the font directly in the HTML, but instead use a style, which is often defined in a separate .css document (which you'd need to download separately to get at the font info).

Another way could be to change your fonts in MUIOWB's Font settings, one at a time, to something clearly recognizable (e.g. a script font or similar). Then check one of you problem pages after each change. Once you see your Greek part being rendered in the special font, you know which of the entries in the prefs is used for that particular text section.

That experiment is also useful to see whether your problem is actually related to the specific font chosen in the prefs; if the Greek becomes English when you hit the right font, you know the problem is specifically with the one you used to have selected in that slot.

In any case, let's see what we can determine when we know the font involved.

Best regards,

Niels


Go to top
Re: MUIOWB fonts
Quite a regular
Quite a regular


See User information
Quote:
Another way could be to change your fonts in MUIOWB's Font settings, one at a time, to something clearly recognizable (e.g. a


I just cut to the chase and changed ALL of the fonts in the MUIOWB fonts requester to "Viking" which is definitely recognizable compared to the standard fonts I had previously chosen.

Result? Nothing changed on any page. All of the standard fonts are still in use! (first try, I closed and re-started the MUIOWB program. When nothing changed, I hard-rebooted the computer. Still no font changes to Viking.)

This seems to be rather weird!

Is there any setting stored in env-arch somewhere? I can't seem to find anything there.

Paul

Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
Go to top
Re: MUIOWB fonts
Just can't stay away
Just can't stay away


See User information
Well, as with all MUI programs, settings are stored in ENVARC:MUI/ - in this case there is an OWB.1.prefs and an OWB.config. As far as I can tell, it is the latter that contains your font selections. So you might try deleting (or renaming) that one and see if that resets your fonts after a reboot.

Best regards,

Niels

Go to top
Re: MUIOWB fonts
Quite a regular
Quite a regular


See User information


Niels, (and all the rest for caring and trying)

I did two things tonight. I got rid of the OWB settings in env-archive MUI, and I set up a whole new fonts directory copied over from the 4.1 original CD.

I then changed the font directory path in my MUIOWB Conf directory (I forget which file now). Several reboots, a Type Manager session and a Fixfonts session and more reboots and I finally can use MUIOWB without all the annoying Greek fonts showing up.

Thanks, again.

Paul

Builder of Frankenthousand The monster A1000
The Young Frankenthousand A1-XE G4
X5000
Go to top
Re: MUIOWB fonts
Just can't stay away
Just can't stay away


See User information
Great news! So perseverance paid off in the end.

Best regards,

Niels

Go to top

  Register To Post
« 1 (2)

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project