Remember me

Lost Password?

Register now!


Who's Online
29 user(s) are online (20 user(s) are browsing Forums)

Members: 2
Guests: 27

balaton, samo79, more...


  Register To Post  

Ignore this! (It's only here because I don't know how to delete it.)
Just popping in
Just popping in

See User information
Sorry! After repeated attempts to run xscanimage brought me a "Device busy" complaint, I spent much time composing what follows (I'll leave it so people who don't ignore it will know what they were supposed to ignore). After posting I made one last attempt, knowing it would fail, and all of a sudden the scanner worked!

Back in September I started a thread that I tried to reuse, but that didn't work, because editing my original post didn't turn it into a new one. I reported that my HP ScanJet 4300C flatbed scanner had suddenly quit working, and that usb.log hinted at a problem:

I: [10:19:32] hub.usbfd | HUB | Device found on port 6 of hub "".
I: [10:19:32] hub.usbfd | Hub port | Device at port 6 of hub "" is full-speed.
I: [10:19:32] USB stack | New Fkt | Fkt 0x5fe0abf0 at level 2
I: [10:19:32] hub.usbfd | HUB | Device on hub port 6 successfully added.
I: [10:19:32] USB Fkt Init | Init Fkt | Fkt 0x5fe0abf0 is {Vendor: 0x03F0, Product: 0x0305, Class: 00.00}
I: [10:19:32] USB Fkt Init | Init Fkt | Fkt 0x5fe0abf0 initialized
W: [10:19:32] USB FD fkt start | BindInterfaceDriver | No interface driver of fkt 0x5fe0abf0/ifc 0x5fd59b40 {Class 16.01} has been found
W: [10:19:32] USB FD fkt start | FD launcher | Could not bind any suitable interface driver for fkt 0x5fe0abf0

I got the suggestions from Chris and Ed, basically that I might be missing libusb.library, and sure enough when I copied one over from my AmigaOne disk to my SAM460 I was able to scan again.

New problem, slightly different. Xscanimage gives me a Select device requester, but when I select the appropriate one, I get "Failed to open device 'niash:libusb:03f0:0305': Device busy." I should probably mention that I upgraded AmiCygnix yesterday.

I reread this thread, noticed that I needed libusb.library version 0.1.12 and checked mine. It came out "0.1" so I thought "Aha!" and got one listed as 0.1.12 from OS4 depot. But it is the same one, and C:Version says "0.1."

I missed the "niash" thing when I first launched xscanimage and accidentally selected "test:0" which brought up what looked like the scanner, but it doesn't scan. Later I tried "test:1" as well. Same result; both pretend to scan solid black, white, or checkerboard images. I can't imagine why.

But later I noticed in Amicygnix:Home/root/.sane that I have three .ppm files, two "preview"ing test_0 and test_1, dated today, and one "preview-niash:libusb:03f0:0305.ppm" dated 2009-12-24!

I hope someone will be able to help me again.

Edited by kilaueabart on 2012/11/17 18:53:41
Edited by kilaueabart on 2012/11/17 18:56:50

Edited by kilaueabart on 2012/11/26 1:38:26
Go to top

  Register To Post


Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )

Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project