Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
127 user(s) are online (37 user(s) are browsing Forums)

Members: 0
Guests: 127

more...

Support us!

Headlines

 
  Register To Post  

(1) 2 3 »
[SOLVED - Hopefully...] HDD Corrupted !
Not too shy to talk
Not too shy to talk


See User information
@All

I generally leave my A1XE-G4 ON all the time... Just shut it down about 30-40 minutes a day...

Saturday, it was ON, and I decided to launch SimpleMail, and the system frozed !
After a little while I had a Requester saying than AOS4: is not available (or something like that). AOS4 is DH0:, my main partition.

-- Clicking on [Retry] keep presenting me with the same requester !
-- So I rebooted... I saw UBoot, loading the module, then stopped (before loading WB or even loading all modules) with a Hard Disk Failure !
It seems one of the block is corrupted !!!

-- I tried booting from an AOS4_Upd1 and from an AOS4_Upd4 CD to no avail... Modifying UBoot didn't do anything, it seems to be just ignored !

So my question is: Can I boot from CD-Rom if it's on the SII Card ? If yes then I might be missing the correct settings in UBOOT. Any idea ?

What I would like is boot from the CD and try to Recover the HDD... Then maybe replace it once all my Data are safe...

Thanks.

Jerry


Edited by AmiGame on 2007/3/25 20:45:24
Edited by AmiGame on 2007/3/25 20:46:46
Edited by AmiGame on 2007/4/16 10:41:23
Edited by AmiGame on 2007/4/17 12:17:52


Defender of my A1XE-G4 / AOS4 Final Update !
Looking for a new toy ? Then try a GP2X...
Go to top
Re: HDD Corrupted ! Please help...
Home away from home
Home away from home


See User information
@AmiGame

Of course you can boot from CD, just put in your OS4final
CD and set the UBoot settings to boot from CD first.

Got a Sil card installed here, too and installed from CD
to HD (both Sil)

May i ask what Filesystem you got installed?

Go to top
Re: HDD Corrupted ! Please help...
Not too shy to talk
Not too shy to talk


See User information
@Raziel

Just got FFS.

In UBoot I changed the setting to SII CDROM Serial (I think it's how it's called), and it doesn't seem to boot at all from the CDROM.
Isn't there a command like "setenv boota SII380" (or whatever number it is I don't have my A1 in front of me at the moment - followed by a "reset") or something like that ?



* It's a freshly burned CD-R with freshly downloaded AOS4Final.
* I'm trying to boot from a DVD (Combo) Drive...

Jerry



Defender of my A1XE-G4 / AOS4 Final Update !
Looking for a new toy ? Then try a GP2X...
Go to top
Re: HDD Corrupted ! Please help...
Home away from home
Home away from home


See User information
@AmiGame

Quote:

In UBoot I changed the setting to SII CDROM Serial (I think it's how it's called), and it doesn't seem to boot at all from the CDROM.
Isn't there a command like "setenv boota SII380" (or whatever number it is I don't have my A1 in front of me at the moment - followed by a "reset") or something like that ?

Err...you got a SATA card?
You don't state what Sil you are using?

You need to set it to Parallel Sil IDE CDRom as first boot device and Parallel Sil IDE Disk as second.

Otherwise set it to Serial Sil IDE CDRom

You burned it with what program?

Go to top
Re: HDD Corrupted ! Please help...
Not too shy to talk
Not too shy to talk


See User information
@Raziel

I believe it's the "ULTRA ATA/133 SiI680 IDE RAID (PCI)" from AmigaKit

I burned the CDRom using Nero Burning Room... on the PeeCee.

Jerry



Defender of my A1XE-G4 / AOS4 Final Update !
Looking for a new toy ? Then try a GP2X...
Go to top
Re: HDD Corrupted ! Please help...
Amigans Defender
Amigans Defender


See User information
@AmiGame
You should be able to recover everything by booting from the CD-ROM which you can configure from the UBoot menu. There are all sorts of options in the UBoot menu for booting so just pick the correct one for your configuration and you should be good to go.

ExecSG Team Lead
Go to top
Re: HDD Corrupted ! Please help...
Home away from home
Home away from home


See User information
@AmiGame

Then it's Paralell Sil CDROM you must set

Nero i don't know, but it should give you a bootable medium

Go to top
Re: HDD Corrupted ! Please help...
Not too shy to talk
Not too shy to talk


See User information
@Raziel & ssolie

Thanks. I will give it another go tonight when I get home...

Do you also know the "manual" command ? Is it something like "setenv boota SII680" then "saveenv" and "reset"?

In the worse scenario, I should be able to connect the DVD-Combo back to IDE (though I would rather avoid, it would give me the oppotunity to clean a bit the inside of the tower as well...).

Jerry



Defender of my A1XE-G4 / AOS4 Final Update !
Looking for a new toy ? Then try a GP2X...
Go to top
Re: HDD Corrupted ! Please help...
Just can't stay away
Just can't stay away


See User information
@AmiGame

Quote:
Do you also know the "manual" command ? Is it something like "setenv boota SII680" then "saveenv" and "reset"?
setenv boot1 psiicdrom

Go to top
Re: HDD Corrupted ! Please help...
Home away from home
Home away from home


See User information
@AmiGame

...you can also type "menu" at the UBoot prompt, press
"ENTER" afterwards and reach, surprise, the UBoot menu.

Once there, go to Boot Options and then to Amiga Multi Boot,
there you can change it BIOS style

Go to top
Re: HDD Corrupted ! Please help...
Not too shy to talk
Not too shy to talk


See User information
@All

I managed to boot from the CDRom (AOS4Final)... But not it looks like I have a problem !

-- MediaToolBox show both Hard Disk as "Not Installed"
-- Partition Wizard can not find any partitions !

If I select "Install" from the Media ToolBox, would I loose all my data ?

Jerry



Defender of my A1XE-G4 / AOS4 Final Update !
Looking for a new toy ? Then try a GP2X...
Go to top
Re: HDD Corrupted ! Please help...
Home away from home
Home away from home


See User information
@AmiGame

Quote:

-- MediaToolBox show both Hard Disk as "Not Installed"

Both?
I though you had a problem on one HD only?

Quote:

-- Partition Wizard can not find any partitions !

HD's not installed means, no information for partitions whatsoever
in the RDB. As i understand it, PartitionWizard reads out the
RDB, so it doesn't find anything.

Quote:

If I select "Install" from the Media ToolBox, would I loose all my data ?

That looks grim, if you "Install" and had a slightly different
RDB before you WILL loose all your data, otoh if the RDB stays
the same, installing might just bring back your partitions,
because the program you installed it with before (MediaToolBox)
is the same and therefor reads out the same geometry...i hope.

So it's a game of luck, i fear.

Don't do anything, better wait for comments of other more
reliable users here

Go to top
Re: HDD Corrupted ! Please help...
Not too shy to talk
Not too shy to talk


See User information
@Raziel

I rebooted and then Partition Wizard returned more info... But stopped/froze just before it indicates the blocks details of the first partition... But all partitions were listed !

Really odd. I would think that it could be something to do with the battery, but I changed it a month or two ago (last Sunday of January IIRC at the 3Cag meeting...)

Jerry



Defender of my A1XE-G4 / AOS4 Final Update !
Looking for a new toy ? Then try a GP2X...
Go to top
Re: HDD Corrupted ! Please help...
Home away from home
Home away from home


See User information
@AmiGame

Worth a try, do you have a spare one?

Go to top
Re: HDD Corrupted ! Please help...
Just can't stay away
Just can't stay away


See User information
@AmiGame

But the led of your hd are on or off after the screen with kickstart loading ?..

If so it could be a problem of validation..

Sometimes happens ( usually after a freeze ) that your hd is not validate for some strange reason..

So let the hd run until the led switch off..

It can take also 5/10 minutes, it depends on how much big is your hard disk..

Go to top
Re: HDD Corrupted ! Please help...
Not too shy to talk
Not too shy to talk


See User information
@nubechecorre

Thanks.
I don't have a spare battery, I will try to buy one this weekend (it might be a bit tight to buy one before)...

Ref the HDD Led... With the tower I have, you don't see the HDD leds unless you open the tower...
This weekend I will open it up and clean the inside as I reckon it could be quite dusty, especially with 2 cats !...

Jerry



Defender of my A1XE-G4 / AOS4 Final Update !
Looking for a new toy ? Then try a GP2X...
Go to top
Re: HDD Corrupted ! Please help...
Amigans Defender
Amigans Defender


See User information
@AmiGame

sounds like your HD is unvalidated just switch A1 on and leave it for 10 to 20 mins all depends on HD size should be fine then :)

Amiga is the heart and soul of computing nothing else comes close
Go to top
Re: HDD Corrupted ! Please help...
Home away from home
Home away from home


See User information
@AmiGame

You still told which filesystem you are using.

Just make sure to switch to SFS, no more validation...

Go to top
Re: HDD Corrupted ! Please help...
Not too shy to talk
Not too shy to talk


See User information
@Raziel

I'm using FFS... I tried SFS when I was on Update3, and I had a few problem (and in fact another faulty 120GB HDD !)... Since then I've always been scared to try again SFS...Maybe I will once everything is recovered AND backed-up...

Jerry



Defender of my A1XE-G4 / AOS4 Final Update !
Looking for a new toy ? Then try a GP2X...
Go to top
Re: HDD Corrupted ! Please help...
Not too shy to talk
Not too shy to talk


See User information
@poweramiga

I will give it another go tonight...

Jerry



Defender of my A1XE-G4 / AOS4 Final Update !
Looking for a new toy ? Then try a GP2X...
Go to top

  Register To Post
(1) 2 3 »

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2023 The XOOPS Project