Home  
Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
48 user(s) are online (31 user(s) are browsing Forums)

Members: 1
Guests: 47

TheDaddy, more...
Support us!
Recent OS4 Files
OS4Depot.net



(1) 2 »


IBrowse 2.4 OEM how to use YT.rexx "SOLVED"
Just popping in
Joined:
1/4 10:56
From Italy
Posts: 83
Hi, I was able to configure IBrowse 2.4 OEM for https: // I would like to use it with yt.rexx
Do I need more plugins from the IBrowser site? to make it work?
or just just configure yt.rexx?
At the moment, SMTube works very well with MickjT-Mplayer
here a little video:
https://youtu.be/H5d3q07mGYs
I apologize for the link but it is to show that it works, so I hope it works the same way with IBrowse
Thanks for any response and suggestions from you, I consider this site a reference point for OS 4.1 fe1


Edited by white on 2018/1/27 13:44:43
Edited by white on 2018/1/27 18:49:18
Edited by white on 2018/1/31 14:38:56
   Report Go to top

Re: IBrowse 2.4 OEM a simple question
Just can't stay away
Joined:
2006/12/4 23:15
Posts: 1977
@white

I don't know the answer, not being a yt.rexx user, but might I suggest you edit your subject, to add YT.rexx in the title, as this question related more to YT than to IB.


_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Just popping in
Joined:
1/4 10:56
From Italy
Posts: 83
@broadblues
Hello thanks for the advice, I changed the topic
Thanks again.

   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Just can't stay away
Joined:
2006/11/24 18:52
From Gloucestershire, UK.
Posts: 1128
@@White

yt.rexx works or doesn't depending on whast country you're in and even down to the age of the files. YT changed things here 6 to 8 monthsa ago and very little works with YT.rexx any more.

run it from a shell and if you get an error like:

Unable to open T:YT-Site.html

then it's probably not worth integrating into ibrowse un til it's fixed.

If it does work open ibrowse grfs / gui /fab menus

open the link list and drag the word custom from the middle section to the right section.

then just fill iun the 3 string gadgets below

Name: YT
Action [AREexx]<your path>yt/yt.rexx[int] %l ibrowse


_________________
Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Just popping in
Joined:
1/4 10:56
From Italy
Posts: 83
@Severin
Thank you very much for your reply
From shell works YT.rexx <url>
the video starts by choosing the format and then play video
I set exactly how it was written in the program guide and how you told me.
Thank you for confirming the settings.
What I do not understand and what I have to do with IBrowse once on the youtube site.
Should I simply click on the video, or should I have a menu to choose from, for example, do I do with YT?

You can put a screenshot of my settings?
What should I use to upload the image?
I can not find any entries for uploading

What I can not understand is because the voice that I create in link does not become dark black but it remains normal is right?
Thank you and sorry for my questions


   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Quite a regular
Joined:
2006/12/1 14:14
From Europe
Posts: 503
@white

Hi Paolo...

_________________
Modern Retro Experience
   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Just popping in
Joined:
1/4 10:56
From Italy
Posts: 83
Hi, AmiKit send me an email, thanks
I remember thanks.

   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Just can't stay away
Joined:
2006/11/24 18:52
From Gloucestershire, UK.
Posts: 1128
@White

When you go to youtube and do a search, right click on the text link on the search result page and select YT from the pop up menu.

if you want to be able to right click on an image you need to add a new fabmenu entry, the same as above but in the imagelink menu

DO NOT open the individual pages as you would normaslly on a modern browser.

_________________
Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Quite a regular
Joined:
2009/4/28 3:57
From Adelaide, Australia
Posts: 894
@Severin

The reason there's been no update is because everything works here and no-one has reported any bugs. I can only fix things I know about :) I've sent you an e-mail.

Also, you need to be using 1.5. If you're still using 1.4, then not much will work with default settings.


@white

If the links don't work in IBrowse, but you can Copy them to clipboard and they work in Odyssey, then the issue is SSL with IBrowse. You can still use the AutoPlay option that YT.rexx has and make a "Play with YT.rexx" menu option. Check YT.guide for instructions on setting that up.


Edit: Remove unnecessary snarkiness :)


Edited by MickJT on 2018/1/28 7:14:33
Edited by MickJT on 2018/1/28 10:35:31
   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Just popping in
Joined:
1/4 10:56
From Italy
Posts: 83
@Severin
Thank you very much for your advice you have helped me to better understand the operation of the menus etc. Thanks again!

@MickJT
Perfect with odyssey it works perfectly, thank you very much.
It would be nice to start directly from the player
But I'm really happy. Thank you!
I've sent you an email if it's useful

   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Quite a regular
Joined:
2009/4/28 3:57
From Adelaide, Australia
Posts: 894
@white

I've already replied to it :) The instructions I gave you in the e-mail are only useful if you're using the AutoPlay option. I'll repeat it here though for anyone reading this.

You only need to follow the instructions in the guide on adding the "Open with YT.rexx" menu option, but add "autoplay" to the list of parameters, and maybe rename the menu item to "Play with YT.rexx" instead so you can remember what it will do, then adjust the TagOrder list at the top of the script to put your preferred resolution at the beginning of the list (see YT.guide regarding that setting).

   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Just popping in
Joined:
1/4 10:56
From Italy
Posts: 83
@MickJT
Thanks you're right I forgot to write it, so:
Autoplay "1"
Tag 22 etc.
Now I will do other tests, really thank you!

   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Quite a regular
Joined:
2009/4/28 3:57
From Adelaide, Australia
Posts: 894
@white

You don't need to set AutoPlay="1" in the script. Just having autoplay as a parameter after "silent" in the IBrowse menu item settings is fine, unless you wanted it on by default.

   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Just popping in
Joined:
1/4 10:56
From Italy
Posts: 83
Hi, thanks to everyone here I made a little video
https://youtu.be/7vCUp9IzvNQ

now I just have to refine the configuration.
Thank you very much for your explanations
And you MickjT for this software made very well. Thanks again!

   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Just popping in
Joined:
2006/12/2 1:41
From VA, USA
Posts: 215

@white

Congrats.

If you add "silent" to the arguments in command line of the
menu item, then you wont get the console window with the
script output (it will just start playing the video).

Enjoy,

PJS

   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Just popping in
Joined:
1/4 10:56
From Italy
Posts: 83
@pjs
Thanks, I'm happy too and thanks for the help.
But I can not figure out where to add the "SILENT" option in odyssey
I no longer asked not to disturb
Could you give me an example?
I have read the documentation but I do not understand where to add this line.
Thanks for a possible answer!

   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Just popping in
Joined:
2006/12/2 1:41
From VA, USA
Posts: 215
@Severin

I can only think you must be running an old version of the
YT.rexx script. YT.rexx is working fine here with the
release version of IBrowse 2.4 (dont forget to reboot
after running beta!).

Granted the YouTube pages have always been heavy on the JS
spyware, so I'd suggest for everyone that you go into the
IB URL Prefs, make a "#?youtube.com#?" entry and turn off
JS for the site.

Then you can go into the FAB menus and set up entries to
"autoplay" or load the HTML links (from YT.rexx) and get
to YouTube vids easy peasy.

Good luck,

PJS


   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Just popping in
Joined:
2006/12/2 1:41
From VA, USA
Posts: 215
@white

In Oddity, I've got an entry that is set as follows:

Category = Link
Label = AutoPlay with YT.rexx
Action = c:rx Internet:YT/YT.rexx %l silent autoplay

That seems to work well for me.

Thanks,

PJS

   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Just popping in
Joined:
1/4 10:56
From Italy
Posts: 83
@pjs
Thanks for the example
with these settings:
c: run data:YT/YT.rexx %l Silent Autoplay
the outpout is invisible
but returns this outpout:
cli5
but the video does not start immediately, it seems slower.
But I'm happy the same
Okay I will continue to read the documentation, thanks you made me understand where to add the command to run it.
If you have other suggestions I accept them willingly.
Thanks!

   Report Go to top

Re: IBrowse 2.4 OEM how to use YT.rexx
Just popping in
Joined:
1/4 10:56
From Italy
Posts: 83
Hi, I think I understand, where and the problem of output (shell 5)
But I can not find a solution.
Initially I used mplayer-gui with the old versions of liveforiit to try to improve the player in my emulation, to synchronize the audio, etc.
Then I also associated mickJT-mplayer with mplayer-gui to see which codecs I had available etc.
I also looked at using mplayer-gui, the -no outoput option is activated,
it probably comes into conflict with mickjT-mplayer even if I do not use it.
But I do not understand how to delete the settings made and where I find the configuration file of mplayer-gui to be able to delete them.

And sorry for the kind of question

Thanks for every suggestion and help.

   Report Go to top


(1) 2 »



[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project