Login
Username:

Password:

Remember me



Lost Password?

Register now!
Sections
Who's Online
58 user(s) are online (48 user(s) are browsing Forums)

Members: 0
Guests: 58

more...
Support us!
Recent OS4 Files
OS4Depot.net





displaying SVG files in Ibrowse
Just popping in
Joined:
2006/12/3 13:54
Posts: 50
I've installed the svg.datatype from os4depot but neither ibrowse or multiview will load a .svg file

check out the examples on http://www.w3schools.com/svg web page.

Any Ideas

_________________
Bloodmoon Games has released its RPG game content for free for personal use visit http://bloodmoongames.com today, or my blogg on http://bloodmoongames.blogspot.com

Wii number is : 4394 2248 4262 8983
   Report Go to top

Re: displaying SVG files in Ibrowse
Home away from home
Joined:
2007/1/26 21:48
From New Zealand
Posts: 2188
@aldur

Have you installed the expat library? The SVG datatype requires it.

Hans

   Report Go to top

Re: displaying SVG files in Ibrowse
Just popping in
Joined:
2006/12/3 13:54
Posts: 50
@Hans

Yes I have version 2.3 installed

I have also added the image/svg+xml mimetype to Ibrowse to attempt to get it to work but no luck

_________________
Bloodmoon Games has released its RPG game content for free for personal use visit http://bloodmoongames.com today, or my blogg on http://bloodmoongames.blogspot.com

Wii number is : 4394 2248 4262 8983
   Report Go to top

Re: displaying SVG files in Ibrowse
Amigans Defender
Joined:
2006/11/26 23:16
From Canada
Posts: 985
@aldur
Quote:
Yes I have version 2.3 installed

From the SVG datatype instructions:
Quote:
This library can be found as part of the expat-ppc (dev/lib) archive on OS4Depot.

If you have version 2.3 installed you are not following the instructions...

_________________
ExecSG Team Lead
   Report Go to top

Re: displaying SVG files in Ibrowse
Just can't stay away
Joined:
2006/11/24 18:52
From Gloucestershire, UK.
Posts: 1167
@aldur

Works here, I had to update the svg datatype (both in classes and devs as the descriptor in devs has changed alot) and install expat.library from the archive ssolie mentioned.

You don't need any mimetypes setup in ibrowse, it just works.

Don't forget to 'adddatatypes refresh' or reboot.

_________________
Amiga user since 1985
AOS4, A-EON, IBrowse & Alinea Betatester

Ps. I hate the new amigans website. <shudder>
   Report Go to top

Re: displaying SVG files in Ibrowse
Just popping in
Joined:
2006/12/3 13:54
Posts: 50
@All

The version of Expat on Os4Depot is version 2.3 the version that is installed with the SDK is 4.1

Thanks its working now

But I did have to add image/svg+xml as a mime type and set it to use internal viewer.

Thanks for all the pointers

_________________
Bloodmoon Games has released its RPG game content for free for personal use visit http://bloodmoongames.com today, or my blogg on http://bloodmoongames.blogspot.com

Wii number is : 4394 2248 4262 8983
   Report Go to top





[Advanced Search]


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project