Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
66 user(s) are online (50 user(s) are browsing Forums)

Members: 0
Guests: 66

more...

Support us!

Headlines




« 1 ... 3 4 5 (6)


Re: Updater locking up
Not too shy to talk
Joined:
2008/3/15 2:00
From Alberta, Canada
Posts: 355
@Raziel

I did not want to reinstall everything from the Enhancer Software package just to check to see if Updater was working. So I cherry-picked and installed AmiSphere, Updater, MultiEdit, Multiviewer and whatever gadgets and libraries I thought might be needed. I could not find a list of required stuff, so I guessed as best as I could and discovered a few more items as I progressed. I also downloaded the test version of listviewer.gadget using a link given to me by kas1e. Hopefully it was for the most recent test version of listviewer.gadget.

I purchased Enhancer Software v1.5 before the Enhancer Core was announced. I do not have the Enhancer Core package.

—-
redfox

   Report Go to top

Re: Updater locking up
Not too shy to talk
Joined:
2008/3/15 2:00
From Alberta, Canada
Posts: 355
@broadblues

I installed the Hotfix on Jan 12 and have rebooted and powered off and on many times (I power off my machine at night).

I did not install the Enhancer NotificationsServer but I do get some notifications from the old RinghioServer.

Just now, I downloaded AmiDVD

Last message is "Downloading updates data ...please wait"

Updater.log shows that The download was successful and it copied AmiDVD successfully.

Ranger shows a port called UPDATER.1 .... this port disappears after I click the close window (quit) gadget on the Updater window..

Cannot relaunch Updater but other programs launch ok, including web browsers.

I will install the Enhancer NotificationServer to see if that helps.



Edit to correct spelling mistakes


Edited by redfox on 2021/1/22 20:43:48
   Report Go to top

Re: Updater locking up
Not too shy to talk
Joined:
2008/3/15 2:00
From Alberta, Canada
Posts: 355
Deleted duplicate post


   Report Go to top

Re: Updater locking up
Home away from home
Joined:
2006/12/4 23:15
Posts: 2232
@redfox

Quote:

I did not install the Enhancer NotificationsServer but I do get some notifications from the old RinghioServer.


So you have RinghioServer in your WBStartup? The original one that came with the OS? (or very early aeon version?).

Try disabling that and see if you still get the lockups.

Quote:

Ranger shows a port called UPDATER.1 .... this port disappears after I click the close window (quit) gadget on the Updater window..

Cannot relaunch Updater but other programs launch ok, including web browsers.


Yes updater main process closes down but waits before final exit for it's child process (possibly while unregistering the app), the child process is hung.

The program needs some rework whatever your findings are but they will hwlp me work out if there are other issues than the ones I have identified.

_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top

Re: Updater locking up
Not too shy to talk
Joined:
2008/3/15 2:00
From Alberta, Canada
Posts: 355
@broadblues

Updater working fine now

Thank you so much for all your help. I really appreciate it.

As per your suggestion, I disabled RinghioServer in WBStartup and now Updater is working correctly.


When the problem was occuring ...

SYS:System/RinghioServer was enabled in WBStartup.

Ringhio 53.27 (31/03/2014) from the AmigaOS 4.1 Final Edition CD.

After disabling RinghioServer in WBStartup, Updater is working just fine and does not lock-up.


Thanks,
redfox


P.S. I disabled RinghioServer for awhile after I installed the original OS4.1 Final Edition Update 2. I was able to update some Enhancer stuff. Then I encountered some issues related to the OS4 kernal and started all over again with another clean install. I did not disable RinghioServer after that install because the Notification messages seemed to be working. But Updater was acting up and I had no clue that it was related to RinghioServer.

Again, thanks so much for your help Andy.






   Report Go to top

Re: Updater locking up
Not too shy to talk
Joined:
2008/3/15 2:00
From Alberta, Canada
Posts: 355
@broadblues

I installed Enhancer NotificationServer and Updater is working fine.

Thanks again for all your help.

---
redfox



   Report Go to top

Re: Updater locking up
Just popping in
Joined:
2020/11/17 12:08
From Slough
Posts: 133
@amigakit

Not one person chimed in here or anywhere else to agree with you. Your 'many other people' are like Trump's 'many fine people' . They don't exist.

   Report Go to top

Re: Updater locking up
Home away from home
Joined:
2006/12/4 23:15
Posts: 2232
@redfox

Glad it's functioning for you now, but the core issue is still there (not to mention a few other gotchas that are bit more random).

I've got a good amount of data out of this conversation to start fixing it though...

_________________
Blender For OS4.x : Blues : Walker Broad
   Report Go to top


« 1 ... 3 4 5 (6)



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project