Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
32 user(s) are online (14 user(s) are browsing Forums)

Members: 1
Guests: 31

Rigo, more...

Support us!

Recent OS4 Files
OS4Depot.net




« 1 (2)


Re: atheros wlan device is working
Not too shy to talk
Joined:
2007/1/6 5:59
Posts: 341
@ncafferkey7

Would it be possible to get some sort of status window / app for a wireless manager?

   Report Go to top

Re: atheros wlan device is working
Just popping in
Joined:
2017/9/9 17:12
From London
Posts: 16
I used to have a Sound card in the PCIe,but revert back to the sound chip on the motherboard. The Abit AW-GE870 wireless card is not showing any light when insert in a PC/Sam 460. It didn't show up in Ranger or device management.
I try the card in PC, and it do not show up, so it broken.
I will try to test it on the PCI port of the Sam 460 when I pick up the Netgear WG311 wireless card at the end of the week.


Edited by Tuskagee on 2020/7/6 19:32:23
   Report Go to top

Re: atheros wlan device is working
Just popping in
Joined:
2008/9/20 23:50
Posts: 56
@Tuskagee

Don't pay too much attention to the lights on the card. They are software controlled and my driver may not light them up. But if the card isn't visble in Ranger's PCI list it could be a sign of a broken card, unless the slot is deactivated (see nbache's post).

@utri007

I might be able to do that in the near future. I'm working on a new version of WirelessManager, and I could activate a simple MUI GUI that's already used in the AROS version.

   Report Go to top

Re: atheros wlan device is working
Just popping in
Joined:
2017/9/9 17:12
From London
Posts: 16
Just try the PCI port with a wireless card (WMP55AG ) in the SAM 460 and the card did not show up in Ranger or work with your driver.
Try the PCIe port with another abit wireless card,no joy.
Try both PIC and PCIe cards in another PC and both work so the problem is with the Sam 460.
Also the D-link 643 on the list is in the wronge class.


Edited by Tuskagee on 2020/7/11 12:16:40
Edited by Tuskagee on 2020/7/11 19:45:19
   Report Go to top

Re: atheros wlan device is working
Just popping in
Joined:
2008/9/20 23:50
Posts: 56
@Tuskagee

That's strange. Is there some Uboot setting needed to enable the slots? I know you said previously that you used a sound card in the PCIe slot, but do other network cards work in any of the slots, e.g. RTL8139 cards?

What do you mean by the wrong class?

   Report Go to top

Re: atheros wlan device is working
Just popping in
Joined:
2017/9/9 17:12
From London
Posts: 16
The D-link DWA 643 is a laptop wireless card.
In the Sam 440 Ranger read -01.06.00 Ethernet Controller
Device-0x0013Rev:0x01(N/A)
Interrupt- Line:0x32pin :A Number:66
Vendor-0x168C(N/A)
I getting non of this on the Sam 460 ,all I getting is could not open "atheros5000.device" unit 0 ( Device/unit failed to open)

   Report Go to top

Re: atheros wlan device is working
Just popping in
Joined:
2008/9/20 23:50
Posts: 56
@Tuskagee

Thanks for the information on the DWA-643. I've removed it from the compatibility list for the next release.

I don't know if I can help any further with getting these cards working on your SAM460, as the problem seems to be with the hardware or OS rather than the driver.

   Report Go to top

Re: atheros wlan device is working
Just popping in
Joined:
2017/9/9 17:12
From London
Posts: 16
The 3 Com 3CRDAG675B wireless adapter pci card work brilliantly in the Sam 440.
Can I try any of the other adapters on the Linux wireless LAN support site?


Edited by Tuskagee on 2020/7/25 16:33:49
Edited by Tuskagee on 2020/7/26 18:34:50
   Report Go to top

Re: atheros wlan device is working
Amigans Defender
Joined:
2006/11/19 17:45
From Cambridgeshire, UK.
Posts: 2088

_________________
Mikey C

No cause is lost if there is but one fool left to fight for it.
   Report Go to top

Re: atheros wlan device is working
Just popping in
Joined:
2008/9/20 23:50
Posts: 56
@Tuskagee

Thanks for the information.

Yes, cards that are compatible with the Linux drivers ath5k or MadWiFi should work, as long as they support 802.11g (my driver doesn't support 802.11a). Any additions to the compatibility list would be welcome

BTW I'm away on holidays at the moment, so I can't easily access the driver docs for comparison, but I'll update them when I'm home.

@Mikey_C

Do the cards in the photos work for you then? If so, in which machines?

   Report Go to top

Re: atheros wlan device is working
Amigans Defender
Joined:
2006/11/19 17:45
From Cambridgeshire, UK.
Posts: 2088
@ncafferkey

The photos are by Taskagee. I just uploaded them somewhere on his behalf :)


_________________
Mikey C

No cause is lost if there is but one fool left to fight for it.
   Report Go to top

Re: atheros wlan device is working
Just popping in
Joined:
2017/9/9 17:12
From London
Posts: 16
We have wireless on the Sam 460 computer,using the PCI-e slot. Using a Atheros AR5007EG full height mini PCI -e Wi-Fi card and a wireless Wi-Fi mini PCI-e express to PCI-e adapter 2 antenna. Ranger is showing device-0x001C Rev:0x01(N/A) Vendor-0x168C. Have it running smoothly for a hour no problem .

   Report Go to top

Re: atheros wlan device is working
Just popping in
Joined:
2017/9/9 17:12
From London
Posts: 16
The wireless Wi-Fi mini PCI-E Express to PCI-E Adapter with 2 antenna from ebay.Also the Atheros mini PCI -Express Wi-Fi card from ebay. Will try other cards.
The way to go is buy a atheros mini PCI-Express card as they are cheap and a adapter that fit the PCI-Express slot.


Edited by Tuskagee on 2020/8/2 9:59:56
   Report Go to top

Re: atheros wlan device is working
Just popping in
Joined:
2008/9/20 23:50
Posts: 56
@Tuskagee

Thanks for all the reports. I've added the information to the next version of the driver manual.

Does the mini-PCIe card you got working have any brand or model number printed on it? Also, did you get your hands on the Netgear WG311 to try?

   Report Go to top

Re: atheros wlan device is working
Just popping in
Joined:
2017/9/9 17:12
From London
Posts: 16
The card that I use can be pick up from the following link: https://www.ebay.co.uk/item/303608589728 and 143238023812.
Also will your driver work with 802.11 n.
I cannot get hold of the Netgear WG 311 wireless card as all Amiga meetings have been cancelled.
For pictures look at the Amiga North Thames Facebook site.


Edited by Tuskagee on 2020/8/7 19:55:42
   Report Go to top

Re: atheros wlan device is working
Just popping in
Joined:
2008/9/20 23:50
Posts: 56
@Tuskagee

Sorry, those eBay links are dead now.

No, 802.11n isn't supported. There will be a new driver for a different chipset that will support it.

   Report Go to top


« 1 (2)



[Advanced Search]



Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project