Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
56 user(s) are online (3 user(s) are browsing News)

Members: 1
Guests: 55

miggymac, more...

Support us!

Headlines


Recent Replied Topics
Topic Replies Last Post
AmigaOS4 OpenAL-soft for AmigaOS [1][2] 20 (7228) kas1e Today 10:56
AmigaOS4 List of wanted Software [1][2][3] 55 (11330) terminills Today 10:41
AmigaOS4 The OpenGL ES 2.0 thread [1][2][3][4][5] 85 (18112) Capehill Today 8:07
Amiga General Forum Introducing the Rear Window blog 10 (668) DStastny Today 2:46
AmigaOS4 Updater tool: latest releases and updates [1][2] ... [4][5][6][7] 121 (37415) Skateman Yesterday 15:45
AmigaOS4 Kensington SlimBlade Trackball 8 (575) Daytona675x Yesterday 13:25
AmigaOS4 Joystick/gamepad usable for os4 [1][2][3] 42 (11861) Capehill Yesterday 11:51
AmigaOS4 Company<->User communication...Is it still a thing today? [1][2] ... [7][8][9][10] 184 (9845) amigakit Yesterday 11:02
AmigaOS4 Shaderjoy 1.16 [1][2] ... [14][15][16][17] 322 (26116) Capehill Yesterday 7:49
AmigaOS4 The MiniGL thread [1][2] ... [8][9][10][11] 218 (28031) Daytona675x 10/24 16:56
Amiga General Forum Announcing David Pleasance to speak at Amiwest 2020 8 (655) nbache 10/23 23:22
Amiga General Forum IRC down? 17 (678) orgin 10/22 15:03
Amiga General Forum New English-language Amiga Magazine 0 (163) eliyahu 10/19 17:52
Amiga General Forum a little bit of graphics art meaning NG amigas 6 (365) Skateman 10/17 10:36
AmigaOS4 Youtube and Odyssey 1.23 r5_beta07 3 (424) tekmage 10/16 0:11
[View all topics]  [Forum Settings]
Software News : AmigaOS 4.1 QuickFix available
Posted by Rogue on 2009/6/21 16:38:09 (4298 reads) News by the same author
Software News

Antwerp, Belgium ? June 21, 2009

Hyperion Entertainment announces the immediate availability for download of a new ?Quickfix? package for all versions of AmigaOS 4.1 (i.e. AmigaOne, SAM/SAM Flex and Pegasos II).

The new ?Quickfix? package is available for registered users of AmigaOS 4.1 and incorporates the first ?Quickfix? package released earlier this year.



Features include:

* Improved overall system stability
* Fixed shared object handling especially for larger applications
* Fixed Radeon Warp3D graphics drivers
* Increased performance of IDE drivers
* Fixed JXFileSystem issues with file scanning
* Fixed Sam440ep ethernet driver to work with hubs and Envoy.


Installation of the new ?Quickfix? package is highly recommended.

Link: Hyperion Entertainment


Printer friendly page Send this story to a friend
The comments are owned by the author. We aren't responsible for their content.
Author Thread
AJS
Published: 2009/6/21 16:43  Updated: 2009/6/21 16:43
Not too shy to talk
Joined: 11/26/2006
From: Here right now!
Comments: 354
 Re: AmigaOS 4.1 QuickFix available
Thanks , downloaded and installed
kas1e
Published: 2009/6/21 17:16  Updated: 2009/6/21 17:27
Home away from home
Joined: 09/11/2007
From: Russia
Comments: 6440
 Re: AmigaOS 4.1 QuickFix available
Personally i am in big interest about more 'deep' details (can't found it in readme/etc). I mean for example what mean " * Fixed Radeon Warp3D graphics drivers" ? What exactly fixed in it , which bugs ? For example this annoing-noise-sound bug on pegasos2 when play with minigl apps still here.

Or for example very intersting about " * Improved overall system stability". What was done for it ? It's of course not so necessary, i just in interest :)

Anyway, very cool to have updates for os4. Every time it's start to be better and better. Thanks for very hard work on it to all the involved ppls.
Kraftwerk
Published: 2009/6/21 17:37  Updated: 2009/6/21 17:37
Just popping in
Joined: 11/29/2006
From:
Comments: 4
 Re: AmigaOS 4.1 QuickFix available
Installed and all is well. I think OWb is a bit more responsive now.
saimo
Published: 2009/6/21 18:03  Updated: 2009/6/21 18:03
Quite a regular
Joined: 12/06/2006
From: Italy
Comments: 665
 Re: AmigaOS 4.1 QuickFix available
@Kraftwerk

Quote:
I think OWb is a bit more responsive now.

I'm under the same impression. Maybe it's a consequence of the fixed shared object handling?

saimo
Akiko
Published: 2009/6/21 18:26  Updated: 2009/6/21 18:27
Just popping in
Joined: 12/03/2006
From:
Comments: 54
 Re: AmigaOS 4.1 QuickFix available
I'm looking forward get home from work.

Thanks Rogue and team
kas1e
Published: 2009/6/21 18:42  Updated: 2009/6/21 18:42
Home away from home
Joined: 09/11/2007
From: Russia
Comments: 6440
 Re: AmigaOS 4.1 QuickFix available
For my peg2, new update fix already this:
1. celestia no more freeze amiga os in 'demo' mode.
2. latest mplayer works fine when do switch beetween full-screen/window mode (before was freeze).
Elwood
Published: 2009/6/21 18:57  Updated: 2009/6/21 18:57
Just can't stay away
Joined: 12/09/2006
From: Lyon, France
Comments: 1337
 Re: AmigaOS 4.1 QuickFix available
> Fixed Radeon Warp3D graphics drivers

it's about the green display
virgola
Published: 2009/6/21 19:00  Updated: 2009/6/21 19:00
Just popping in
Joined: 02/01/2007
From: Bergamo, Italy
Comments: 99
 Re: AmigaOS 4.1 QuickFix available
Great!!!
Finally Warp3D apps with real colors!
That green was driving me mad!

Thanks!!!
BillE
Published: 2009/6/21 19:07  Updated: 2009/6/21 19:07
Quite a regular
Joined: 11/27/2006
From: Scarfskerry
Comments: 588
 Re: AmigaOS 4.1 QuickFix available
Excellent news, I have just installed it. Hoping IBrowse will be a bit more stable now.

A "Summer Solstice" Quick Fix too. What a good idea


Bill.
Mrodfr
Published: 2009/6/21 19:21  Updated: 2009/6/21 19:22
Quite a regular
Joined: 10/14/2008
From: France
Comments: 647
 Re: AmigaOS 4.1 QuickFix available
Quote:
A "Summer Solstice" Quick Fix too. What a good idea


that mean the next one is around 12/21 ??

Thanks for the AOS4.1 development team for this quickfix

hum, maybe DVplayer will be improved soon ???
kas1e
Published: 2009/6/21 19:31  Updated: 2009/6/21 19:44
Home away from home
Joined: 09/11/2007
From: Russia
Comments: 6440
 Re: AmigaOS 4.1 QuickFix available
@elwood
As i can see at moment, not only "grey" problem on Sam was fixed. Also for peg2 warp3d drivers, was some 'deep/inside/coding' problems with "freetexture" functions, and looks like (i am at moment not sure on 100%, but everythnk looks like that) - it fixes. But i need more tests..

Becouse of it, will be very interesting to read/see somethere the "deep" changes of all these new updates. Like:
1. rewrite fucntion this and this
2. updated this and this
3. fixed bug which caused, this and this

I am sure, that developers have this kind of readme for deep/iside purposes, so maybe it possible to see what exactly was changes (from the coder/programmer side) for warp3d ?

As i can see changes are huge by just comparing the size of libs. Becouse previus versions of warp3d drivers was:
w3d_r200.library - 182.364
w3d_radeon.library - 316.436

The new one:
w3d_r200.library - 240.328
w3d_radeon.library - 371.272

Looks like there is more than just "grey-fix" for sam ?
TSK
Published: 2009/6/21 19:35  Updated: 2009/6/22 1:09
Just can't stay away
Joined: 02/23/2007
From: Finland, the land of Santa, sauna, sisu and salmiakki
Comments: 1104
 Re: AmigaOS 4.1 QuickFix available
Big thanks to all involved ! System feels somehow snappier/faster.
Chris
Published: 2009/6/21 20:26  Updated: 2009/6/21 20:26
Amigans Defender
Joined: 11/17/2006
From: England
Comments: 3245
 Re: AmigaOS 4.1 QuickFix available
Cool, thanks!

Any news on a fix for the SAM USB problems?
bean
Published: 2009/6/21 21:00  Updated: 2009/6/21 21:00
Not too shy to talk
Joined: 11/26/2006
From:
Comments: 402
 Re: AmigaOS 4.1 QuickFix available
Many Thanks! (Registered and installed).
tommo1975
Published: 2009/6/21 21:42  Updated: 2009/6/21 22:12
Just popping in
Joined: 02/05/2009
From: Leighton Buzzard/Milton Keynes (UK)
Comments: 98
 Re: AmigaOS 4.1 QuickFix available
Great stuff - Quake 2 without the green! This makes me very happy!!

[edit 1] Quake 2 works well, but now you get red lines that appear if you resize windows. It doesn't look pretty

Maybe a quick fix for the quick fix is needed??

[edit 2] I got rid of the red lines by going into WBPattern and in the Window tab, changing Image Type from Picture to Pattern.

The courruption was getting worse with every reboot. It started with a small red dot, and preogressed to large ugly red lines that "bled" into the surrounding pixels when I was resizing windows. The corruption survived a reboot. From the testing I did it didn't affect any programs or games.
Kicko
Published: 2009/6/21 22:33  Updated: 2009/6/21 22:33
Just can't stay away
Joined: 10/25/2007
From: Gothenburg / Sweden
Comments: 1175
 Re: AmigaOS 4.1 QuickFix available
Im with Kas1e. Would be nice to have more info on whats fixed. Its good for both devs and users :)
Jack
Published: 2009/6/22 0:07  Updated: 2009/6/22 0:07
Quite a regular
Joined: 11/27/2006
From: Israel
Comments: 932
 Re: AmigaOS 4.1 QuickFix available
I was hoping for improvement in python's behaviour in presence OWB and Cygnix gtk2 apps (there is an impression it's related to .so loader), but the ISI when starting the python is still here. Otherwise all's well. Keep on!

Jack
TSK
Published: 2009/6/22 1:07  Updated: 2009/6/22 1:07
Just can't stay away
Joined: 02/23/2007
From: Finland, the land of Santa, sauna, sisu and salmiakki
Comments: 1104
 Re: AmigaOS 4.1 QuickFix available
I made some tests putting ram disk full of random stuff and then launching apps and opening new tabs into OWB. It looks like memory paging and low memory related problems are gone. Amiga OS 4.1 works realiable, fast, great and like a charm now. That's very important.
Antique
Published: 2009/6/22 1:22  Updated: 2009/6/22 1:22
Home away from home
Joined: 11/30/2006
From: Norway
Comments: 2484
 Re: AmigaOS 4.1 QuickFix available
Registered and dl all updates.
Works nice here.
nubechecorre
Published: 2009/6/22 2:39  Updated: 2009/6/22 2:39
Just can't stay away
Joined: 11/24/2006
From: Sanremo
Comments: 1841
 Re: AmigaOS 4.1 QuickFix available
Thanks that's a big surprise for me i am back right now to home and i find a big update available !! many thanks
redfox
Published: 2009/6/22 3:41  Updated: 2009/6/22 3:41
Not too shy to talk
Joined: 03/15/2008
From: Alberta, Canada
Comments: 315
 Re: AmigaOS 4.1 QuickFix available
Downloaded and installed AmigaOne version.

Thanks to all involved.
---
redfox
Paul
Published: 2009/6/22 3:52  Updated: 2009/6/22 3:52
Not too shy to talk
Joined: 12/01/2006
From: Michigan, USA
Comments: 493
 Re: AmigaOS 4.1 QuickFix available
aaarrrrgggghhhhh!!!!!!

I'm away from my Amiga for a week! I can't play with the rest of you 'til I get back home.

sniff...sniff

Have fun, the rest of you.

Paul
ferrels
Published: 2009/6/22 4:22  Updated: 2009/6/22 4:22
Just popping in
Joined: 10/20/2008
From: Arizona
Comments: 64
 Re: AmigaOS 4.1 QuickFix available
Any fix for USB2.0 on the PegII?
Rogue
Published: 2009/6/22 8:31  Updated: 2009/6/22 8:31
Quite a regular
Joined: 11/24/2006
From:
Comments: 624
 Re: AmigaOS 4.1 QuickFix available
Quote:
Any fix for USB2.0 on the PegII?


What fix for USB 2,0? AFAIK USB works just fine on the Pegasos; if you mean USB 2,0 support, that is way beyond a "fix".
kas1e
Published: 2009/6/22 10:04  Updated: 2009/6/22 10:26
Home away from home
Joined: 09/11/2007
From: Russia
Comments: 6440
 Re: AmigaOS 4.1 QuickFix available
@Rogue
usb on pegasos works fine, but, if you start to try use/run/ programms which heavy works with reading data from the filesystem (usb one), then some time i have "usb" crashes. Can send a log if you in interest.

and what about warp3d ?:) can you a bit more deeply describe what was done ? Or you can't ?

ps. also in interest, maybe you already know what problem caused this strange "noise" bug when use minigl apps on peg2 ?

ps2. I also found a new "feature" which dunno good or not. Before, i have working one 68k scene diskmag. With this update, i have on the running stage window: "BPCL programms not allowed anymore". But programm working fine before, dunno for what need dissallow it by so "hardcore" way. Let's user choice yourself, want he or not to run this ?
Slayer
Published: 2009/6/22 10:49  Updated: 2009/6/22 10:49
Quite a regular
Joined: 03/11/2008
From: Dunedin, New Zealand
Comments: 868
 Re: AmigaOS 4.1 QuickFix available
Excellent Work Team!

Much Appreciated!!!!
ferrels
Published: 2009/6/22 20:41  Updated: 2009/6/22 20:41
Just popping in
Joined: 10/20/2008
From: Arizona
Comments: 64
 Re: AmigaOS 4.1 QuickFix available
No, half the devices I plug into the USB port don't even get powered or recognized. And when they do, the performance is spotty. I was hoping for USB2.0 support that would hopefully eliminate the problems.
Raziel
Published: 2009/6/22 21:02  Updated: 2009/6/22 21:02
Home away from home
Joined: 11/26/2006
From: a dying planet
Comments: 3772
 Re: AmigaOS 4.1 QuickFix available
Awesome, thanks a lot to the whole team

Will try the JXFS on my partition once more (seeing that the scanning behaviour was fixed).

Can?t wait to get back to my miggy
ChrisH
Published: 2009/6/22 21:17  Updated: 2009/6/22 21:20
Home away from home
Joined: 05/19/2007
From: England
Comments: 3553
 Re: AmigaOS 4.1 QuickFix available
@ferrels
USB2.0 support would NOT fix the USB problem, although it might make it worse since I imagine that USB2 is more complex than USB1. What we want is USB1 to be improved, and especially USB driver for Sam440 to be fixed (loosing keyboard & mouse is extremely annoying, especially when compiling).

@all
The improved speed (subjective) on Sam440 may be due to OS4 no-longer defaulting to the debug kernel. I need to try DVD playback, to see if that is any faster (it was nearly fast enough already)...
Chris
Published: 2009/6/22 21:58  Updated: 2009/6/22 21:58
Amigans Defender
Joined: 11/17/2006
From: England
Comments: 3245
 Re: AmigaOS 4.1 QuickFix available
@ChrisH
Quote:
What we want is USB1 to be improved, and especially USB driver for Sam440 to be fixed (loosing keyboard & mouse is extremely annoying, especially when compiling).


Haven't seen any problems with keyboard and mouse, but the inability to recognise most USB flash drives is particularly annoying (and these are ones that work on the AmigaOne). I suspect it is all part of the same problem anyway (as well as the similar PegII issue).
Swisso
Published: 2009/6/22 23:16  Updated: 2009/6/22 23:16
Not too shy to talk
Joined: 11/29/2006
From: Earth
Comments: 257
 Re: AmigaOS 4.1 QuickFix available
All ways happy to get an update, however small, it shows that people are still working hard on our behalf. Thanks Hyperion
VooDoo
Published: 2009/6/22 23:19  Updated: 2009/6/22 23:19
Not too shy to talk
Joined: 11/29/2006
From: Croatia
Comments: 325
 Re: AmigaOS 4.1 QuickFix available
hmm..have problem wiht this update...when i turn on Amiga for first time I cant boot WB.. after OS4.1 logo I get Wb screem...without icon ..only empty sceet ant title bar "Workbenc screen" after reset all is OK!

What is problem ?

before this update I dont have this problem!
redfox
Published: 2009/6/23 3:35  Updated: 2009/6/23 5:38
Not too shy to talk
Joined: 03/15/2008
From: Alberta, Canada
Comments: 315
 Re: AmigaOS 4.1 QuickFix available
@VooDoo

This might be what I call the White Workbench screen. Bootup seems to proceed normally, but you get a white screen with a title bar which says Workbench but no icons. I have not seen it yet with this update.

However, I used to see it occasionally in the past on first power up if I unplugged my machine from the power outlet for a few days or sometimes even just overnight. For awhile we were a bit tight for space at the computer desk, and I would unplug my machine and move it out of the way when I was not using it. Sometimes I would get the White Workbench screen when I powered up again the next day or a few days later (if I waited that long). A quick ctrl alt alt would reboot the system to a normal Workbench screen.

---
redfox
MicroA1
Rogue
Published: 2009/6/23 10:40  Updated: 2009/6/23 10:40
Quite a regular
Joined: 11/24/2006
From:
Comments: 624
 Re: AmigaOS 4.1 QuickFix available
Quote:
usb on pegasos works fine, but, if you start to try use/run/ programms which heavy works with reading data from the filesystem (usb one), then some time i have "usb" crashes. Can send a log if you in interest.


What does that have to do with USB 2.0?

Quote:
and what about warp3d ?:) can you a bit more deeply describe what was done ? Or you can't ?


As has been pointed out before, the green texture issue on SAM440 has been sorted out.

Quote:
ps. also in interest, maybe you already know what problem caused this strange "noise" bug when use minigl apps on peg2 ?


This isn't a MiniGL issue, it can also occur on non-Warp3D/non-MiniGL programs. It is generally happening when something does make frequent use of the PCI bus.

Quote:
Let's user choice yourself, want he or not to run this ?


BCPL programs are no longer supported, if they work then it's a coincidence. This is not likely to change.
Rogue
Published: 2009/6/23 10:44  Updated: 2009/6/23 10:44
Quite a regular
Joined: 11/24/2006
From:
Comments: 624
 Re: AmigaOS 4.1 QuickFix available
Quote:
No, half the devices I plug into the USB port don't even get powered or recognized. And when they do, the performance is spotty. I was hoping for USB2.0 support that would hopefully eliminate the problems.


As far as I remember, the Pegasos II has USB 1.1 ports built in, so EHCI support would only help if you have an addiitonal plugin card. I wonder though what kind of USB devices you are using, all my USB devices work (although some of them are unsupported due to lack of drivers).

Make sure you don't plug too many of them into the same port, as they do have a power limit, and IIRC the VIA chipset doesn't always meet them.
Rogue
Published: 2009/6/23 10:48  Updated: 2009/6/23 10:48
Quite a regular
Joined: 11/24/2006
From:
Comments: 624
 Re: AmigaOS 4.1 QuickFix available
Quote:
What is problem ?


See, that is awfully little information to go with.

You might want to try adding a "set echo on" to the beginning of your startup sequence to see what program hangs; it might be IPrefs. Is the screen the correct resolution?
jbni
Published: 2009/6/23 14:44  Updated: 2009/6/23 14:44
Just popping in
Joined: 05/09/2009
From:
Comments: 53
 Re: AmigaOS 4.1 QuickFix available
I managed to fix my Sam440 losing the keyboard and mouse by... replacing the power supply.

Might be worth a shot.
pekdar
Published: 2009/6/23 15:09  Updated: 2009/6/23 15:09
Just popping in
Joined: 11/12/2008
From: Poland
Comments: 9
 Re: AmigaOS 4.1 QuickFix available
Will be OS4.1 for classic Amiga? Please.
nubechecorre
Published: 2009/6/24 15:05  Updated: 2009/6/24 15:05
Just can't stay away
Joined: 11/24/2006
From: Sanremo
Comments: 1841
 Re: AmigaOS 4.1 QuickFix available
i'd really like to have it in my miggy 1200 with mediator radeon 9250 pci power pc and 256 megabyte of ram
Orion
Published: 2009/6/26 16:43  Updated: 2009/6/26 16:43
Just popping in
Joined: 01/31/2009
From: Carmel, Indiana, USA
Comments: 1
 Re: AmigaOS 4.1 QuickFix available
I have not been able to register my Amiga OS4.1 with Hyperion to obtain this QuickFix or the earlier fix for the SAM440ep version. I have tried three different email addresses over the past four months, each with a unique name, user name, and password. Each time the Hyperion site says that an account was created and an email needed for activation was sent to my email address. I never received these emails. Hyperion has not answered my many requests for help sent to: webmaster@hyperion-entertainment.biz.

Has anyone had similar problems? How was the problem resolved? Does anyone have a different email address I could use to contact Hyperion?

Thanks.
Ricossa
Published: 2009/6/27 6:29  Updated: 2009/6/27 6:29
Just popping in
Joined: 11/29/2006
From: Geneva CH
Comments: 227
 Re: AmigaOS 4.1 QuickFix available
I had big problems with my SAM (not flex) and had to restaure the old files :
graphic corruption with freeze, usb card-reader no more working ...
sundown
Published: 2009/6/29 20:58  Updated: 2009/6/29 20:58
Not too shy to talk
Joined: 11/27/2006
From: California - S.F. Bay area
Comments: 380
 Re: AmigaOS 4.1 QuickFix available
@Rogue

Quote:
You might want to try adding a "set echo on" to the beginning of your startup sequence to see what program hangs; it might be IPrefs. Is the screen the correct resolution?

I boot sometimes to a blank shell WB screen after the quickfix. The mouse pointer is active & I can pull the screen down to see a blank black screen behind it. Took 2 warm boot attempts to get the WB screen loaded.

WB boot shell
General
Site sponsors
Advertise Here

Site statistics
Registered members
  1492
Logged in last:
  24 hours, 45
  7 days, 92
  30 days, 139

Top Posters
1 kas1e
kas1e 6440
2 Raziel
Raziel 3772
3 ChrisH
ChrisH 3553
4 samo79
samo79 3366
5 Chris
Chris 3245
6 orgin
orgin 3199
7 LiveForIt
LiveForIt 2822
8 Antique
Antique 2484
9 328gts
328gts 2417
10 Hans
Hans 2310

New Members
zidz
zidz 10/19/2020
Bluewater41
Bluewater41 10/19/2020
Beajar
Beajar 10/17/2020
slygon
slygon 10/15/2020
OldGrump
OldGrump 09/28/2020
mid
mid 09/22/2020
landrock
landrock 09/21/2020
Jazzy_J
Jazzy_J 09/18/2020
Scodera
Scodera 09/14/2020
ChrisGNZ
ChrisGNZ 09/07/2020


Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project