Login
Username:

Password:

Remember me



Lost Password?

Register now!

Sections

Who's Online
25 user(s) are online (17 user(s) are browsing Forums)

Members: 1
Guests: 24

Rob, more...

Headlines

 
  Register To Post  

can't send an email with the latest Claws email client?
Home away from home
Home away from home


See User information
can't send an email...getting 'SSL handshake failed'...all my seetings are correct....looks like an SSL certifcate its looking for but where/how?

Go to top
Re: can't send an email with the latest Claws email client?
Quite a regular
Quite a regular


See User information
@328gts

Claws-Mail uses the gnutls 2.12.24 library for SSL/TLS. It searches for cert files like this:

* If the variable "Cygnix/SSL_CERT_FILE" is set to a cert collection file, it uses this file (path must be unix style).

* If the variable is not set, it takes the file "Cygnix:CygnixPPC/gtk2.24/share/curl/curl-ca-bundle.crt" or "Cygnix:CygnixPPC/share/curl/curl-ca-bundle.crt". A file "Cygnix:CygnixPPC/share/curl/curl-ca-bundle.crt" is provided with the AmiCygnix base package V1.5.

Maybe it helps to replace the file with a newer one.
But I guess, that you a need newer version of gnutls. Current version is 3.6.13. If a cert file is too old, Claws-Mail asks for a permission to use the received cert and stores it in the settings (see menu "Extras").

My port of gnutls will be updated in the next AmiCygnix release.

Go to top
Re: can't send an email with the latest Claws email client?
Home away from home
Home away from home


See User information
@cygnusEd

thanks for the quick repsonse Ed! seems problem is I don't have curl when I checked the folders you notd above??? Reinstalling latest AmiCygnix Update now...

update:
reinstalled and still no 'curl' folder? No idea what happened as I was sending emails out with Sylpheed ?


Edited by 328gts on 2020/4/9 19:28:16
Edited by 328gts on 2020/4/9 20:09:24
Go to top
Re: can't send an email with the latest Claws email client?
Quite a regular
Quite a regular


See User information
@328gts

Sylpheed uses OpenSSL 0.98d. It's funny, that this outdated version works and the more current gnutls 2.12 not. I think gnutls uses a higher level TLS and old OpenSSL falls back to simple SSL - but I don't know exactly.

Looked again into the base package and into a test installation: The curl cert file is there! Maybe your archive is corrupt? Please check again for "curl-ca-bundle.crt" in "Cygnix:CygnixPPC/share/curl".

There is a TLS client included in the base package called "gnutls-cli". With this tool you can see what happens while creating your SSL/TLS connection and also send and receive data.

Open an amiga shell and type:

gnutls-cli hostname:995 (Maybe you have an other port number.)

There is also a second command for debugging:

gnutls-cli-debug hostname:995

Go to top

  Register To Post

 




Currently Active Users Viewing This Thread: 1 ( 0 members and 1 Anonymous Users )




Powered by XOOPS 2.0 © 2001-2016 The XOOPS Project